[SOLVED] Energiesparoptionen Gigabyte C246-WU4


olco

57 posts in this topic Last Reply

Recommended Posts

46 minutes ago, olco said:

Macht es Sinn das Mal durchzuführen ohne dass HDDs angeschlossen sind

 

Um nur die Differenz der HDDs zu ermitteln, brauchst du das nicht. Wobei mit Powertop die HDD im Standby weniger verbraucht, weil der SATA Port selbst ebenfalls in den Standby wechselt. Da ist die Frage was du alles wissen willst.

 

46 minutes ago, olco said:

Ohne HDDs misst der Stecker im Idle 17,9-18,7 Watt.

 

Hast du im BIOS CEC2019 aktiviert und Audio deaktiviert? Diese beiden Optionen sparen bereits ein paar Watt. Hilft dir jetzt natürlich nicht bei der Ermittlung der HDD-Differenz, aber eben allgemein beim Strom sparen.

 

Beim Messen empfehle ich dir außerdem den Browser zu schließen. Die WebGUI verbindet sich alle paar Sekunden mit dem Server um evtl Benachrichtigungen anzeigen zu können. Das beeinflusst natürlich den Schlafzustand der CPU.

Link to post
  • Replies 56
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Ins Go File einfach ans Ende folgendes eintragen (aus dem Powertop-Thread):  

Posted Images

Im BIOS habe ich CEC2019 aktiviert und auch das Audio deaktiviert.

 

Nun habe ich auch noch mal powertop --auto-tune ausgeführt. Hat nichts am momentanen Verbrauch im Idle geändert.

Also habe ich noch wie im Thread von dir beschrieben die entsprechenden Befehle für den Start in das Go File geschrieben und neugestartet.

Der Verbrauch ist unverändert bei etwa 18 Watt.

 

Dann liegt mein Mehrverbrauch gegenüber deinen Messungen ggf im stromhungrigeren RAM, Netzteil, Mainboard (aufgrund des integrierten SATA Controllers für die zusätzlichen 2 Ports).

Link to post

18W ohne HDDs ist nicht ohne. Mich wundert allerdings, dass weder CEC2019 noch Powertop etwas bringt. Das sollte in jedem Fall ein paar Watt bringen. Die verbauten Komponenten sind da "egal". Die Ersparnis kommt ja durch Abschaltung der PCIe Slots, SATA Buchsen, USB-Buchsen, usw. Einfach gar keine Änderung ist komisch. Vielleicht doch das Messgerät!? Welches Modell hast du da genau bzw was misst das eigentlich, wenn der Server heruntergefahren wurde? Dann ist das Board ja im "Standby". Mit aktivem ErP sollte der Verbrauch dann auf unter 1W fallen. Ohne meine ich um die 2W.

Link to post

Dann müsste ich eigentlich noch Mal CEC2019 aktivieren sowie den Audiochip, um zu sehen, wie stark der Stromverbrauch dann steigt.

 

Aber ich sehe auf jeden Fall einen Unterschied, in der Server mit Platten im Idle läuft oder ohne.

 

Ohne HDDs: 18 Watt

4 HDDs im Spin Down: 21 Watt

4 HDDs aktiv: ca. 40 Watt aber stärker schwankend

 

Zum Messen verwende ich einen Teckin SP22 Stecker.

Die Werte im Betrieb mit 2 aktiven Platten deckten sich mit denen, die ich mit einem TCM Zwischenstecker vom Schwiegervater gemessen habe.

Link to post
18 minutes ago, mgutt said:

Du meinst deaktivieren?!

Ja, sorry ich meinte deaktivieren.

 

Kann gerade nicht an meinen Monitor und habe kein Kabel um den Server mit dem TV zu verbinden aber prüfe das morgen noch mal.

Link to post
4 hours ago, mgutt said:

Das kannst du dir eigentlich sparen, denn wenn das Messgerät billig ist, dann misst es die Blindleistung mit.

...es hiess, es geht um eine Smarte Steckdose, offenbar mit Power-Messfunktion...kein Messgerät.

Die sind garnict so schlecht...habe einige davon und die Abweichung ist sehr gering, verglichen zB mit meinem ELV Messgerät....aber auch untenrum bei 5-10W nicht ganz so toll.

Mit oiner Glühbürne "zusätzlich" ist das Ding in einem Bereich, der 25% genauer ist.

 

Allerdings - und darauf bezog ich mich - muss man die Leistungsmessung in den Dingern kalibrieren, wg. Blind- und Wirkleistung daher mit einer Glühbirne.

Meine "Messdose" zeigt dann sowas...zB mein Netzwerk/IT-Schrank...so kann ich mal den USV-Test vom Sofa aus machen (die USV selbst zeigt übrigens nur die "Apparent Power", also inkl. Blindleistung an in unRaid).

image.png.6cee7e6db26cd42388bc173ea1286cdf.png

Link to post
  • ich777 changed the title to [SOLVED] Energiesparoptionen Gigabyte C246-WU4

Habe gestern Abend endlich noch Mal einen Monitor an der Server anschließen können.

Audio ist im BIOS deaktiviert

CEC2019 ist aktiviert

 

Der Verbrauch liegt dennoch, wie oben ausgeführt, bei etwa 18Watt ohne HDDs.

Link to post

Fahr mal das Array herunter und führe diese Kommandos über das Web-Terminal aus um alle Laufwerke herunterzufahren (das Dashboard wird es nicht unbedingt korrekt anzeigen):

mdcmd spindown 0
mdcmd spindown 1
mdcmd spindown 2
mdcmd spindown 3
mdcmd spindown 4
mdcmd spindown 5
mdcmd spindown 6
mdcmd spindown 7
mdcmd spindown 29

 

0 = Parität 1

29 = Parität 2

1 bis 7 = deine Disks (kannst du entsprechend anpassen)

 

Nach 30 Sekunden oder so wiederhole das ganze ruhig noch mal bzw lausche ob noch eine Platte läuft.

 

Jetzt messen. Damit sind nun Container und VMs außen vor. Außerdem kannst du ja testweise noch mal "powertop --auto-tune" ausführen.

 

Noch was. Wenn du powertop startest, dann hast du ja den "Idle stats" Bildschirm. Sieht es da wie bei mir aus?940213210_2021-01-2816_07_18.thumb.png.0be4aff98f3738ca818d8c58188c267a.png

 

 

Wichtig ist, dass die CPU Kerne auf C7 (HW) bzw C10 (OS) runtergehen. Das Package sollte auch auf C6 bis C8 gehen. Bei mir ist das wie du siehst nicht der Fall. Ich glaube das liegt daran, weil ich aktuell nicht alle SATA Ports schlafen schicken kann. Das liegt daran, dass die Firmware von dem M.2 auf SATA Adapter scheinbar einen Fehler hat. Daher habe ich das Energiesparen von den SATA Ports erstmal deaktiviert.

 

EDIT: Ich wollte es nun wissen. Ich habe gezielt meine SATA Onboard-Ports mit der Schlafmöglichkeit versehen:

echo 'med_power_with_dipm' > /sys/class/scsi_host/host1/link_power_management_policy
echo 'med_power_with_dipm' > /sys/class/scsi_host/host2/link_power_management_policy
echo 'med_power_with_dipm' > /sys/class/scsi_host/host3/link_power_management_policy
echo 'med_power_with_dipm' > /sys/class/scsi_host/host4/link_power_management_policy
echo 'med_power_with_dipm' > /sys/class/scsi_host/host5/link_power_management_policy
echo 'med_power_with_dipm' > /sys/class/scsi_host/host6/link_power_management_policy
echo 'med_power_with_dipm' > /sys/class/scsi_host/host7/link_power_management_policy
echo 'med_power_with_dipm' > /sys/class/scsi_host/host8/link_power_management_policy

 

Das ist auch das was "powertop --auto-tune" einstellt, brauchst du also nicht machen.

 

Jedenfalls ist mein Verbrauch nur deswegen um 4 Watt gefallen:

951844466_2021-01-2816_26_31.png.3661657c6f6e34398e745093dc8bc36d.png

 

Dadurch ist nämlich auch das Package auf C3 gesunken:

220685715_2021-01-2816_25_38.png.fb8253182a7072f01222191eace93ecd.png

 

 

 

Demnach kostet mich der M.2 auf 5-Port Adapter also 4W.

 

Ich teste mal ob ich noch was spare, wenn ich die darauf ungenutzten Ports schlafen schicke (11, 12 und 13 sind belegt):

echo 'med_power_with_dipm' > /sys/class/scsi_host/host9/link_power_management_policy
echo 'med_power_with_dipm' > /sys/class/scsi_host/host10/link_power_management_policy

 

EDIT: Nein, dadurch ändert sich leider kaum bis gar nichts:

1874481735_2021-01-2816_31_47.png.1ee1f0602f1c0834fad268e72da8ab0f.png

 

Die Tage werde ich noch eine 5-Port SATA PCIe Karte testen. Die hat den selben Chipsatz. Mal sehen ob der Fehler da auch ist. Außerdem ersetze ich die 10G RJ45 Karte gegen SFP+. Das sollte noch mal 3W beim Server und 3W beim Switch sparen.

Link to post

Habe das Array heruntergefahren und dann per "mdcmd spindown X" nacheinander alle Platten in den Spindown geschickt.

Der Verbrauch liegt bei 22 Watt, wie auch nach Herunterfahren des Arrays sowie aktivieren des Spindowns per Web GUI.

 

Dann habe ich powertop --auto-tune ausgeführt:

modprobe cpufreq_stats failedCannot load from file /var/cache/powertop/saved_results.powertop
Cannot load from file /var/cache/powertop/saved_parameters.powertop
File will be loaded after taking minimum number of measurement(s) with battery only 
RAPL device for cpu 0
RAPL device for cpu 0
Devfreq not enabled
glob returned GLOB_ABORTED
Cannot load from file /var/cache/powertop/saved_parameters.powertop
File will be loaded after taking minimum number of measurement(s) with battery only 
 the port is sda
 the port is sdb
 the port is sdc
 the port is sdd
 the port is sde
 the port is sdf
Leaving PowerTOP

 

Verbrauch Bleibt bei ca. 22 Watt.

 

Die Powertop Idle Stats sehen wie dargestellt aus. Also Core(HW) gehen offenbar auf C7 und CPU(OS) gehen auf C10. Package geht auf C3 von daher scheint eigentlich alles fein zu sein (siehe Anhang).

 

Bei mir wird aber auch die iGPU nicht gesondert angezeigt. Ist es bei dir die iGPU die angezeigt wird oder hast du eine extra Grafikkarte verbaut?

powertop 1.PNG

Link to post

Mach das Fenster noch größer. Die GPU ist ganz unten.

 

Was steht unter "Tunables". Ist alles auf "Good"?

 

Wenn ja, dann tippe ich langsam auf das Messgerät. Wenn alle HDDs schlafen und nach powertop --auto-tune kein Verbrauch sinkt, dann macht das eigentlich keinen Sinn.

Link to post

Auch wenn ich das Fenster größer ziehe, den Zoom auf 50% stelle oder runter scrolle, da steht bei mir nichts von der iGPU. Komisch.

 

Unter Tunables steht alles auf "Good".

 

Ja vielleicht liegt es an dem "Messgerät". Muss im Keller mal suchen, ob ich da noch eine 100Watt Birne finde oder ähnliches.

60Wat sollten es ja auch tun.

 

Sonst kann es ja eigentlich nur am Sata Controller liegen aber dass der so viel Energie benötigt kann ich mir kaum vorstellen.

powertop gpu fehlt.png

powertop tunables.PNG

Link to post

Führe mal diese Zeilen im Terminal aus:

# -------------------------------------------------
# enable hardware transcoding on intel
# -------------------------------------------------
modprobe i915
chown -R nobody:users /dev/dri
chmod -R 777 /dev/dri

 

Danach noch mal in powertop nach der GPU schauen. Damit wird der Kernel Treiber für die iGPU installiert.

Link to post

Ok, gut zu wissen. Ich hatte das nur wegen Plex drin.

 

Wenn du das dauerhaft drin haben willst > Config Editor installieren und in der Go Datei einfügen. Wird dann beim Serverneustart ausgeführt.

Link to post

Fürs Transcoding in Plex hattest du die GPU drinnen?

Brauche ich aktuell nicht, dann kann ich es raus lassen.

 

Aber der Stromverbrauch ist auch noch immer gleich bei 22Watt.

Link to post
6 minutes ago, olco said:

Fürs Transcoding in Plex hattest du die GPU drinnen?

 

Das ist die iGPU des Prozessors. Keine separate GPU. Und ja, die nutze ich natürlich für Plex. Sonst müsste ja die PC transcodieren.

Link to post

Dass alle HDDs, nachdem das System per WOL geweckt wird, hochdrehen, ist das eine Sache vom Mainboard oder vom OS?

Hatte gestern Mal herumprobiert und da fiel mir das auf.

Link to post
  • 3 weeks later...
On 1/30/2021 at 8:55 AM, olco said:

Sonst kann es ja eigentlich nur am Sata Controller liegen aber dass der so viel Energie benötigt kann ich mir kaum vorstellen.

 

Kannst du den Controller eigentlich über das BIOS deaktivieren und hattest du die HDDs an anderen SATA Ports?

 

Du hattest auch meine ich nicht gesagt welches Netzteil du verwendest. Wenn du willst, kann ich dir mal meine PicoPSU ausleihen. Als Warensendung kostet das Porto 2,20 €. Dann könntest du mal prüfen wie viel dein Netzteil ausmacht.

Link to post
  • 1 month later...

Ich grabe den Thread hier mal wieder aus, da ich mich mit dem Thema Strom sparen beschäftige und das gleiche MB habe.
 

Ich habe zuvor ohne Einstellungen am BIOS einen Verbrauch von 26.3 - 29.0 W gehabt. Dies wurde mittels TP Link HS110 gemessen, dass HS110 hatte ich mal mit einem geeichten Messgerät vermessen und daraus hat sich bei 500 W Verbrauch eine Abweichung von 0.5 % und bei 1.3 W Verbrauch eine Abweichung von 0.45% ergeben. Ich habe bei der aktuellen HS110 eine REV. 2.0, damals habe ich aber eine REV. 1.0 vermessen, danke sollte sich nichts geändert haben, bei Gelegenheit vermesse ich diese erneut. 

 

Was habe ich in den BIOS Settings geändert.:

  • AudioController von Enabled auf Disabled
  • C-States Control von Auto to Enabled
  • CPU Enhanced Halt (C1E) von Auto to Enabled
  • C3 State Support von Auto to Enabled
  • C6/C7 State Support von Auto to Enabled
  • C8 State Support von Auto to Enabled
  • C10 State Support von Auto to Enabled
  • Package C State Limit von Auto to C10 damit er bis C10 gehen kann
  • CPU EIST Function von Auto to Enabled
  • Race to Halt (RTH) von Auto to Enabled
  • Energy Efficient Turbo von Auto to Enabled

1939656991_AdvancedCPUSettings_07-52-11.jpg.eb1ff26a0332ef9bdd94ae3c1e8dfd9d.jpg

 

Wie man sieht, sind dann automatisch die Platform Power Management auf Enabled

27447382_Power_08-07-55.jpg.6aa30c911ffa15a78a490fa1f2062bb6.jpg

 

Des Weiteren erreiche ich bei der Übersicht von PowerTop bei Pkg(HW) nur C2 und bei Core(HW) nur C7

powertop_1_1.thumb.jpg.f1e69e54acd4851916bf62d7ec346cbb.jpg

powertop_1_2.jpg.80e605eab26b710a3c75c4e0de9cb65a.jpg

 

Was mir noch aufgefallen ist, dass die CPU sich nicht runtertaktet

powertop_1_3.thumb.jpg.b939a394f6dffd4f407e50ce4752d80c.jpg

Zeigt die aktuelle CPU Frequenz

grep MHz /proc/cpuinfo

Gibt jede Sekunde die CPU Frequenz zurück

watch -n 1 grep MHz /proc/cpuinfo

 

 

Der Verbrauch hat sich auf 22.0 - 23.5 W gesenkt, was schonmal eine Verbesserung ist.
Ich werde nun auch mal diesen Befehl versuchen

powertop --auto-tune

Dieser soll ungenützte Ports usw. abschalten

 

Bei allen Messungen sind die HDDs im SpinDown und die Docker,VMs aus und Zugriff per CMD mittels SSH.

 

Fragen.:

1)  Sind die Settings im BIOS so sinnvoll?

2) Warum taktet die CPU nicht runter und würde dies Strom sparen?
3) Hat sonst noch jemand Tipps? Vor allem wie ich noch niedrigere C-States erreichen kann, um mehr Strom zu sparen?

Edited by MPHxLegend
Link to post
29 minutes ago, MPHxLegend said:

Was mir noch aufgefallen ist, dass die CPU sich nicht runtertaktet

Das ist normal und hat keinen nennenswerten Einfluss auf den Verbrauch.

 

29 minutes ago, MPHxLegend said:

Ich werde nun auch mal diesen Befehl versuchen

Ohne den sind deine bisherigen Messungen quasi irrelevant. Erst der macht es möglich, dass ungenutzte SATA, PCIe und USB Ports schlafen gehen. Linux lässt in den Grundeinstellungen ansonsten alle Ports voll aktiv.

 

Ich würde auch testen, ob das manuelle ausführen der Kommandos nicht sogar mehr bringt, da diese wirklich alle Slots abdecken:

https://forums.unraid.net/topic/98070-reduce-power-consumption-with-powertop/

 

zB das hier kannst du im WebTerminal ausführen und der Effekt sollte sofort auf dem Messgerät sichtbar sein:

for i in /sys/class/scsi_host/host*/link_power_management_policy; do
    echo 'med_power_with_dipm' > $i
done

 

Im Link sind noch mehr Befehle, die man dann nacheinander ausführen kann. powertop führt das selbe aus, aber nur bei einer festen Liste von Geräten.

 

Beachte außerdem, dass du das Array startest, aber Docker und VM vollständig deaktiviert hast. Außerdem alle Disks runterfahren. Einfach um sicher zu gehen, dass wirklich nirgends Aktivität auf den Disks ist.

 

29 minutes ago, MPHxLegend said:

Wie man sieht, sind dann automatisch die Platform Power Management auf Enabled

27447382_Power_08-07-55.jpg.6aa30c911ffa15a78a490fa1f2062bb6.jpg

 

Hier solltest du noch ErP aktivieren, was den Standby-Verbrauch reduziert und CEC 2019, was allgemein den Verbrauch senken kann, wobei es bei mir in Windows einen größeren Effekt als in Linux hatte.

 

Schau auch mal bitte ob im BIOS eine Option existiert womit der zusätzliche SATA Controller (ASMEDIA) deaktiviert werden kann. Damit gehen dir natürlich zwei SATA Ports flöten, aber ich will damit testen, ob er dann vielleicht tiefer geht als C2. Aber mach das erst ganz am Ende, wenn die oben genannten Punkte nichts geholfen haben.

Link to post
3 hours ago, mgutt said:

Ohne den sind deine bisherigen Messungen quasi irrelevant. Erst der macht es möglich, dass ungenutzte SATA, PCIe und USB Ports schlafen gehen. Linux lässt in den Grundeinstellungen ansonsten alle Ports voll aktiv.

Mit powertop --auto-tune ist der Verbrauch auf 18.1 - 19.9 gefallen.
Dies muss ich nach jedem Neustart ausführen, gibt es die Möglichkeit dies automatisch zutun? 

 

3 hours ago, mgutt said:

Ich würde auch testen, ob das manuelle ausführen der Kommandos nicht sogar mehr bringt, da diese wirklich alle Slots abdecken:

https://forums.unraid.net/topic/98070-reduce-power-consumption-with-powertop/

 

zB das hier kannst du im WebTerminal ausführen und der Effekt sollte sofort auf dem Messgerät sichtbar sein:


for i in /sys/class/scsi_host/host*/link_power_management_policy; do
    echo 'med_power_with_dipm' > $i
done

 

Im Link sind noch mehr Befehle, die man dann nacheinander ausführen kann. powertop führt das selbe aus, aber nur bei einer festen Liste von Geräten.

Dies funktioniert bei mir im WebTerminal nicht, muss ich dazu ein Script anlegen und dieses ausführen?

 

4 hours ago, mgutt said:

Beachte außerdem, dass du das Array startest, aber Docker und VM vollständig deaktiviert hast. Außerdem alle Disks runterfahren. Einfach um sicher zu gehen, dass wirklich nirgends Aktivität auf den Disks ist.

Docker und VM sind deaktiviert. 

 

4 hours ago, mgutt said:

Hier solltest du noch ErP aktivieren, was den Standby-Verbrauch reduziert und CEC 2019, was allgemein den Verbrauch senken kann, wobei es bei mir in Windows einen größeren Effekt als in Linux hatte.

Habe ich Enabled aber hat sich nichts geändert am Verbrauch, auch nicht im Standby. 

 

4 hours ago, mgutt said:

Schau auch mal bitte ob im BIOS eine Option existiert womit der zusätzliche SATA Controller (ASMEDIA) deaktiviert werden kann. Damit gehen dir natürlich zwei SATA Ports flöten, aber ich will damit testen, ob er dann vielleicht tiefer geht als C2. Aber mach das erst ganz am Ende, wenn die oben genannten Punkte nichts geholfen haben.

Habe ich nichts gefunden, wie der Threadersteller auch schon zuvor

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.