OpenVPN Server & Client for unRAID 6.2+ (6.1 are still supported)


peter_sm

941 posts in this topic Last Reply

Recommended Posts

  • Replies 940
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I have updated the OpenVPN Server & Client plugins for the V6.2+ plugin manager. Post all issue you have in this thread !! To install. Install the plugins, go to the 'Extensions' pa

Had the same issue, you need to edit that line and replace "-f16" with "-f14". Install works great after this edit. Github probably modified its HTML.

Hi,   I changed from OpenVPN AS from Linuxservers to yours. At first, good job Everything is working fine for me at the moment.   But I have one question, maybe I oversee som

Posted Images

Any advice on how to manually stop/start/restart the openvpn client? When I was running unraid 5.0.5 and an older version of the plugin this would work (as per instructions)

To start:       /etc/rc.d/rc.openvpn start
Stopping:     /etc/rc.d/rc.openvpn stop

however there is nothing relating to openvpn in my /etc/rc.d/ folder.

 

I'm using unraid 6.0.1 and openvpn client 2015.09.01

 

Thanks

 

Link to post

i want to be able to connect to my unraid from my phone outside the network, is the server plugin the only thing i need or do i have to install both the server and client?

Server on unraid, phone os specific openvpn client, port forward specific openvpn port on router to unraid.
Link to post

I am getting this error and the Client folder gets a empty client

 

Data Base Updated

cp: cannot stat 'boot/myVPNserver/easy-rsa/easyrsa3/pki/issued/DragonTower_PB3.crt': No such file or directory

cp: cannot stat 'boot/myVPNserver/easy-rsa/easyrsa3/ta.key': No such file or directory

cp: cannot stat 'boot/myVPNserver/easy-rsa/easyrsa3/pki/ca.crt': No such file or directory

cp: cannot stat 'boot/myVPNserver/easy-rsa/easyrsa3/pki/private/DragonTower_PB3.key': No such file or directory

/usr/local/emhttp/plugins/openvpnserver/scripts/rc.openvpnserver: line 386: boot/myVPNserver/clients/DragonTower_PB3/DragonTower_PB3.ovpn: No such file or directory

/usr/local/emhttp/plugins/openvpnserver/scripts/rc.openvpnserver: line 412: cd: boot/myVPNserver/clients/DragonTower_PB3: No such file or directory

creating a zip file .....

boot/myVPNserver/clients/DragonTower_PB3/DragonTower_PB3.zip

zip warning: name not matched: DragonTower_PB3.ovpn

zip warning: name not matched: DragonTower_PB3.crt

zip warning: name not matched: DragonTower_PB3.key

zip warning: name not matched: ca.crt

zip I/O error: No such file or directory

zip error: Could not create output file (boot/myVPNserver/clients/DragonTower_PB3/DragonTower_PB3.zip)

Client files have been stored in this folder ..

 

 

this is on my boot drive i don't like using the cache drive.. But i don't think it is in read only mode because i have re installed the plugin several times. I am on version 6.1.1

Link to post

So i'm having a similar problem. Currently if i connect to the openVPN server on my unraid I can see everything hosted on it and access all other ip's on my network no problem. Last night in unraid i enabled bridge so my vm's could be bridge onto my normal network and get an ip from my router. However this broke OpenVPN. Now if i connect i only see the unraid ip and services it runs. I can't connect to anything else on my network. I get the same result if i try to bond two of my NIC's together. I'm running Unraid 6.1.2

 

Anyone else experiencing this?

Link to post
  • 2 weeks later...

 

I will change download location later in my  plugin, see below, you can DL these files manually to your extra folder.

 

 

http://mirrors.slackware.com/slackware/slackware64-current/slackware64/n/openvpn-2.3.6-x86_64-1.txz
http://mirrors.slackware.com/slackware/slackware64-current/slackware64/tcl/expect-5.44.1.15-x86_64-2.txz
http://mirrors.slackware.com/slackware/slackware64-current/slackware64/tcl/tcl-8.6.4-x86_64-1.txz

 

Link to post

Forgive me for being thick, but where is or where do i create the extra folder? I've downloaded the 3 additional files and tried placing them inside the plugins folder along with the original .plg file (as well as putting them into an extra folder inside it). I bet ya im doing something really stupid!

 

Link to post
  • 2 weeks later...

Peter, many thanks for this excellent plugin!! I have been using the server a lot.

However, when rebooting the server it does not start automatically. Although I have checked the box within the application.

When starting the openvpn server manually, it starts.

 

The appdata is not residing on the cachedrive, but on a SSD mounted by unassigned devices, where all my docker apps are residing as well. Could this be causing the issue? Does the appdata need to reside on the cache drive? Or could i build in a delay for the plugin to start to ensure the SSD is mounted? I have a feeling this is the underlying problem.

Link to post

If anyone here has any experience setting up openvpn client with the VPN company "Private Internet Access" would love your help.

 

I have the .ovpn which I downloaded from there site. Not to sure where to put the file however.

 

I assume I dont need to have openvpn server running.

Link to post

Put these on your flash on a folder named openvpn, see instructions

 

Sorry for sounding like I have no idea what im doing.

 

I have a folder in config/plugins/openvpn

 

I have placed the .ovpn file in there, lets just call it japan.ovpn.

 

It would seem that no matter where I place that ovpn file be it in the folder I created "openvpn" or the folder that is created when openvpn installs called "openvpnclient" when I go to the gui and go to settings there is a dropdown box for client config file where I would assume you choose the ovpn file.

 

There in is the problem, no matter what or where I place that ovpn file the drop down box simply says "Chose a file".

Alt+F5 doesnt give me anything in that dropdown box, rebooting doesnt give me anything in that dropdown box as well.

Link to post

Presently I have my VPN set up in my Router.  With Google Fiber coming, I will have to give up my DD-WRT router unless I want to hack my own bypass to Google fiber network box.  I prefer to run with supported, known working stuff, so am not eager to hack the Google Fiber Network Box.  However, I need to create a secure VPN entry to my entire lan which the GFNB is not able to do. 

 

Will OpenVPN on unRaid do that?  Is the plugin more or less suited to this than the Docker?

 

My main use case is to access my entire network remotely, not just my unRaid box.  (I am not wanting to hide my internet downloading.)

 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.