[Support] Linuxserver.io - Plex Media Server


5049 posts in this topic Last Reply

Recommended Posts

1 hour ago, Hoopster said:

 

I am using hardware transcoding on my Intel Xeon with integrated GPU and Quick Sync support.  The quality is good and I do not see a lot of artifacts.  Those mentioning artifiact issues are transcoding from 1080p down to 480p or to a much lower bitrate than the original.  If you are are transcoding 1080p to 720p  or 1080 to 1080 for example with a target bitrate of 4Mbps or higher, you really should not see a lot or artifacts.  I have done many very acceptable 3 Mbps transcodes as well.

 

thanks alot for the info, my main purpose is LiveTV, so 1080i to 720p or 1080p, around 4-12 Mbps, depending on target (pc or mobil).

 

i ll give it a try now and see, i guess i have to set the intel gpu as main one and then fix perm as described here somewhere.

Link to post
  • Replies 5k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Go to the appdata share and look in Plex\Library\Application Support\Plex Media Server\Crash Reports You will find folders for your previous versions named as the release version.

Yep, seems like the problem.   Not to be outdone... google.  And what do I find.... Hoopster's post from over a year ago. I see your post here regarding the iGPU not being enabled corr

Application Name: Plex Media Server Application Site: https://plex.tv/ Docker Hub: https://hub.docker.com/r/linuxserver/plex/ Github: https://github.com/linuxserver/docker-plex  

Posted Images

I've got the linuxserver.io docker installed on my unRAID server (version 6.3.5).  I was able to get the libraries setup but my Nvidia Shield doesn't acknowledge the server as being online.  The Shield shows the unRAID server in the Settings, but can't see it as being online.  The Plex WebUI sees the Shield as being an available player, but it's not listed under the Devices tab.  When I checked the Plex Docker log (attached) it shows an IPv6 error.  I'm wondering if this is the issue.  If so, how to I go about fixing it?

Plex Docker Log.png

Link to post

I am having random loss of audio when playing movies. It has been reported a couple of months ago on the Plex Support forums without resolution and I wondered if there was a way I could work round the issue to be able to use Plex?

 

Yes, I am a Plex Pass user.

 

The symptoms are that I will start a movie on the Apple TV, everything will start as expected with video and audio playback then, within the first ten minutes the audio will drop out but the video will continue. If I press pause and then play on the remote, the audio will immediately resume at whatever place the video had got to. Then, after a few more minutes the audio will drop off again. It does not appear to be dependent on which movie I watch... it seems to be all of them. It does not appear to be at a fixed interval. All hardware components are ethernet, not wifi.

 

Since my wife is disabled and cannot operate the remote herself, it makes the app useless. Because of her illness we had taken a couple of months break in watching films in her library so the issue has appeared with either a TV OS update, the Plex App for Apple TV or the PMS docker itself in the past two months.

 

I would really appreciate help finding a work around while the Plex team continue to look into it. This is the thread on the Plex Support forum. It has just spread to a second page... https://forums.plex.tv/discussion/288620/apple-tv-audio-stops-randomly/p1

 

NAS : unRAID 6.3.5 in my signature

Docker : linuxserver/plex:latest

PMS Version : Plex Pass 1.10.1.4602

Apple TV : 4th Gen

Plex App : 1.20.1 4th December 2017

 

The movies that drop the audio are in the following format...

<MediaContainer size="1" allowSync="1" identifier="com.plexapp.plugins.library" librarySectionID="1" librarySectionTitle="Movies" librarySectionUUID="5671a3cf-9bfb-4ba2-8cb4-368abfd574cc" mediaTagPrefix="/system/bundle/media/flags/" mediaTagVersion="1513172439">
<Video ratingKey="192" key="/library/metadata/192" guid="com.plexapp.agents.imdb://tt0120917?lang=en" librarySectionID="1" librarySectionKey="/library/sections/1" librarySectionTitle="Movies" studio="Walt Disney Pictures" type="movie" title="The Emperor's New Groove" titleSort="Emperor's New Groove" contentRating="G" summary="Kuzco is a self-centered emperor who summons Pacha from a village and to tell him that his home will be destroyed to make room for Kuzco's new summer home. Kuzco's advisor, Yzma, tries to poison Kuzco and accidentally turns him into a llama, who accidentally ends up in Pacha's village. Pacha offers to help Kuzco if he doesn't destroy his house, and so they form an unlikely partnership." rating="7.0" viewOffset="411871" viewCount="7" lastViewedAt="1513528694" year="2000" tagline="It's All About.....ME!" thumb="/library/metadata/192/thumb/1505178281" art="/library/metadata/192/art/1505178281" duration="4715744" originallyAvailableAt="2000-12-09" addedAt="1461776848" updatedAt="1505178281" chapterSource="media">
<Media videoResolution="1080" id="206" duration="4715744" bitrate="27135" width="1920" height="1080" aspectRatio="1.78" audioChannels="6" audioCodec="ac3" videoCodec="h264" container="mp4" videoFrameRate="24p" optimizedForStreaming="0" has64bitOffsets="1" videoProfile="high">
<Part accessible="1" exists="1" id="265" key="/library/parts/265/1461776585/file.m4v" duration="4715744" file="/MyMedia/Movies/HD/The Emperor's New Groove (2000)/The Emperor's New Groove (2000).m4v" size="15995437402" container="mp4" has64bitOffsets="1" hasChapterTextStream="1" optimizedForStreaming="0" videoProfile="high">
<Stream id="641" streamType="1" default="1" codec="h264" index="0" bitrate="26741" language="English" languageCode="eng" bitDepth="8" chromaSubsampling="4:2:0" frameRate="23.976" hasScalingMatrix="0" height="1080" level="41" profile="high" refFrames="4" streamIdentifier="1" width="1920"/>
<Stream id="642" streamType="2" selected="1" default="1" codec="ac3" index="1" channels="6" bitrate="448" language="English" languageCode="eng" audioChannelLayout="5.1(side)" samplingRate="48000" streamIdentifier="2"/>
</Part>
</Media>
</Video>
</MediaContainer>

 

I have also attached a Plex Log. The last audio drop would have been withing five minutes of the creation of the log.

 

I am considering trying the original MKV version of the affected movies (2 out of 2 tried so far) rather than the Apple converted version that I have here but beyond that I am totally out of ideas.

Plex Media Server Logs_2017-12-17_16-41-11.zip

Link to post

We're not Plex devs so to be honest there's very little we can do. Had a read of the thread and seems it's a client side problem (probably)

Could Emby be worth a look? Might bridge the gap until Plex sort out the issue, not checked but pretty sure there's an iOS app for it.

Personally I use Emby as a back end and direct play (No transcoding) on a relatively cheap Khadas Vim flashed to LibreELEC, don't know if hardware upgrades are within budget but something else to consider, although if you have purchased a lot of media in the Apple ecosystem I can also see how that might not be ideal.

Sorry can't be of more help, but perhaps if you tell us a bit more of your requirements we can offer some more advice.

Is streaming directly an option? I'm sure there must be some iOS app that can play directly over SMB/NFS?

Sent from my LG-H815 using Tapatalk

Link to post

Actually the movies were not bought on the Apple store - they are my own. I hold all the MKV files in an archive but took the decision to use ffmpeg to convert them to a more Apple-friendly format up front so we don't have to transcode every single time they are watched. The NAS is capable of transcoding up to two streams at a time so I can test using the MKV rather than the M4V version to see if I made a transcoding error.

 

When we watch a movie I can see on the Plex UI that the video is streaming direct but the audio is being transcoded from 5.1  (or whatever) down to stereo which is all our TV will handle at the moment.

Link to post

I would definitely try every option with your files until you figure out what works and what does not work. 

 

I personally used HandBrake on every one of my Movies to convert them from 1080 6Channel down to 720 2Channel for all my devices and of course kept the originals for my HD Capable devices. So my ipads, iphones or whatever just stream with no effort, but notices my Library got rather HUGE. Lol

Link to post
3 hours ago, wgstarks said:

Just bought a lifetime plexpass license and updated the docker to the plexpass version. One question occurs to me after updating. Will I have to manually enter the version number for every update?

After actually reading the instructions it looks like maybe I did this wrong.?

 

I thought at one time it was necessary to use a version number for plexpass so I set version=<version number> but maybe it should have been version=plexpass?

Link to post
42 minutes ago, wgstarks said:

So version=latest will install the most recent beta release and version=public will install the most recent stable release. Right? And both will be plexpass?

 

Yeah I guess that's one way of putting it, never thought of the plexpass releases as beta myself.

Link to post
26 minutes ago, CHBMB said:

 

Yeah I guess that's one way of putting it, never thought of the plexpass releases as beta myself.

 

 

I'm just reading it off the github page.

 



Valid settings for VERSION are:-

IMPORTANT NOTE:- YOU CANNOT UPDATE TO A PLEXPASS ONLY VERSION IF YOU DO NOT HAVE PLEXPASS
  • latest: will update plex to the latest version available that you are entitled to.
  • public: will update plexpass users to the latest public version, useful for plexpass users that don't want to be on the bleeding edge but still want the latest public updates.
  • <specific-version>: will select a specific version (eg 0.9.12.4.1192-9a47d21) of plex to install, note you cannot use this to access plexpass versions if you do not have plexpass.

 

To me, "bleeding edge" would refer to nightly versions or equivalent. Not sure if that's true in this case though?

Link to post
On 15.12.2017 at 8:06 PM, Hoopster said:

 

I am using hardware transcoding on my Intel Xeon with integrated GPU and Quick Sync support.  The quality is good and I do not see a lot of artifacts.  Those mentioning artifiact issues are transcoding from 1080p down to 480p or to a much lower bitrate than the original.  If you are are transcoding 1080p to 720p  or 1080 to 1080 for example with a target bitrate of 4Mbps or higher, you really should not see a lot or artifacts.  I have done many very acceptable 3 Mbps transcodes as well.

 

thanks again, all really nice and smooth now, 8-12 Mbps 1080p on browser playback, 3 Mbps 720p on cellular, just plays now and i cant say i have any artefact issues.

 

Also its stable now as expected, before with CPU transcode i had alot pause and play ... even on my i7 7700 and 4 cores running for unraid.

 

So, thanks again ;)

Link to post
  • 2 weeks later...
2 hours ago, zin105 said:

Just switched to this container from the official one from Plex and I got this in my container log

 


*** WARNING: Detected another IPv4 mDNS stack running on this host. This makes mDNS unreliable and is thus not recommended. ***

socket() failed: Address family not supported by protocol

What does it mean and should I just ignore it? Everything seems to work as expected so far.

 

Ignore it.

Link to post

I've tried searching before posting for help and haven't quite been able to find what I need help with all the way. If it's out there i'm sorry. I found out that plex doesn't place files that are transcoded for mobile syncing in the same place that it puts normal transcodes which i currently have going into RAM and there is no way to change that like there is with the normal transcodes. I have an SSD mounted in unassigned devices that I'd like to dedicate solely to mobile sync files, lets call it sandisk. I moved all of the files from /mnt/cache/appdata/PlexMediaServer/Library/Application Support/Plex Media Server/Cache/Transcode/Sync+ to sandisk/sync+ and from midnight commander created a symlink from sandisk/sync+ to /mnt/cache/appdata/PlexMediaServer/Library/Application Support/Plex Media Server/Cache/Transcode/Sync+ 

 

I mapped the sandisk to the plex container but every time I try to sync, plex gives an error saying cannot write to disk. I'm at a loss at what to do from here, its probably something simple but I am a linux/command line noob. Thanks for any help.

symlink.JPG

Link to post

Hi all,

 

Fairly new unraid/plex user here with a bit of an interesting dilemma... 

 

I've had the Plex docker running on my server for about 5 months now without a single issue. Playback was great across all my devices and users; completely smooth sailing. That is until yesterday. While watching a standard 30 min episode my steam cut out completely and I received an error saying that "plex could not be reached at this time."  This was odd as my server was running just fine, the network was fine, no issues at all.

 

I went ahead and restarted the docker and BAM everything worked great. That is for 1 more episode...then the exact same thing occurred. Plex would not stream a single thing from the library. I then deleted the docker completely (not app data though) and it loaded up one episode perfectly...but then again stopped after that one. This was even the case on my Desktop (using Chrome to view Plex). All plex would do is sit there and spin, no video would ever appear. 

 

I would really hate to completely wipe out the docker and the image as everything is configured nicely across my devices and all my users. My server is pretty beefy and I'm nowhere near using it near its full potential. I haven't done any updates within this time period or any notable system changes/edits. I'm pretty lost at the moment. 

 

Any advice would be great. Thanks! 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.