[Support] binhex - DelugeVPN

Recommended Posts

2 hours ago, Dukko said:

Hey folks, struggling with a weird new issue. Suddenly, Deluge is not downloading anything. I have a feeling it's related to a storage update DockStarter ran recently.

These are my configs:


Any idea?

Same issue here.  Just installed a few days ago and was working fine.  I can add torrents but none are downloading and all show paused.  

Link to comment
19 hours ago, nfragol said:

This is for the folders

drwxrwxr-x   1 nobody users  796 Jan  4 17:00 config

drwxrwxrwx 1   1000 users     938 Jan  3 15:21 nzbToMedia


and this is for the script

-rwxrwxrwx 1 1000 users 16938 Dec 14 10:34 TorrentToMedia.py


Hi guys,


I have been struggling for 2 days to get the execute plugin to work.

On Binhex's advice i tried the following command but still cant get it to work.


"/usr/sbin/python /config/nzbToMedia/TorrentToMedia.py"


Above i have the permissions for the folders and script.

I am new to linux and unraid, can someone please point me in the right direction ?



Link to comment

Hello All!  first time posting here.  Thanks in advance!


I tried to setup DelugeVPN and its not wanting to load the webui when the vpn is set to ON.  I went through the config settings and put the cert+vpn list in the openvpn directory just like spaceinvaderone did in the demo but it won't work.  I start the console on Deluge and run the curl ifconfig.io and it gives me a different public ip, so something is working.  I go through the same steps with qbit and it seems to work but would rather not use that client. 


What files do I need to look at for logging?  Anyone have suggestions?

Link to comment
4 minutes ago, nfragol said:

What provider are you using ?

Did you use 1 country file ?

provider = PrivateInternetAccess

I've tried using one country file (netherlands), i've tried using the list that SI1 displays, i've tried using all of them.  I restarted it several times out of frustration and the webui works now.  Does that seem very stable?


Now I go to do a test torrent (ubuntu) and get the message Failed to Upload Torrent.  same torrent worked in qbit.

Link to comment
8 minutes ago, nfragol said:

As far as i know, you can only use one country file. It takes some time to connect to certain spots.

If you have webui, that apparently means you are connected.


Try the france file.

I get the webui, but still get this failed to upload torrent message.


Link to comment
6 minutes ago, nfragol said:

at the bottom right of the deluge webui, do you see the new ip address given by the vpn provider ?

I get the new public IP, everything looks great but I get this message when I go to test the torrent.  


actually, i forgot i have to work now.  I'll work on this again tonight.


Link to comment
10 minutes ago, nfragol said:

Thanks good to know.

I think that @DaSlinky has already created a connection to one server.


can he still use this multiple servers addition ?

Just need to edit the ovpn file and restart the docker. It will attempt to connect to each server (in the order listed) until it gets a successful connection.

Link to comment

Hi I'm new to unraid etc and just installed my delugevpn container following spaceinvaderone's video. I'm using PIA as the VPN and that IP address does show in the deluge webui. I used the ubuntu bittorrent link as a test and that downloaded just fine and made it into my user/downloads/completed folder.  However when I try to start a torrent on any of the private trackers I use I cannot get anything to download.  the 1st tracker I am able to add the torrent file and the torrent shows up in my webui but never starts downloading.  for the 2nd tracker I can't even add the torrent file.  As I'm new to all this I'm not even sure where to begin troubleshooting.  Please let me know what additional info, screen caps shares etc you may need to help.  I'm assuming I configured something wrong but I'm not sure. Thank you in advance.

Link to comment
On 1/4/2021 at 9:28 PM, jace055 said:

Same issue here.  Just installed a few days ago and was working fine.  I can add torrents but none are downloading and all show paused.  

I'm having this same issue. Nothing downloads anymore... I can't figure out why. There are no errors in the logs. It is connected to PIA just fine. The only error I see is in the bottom right where it used to show free space now just says error...


I am not even sure where to start troubleshooting, any help would be appreciated!

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.