Jump to content

[Support] binhex - DelugeVPN


Recommended Posts

I can't access the Web UI after initial setup. There is a timeout and the UI is not coming up.

 

The log file says the following:

 

2024-04-12 14:42:44,213 DEBG 'start-script' stdout output:
2024-04-12 14:42:44 TLS: tls_multi_process: initial untrusted session promoted to trusted

2024-04-12 14:42:44,334 DEBG 'start-script' stdout output:
2024-04-12 14:42:44 PUSH: Received control message: 'PUSH_REPLY,redirect-gateway def1,dhcp-option DNS 103.86.96.100,dhcp-option DNS 103.86.99.100,explicit-exit-notify,comp-lzo no,route-gateway 10.8.1.1,topology subnet,ping 60,ping-restart 180,ifconfig 10.8.1.2 255.255.255.0,peer-id 0,cipher AES-256-GCM'

2024-04-12 14:42:44,335 DEBG 'start-script' stdout output:
2024-04-12 14:42:44 OPTIONS IMPORT: --ifconfig/up options modified
2024-04-12 14:42:44 OPTIONS IMPORT: route options modified
2024-04-12 14:42:44 OPTIONS IMPORT: route-related options modified
2024-04-12 14:42:44 OPTIONS IMPORT: --ip-win32 and/or --dhcp-option options modified
2024-04-12 14:42:44 net_route_v4_best_gw query: dst 0.0.0.0
2024-04-12 14:42:44 net_route_v4_best_gw result: via 172.17.0.1 dev eth0
2024-04-12 14:42:44 ROUTE_GATEWAY 172.17.0.1/255.255.0.0 IFACE=eth0 HWADDR=02:42:ac:11:00:05
2024-04-12 14:42:44 TUN/TAP device tun0 opened

2024-04-12 14:42:44,335 DEBG 'start-script' stdout output:
2024-04-12 14:42:44 net_iface_mtu_set: mtu 1500 for tun0
2024-04-12 14:42:44 net_iface_up: set tun0 up
2024-04-12 14:42:44 net_addr_v4_add: 10.8.1.2/24 dev tun0
2024-04-12 14:42:44 /root/openvpnup.sh tun0 1500 0 10.8.1.2 255.255.255.0 init

2024-04-12 14:42:44,338 DEBG 'start-script' stdout output:
2024-04-12 14:42:44 net_route_v4_add: 185.239.149.3/32 via 172.17.0.1 dev [NULL] table 0 metric -1

2024-04-12 14:42:44,339 DEBG 'start-script' stdout output:
2024-04-12 14:42:44 net_route_v4_add: 0.0.0.0/1 via 10.8.1.1 dev [NULL] table 0 metric -1
2024-04-12 14:42:44 net_route_v4_add: 128.0.0.0/1 via 10.8.1.1 dev [NULL] table 0 metric -1
2024-04-12 14:42:44 Initialization Sequence Completed
2024-04-12 14:42:44 Data Channel: cipher 'AES-256-GCM', peer-id: 0, compression: 'stub'
2024-04-12 14:42:44 Timers: ping 60, ping-restart 180
2024-04-12 14:42:44 Protocol options: explicit-exit-notify 1

2024-04-12 14:42:45,490 DEBG 'start-script' stdout output:
[info] Attempting to get external IP using 'http://checkip.amazonaws.com'...

2024-04-12 14:42:46,026 DEBG 'start-script' stdout output:
[info] Successfully retrieved external IP address 185.239.149.31

2024-04-12 14:42:46,030 DEBG 'start-script' stdout output:
[info] VPN provider 'custom' not supported for automatic port forwarding, skipping incoming port assignment

2024-04-12 14:42:46,111 DEBG 'watchdog-script' stdout output:
[info] Deluge listening interface IP 0.0.0.0 and VPN provider IP 10.8.1.2 different, marking for reconfigure

2024-04-12 14:42:46,118 DEBG 'watchdog-script' stdout output:
[info] Deluge not running

2024-04-12 14:42:46,124 DEBG 'watchdog-script' stdout output:
[info] Deluge Web UI not running

2024-04-12 14:42:46,126 DEBG 'watchdog-script' stdout output:
[info] Attempting to start Deluge...
[info] Removing deluge pid file (if it exists)...

2024-04-12 14:42:46,537 DEBG 'watchdog-script' stdout output:
[info] Deluge key 'listen_interface' currently has a value of '10.8.0.2'
[info] Deluge key 'listen_interface' will have a new value '10.8.1.2'
[info] Writing changes to Deluge config file '/config/core.conf'...

2024-04-12 14:42:46,805 DEBG 'watchdog-script' stdout output:
[info] Deluge key 'outgoing_interface' currently has a value of 'tun0'
[info] Deluge key 'outgoing_interface' will have a new value 'tun0'
[info] Writing changes to Deluge config file '/config/core.conf'...

2024-04-12 14:42:47,238 DEBG 'watchdog-script' stdout output:
[info] Deluge key 'default_daemon' currently has an undefined value
[info] Deluge key 'default_daemon' will have a new value '7f1c2b9474b44998aa3f2a286d9fec44'
[info] Writing changes to Deluge config file '/config/web.conf'...

2024-04-12 14:42:47,312 DEBG 'watchdog-script' stdout output:
[info] Deluge process started
[info] Waiting for Deluge process to start listening on port 58846...

2024-04-12 14:42:47,865 DEBG 'watchdog-script' stdout output:
[info] Deluge process listening on port 58846

2024-04-12 14:42:50,208 DEBG 'watchdog-script' stderr output:
<Deferred at 0x14e855d36e90 current result: None>

2024-04-12 14:42:50,287 DEBG 'watchdog-script' stdout output:
[info] No torrents with state 'Error' found

2024-04-12 14:42:50,288 DEBG 'watchdog-script' stdout output:
[info] Starting Deluge Web UI...

2024-04-12 14:42:50,288 DEBG 'watchdog-script' stdout output:
[info] Deluge Web UI started

Link to comment
10 hours ago, binhex said:

you sure about that? so in advanced view for the container in 'extra parameters' you have the following defined?:-
 

--sysctl="net.ipv4.conf.all.src_valid_mark=1"

 

$ docker inspect delugevpn | sed -e 's/"VPN_USER=.*"/"VPN_USER=*******"/g' -e 's/"VPN_PASS=.*"/"VPN_PASS=*******"/g' | jq ".[0].HostConfig, .[0].Config.Env"
{
  "Binds": [
    "/data/deluge/data:/data",
    "/etc/localtime:/etc/localtime:ro",
    "/data/deluge/downloads:/downloads",
    "/data/deluge/config:/config"
  ],
  "ContainerIDFile": "",
  "LogConfig": {
    "Type": "json-file",
    "Config": {}
  },
  "NetworkMode": "my-main-net",
  "PortBindings": {
    "58846/tcp": [
      {
        "HostIp": "",
        "HostPort": "58846"
      }
    ],
    "58946/tcp": [
      {
        "HostIp": "",
        "HostPort": "58946"
      }
    ],
    "58946/udp": [
      {
        "HostIp": "",
        "HostPort": "58946"
      }
    ],
    "8112/tcp": [
      {
        "HostIp": "",
        "HostPort": "8112"
      }
    ],
    "8118/tcp": [
      {
        "HostIp": "",
        "HostPort": "8118"
      }
    ]
  },
  "RestartPolicy": {
    "Name": "unless-stopped",
    "MaximumRetryCount": 0
  },
  "AutoRemove": false,
  "VolumeDriver": "",
  "VolumesFrom": null,
  "ConsoleSize": [
    0,
    0
  ],
  "CapAdd": [
    "AUDIT_WRITE",
    "CHOWN",
    "DAC_OVERRIDE",
    "FOWNER",
    "FSETID",
    "KILL",
    "MKNOD",
    "NET_BIND_SERVICE",
    "NET_RAW",
    "SETFCAP",
    "SETGID",
    "SETPCAP",
    "SETUID",
    "SYS_CHROOT",
    "SYS_MODULE"
  ],
  "CapDrop": [
    "AUDIT_CONTROL",
    "BLOCK_SUSPEND",
    "DAC_READ_SEARCH",
    "IPC_LOCK",
    "IPC_OWNER",
    "LEASE",
    "LINUX_IMMUTABLE",
    "MAC_ADMIN",
    "MAC_OVERRIDE",
    "NET_ADMIN",
    "NET_BROADCAST",
    "SYSLOG",
    "SYS_ADMIN",
    "SYS_BOOT",
    "SYS_NICE",
    "SYS_PACCT",
    "SYS_PTRACE",
    "SYS_RAWIO",
    "SYS_RESOURCE",
    "SYS_TIME",
    "SYS_TTY_CONFIG",
    "WAKE_ALARM"
  ],
  "CgroupnsMode": "private",
  "Dns": [],
  "DnsOptions": [],
  "DnsSearch": [],
  "ExtraHosts": [],
  "GroupAdd": null,
  "IpcMode": "private",
  "Cgroup": "",
  "Links": null,
  "OomScoreAdj": 0,
  "PidMode": "",
  "Privileged": true,
  "PublishAllPorts": false,
  "ReadonlyRootfs": false,
  "SecurityOpt": [
    "label=disable"
  ],
  "UTSMode": "",
  "UsernsMode": "",
  "ShmSize": 67108864,
  "Sysctls": {
    "net.ipv4.conf.all.src_valid_mark": "1"
  },
  "Runtime": "runc",
  "Isolation": "",
  "CpuShares": 0,
  "Memory": 0,
  "NanoCpus": 0,
  "CgroupParent": "",
  "BlkioWeight": 0,
  "BlkioWeightDevice": null,
  "BlkioDeviceReadBps": null,
  "BlkioDeviceWriteBps": null,
  "BlkioDeviceReadIOps": null,
  "BlkioDeviceWriteIOps": null,
  "CpuPeriod": 0,
  "CpuQuota": 0,
  "CpuRealtimePeriod": 0,
  "CpuRealtimeRuntime": 0,
  "CpusetCpus": "",
  "CpusetMems": "",
  "Devices": [],
  "DeviceCgroupRules": null,
  "DeviceRequests": [],
  "MemoryReservation": 0,
  "MemorySwap": -1,
  "MemorySwappiness": null,
  "OomKillDisable": null,
  "PidsLimit": null,
  "Ulimits": null,
  "CpuCount": 0,
  "CpuPercent": 0,
  "IOMaximumIOps": 0,
  "IOMaximumBandwidth": 0,
  "MaskedPaths": [
    "/proc/asound",
    "/proc/acpi",
    "/proc/kcore",
    "/proc/keys",
    "/proc/latency_stats",
    "/proc/timer_list",
    "/proc/timer_stats",
    "/proc/sched_debug",
    "/proc/scsi",
    "/sys/firmware"
  ],
  "ReadonlyPaths": [
    "/proc/bus",
    "/proc/fs",
    "/proc/irq",
    "/proc/sys",
    "/proc/sysrq-trigger"
  ],
  "Init": false
}
[
  "VPN_ENABLED=yes",
  "VPN_USER=*******",
  "VPN_PASS=*******",
  "VPN_PROV=pia",
  "VPN_CLIENT=wireguard",
  "STRICT_PORT_FORWARD=yes",
  "ENABLE_PRIVOXY=yes",
  "LAN_NETWORK=172.18.0.0/16",
  "NAME_SERVERS=84.200.69.80,37.235.1.174,1.1.1.1,37.235.1.177,84.200.70.40,1.0.0.1",
  "DELUGE_DAEMON_LOG_LEVEL=debug",
  "DELUGE_WEB_LOG_LEVEL=debug",
  "DELUGE_ENABLE_WEBUI_PASSWORD=yes",
  "VPN_INPUT_PORTS=1234",
  "VPN_OUTPUT_PORTS=5678",
  "DEBUG=false",
  "UMASK=000",
  "PUID=0",
  "PGID=0",
  "PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin",
  "HOME=/home/nobody",
  "TERM=xterm",
  "LANG=en_GB.UTF-8"
]
Edited by mirhunter
Link to comment

Hi All wonder if anyone can help with an issue i have encountered.

 

I have DelugeVPN setup and i have my SabNZBD going via this but im experiencing slow downloads when doing this if nothing is downloading via torrents SABNZBD runs at its normal speed but if Deluge is downloading the speed on SABNZDB drops from 13MB/s to 1MB/s meanwhile Deluge  is not getting above 400 KiB/s.

 

Does anyone know why this could be occuring

Link to comment

Hi there, I'm having an issue, my DelugeVPN Docker container stopped working!

 

 

2024-04-20 13:21:24,478 DEBG 'start-script' stdout output:
2024-04-20 13:21:24 read UDPv4 [ECONNREFUSED]: Connection refused (fd=3,code=111)

2024-04-20 13:21:26,712 DEBG 'start-script' stdout output:
2024-04-20 13:21:26 read UDPv4 [ECONNREFUSED]: Connection refused (fd=3,code=111)

2024-04-20 13:21:30,052 DEBG 'start-script' stdout output:
2024-04-20 13:21:30 read UDPv4 [ECONNREFUSED]: Connection refused (fd=3,code=111)

2024-04-20 13:21:38,806 DEBG 'start-script' stdout output:
2024-04-20 13:21:38 read UDPv4 [ECONNREFUSED]: Connection refused (fd=3,code=111)

 

Same message, but the number before DEBG changes each time.

 

Here it the error message I'm keep getting. Rebooting the server didn't solve the issue. I've looked online, and seen, that there was this issue a year ago, but there is no answer how to solve it...

 

I have completely reinstalled the docker container, but the issue persists.

 

Does anyone has an idea what to do?? I think it has something to do with read write permissions .. but I don't know what to change and how...

 

Edit: Don't know if important, but today I've restarted the server (adding more RAM). And additionally I've increased the docker virtual disk.

 

Edit2: Found a solution. In my case it seems that the VPN Provider Server, which was used for the past years, doesn't exist anymore. After reinstalling everything from scratch, I needed the new VPN Settings and found out, that my old server wasn't available anymore (couldn't find the .ovpn server file anymore).

 

Cheers!

Edited by Doublemyst
found solution
Link to comment

Hi!

I had this issue last year but fell sick so sadly had to drop troubleshooting. For that please forgive me. 

For some reason that I cannot fathom I'm unable to get Sonarr to route through Deluge VPN however, I've managed to get Radarr working through it fine. Below are steps that i've done. 

1. Gone to the Sonarr docker image, and under extra params added `--net=container:binhex-delugevpn`
2. Under the same Sonarr docker image, I've set the network type to `none`
3. Gone to the deluge vpn docker image, edited it and added port `8989` under `VPN_INPUT_PORTS` & `VPN_OUTPUT_PORTS`
4. Added another port for `TCP` under the same deluge vpn docker for port `8989`

When i visit the deluge vpn image ip address followed by `:8989`, it simply refuses to load. But when i do `:7878` (used by Radarr) for which i've followed the same process for as the above four steps it works. Its simply Sonarr that doesn't want to talk to the vpn image. FWIW I'm of-course using all binhex images for sonarr, radarr and deluge-vpn.

Any help would be appreciated. Thank you! 

Edited by Inch
Link to comment
2 minutes ago, JonathanM said:

If you set the network to bridge without changing anything else, does it work as expected, other than not running through the vpn?

Hi :)

Yes when i removed `--net=container:binhex-delugevpn`, and set the network to bridge, it works fine and goes through the first time setup. 

Link to comment
2 minutes ago, JonathanM said:

Try deleting that and entering it again. It's missing the container port entry for some reason.

image.png.8f6d50bd7c25531c28eae18eb25a8673.png

Tried that, still doesn't show it. The same applies to the 7878 port that i added to the container for Radarr and thats working fine. It is showing container port under it though. 
image.thumb.png.ec6c3bf0c9724c7a3184e698e0ee5a06.png

Link to comment
2 minutes ago, Inch said:

Tried that, still doesn't show it.

Probably because you are using a custom network for delugevpn instead of the default bridge. Binhex doesn't support anything but plain bridge. Doesn't mean you can't make it work, but it can be challenging.

 

Maybe the radarr port was added while you were in plain bridge mode?

Link to comment
Just now, JonathanM said:

Probably because you are using a custom network for delugevpn instead of the default bridge. Binhex doesn't support anything but plain bridge. Doesn't mean you can't make it work, but it can be challenging.

 

Maybe the radarr port was added while you were in plain bridge mode?

I've tried plain bridge mode and custom network with the same results. I've just switched back to bridge, readded the sonarr port (specified 8989 in both) and it still doesn't work yet Radarr does still. 

Link to comment
1 minute ago, Inch said:

I've tried plain bridge mode and custom network with the same results. I've just switched back to bridge, readded the sonarr port (specified 8989 in both) and it still doesn't work yet Radarr does still. 

Strange. I'm out of things to try at this point. Maybe someone else will have some ideas.

Link to comment

I forgot my web-gui password to binhex - DelugeVPN. I tried the following without success.

 

Quote

How can I reset forgotten password?

Stop the Web UI before modifying the web.conf file.

Edit web.conf in config and delete the entire pwd_sha1 line or use quick method via command-line e.g.:

sed -i.bak "/pwd_sha1/d" ~/.config/deluge/web.conf

Start the Web UI and the password will have been reset to default password deluge.

 

 I did not try the command-line since I don't know what I'm doing.

Any suggestion would be appreciated.

Link to comment

Hey y all !
So i am having this issue here :
First of all my deluge was not seeding, so i looked in the detail of the protonvpn and to add peertopeer i needed to add p2p to username, okay boom ! Done it works but now i have the following
When trying to add a torrent i got the not authorized error.
I do not know what do, did all updates, tried restarting all dockers. Still nothing thanks for the help !
 

 

2024-04-23 13:46:27,794 DEBG 'watchdog-script' stdout output:
[info] Privoxy not running

2024-04-23 13:46:27,795 DEBG 'watchdog-script' stdout output:
[info] Attempting to start Deluge...
[info] Removing deluge pid file (if it exists)...

2024-04-23 13:46:27,951 DEBG 'watchdog-script' stdout output:
[info] Deluge key 'listen_interface' currently has a value of '10.98.0.14'
[info] Deluge key 'listen_interface' will have a new value '10.98.0.14'
[info] Writing changes to Deluge config file '/config/core.conf'...

2024-04-23 13:46:28,125 DEBG 'watchdog-script' stdout output:
[info] Deluge key 'outgoing_interface' currently has a value of 'tun0'
[info] Deluge key 'outgoing_interface' will have a new value 'tun0'
[info] Writing changes to Deluge config file '/config/core.conf'...

2024-04-23 13:46:28,305 DEBG 'watchdog-script' stdout output:
[info] Deluge key 'default_daemon' currently has a value of '14dceec26aea434e91fbe8879ac984c6'
[info] Deluge key 'default_daemon' will have a new value '14dceec26aea434e91fbe8879ac984c6'
[info] Writing changes to Deluge config file '/config/web.conf'...

2024-04-23 13:46:28,341 DEBG 'watchdog-script' stdout output:
[info] Deluge process started
[info] Waiting for Deluge process to start listening on port 58846...

2024-04-23 13:46:28,776 DEBG 'watchdog-script' stdout output:
[info] Deluge process listening on port 58846

2024-04-23 13:46:30,489 DEBG 'watchdog-script' stderr output:
<Deferred at 0x14942c291f90 current result: None>

2024-04-23 13:46:30,558 DEBG 'watchdog-script' stdout output:
[info] No torrents with state 'Error' found

2024-04-23 13:46:30,559 DEBG 'watchdog-script' stdout output:
[info] Starting Deluge Web UI...

2024-04-23 13:46:30,559 DEBG 'watchdog-script' stdout output:
[info] Deluge Web UI started

2024-04-23 13:46:30,560 DEBG 'watchdog-script' stdout output:
[info] Attempting to start Privoxy...

2024-04-23 13:46:31,567 DEBG 'watchdog-script' stdout output:
[info] Privoxy process started
[info] Waiting for Privoxy process to start listening on port 8118...

2024-04-23 13:46:31,575 DEBG 'watchdog-script' stdout output:
[info] Privoxy process listening on port 8118

2024-04-23 13:47:24,407 DEBG 'watchdog-script' stderr output:
Unhandled error in Deferred:

2024-04-23 13:47:24,420 DEBG 'watchdog-script' stderr output:

Traceback (most recent call last):
  File "/usr/lib/python3.11/site-packages/twisted/internet/defer.py", line 892, in _runCallbacks
    current.result = callback(  # type: ignore[misc]
  File "/usr/lib/python3.11/site-packages/twisted/internet/defer.py", line 1371, in _cbDeferred
    self.callback(cast(_DeferredListResultListT, self.resultList))
  File "/usr/lib/python3.11/site-packages/twisted/internet/defer.py", line 696, in callback
    self._startRunCallbacks(result)
  File "/usr/lib/python3.11/site-packages/twisted/internet/defer.py", line 798, in _startRunCallbacks
    self._runCallbacks()
--- <exception caught here> ---
  File "/usr/lib/python3.11/site-packages/twisted/internet/defer.py", line 892, in _runCallbacks
    current.result = callback(  # type: ignore[misc]
  File "/usr/lib/python3.11/site-packages/deluge/ui/web/json_api.py", line 187, in _on_rpc_request_failed
    return self._send_response(request, response)
  File "/usr/lib/python3.11/site-packages/deluge/ui/web/json_api.py", line 229, in _send_response
    response = json.dumps(response)
  File "/usr/lib/python3.11/json/__init__.py", line 231, in dumps
    return _default_encoder.encode(obj)
  File "/usr/lib/python3.11/json/encoder.py", line 200, in encode
    chunks = self.iterencode(o, _one_shot=True)
  File "/usr/lib/python3.11/json/encoder.py", line 258, in iterencode
    return _iterencode(o, 0)
  File "/usr/lib/python3.11/json/encoder.py", line 180, in default
    raise TypeError(f'Object of type {o.__class__.__name__} '
builtins.TypeError: Object of type Failure is not JSON serializable


2024-04-23 13:47:24,420 DEBG 'watchdog-script' stderr output:
Unhandled error in Deferred:

Traceback (most recent call last):
Failure: deluge.error.NotAuthorizedError: Auth level too low: 0 < 5


 

Link to comment
  • 2 weeks later...

The 2.1.1-5-01 update broke my YaRSS2 plugin.  I tried a few different versions of the egg and ways to name it, since it can be a bit fussy, but was unable to get it to enable.  Rolled back to 2.1.1-4-09 and it's working there.  

Link to comment
  • 3 weeks later...

I run on UnRaid and have had zero problems for more than a year but after the most recent update of the container the client do not work as it should 😞

After seemingly succeeding to connect I see no list of torrents in progress and I cant add new torrents. I can however 

I see and even change the preferences.

 

In Deluged container log I see no errors but in the file config/deluged.log (that I can list when connecting to the container console) I find this:

 

Deluge client disconnected: Connection to the other side was lost in a non-clean fashion: Connection lost.

 

Any tips?

 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...