**VIDEO GUIDE** How to Install MacOS Mojave or High Sierra as a VM


Recommended Posts

42 minutes ago, ChadwickTheCrab said:

Hey, just trying out this guide on RC15 and I'm running into a snag. I set the OVMF resolution to 1920x1080 but it seems like my noVNC window is cropping the display. I boot fine into the setup but I can't see all of the screen. How do I get noVNC 1:1 with the VM?

Grab the window and adjust the size. Vnc should then auto readjust the size based on window size.

Link to comment
4 hours ago, david279 said:

try a different vnc client. Chicken of the VNC, VNC viewer, tightVNC etc.

I get similar results with TightVNC. Is there a way to adjust the resolution of Clover from the Clover GUI? I feel like it's not matching up to whatever the default is set to.


Edit: I think I may be on to something. I edited the Clover config.plist file and found the resolution was set to 1280x1024. I modified it to 1920x1080 and I'm going to try again.

Edited by ChadwickTheCrab
Link to comment
10 hours ago, Froger said:



I got it to boot !!! Looks like the Clover is the problem. After removing video card from the VM and injecting VNC to the xml it booted ! I checked Clover settings inside Mac VM and it seems like everything is fine there. Same as in Advanced OSX VM techniques for KVM in unRAID ;) Any idea how to make it work ? Should I update Clover ? My version: 3974

Ah, I would probably guess then that the VM is actually booting and the GPU is actually working.

But now OSX is outputting from a different port from your GPU as the default. I had this happen when I upgraded from el Capitan to Sierra.  If you have your card connected by HDMI to your monitor you may find that it is outputting from the DVI port. Can you connect it from that port to the monitor? Also, try the display port.

I am sure you will find one is working.

You can update clover to the last version (but I doubt this would help your problem) but for clover to work un patched we must use vmware-cpuid-freq=on in our XML so the VM runs at the correct speed.


<qemu:arg value='Penryn,vendor=GenuineIntel,kvm=on,+invtsc,vmware-cpuid-freq=on'/>

Also for the vmware-cpuid-freq=on to be recognised you need to be using pc-q35-2.9 or above so 

<type arch='x86_64' machine='pc-q35-2.10'>hvm</type>

Using the vmware - cpuid -freq=on you should be free to update clover to whatever version comes out without issue. Before we couldn't due to the timing issues without using a patched clover.


Link to comment
7 hours ago, ChadwickTheCrab said:

I get similar results with TightVNC. Is there a way to adjust the resolution of Clover from the Clover GUI? I feel like it's not matching up to whatever the default is set to.


Edit: I think I may be on to something. I edited the Clover config.plist file and found the resolution was set to 1280x1024. I modified it to 1920x1080 and I'm going to try again.

Yes the resolution in the ovmf and osx (from config.plist must match) in my guide to create the install media you will find a config.plist which has the correct resolution and correct machine definitions etc https://youtu.be/BFPiK1Ggbks?t=6m42s      link to those files  https://www.dropbox.com/s/zq4020mly9mgkw4/os sierra_highsierra support files.zip?dl=0


Link to comment
On 12/7/2017 at 9:45 AM, david279 said:

Update successful.....Ran update selected the install from HD selection in clover. It installs then boots right back up. Installed the alternate graphic drivers and everythings all good. Will try updating clover now.  

Thank you for the info David!  I've been trying to get my Mac VM installed and running since Sunday.  Probably tried 15 times since then to get the 10.13.2 update to work.  VERY IMPORTANT TIP for anyone else......  You have to use the "Install from <Hard Drive>" option at the Clover menu for this to complete right.  I'm no expert with Clover, but all the other attempts, I let it do the automatic selection with the Preboot Install option and it always hung with the progress bar about 1/8 of the way across.

For informational purposes, this was a clean install of High Sierra following the video.  No custom anything until I got the update to run.  I tried q35-2.9 and 2.10.  I tried multiple Clover versions starting at 4200 up to the current of 4334.  Nothing had any affect until I tried the "Install from HD" menu option in Clover.


I've also had mixed experiences with the VNC mouse cursor.  New install 4 times through this process.  First attempt, cursor sync was fine.  Next 3, it's all messed up.  1 time in between, when I had changed q35-2.9 to 2.10 in the XML file, the cursor fixed itself.  No other changes on that boot, but the cursor was syncing fine.  Right now, it's messed up, but if using NoMachine, Splashtop or Mac Screensharing from another Mac the cursor works fine.  I'm only using the built in VNC to access the clover menu.  After that I switch and normal boots, I don't need to select anything on the Clover menu, so it won't matter.


Happy to finally have it installed and fully updated!  Everything appears to be working great!

Off the get my passthrough devices working so I can use this for my daily desktop machine instead of my older Macbook Pro.

Link to comment

Anyone have any luck with dual monitors?  After my last post, I have ALL of my passthrough hardware working correctly.  I passed through one of the USB controller on my motherboard and that is working wonderfully.  I passed through 2 different NVIDIA GTX 960 video cards.  1 is an MSI and the other is a Gigabyte and have had the same results with both cards.  If I boot with a single display connected, everything works as expected.  If I boot with 2 displays plugged in, after the apple logo loading screen, the displays go blank and say there is no signal.  If I boot single display and then hotplug the second display, I have to play games with the hotplugging to get them to work.  They go snow, then 1 will show the desktop, then snow, then the other shows the desktop.  Eventually, after 3 or 4 tries, I can et both displays to work correctly.

If anyone else has any experiences with dual monitors and/or knows of a fix or somewhere to look, please let me know.  I did do a couple of searches, but didn't find anything specifically related to High Sierra.  I also found some details about AMD cards, but not NVIDIA.

I must say that I am extremely happy otherwise with my build.  I have an Unraid server, my game machine and my daily Mac desktop all on 1 piece of hardware and it's all running really smooth and snappy.  The graphics performance on both operating systems is phenomenal, even when using both at the same time.  I have not noticed any drive performance issues either, even when copying some pretty large files over from my old gaming PC and still working on my Mac install at the same time.


Thanks so much for your information and guidance gridrunner.

Link to comment
  • 2 weeks later...

Has anyone been having any weird oddities with their NVIDIA GPU in High Sierra?  I definitely can’t boot MacOS with 2 displays connected.  With a single display, it loads and works fine, but then occasionally the display will just go black for 4-5 seconds and then come back on.  Once in a while, the display actually go black and then my screen says there’s no signal.  This is with only 1 connected.  To correct it, I have to pull the HDMI cable for a few seconds and plug it back in.

2 Displays has some oddities too after the OS loads.  Whether on mirror or not, when plugging in the 2nd display the screens will only sometimes go to snow, then black, then back to snow and then to the proper display.  Sometimes I need to pull cables and plug them back in to get the correct display.

I love everything else about this install, but the video issues are just weird and can be annoying.  I’d post this elsewhere, but I’m assuming the problems with the display are related to High Sierra being that I’m having issues with single display and everyone says Sierra works perfect.  I have not seen any threads specific to High Sierra and NVIDIA gpu passthrough problems.

Link to comment

Got everything working up until the part where I need to format my vdisk with Disk Utility, I get an error everytime I try to format the disk.  the vdisk I created is set to SATA like you explicitly say.  Not sure how to proceed.  I have tried formatting the disk with several of the available options, all fail, with the same error.



Screen Shot 2018-01-01 at 11.23.06 AM.png

Link to comment

Spx404, do some searches or read through this message thread.  Well I don’t remember what the answer is, I could swear that there was something posted about what to do if that happens. Maybe I’m wrong, but I’m pretty sure.  If not, I’m sure someone on here can make a suggestion.

Link to comment
57 minutes ago, ckoepf said:

planetwilson, see my message a few back about the update.  You HAVE to select the right boot option on clover or it won't work.  I said that I was having exactly the same problem.


Okay thanks will see if I can get one of the other options to work. It's a bit confusing really. I removed the disk image from the VM XML so I don't understand why I have 3 or 4 different boot options in Clover now.

Edited by planetwilson
Link to comment

Thanks again @gridrunner for the video and all the other helpful Unraid videos.


I gave it another try with the very latest clover file and now all appears to work for me. Fingers crossed this stays stable for me.


One Q - is it helpful and even possible to update Clover to later versions over the next weeks and months. Would I need an USB image again or could do this right out of the VM? Right now, my VM starts a xmas Clover screen upon bootup.

Link to comment

Download the new version and install using the same parameters as your install disk. Then copy the clover folder from your Mac os install disk over to the efi of your Hackintosh main disk. Use the efi mounter program to mount the efi partition. I personally keep a copy of my install disk clover folder in a Hackintosh folder on my desktop along with all the other Hackintosh tools I need for installs.

Sent from my SM-G955U using Tapatalk

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.