Jump to content
barakthecat

Time Machine over SMB (Mac OS Sierra)

82 posts in this topic Last Reply

Recommended Posts

14 hours ago, phenomeus said:

tried everything by now… not working. same odd error "The network backup disk does not support the required capabilities"

 

even a freshly installed Mojave macOS on another macbook gets the same error. so I assume I have to search here at unraid for the solution. did exactly what everyone else did. hidden time machine, normal, secured, public, empty directory, deleted share, created a new one 

 

every time the same error. its mounting the drive but error 45 in console. I can upload files to it, its not about write permissions

 

I've had no issues at all but I've used a new share on my unraid server for Time-Machine and completely disabled AFP in unraid beforehand.

I tested with and without the use of my cache drive and settled on without since the backup speed saw little difference!

Both MacBooks are running the latest version of OSX.

 

image.png.e29ef4b2b406a8b164eb3ccedb951b97.png

Share this post


Link to post
Posted (edited)

I had a lot of problems to connect too until I changed the name of the share. I used "TimeMachine" as the name of the share and I got errors back from timemachine (Permission denied (error 13) even the username/password were correct) until I changed the name of the share to something else. Then suddenly it connected without problems.

Edited by boris

Share this post


Link to post

I tried that already. still no luck…

 

- afp is disabled

- Enhanced macOS interoperability is on

- public, secure or private doesnt matter

- new share names

- Different sizes

- with or without cache drive

- 2 MacBooks, brand new reinstalled or one that worked with afp 

- up2date macOS installations

- … 

Share this post


Link to post
Posted (edited)
On 4/11/2019 at 2:38 PM, phenomeus said:

I tried that already. still no luck…

 

- afp is disabled

- Enhanced macOS interoperability is on

- public, secure or private doesnt matter

- new share names

- Different sizes

- with or without cache drive

- 2 MacBooks, brand new reinstalled or one that worked with afp 

- up2date macOS installations

- … 

 

@phenomeus - my brother was just having this same issue with his. "The network backup disk does not support the required capabilities"

 

I tweaked his settings and seemed to fix it. He had the "Split level" set to manual - changed it to automatic and changed to only a single included disk and no cache. Also changed share name to "TimeMachine", set export to yes/Time Machine (hidden) and Public security and hit apply. Seemed to clear it up for him. Good luck!

Edited by sreknob
added in error

Share this post


Link to post

finally did it. sreknobs tips couldn't help… 

 

so I took all the crap out of my smb extra configurations:

 

[global]
security = USER
guest account = nobody
public = yes
guest ok = yes
map to guest = bad user
kernel oplocks = no
oplocks  = no
level2 oplocks = no

#unassigned_devices_start
#Unassigned devices share includes
   include = /tmp/unassigned.devices/smb-settings.conf
#unassigned_devices_end

 

and emptied it. voila! it's working. can anyone tell me what was important in that config?

Share this post


Link to post

i reinserted it and commented everything out besides the low include command for unassigned shares. so its still working. something in the global part f'ckd something up

Share this post


Link to post
3 minutes ago, phenomeus said:

can anyone tell me what was important in that config?

I would leave the Unassigned Devices section. AFAIK it’s still needed.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.