Jump to content
linuxserver.io

[Support] Linuxserver.io - Duplicati

250 posts in this topic Last Reply

Recommended Posts

Can this be used to backup one unraid server to another?  I'd love to be able to take a couple of the shares on my primary server, encrypt them, and drop them on my secondary unraid server once a month.  

 

Disregrad..... testing it now.

Edited by tucansam

Share this post


Link to post

Has anyone tried this container successfully on Alpine linux (host)? 

 

And when I try to run the same container on Ubuntu as host it runs the server fine:

[services.d] starting services
[services.d] done.
Server has started and is listening on 0.0.0.0, port 8200

 

On Alpine linux as host the log ends at:

.

.[services.d] starting services
[services.d] done.

 

 - - edit - -

 

When I run the start script from within the container on Alpine (host):

$ bash /etc/services.d/duplicati/run

Then the message is Segmentation fault.

 

Any hints as to how to get s6 overlay to play nice with Alpine (host)?

 

Edited by Ari

Share this post


Link to post

Hi,

according to Duplicati interface -> About -> "You are currently running Duplicati - 2.0.2.1_beta_2017-08-01"

 

Is this correct if I'm running the latest docker?

 

 

 

Share this post


Link to post

Is someone using any of the script options (--run-script-before   /   --run-script-before-required   /   --run-script-after)?

 

I am always getting an error:  The script "/path/to/script/foobar.sh" returned with exit code 255.

 

I've searched for error code 255 without much luck.

Share this post


Link to post
2 minutes ago, BBriner said:

Is someone using any of the script options (--run-script-before   /   --run-script-before-required   /   --run-script-after)?

 

I am always getting an error:  The script "/path/to/script/foobar.sh" returned with exit code 255.

 

I've searched for error code 255 without much luck.

 

Don't know this container,  but are you using the unraid path or have you placed the script inside a volume in the container? 

Share this post


Link to post
24 minutes ago, saarg said:

 

Don't know this container,  but are you using the unraid path or have you placed the script inside a volume in the container? 

 

The path is accessible from outside and inside the container and I can run it without any problem from the shell inside the container.

 

I also tried to copy the script to a path that is only accessible inside the container and the same error shows up.

Share this post


Link to post

Easier if you just type the path here and I'll tell you if it can be used.

Share this post


Link to post
56 minutes ago, saarg said:

Easier if you just type the path here and I'll tell you if it can be used.

 
 

Container Path: /source
Host Path: /mnt/

In the Container, run-script-before: /source/user/Documents/Scripts/SendMessage.sh "Duplicati Job Started"


Script SendMessage.sh

 

#/bin/bash

curl -k -s \
-X POST \
https://api.telegram.org/botfoobarfoobar:FooBarFooBar/sendMessage \
-d text="$1" \
-d chat_id=12345678 \

exit 0

Share this post


Link to post

Can you post the output of the two below commands.

 

ls -la /mnt/user/Documents/Scripts/
docker exec -it -u abc duplicati ls -la /source/user/Documents/Scripts/

 

Share this post


Link to post
On 11/9/2017 at 7:50 PM, tompa said:

Hi,

according to Duplicati interface -> About -> "You are currently running Duplicati - 2.0.2.1_beta_2017-08-01"

 

Is this correct if I'm running the latest docker?

 

Looks right due to update channel is "Default", guess all later updates are on "Beta" channel?

Didn't see this (Update channel) when I first asked.

Share this post


Link to post
6 hours ago, saarg said:

Can you post the output of the two below commands.

 


ls -la /mnt/user/Documents/Scripts/

docker exec -it -u abc duplicati ls -la /source/user/Documents/Scripts/

 

 

 

I started from scratch everything (Docker, Duplicati Jobs, Script) and now it is working fine. Probably something very silly was happening.

Share this post


Link to post

Im also on this Beta Chanel. Is that a problem wich I should work on or will that change with container updates?

Furthermore I have a problem that my Docker image is growing significantly, every time my backups are running and deflates again when they are ready. Can I map a directory outside my container that these temporary data witch seems to blow up my image is stored outside the container?

Share this post


Link to post

I ran into an interesting issue that hopefully i can get some insight on. I added a smb share in unassigned devices and mounted it, then i installed duplicati and had the destination folder be the newly mapped smb share. I started the backup procedure but after ~5 minutes of it running duplicati itself goes unresponsive. I cannot access the webgui, i cannot stop/restart the container and docker in general appears to only be partially functional afterwards. If i try to stop the array it never actually stops because the duplicati container wont stop. If i end up getting it rebooted and the array back online then as soon as duplicati runs again the same situation happens.

 

Any ideas?

Share this post


Link to post

Duplicati was working fine for weeks but now all of a sudden I get a "The connection to the server is lost" I've tried restarting it but same error comes up

Share this post


Link to post
On 12/9/2017 at 9:42 PM, hermy65 said:

I ran into an interesting issue that hopefully i can get some insight on. I added a smb share in unassigned devices and mounted it, then i installed duplicati and had the destination folder be the newly mapped smb share. I started the backup procedure but after ~5 minutes of it running duplicati itself goes unresponsive. I cannot access the webgui, i cannot stop/restart the container and docker in general appears to only be partially functional afterwards. If i try to stop the array it never actually stops because the duplicati container wont stop. If i end up getting it rebooted and the array back online then as soon as duplicati runs again the same situation happens.

 

Any ideas?

Same here. Worrying that a docker can bring down the webui and make the server refuse to shutdown/reboot.

Share this post


Link to post
On 12/9/2017 at 4:42 PM, hermy65 said:

I ran into an interesting issue that hopefully i can get some insight on. I added a smb share in unassigned devices and mounted it, then i installed duplicati and had the destination folder be the newly mapped smb share. I started the backup procedure but after ~5 minutes of it running duplicati itself goes unresponsive. I cannot access the webgui, i cannot stop/restart the container and docker in general appears to only be partially functional afterwards. If i try to stop the array it never actually stops because the duplicati container wont stop. If i end up getting it rebooted and the array back online then as soon as duplicati runs again the same situation happens.

 

Any ideas?

 

4 minutes ago, PlayerOne said:

Same here. Worrying that a docker can bring down the webui and make the server refuse to shutdown/reboot.

 

 

Solution: https://forums.lime-technology.com/topic/57181-real-docker-faq/?page=2&tab=comments#comment-608304

 

Share this post


Link to post

Am I the only one that gets a Password screen on entering the docker? 

 

I tried every password i know, and nothing happens...

 

I tried to remove and re-install the docker, same thing.........

duplicati.png

Share this post


Link to post

You should only see that if you've set a password in Duplicati's settings.  Probably the easiest solution for you is to remove the app, delete the appdata (or use a different appdata folder for the /config) and then reinstall

Share this post


Link to post

Trying to set this up with Google Drive and getting the below message when the backup runs. I did enable no-auto-compact. I'm running a fresh backup for the first time so I don't care about losing data on the Google Drive (there isn't any there anyway). Any ideas?

 

"The backup contains files that belong to another operating system. Proceeding with a backup would cause the database to contain paths from two different operation systems, which is not supported. To proceed without losing remote data, delete all filesets and make sure the --no-auto-compact option is set, then run the backup again to re-use the existing data on the remote store."

Share this post


Link to post
11 hours ago, ScoHo said:

Trying to set this up with Google Drive and getting the below message when the backup runs. I did enable no-auto-compact. I'm running a fresh backup for the first time so I don't care about losing data on the Google Drive (there isn't any there anyway). Any ideas?

 

"The backup contains files that belong to another operating system. Proceeding with a backup would cause the database to contain paths from two different operation systems, which is not supported. To proceed without losing remote data, delete all filesets and make sure the --no-auto-compact option is set, then run the backup again to re-use the existing data on the remote store."

 

Could you try backing up somewhere else? Like B2, just as a test don't do the full backup. Just to work out if its Google Drive or something else?

Share this post


Link to post
10 minutes ago, MyKroFt said:

Anyway the following can be added to the container?  Would be nice to know what its doing via email etc...

 

https://github.com/HandyGuySoftware/dupReport

 

Thanks

Myk

 

 

Not really a fan of starting to add random plugins to containers. 

 

You could create a subfolder in duplicati appdata called dupreport and call the script using user.scripts

 

docker exec -it duplicati /path/to/python /config/dupreport/dupReport.py

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.