Jump to content
Djoss

[Support] Djoss - JDownloader 2

206 posts in this topic Last Reply

Recommended Posts

Support for JDownloader 2 docker container

 

Application Name: JDownloader 2
Application Sitehttp://jdownloader.org/
Docker Hub: https://hub.docker.com/r/jlesage/jdownloader-2/

Github: https://github.com/jlesage/docker-jdownloader-2

 

Unlike other containers, this one is based on Alpine Linux, meaning that its size is very small (at least 50% smaller).  It also has a very nice, mobile-friendly web UI to access JDownloader 2's graphical interface and is actively supported!


Make sure to look at the complete documentation, available on Github !

 

Post any questions or issues relating to this docker in this thread.

Edited by Djoss

Share this post


Link to post

 
Unlike other containers, this one is [...] actively supported!



Ouch, that hurt

Jokes aside, great job on the vnc baseimage

Share this post


Link to post
13 minutes ago, aptalca said:

 


Ouch, that hurt emoji14.png

Jokes aside, great job on the vnc baseimage emoji106.png

 to be fare the last one if used was one i converted from dockerhub :D

But really even with your docker the vnc webui sometimes just hangs at least with my setup. And tbh i really cant stand that guacamole implementation any more. It feels like i only have issues with these ones. I havent had that issue with Djoss's Docker as of yet. The only thing missing right now is the extraction fix which he is working on, then its perfect at least for me. :D

Edited by DaLeberkasPepi

Share this post


Link to post
9 hours ago, aptalca said:

 


Ouch, that hurt emoji14.png

Jokes aside, great job on the vnc baseimage emoji106.png

 

I must admit, I am the one who asked for this, referencing the last push of your container. O.o

 

I could not resist noVNC and the alpine base...

 

Thanks for your work, both aptalca and Djoss!

 

___

 

After a bit of testing I have ran across the following issue: https://github.com/jlesage/docker-jdownloader-2/issues/1

 

JDownloader seems to require glibc to extract archives.

 

Edited by rix

Share this post


Link to post

I do not get it working. I get ERR_CONNECTION_REFUSED  as Error. I used the commands in the wiki and installed it with default values. Any hint for me?

Share this post


Link to post

Commands in the wiki?  Did you installed the container via the Community Applications plugin?

Share this post


Link to post
5 minutes ago, Djoss said:

Commands in the wiki?  Did you installed the container via the Community Applications plugin?

Yeah I installed first via Community Application, it did not work also the connection refused. I did not change any settings just set additional the values for config and output. After that I uninstalled and installed it again with other ports etc still no connection. At last i used the commands in the Readme in github but same error

Share this post


Link to post

Ok so remove it again and make sure to install it via the CA plugin.  Then, only set the output directory, nothing else needs to be changed.

 

After that, how do you connect to the container?

Share this post


Link to post
3 minutes ago, Djoss said:

Ok so remove it again and make sure to install it via the CA plugin.  Then, only set the output directory, nothing else needs to be changed.

 

After that, how do you connect to the container?

I reinstalled and only set the output. I connect via Dashboard pressing on the icon and clicking on webui. Still the same error.

Share this post


Link to post

To which port it tries to connect to?  What do you have in the container's log?

Share this post


Link to post
1 minute ago, Djoss said:

To which port it tries to connect to?  What do you have in the container's log?

It tries to connect to 7807

 

the log is:



[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] 00-app-niceness.sh: executing...
[cont-init.d] 00-app-niceness.sh: exited 0.
[cont-init.d] 00-app-user-map.sh: executing...
[cont-init.d] 00-app-user-map.sh: exited 0.
[cont-init.d] 00-set-home.sh: executing...
[cont-init.d] 00-set-home.sh: exited 0.
[cont-init.d] 00-take-config-ownership.sh: executing...
[cont-init.d] 00-take-config-ownership.sh: exited 0.
[cont-init.d] 10-startapp-attrs.sh: executing...
[cont-init.d] 10-startapp-attrs.sh: exited 0.
[cont-init.d] 10-vnc-password.sh: executing...
[cont-init.d] 10-vnc-password.sh: exited 0.
[cont-init.d] jdownloader2.sh: executing...
chown: /output: Operation not permitted
[cont-init.d] jdownloader2.sh: exited 1.
[cont-finish.d] executing container finish scripts...
[cont-finish.d] done.
[s6-finish] syncing disks.
[s6-finish] sending all processes the TERM signal.
[s6-finish] sending all processes the KILL signal and exiting.

Share this post


Link to post
1 minute ago, UltimateWidder said:

chown: /output: Operation not permitted

You seems to have permission issue with the output folder.  In the container settings, make sure permissions are set to Read/Write.  If it's the case, then check permissions on unraid iself...

Share this post


Link to post
5 minutes ago, Djoss said:

You seems to have permission issue with the output folder.  In the container settings, make sure permissions are set to Read/Write.  If it's the case, then check permissions on unraid iself...

Thank you very much for your fast help that was the problem

Edited by UltimateWidder

Share this post


Link to post

Hi,

 

thanks for this container.

Works like a charm. :)

 

Just one quick question.

I'm using your default container settings with 5800 --> 7808 (app to host)

Now I'm a bit confused why it's possible to reach the container with: http://<HOST IP ADDR>:5800

Shouldn't I only be able to reach the container when typing port 7808 there?

 

Thanks for clarifying

 

Edited by Marv

Share this post


Link to post
25 minutes ago, Marv said:

Shouldn't I only be able to reach the container when typing port 7808 there?

Yes, this should be the case.

So you can reach the container's web interface via port 5800 but not 7808?  Did you change the network type?  It should be set to bridge, not host.

Share this post


Link to post

Sorry I think I expressed myself not correct.

I'm not able to reach the container via port 5800 but in the container settings the WebUI is specified with: http://[IP]:[PORT:5800]

Still when opening the WebUI via my server's dashboard it opens correctly with port 7807.

Why is this working when the docker settings are not correct?

Hope this makes sense :)

Edited by Marv

Share this post


Link to post

When using the bridge network mode, the container's network is isolated from the host's one.
Thus, network ports need to be mapped between the host and the container. Ports used by the container are usually stable and always the same. It's the port on the host side that is configured.
In your case, 5800 is the port inside the container. 7807 is the port on the host. The Docker's network driver takes care of doing the proper translation. It's like having NAT between the container and the host.

  • Like 1
  • Upvote 1

Share this post


Link to post

So the setting http://[iP]:[PORT:5800] is correct. PORT is a placeholder for the configured host network port mapped to container port 5800 (web ui).

Share this post


Link to post

Good afternoon

 

I just tried to run this docker on unRaid 6.4 with a fixed IP adress, but JDownloader seems to fail to start?

When I open the browser I eventually get Server disconnected (code: 1006)

When I start the docker with bridged networking everything works as it should. Other Dockers like Plex etc. run fine with those settings.

 

See screenshots for details: 

 

JDownloader2Docker.jpg

 

Edit: I don't seem to get Click'n Load to work? I forwarded the port 9666 to the server, but it seems JDownloader is not running. 

I used -p 9666:9666/tcp to open the port, but according to the Jdownloader2 wiki you should be able to see a website on http://192.168.1.15:9666/flash/

but I can't connect. (I'm currently running the container in bridged mode).

 

I used the following command to forward the port: netsh interface portproxy add v4tov4 listenport=9666 connectaddress=<Zieladresse> connectport=9666 listenaddress=127.0.0.1

 

Edited by Meriana

Share this post


Link to post

Awesome container :)
Thank you.


But I wanted to ask if it would be possible for you to add some kind of "nice" shutdown script or something to the container when stopping it from unRAID webUI without first Exiting it from inside the container first?
See below when starting container up after shutdown.
 

Capture.JPG

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.