Jump to content
fanningert

[Support] Rocket.Chat

39 posts in this topic Last Reply

Recommended Posts

Application Name: Rocket.Chat

Application Site: https://rocket.chat/

Docker Hub: https://hub.docker.com/r/library/rocket.chat/

Github: https://github.com/RocketChat/Rocket.Chat

Template-Repository: https://github.com/fanningert/unraid-docker-templates

 

Requirements:

  •  Mondo-DB (There is a mondoDB docker image for unraid in the CA)

 

Installation (external MongoDB):

  1. Install and Start MongoDB
  2. Install Rocket.Chat docker
  3. Change the variable "Mono DB" (tech name: MONGO_URL) with the URL of your mongoDB
  4. Start Rocket.Chat and after some second it should be reachable over the Web-Frontend URL

Installation (MongoDB as docker):

  1. Install and Start MongoDB
  2. Install Rocket.Chat docker
  3. Add in the attribute "Extra Parameters" the value "--link "MongoDB:db"". MongoDB is the name of the MongoDB docker container.
  4. Change the variable "Mono DB" (tech name: MONGO_URL) to "mongodb://db/rocketchat"
  5. Start Rocket.Chat and after some second it should be reachable over the Web-Frontend URL

 

Hints:

  • By default, the first account to register on Rocket Chat becomes the admin, so if your chat room is public, do this immediately in order to prevent someone else from registering and becoming the administrator.
Edited by fanningert

Share this post


Link to post

Thanks for setting this up! I'll check it out as we are considering this for a Slack alternative at work. 

Share this post


Link to post

Trying to get this up and running, but it doesn't work. Your instructions:

 

Add in the attribute "Extra Parameters" the value "--link "MongoDB:db"". MongoDB is the name of the MongoDB docker container.

 

Don't really make any sense. There's no place to add "attributes" only variables, and variables require 3 parameters: Name, Key, and Value. The Value field can not contain quotations. 

 

So the above has to be done when creating the container under the "Advanced options" which isn't shown by default. Well and good, but even adding that doesn't help. Still fails to start MongoError: failed to connect to server [mongo:27017] on first connect [MongoError: getaddrinfo ENOTFOUND mongo mongo:27017]

Edited by joshz

Share this post


Link to post

Ok, so for anyone stuck like I was, here's how to get Rocket Chat up and running with a MongoDB docker image:

 

  1. Install and Start MongoDB docker image
  2. Install Rocket.Chat docker image
  3. Change the MONGO_URL to reflect your host IP address ( Example: mongodb://192.168.1.10:27017/rocketchat )
    1. Just be sure to use your host IP and the port you assigned to the MongoDB docker
  4. Change the ROOT_URL variable to also point to your host IP address ( Example: http://192.168.1.10:3000/rocketchat )
  5. Click apply to create the docker and it should start on its own

There doesn't appear to be any particular need to link the containers, but you could do that if you wanted and fiddle with the two variables above to reflect that.

Share this post


Link to post

@GreatWhiteGibby sorry to say it. But I am using the official docker image of RocketChat (latest tag). So every update is coming from RocketChat (last update 16 days ago -> link).

But what you can test is to force docker update over the docker advanced view of unRaid.

Share this post


Link to post

Hi there,

 

Since last night's update i cant seem to get rocket.chat started on my unraid server.

 

Logs only show this:

Will load cache for users
7 records load from users
Will load cache for rocketchat_room
13 records load from rocketchat_room
Will load cache for rocketchat_subscription
37 records load from rocketchat_subscription
Will load cache for rocketchat_settings
628 records load from rocketchat_settings
Updating process.env.MAIL_URL
Starting Email Intercepter...

 

And after that i see that the container has stopped.

Any idea what this could be?

 

Thanks in advance!

Share this post


Link to post

Hi! I have the same issue. I believe the container stops with the 139 exit code. I rolled back to the previous version temporarily, which is working fine in the same environment.

Share this post


Link to post

Hi guys, need some help with Rocket-chat and letsencrypt docker container (linuxservers).

I got running nextcloud and emby througt letsencrypt reverse proxy, everything is working fine, but I cant access from rocket chat ios app to my server.

But I can connect to rocket chat in browser...

Please help me to config nginx file in site-conf of letsencrypt appdata folder to get it working whith rocket chat 

I tried this

server {
        listen 80;
        server_name chat.vanes.mydomain.com;
        return 301 https://chat.vanes.mydomain.com$request_uri;
}
server {
	listen 443 ssl;
	server_name chat.vanes.mydomain.com;
	root /config/www;
	index index.html index.htm index.php;
	include /config/nginx/ssl.conf;
	client_max_body_size 0; add_header Strict-Transport-Security "max-age=31536000; includeSubDomains";
	location / {
        proxy_pass http://192.168.0.10:3000/;
	proxy_max_temp_file_size 2048m;
	include /config/nginx/proxy.conf;
        }
}

 

 

Share this post


Link to post

It seems I made it work

I found https://rocket.chat/docs/installation/paas-deployments/aws/#5-configure-nginx-web-server-with-tlsssl , then edited file like this

 server {
 listen 443 ssl;
 server_name chat.my.domain.com;
 ssl_certificate /config/keys/letsencrypt/fullchain.pem;
 ssl_certificate_key /config/keys/letsencrypt/privkey.pem;
 ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
 ssl_prefer_server_ciphers on;
 ssl_ciphers 'EECDH+AESGCM:EDH+AESGCM:AES256+EECDH:AES256+EDH';
 root /config/www;
 add_header Strict-Transport-Security "max-age=31536000; includeSubDomains";
 index index.html index.htm;
 # Make site accessible from http://localhost/
 server_name localhost;
 location / {
     proxy_pass http://192.168.0.10:3000/;
     proxy_http_version 1.1;
     proxy_set_header Upgrade $http_upgrade;
     proxy_set_header Connection "upgrade";
     proxy_set_header Host $http_host;
     proxy_set_header X-Real-IP $remote_addr;
     proxy_set_header X-Forward-For $proxy_add_x_forwarded_for;
     proxy_set_header X-Forward-Proto http;
     proxy_set_header X-Nginx-Proxy true;
     proxy_redirect off;
 }
 }
 server {
 listen 80;
 server_name chat.my.domain.com;
 return 301 https://$host$request_uri;
 }

now ios app can connect!

ssllab shows A+

Share this post


Link to post

Hey gang, for integrations like this for example (https://github.com/FinndropStudios/GifRocket) where would we store the files? Is there a sub directory of /mnt/user/appdata/rocketchat that I need to drop it in? 

 

thanks!

Share this post


Link to post

Hello,

since last week rocket.chat server will not start.

It says replica set required.

 

any idea how to solve this?

thank you very much

 

 

Share this post


Link to post
On 5/8/2019 at 2:05 PM, Janndr said:

Hello,

since last week rocket.chat server will not start.

It says replica set required.

 

any idea how to solve this?

thank you very much

 

 

I was able to get it working by doing the following:

Click on the MongoDB docker icon and select console

cp /etc/mongod.conf* /data/db/             ( I renamed it before copying, I think it was called mongod.conf-sample )

exit the MongoDB console

go to /mnt/user/appdata/mongodb and edit the sample conf changing the dbPath: to /data/db and the modifications to the conf file noted in https://rocket.chat/docs/installation/manual-installation/mongo-replicas/

rename the file to mongod.conf

modify the mongodb docker application

Select advanced view

Add "-f /data/db/mongod.conf" to the post arguments

and restart the mongodb docker

go back into the mongodb console, and run mongo and run rs.initiate()

then modify the rocket.chat docker container adding the variable:

MONGO_OPLOG_URL: mongodb://<SERVER>:27017/local?replSet=rs01

restart rocket.chat and it should be working fine.

Share this post


Link to post
Posted (edited)
9 hours ago, Frank76 said:

I was able to get it working by doing the following:

Click on the MongoDB docker icon and select console

cp /etc/mongod.conf* /data/db/             ( I renamed it before copying, I think it was called mongod.conf-sample )

exit the MongoDB console

go to /mnt/user/appdata/mongodb and edit the sample conf changing the dbPath: to /data/db and the modifications to the conf file noted in https://rocket.chat/docs/installation/manual-installation/mongo-replicas/

rename the file to mongod.conf

modify the mongodb docker application

Select advanced view

Add "-f /data/db/mongod.conf" to the post arguments

and restart the mongodb docker

go back into the mongodb console, and run mongo and run rs.initiate()

then modify the rocket.chat docker container adding the variable:

MONGO_OPLOG_URL: mongodb://<SERVER>:27017/local?replSet=rs01

restart rocket.chat and it should be working fine.

can you show me what you did in the config file?

Edited by Ladrek

Share this post


Link to post
Posted (edited)

I really wanted this to work, but when I add "-f /data/db/mongod.conf" to the post arguments it says it's successful, but the MongoDB docker won't start. I tried with and without the quotes.

 

Here's my mongod.conf

# mongod.conf

# for documentation of all options, see:
#   http://docs.mongodb.org/manual/reference/configuration-options/

# Where and how to store data.
storage:
  dbPath: /data/db
  journal:
    enabled: true
#  engine:
#  mmapv1:
#  wiredTiger:

# where to write logging data.
systemLog:
  destination: file
  logAppend: true
  path: /var/log/mongodb/mongod.log

# network interfaces
net:
  port: 27017
  bindIp: 127.0.0.1


# how the process runs
processManagement:
  timeZoneInfo: /usr/share/zoneinfo

#security:

#operationProfiling:

#replication:

#sharding:

## Enterprise-Only Options:

#auditLog:

#snmp:

echo -e "replication:\n  replSetName: \"rs01\"" | sudo tee -a /etc/mongod.conf

 

Edited by RichardU

Share this post


Link to post
Posted (edited)
On 5/10/2019 at 3:58 AM, Frank76 said:

I was able to get it working by doing the following:

Click on the MongoDB docker icon and select console

cp /etc/mongod.conf* /data/db/             ( I renamed it before copying, I think it was called mongod.conf-sample )

exit the MongoDB console

go to /mnt/user/appdata/mongodb and edit the sample conf changing the dbPath: to /data/db and the modifications to the conf file noted in https://rocket.chat/docs/installation/manual-installation/mongo-replicas/

rename the file to mongod.conf

modify the mongodb docker application

Select advanced view

Add "-f /data/db/mongod.conf" to the post arguments

and restart the mongodb docker

go back into the mongodb console, and run mongo and run rs.initiate()

then modify the rocket.chat docker container adding the variable:

MONGO_OPLOG_URL: mongodb://<SERVER>:27017/local?replSet=rs01

restart rocket.chat and it should be working fine.

@Frank76

 

Can you post your config file for us?

Edited by Ladrek

Share this post


Link to post
22 hours ago, Ladrek said:

@Frank76

 

Can you post your config file for us?

Sure... I see the problem. The echo line they said to in the link that I sent is supposed to be done from the command line, which ends up in the config file like:

replication:
  replSetName: "rs01"

here's my full mongod.conf:

# mongod.conf

# for documentation of all options, see:
#   http://docs.mongodb.org/manual/reference/configuration-options/

# Where and how to store data.
storage:
  dbPath: /data/db
  journal:
    enabled: true
#  engine:
#  mmapv1:
#  wiredTiger:

# where to write logging data.
systemLog:
  destination: file
  logAppend: true
  path: /var/log/mongodb/mongod.log

# network interfaces
net:
  port: 27017
  bindIp: 127.0.0.1


# how the process runs
processManagement:
  timeZoneInfo: /usr/share/zoneinfo

#security:

#operationProfiling:

#replication:

#sharding:

## Enterprise-Only Options:

#auditLog:

#snmp:
replication:
  replSetName: "rs01"

 

Share this post


Link to post
Posted (edited)
32 minutes ago, Frank76 said:

Sure... I see the problem. The echo line they said to in the link that I sent is supposed to be done from the command line, which ends up in the config file like:


replication:
  replSetName: "rs01"

here's my full mongod.conf:


# mongod.conf

# for documentation of all options, see:
#   http://docs.mongodb.org/manual/reference/configuration-options/

# Where and how to store data.
storage:
  dbPath: /data/db
  journal:
    enabled: true
#  engine:
#  mmapv1:
#  wiredTiger:

# where to write logging data.
systemLog:
  destination: file
  logAppend: true
  path: /var/log/mongodb/mongod.log

# network interfaces
net:
  port: 27017
  bindIp: 127.0.0.1


# how the process runs
processManagement:
  timeZoneInfo: /usr/share/zoneinfo

#security:

#operationProfiling:

#replication:

#sharding:

## Enterprise-Only Options:

#auditLog:

#snmp:
replication:
  replSetName: "rs01"

 

 

I did the variable however rocket wont start now.

 

image.png.c382a01c8f4d1246c1b02a5c57ba17d7.png

Edited by Ladrek

Share this post


Link to post

The new conf also did not work for me. I could get MongoDB to start if I remove  "-f /data/db/mongod.conf" from post arguments. Could that be the problem?

Share this post


Link to post
5 minutes ago, RichardU said:

The new conf also did not work for me. I could get MongoDB to start if I remove  "-f /data/db/mongod.conf" from post arguments. Could that be the problem?

i got my MongoDB working

Share this post


Link to post
16 minutes ago, Ladrek said:

i got my MongoDB working

Great. How? Could you post any changes to the conf and/or your docker cofiguration setting? Thanks.

 

Share this post


Link to post

It was working before I updated all my dockers in preparation for upgrading to 6.7, now I can't get Rocket.Chat working again.

My MongoDB seems to be running just fine, but rocket.chat is giving an error on startup saying

MongoError: not master and slaveOk=false

I have found some documentation on how to allow reading from the slave, but it is per connection, and RC creates a new connection and I can't figure out how to set that variable for RC to use. I'm getting very close to just installing it on my centos VM and be done with it.

 

 

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.