Jump to content

Can not type pipe '|' key via unraid vnc


Recommended Posts

Hi guys,


I have a few linux vms created with unraid and I am struggling to find a way to type pipe(|) in terminal via unraid vnc, either the browser version of novnc or tightvnc viewer. the keyboard mapping are all default to us keyboard, they all turn '|' to '>' for either lubuntu, manjaro or mxlinux.


when I ssh in, everything works just fine.


Could anyone give some suggestions?

  • Like 1
Link to comment

I'm having the same issue and not only does typing the '|' character ('shift + \' ) produce '>' and not the expected '|'  but the '<' key ('shift + ,') also produces '>' and not the expected '<'.  typing the non-shifted characters works fine, \ and ,


I've tried the browser vnc, tight vnc and tiger vnc.


unraid 6.5.3


arch linux typing 'SHIFT + \' produces '>' and 'SHIFT + <' produces '>'

ubuntu 14.04 typing 'SHIFT + \' produces '>' and 'SHIFT + <' produces '>'


osx high sierra both 'SHIFT + \' and 'SHIFT +' , produce a '+' over top a '_' (a "plus-minus" symbol if you will)


windows 10 - the '\' and '|' can be typed fine, but 'SHIFT + ,' produce '|' instead of '<' and 'SHIFT + .' produce '|' instead of '>'


If any logs or anything are needed, please lmk

Edited by juanamingo
Link to comment

I am also experiencing the same issue reported here.



ubuntu 16.04 typing 'SHIFT + \' produces '>' and 'SHIFT + <' produces '>'


I was setting up a new server when I experienced this issue.  I then tried booting an existing Ubuntu server that I've used for 2 years, initially setup in an unRAID VM with no issues with the pipe character.  When trying to type a pipe character, this old server also produced a > instead of |.  This appears to be an issue with either unRAID, or more likely the noVNC being used.


Link to comment
  • 2 weeks later...
  • 2 weeks later...
  • 2 years later...
  • 4 weeks later...
  • 5 months later...

I've been experiencing this issue as well. I can't type the | character, and several other keys are swapped such as # and ~. I may not have noticed but I'm taking an Intro to Linux course and just got to a section dealing with pipes. The keyboard works just fine in any other app, works fine on the unraid terminal, docker terminals etc. 


I've tried changing the keyboard layouts in the various vm's I've  got running with no effect. I'm running the ENG (Canada) layout on the Win10 machine that is accessing the vm's using VNC.


Would love to find a fix for this! Thanks!

Link to comment
  • 3 weeks later...
12 hours ago, Chlorgas said:

I've got the same issue on unraid 6.9.2. It's not possible for me to activate the "nodeadkey"-Layout in the VM-template nor the installed linux. Has someone a viable workaround for this issue?


I'm on 6.9.2 as well. Just realised I hadn't mentioned that in my post. I've also tested this with VMware and the keyboard works fine. 

Link to comment
  • 3 months later...
  • 2 months later...
  • 2 months later...
  • 2 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...