Jump to content
dorgan

[Plugin] Network Stats

209 posts in this topic Last Reply

Recommended Posts

On 10/7/2018 at 7:15 PM, dorgan said:


I am using DOCKER_APP_CONFIG_PATH in the versions I released today.

As for the other plugin, I didn’t make a requirement or anything. What happens when that’s not installed?

Just FYI if this plugin isn't installed I don't have a "stats" tab at the top of the screen. Once I installed it I was able to view the network stats from your plugin. 🙂 

Share this post


Link to post

I don't have a "Stats" tab like (apparently) everyone else here... even though I installed the plugin, it didn't create a "Stats" tab.. so I'm not sure if this is even working or not...

Share this post


Link to post
3 hours ago, CoZ said:

I don't have a "Stats" tab like

Install Dynamix System Stats.  I gets @dorgan hasn't included the stats.page file as of yet in his plugin

Share this post


Link to post
Install Dynamix System Stats.  I gets [mention=78375]dorgan[/mention] hasn't included the stats.page file as of yet in his plugin

I’ll make this update and the other on above tomorrow. Sorry life has been hectic lately.

Share this post


Link to post
On 12/9/2018 at 12:00 AM, dorgan said:


I’ll make this update and the other on above tomorrow. Sorry life has been hectic lately.

Thanks for the work on this so far, unfortunetaly I don't have "Dynamix System Stats" so I have no stats page, but your plugin is running on my server and the service is started.  Looking forward to an updated version that gives me the "Stats" tab on my UnRaid 6.6.6.

 

I just want to be clear, you are planning to update your plugin to add this "Stats" tab right?  I would prefer not to install more plugins then I need to if I don't have to.

Share this post


Link to post

I just want to be clear, you are planning to update your plugin to add this "Stats" tab right?  I would prefer not to install more plugins then I need to if I don't have to.


Correct, I just need to do some final testing and I will be releasing a new version.

Share this post


Link to post

New version released that fixes the log spamming and removes the dependency on Dynamix.System.Stats

Share this post


Link to post
On 12/8/2018 at 11:54 PM, Squid said:

Install Dynamix System Stats.  I gets @dorgan hasn't included the stats.page file as of yet in his plugin

Thanks.  That fixed it... I now have the Stats tab AND the Network plugin is working for me.

Share this post


Link to post

Just got some more spam after the update.
 

Quote

Dec 13 15:08:26 Gaming vnstatd[33358]: Traffic rate for "vnet0" higher than set maximum 10 Mbit (30->42, r5 t283), syncing.
Dec 13 15:08:56 Gaming vnstatd[33358]: Traffic rate for "vnet0" higher than set maximum 10 Mbit (30->42, r14 t833), syncing.
Dec 13 15:09:26 Gaming vnstatd[33358]: Traffic rate for "vnet0" higher than set maximum 10 Mbit (30->42, r13 t804), syncing.
Dec 13 15:09:56 Gaming vnstatd[33358]: Traffic rate for "vnet0" higher than set maximum 10 Mbit (30->42, r13 t785), syncing.
Dec 13 15:10:26 Gaming vnstatd[33358]: Traffic rate for "vnet0" higher than set maximum 10 Mbit (30->42, r14 t838), syncing.
Dec 13 15:10:56 Gaming vnstatd[33358]: Traffic rate for "vnet0" higher than set maximum 10 Mbit (30->42, r13 t799), syncing.
Dec 13 15:11:26 Gaming vnstatd[33358]: Traffic rate for "vnet0" higher than set maximum 10 Mbit (30->42, r13 t752), syncing.
Dec 13 15:11:56 Gaming vnstatd[33358]: Traffic rate for "vnet0" higher than set maximum 10 Mbit (30->42, r13 t783), syncing.
Dec 13 15:12:26 Gaming vnstatd[33358]: Traffic rate for "vnet0" higher than set maximum 10 Mbit (30->42, r13 t800), syncing.
Dec 13 15:12:56 Gaming vnstatd[33358]: Traffic rate for "vnet0" higher than set maximum 10 Mbit (30->42, r15 t907), syncing.
Dec 13 15:13:26 Gaming vnstatd[33358]: Traffic rate for "vnet0" higher than set maximum 10 Mbit (30->42, r13 t809), syncing.
Dec 13 15:13:56 Gaming vnstatd[33358]: Traffic rate for "vnet0" higher than set maximum 10 Mbit (30->42, r15 t922), syncing.
Dec 13 15:14:26 Gaming vnstatd[33358]: Traffic rate for "vnet0" higher than set maximum 10 Mbit (30->42, r14 t836), syncing.
Dec 13 15:14:56 Gaming vnstatd[33358]: Traffic rate for "vnet0" higher than set maximum 10 Mbit (30->42, r15 t915), syncing.
Dec 13 15:15:26 Gaming vnstatd[33358]: Traffic rate for "vnet0" higher than set maximum 10 Mbit (30->42, r15 t901), syncing.
Dec 13 15:15:56 Gaming vnstatd[33358]: Traffic rate for "vnet0" higher than set maximum 10 Mbit (30->42, r15 t889), syncing.
Dec 13 15:16:26 Gaming vnstatd[33358]: Traffic rate for "vnet0" higher than set maximum 10 Mbit (30->42, r14 t849), syncing.
Dec 13 15:16:56 Gaming vnstatd[33358]: Traffic rate for "vnet0" higher than set maximum 10 Mbit (30->42, r14 t846), syncing.
Dec 13 15:17:26 Gaming vnstatd[33358]: Traffic rate for "vnet0" higher than set maximum 10 Mbit (30->42, r14 t845), syncing.
Dec 13 15:17:56 Gaming vnstatd[33358]: Traffic rate for "vnet0" higher than set maximum 10 Mbit (30->42, r14 t822), syncing.
Dec 13 15:18:26 Gaming vnstatd[33358]: Traffic rate for "vnet0" higher than set maximum 10 Mbit (30->42, r13 t757), syncing.
Dec 13 15:18:56 Gaming vnstatd[33358]: Traffic rate for "vnet0" higher than set maximum 10 Mbit (30->42, r4 t256), syncing.
Dec 13 15:45:27 Gaming vnstatd[33358]: Traffic rate for "vnet0" higher than set maximum 10 Mbit (30->42, r5 t158), syncing.
Dec 13 15:53:57 Gaming vnstatd[33358]: Traffic rate for "vnet0" higher than set maximum 10 Mbit (30->42, r10 t333), syncing.
Dec 13 15:54:27 Gaming vnstatd[33358]: Traffic rate for "vnet0" higher than set maximum 10 Mbit (30->42, r3 t43), syncing.
Dec 13 16:06:27 Gaming vnstatd[33358]: Traffic rate for "vnet0" higher than set maximum 10 Mbit (30->42, r50 t1), syncing.
Dec 13 16:14:57 Gaming vnstatd[33358]: Traffic rate for "vnet0" higher than set maximum 10 Mbit (30->42, r47 t1), syncing.
Dec 13 16:21:57 Gaming vnstatd[33358]: Traffic rate for "vnet0" higher than set maximum 10 Mbit (30->42, r44 t1), syncing.
Dec 13 16:30:57 Gaming vnstatd[33358]: Traffic rate for "vnet0" higher than set maximum 10 Mbit (30->42, r44 t1), syncing.
Dec 13 16:34:27 Gaming vnstatd[33358]: Traffic rate for "vnet0" higher than set maximum 10 Mbit (30->42, r52 t2), syncing.
Dec 13 16:45:27 Gaming vnstatd[33358]: Traffic rate for "vnet0" higher than set maximum 10 Mbit (30->42, r2 t108), syncing.
Dec 13 16:45:57 Gaming vnstatd[33358]: Traffic rate for "vnet0" higher than set maximum 10 Mbit (30->42, r5 t270), syncing.


image.thumb.png.c658fd5085df86c255b87adfc92105d8.png

 

gaming-diagnostics-20181213-1711.zip

Edited by slimshizn

Share this post


Link to post

Hey I have a question. 

 

Currently I use the plugin and it tells me my usage. But I'm having a problem where I need to know, how much INTERNET TRAFFIC I'm using and INTERNAL TRAFFIC. 

 

I think your plugin gives you both as one right. 

Share this post


Link to post

@dorgan I also noticed. Does this plugin save bandwidth information from previous months?

 

I can only see information from the current month. 

Share this post


Link to post
23 hours ago, gacpac said:

@dorgan I also noticed. Does this plugin save bandwidth information from previous months?

 

I can only see information from the current month. 

@dorgan Hey I restarted my server today and now I see this. 

 

image.png.6a079d318fcc79a4d8534815c87d9c94.png

 

Is this how it's supposed to work. Because it looks like it's saving information for the running server. It's lost after restart. 

Share this post


Link to post

I do apologize for not being active in responding.  I have been in the processed of moving and have not had a chance to take a look at things.

 

Regarding losing data on restart, yes that is currently known and stated in the thread.  I am still determining the best way to copy the data to the usb, or another location between restarts.

Share this post


Link to post
I do apologize for not being active in responding.  I have been in the processed of moving and have not had a chance to take a look at things.
 
Regarding losing data on restart, yes that is currently known and stated in the thread.  I am still determining the best way to copy the data to the usb, or another location between restarts.
In the new 6.7.0rc2 the graphs from stats are not showing. Have a loot at that

Sent from my Pixel 2 XL using Tapatalk

Share this post


Link to post
1 hour ago, Alim Nassor said:

Same here in 6.7.0-rc3 no output, just 2 broken images.

Cheers, Alim

Capture.PNG

 

1 hour ago, Alim Nassor said:

Same here in 6.7.0-rc3 no output, just 2 broken images.

Cheers, Alim

Capture.PNG

Same on my end

Share this post


Link to post

The issue of displaying the images has been corrected.  Something must have changed in PHP.

Share this post


Link to post

FYI. The compatibility plugin from fix commons problems keeps telling me this everytime I update the server. Can you please look into this?

e3a263fcbb51bafc48d348ce1ab31127.jpg

Sent from my Pixel 2 XL using Tapatalk

Share this post


Link to post

Is FCP up to date?

Sent via telekinesis

Share this post


Link to post

Yes it is. But again, doesn't really bother me. Just an FYI

Sent from my Pixel 2 XL using Tapatalk

Share this post


Link to post

This is controlled by Community Applications.  I would recommend removing the plugin and reinstalling via Community Applications.

Share this post


Link to post

I did a couple of times. Even restarted the server. And did it again just now. 

 

Anyhow, this is a false positive as I see. @Squid

 

 

Share this post


Link to post

Depends upon how you look at it.  The URL listed in the .plg file is slightly different than the URL listed within CA.  Hence FCP doesn't recognize that its the same thing, and therefore it's unknown.  Dorgan needs to change one of them to match the other.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.