[Support] ich777 - Gameserver Dockers


4180 posts in this topic Last Reply

Recommended Posts

4 minutes ago, CoZ said:

 

I would leave it enabled by default and give the user the option to disable it if they want.  This way everyone is on the same exact container version.  Going forward there might be more bugs and then you'll have to troubleshoot which version of the container the person is on because Person "X" didn't want to update due to the automatic update being forced on them with no way to disable / enable it.

 

Just my .2c

Yes, but I can't solve this not in any other way, they can disable it but they have to create the Variable inside the template or they pull the template again from the CA App with the exact same settings as their existing Container and the template will be updated.

 

EDIT: I have updated the post.

Link to post
  • Replies 4.2k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Summary: Support Thread for ich777 Gameserver Dockers (CounterStrike: Source & ConterStrike: GO, TeamFortress 2, ArmA III,... - complete list in the second post) Application: SteamCMD Do

Just thought I'd share my experience setting up a Valheim server with this docker app from @ich777(thank you!)   You don't need to worry about Steam authentication for Valheim, the default a

Dockers Available so far:   SteamCMD DedicatedServers: CounterStrike: Source CounterStrike: Global Offensive TeamFortress 2 ArmA3 - requested by @MrSage D

Posted Images

Ok so the instructions would look like:

 

Pull the new updated container down from the App Store

Follow the previous post for manually adding that key to enable/disable the auto-update-check-feature

Hit apply on the container

 

?

Link to post
1 hour ago, CoZ said:

Pull the new updated container down from the App Store

No update the Container and add the variable or redownload it from the CA App.

 

 

 

Link to post

@ich777 I came across this compression mod, but something is going on and it is not working.

 

Speaking to the mod dev, I have installed BepInEx (FULL) over the client/server to update that. I also have V+ installed. I can connect fine with these 2 changes.

 

Then I install his mod (server + client) but not getting to connect. Anything you see right off the bat that may be a cause?

 

He's not seeing where things would be stopped on the mod DLL end. The mod config log shows it is enabled. Unfortunately I can't see the console as web console doesn't show anything.

 

This mod could be pretty big for reducing server lag and wanted to test it out. Not sure what could be the issue here.

https://valheim.thunderstore.io/package/Seb/SebNetCompressionPlugin/

Link to post
Just now, Skrumpy said:

This mod could be pretty big for reducing server lag and wanted to test it out. Not sure what could be the issue here.

Sorry I don't give mod support.

I only can tell you that you have to install the mod on both ends the server and the client.

If it says it's enabled it should work.

Link to post
14 hours ago, ich777 said:

Also how do you try to connect? Steam Server Browser, in game, LOCALIP:PORT+1, PUBLICIP:PORT+2?

Have you fowarded the ports in your firewall from 2456-2458 UDP?

Hello! thank you for setting up this docker. My main goal is to set up the server so that my friends outside the network could join. I was able to portforward ports 2456-2458 with the UDP protocol.  When I run the container, I can connect via steam server list using LocalIP:PORT+1 and I can actually play in game. But My friends cannot find the server (either ingame or steam server list) Which seems to be an issue with the port forward. Is there something else I'm Missing? server.thumb.JPG.60a298e07fbb71225b71c85d11a1f4d6.JPG

Link to post
10 minutes ago, serge88 said:

But My friends cannot find the server

With which IP are your friends connecting.

Please be sure to give them your PUBLICIP:GAMPORT+1 also make sure that only forwarded the ports for UDP and not TCP or TCP & UDP.

Eventually your ISP is blocking the ports and a port forwarding isn't possible. Have you got other services running that are reachable from "outside".

Link to post
On 3/2/2021 at 5:55 PM, ich777 said:

That wouldn't work because of two things:

  1. You have to restart the container to check for updates
  2. You can't update a game that is running since it replaces files

The best thing is to restart the container and it will check for updates and install them.

 

If you want a auto update you have to talk to the game developers (Discord/Forums/Steam Community Hub).

 

Thanks Ich777, but is there really no way to run SteamCMD commands in your dockers as there is in the normal SteamCMD when u run it on a PC?

Link to post
42 minutes ago, ich777 said:

With which IP are your friends connecting.

Please be sure to give them your PUBLICIP:GAMPORT+1 also make sure that only forwarded the ports for UDP and not TCP or TCP & UDP.

Eventually your ISP is blocking the ports and a port forwarding isn't possible. Have you got other services running that are reachable from "outside".

Looks like I was having them use the local ip address. I don't have any other services I use from the outside. How would I go about finding the public address for my unraid machine? 

Thank you for replying! 

Link to post

Hi and thank you so much for the container! I'm having an issue connecting to my Valheim server.

 

I have forwarded UDP ports 2456-2458 to my unraid server

 

Here's the log 10-15mins after starting the container:

 

---Checking if UID: 99 matches user---
---Checking if GID: 100 matches user---
---Setting umask to 000---
---Checking for optional scripts---
---No optional script found, continuing---
---Starting...---
---Update SteamCMD---
Redirecting stderr to '/serverdata/serverfiles/Steam/logs/stderr.txt'
[ 0%] Checking for available updates...
[----] Verifying installation...
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK.

Connecting anonymously to Steam Public...Logged in OK
Waiting for user info...OK
---Update Server---
Redirecting stderr to '/serverdata/serverfiles/Steam/logs/stderr.txt'
[ 0%] Checking for available updates...
[----] Verifying installation...
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK.

Connecting anonymously to Steam Public...Logged in OK
Waiting for user info...OK
Success! App '896660' already up to date.
---Prepare Server---
---Server ready---
---Starting Backup daemon---
---Start Server---
[S_API] SteamAPI_Init(): Loaded local 'steamclient.so' OK.
CAppInfoCacheReadFromDiskThread took 2 milliseconds to initialize
CApplicationManagerPopulateThread took 0 milliseconds to initialize (will have waited on CAppInfoCacheReadFromDiskThread)
RecordSteamInterfaceCreation (PID 68): SteamGameServer013 /
RecordSteamInterfaceCreation (PID 68): SteamUtils009 /
Setting breakpad minidump AppID = 892970
RecordSteamInterfaceCreation (PID 68): SteamGameServer013 / GameServer
RecordSteamInterfaceCreation (PID 68): SteamUtils009 / Utils
RecordSteamInterfaceCreation (PID 68): SteamNetworking006 / Networking
RecordSteamInterfaceCreation (PID 68): SteamGameServerStats001 / GameServerStats
RecordSteamInterfaceCreation (PID 68): STEAMHTTP_INTERFACE_VERSION003 / HTTP
RecordSteamInterfaceCreation (PID 68): STEAMINVENTORY_INTERFACE_V003 / Inventory
RecordSteamInterfaceCreation (PID 68): STEAMUGC_INTERFACE_VERSION014 / UGC
RecordSteamInterfaceCreation (PID 68): STEAMAPPS_INTERFACE_VERSION008 / Apps
[S_API FAIL] Tried to access Steam interface SteamNetworkingUtils003 before SteamAPI_Init succeeded.
RecordSteamInterfaceCreation (PID 68): SteamNetworkingUtils003 /
RecordSteamInterfaceCreation (PID 68): SteamNetworkingSockets008 /

 

Here's a picture of my docker setup:

 

Any suggestions? I tried connecting to the server through the steam server viewer with <PUBLICIP>:2457 and <PUBLICIP>:2458

Screenshot 2021-03-03 180730.png

Link to post
7 hours ago, truetype said:

 

Thanks Ich777, but is there really no way to run SteamCMD commands in your dockers as there is in the normal SteamCMD when u run it on a PC?

Yes you can run them from inside the container with this command: '${STEAMCMD_DIR}/steamcmd.sh +login anonymous +force_install_dir ${SERVER_DIR} +app_update ${GAME_ID} +quit'

 

But keep in mind that you are having a hard time to update a running game and the update will fail.

 

Btw have you read this, if we are talking about Valheim:

 

 

6 hours ago, serge88 said:

How would I go about finding the public address for my unraid machine?

For example here: Click

 

6 hours ago, greaterbeing said:

Here's the log 10-15mins after starting the container

The log and the configuration looks good and indicate a successfull startup.

 

6 hours ago, greaterbeing said:

I tried connecting to the server through the steam server viewer with <PUBLICIP>:2457 and <PUBLICIP>:2458

If your Router/Firewall doesn't support NAT Reflection then you can't connect from your local network with your PUBLICIP:2457, I would first try to connect to with your LOCALIP:2457

 

If you forwarded the ports correctly in your Router/Firewall 2456-2458 UDP (and only UDP) then you should be able to connect to the server from outside with PUBLICIP:2457

 

 

Was the server running before because I see you are using a old template, version of the Container, if it was running before eventually you are affected by the world destroy bug (I built in a backup function in the Container so that you can restore the world if needed - see the second recommended post in this thread on the top for more information).

Link to post
12 hours ago, ich777 said:

If your Router/Firewall doesn't support NAT Reflection then you can't connect from your local network with your PUBLICIP:2457, I would first try to connect to with your LOCALIP:2457

 

If you forwarded the ports correctly in your Router/Firewall 2456-2458 UDP (and only UDP) then you should be able to connect to the server from outside with PUBLICIP:2457

 

 

Was the server running before because I see you are using a old template, version of the Container, if it was running before eventually you are affected by the world destroy bug (I built in a backup function in the Container so that you can restore the world if needed - see the second recommended post in this thread on the top for more information).

 

I had downloaded the old template before but could never get the server working.

After seeing you say I had an old version I just removed the container / files completely and re-downloaded from the community app store. Used all of my old settings and it instantly started up 😃

Thanks so much again!

Link to post

Still fairly new to Unraid. I got the Valheim server up and running with no problems just downloaded docker and forwarded the ports. My question is how can I increase usage that Valheim server uses of my CPU? Currently it only uses around 4-8% out of my 6 core i7 5th Gen with 32GB of DDR4.

 

My server at times becomes laggy and I am unsure on how to help. Server is connected via ethernet with 1 gig fiber connection so should be good on that part. I am not sure if I can tell docker it can use more resources or not. Only other docker I use is Plex and GPU is doing a lot of the transcoding and what not.

 

Thank you for your time and keep up the great work!

Link to post
15 hours ago, ich777 said:

Yes you can run them from inside the container with this command: '${STEAMCMD_DIR}/steamcmd.sh +login anonymous +force_install_dir ${SERVER_DIR} +app_update ${GAME_ID} +quit'

 

But keep in mind that you are having a hard time to update a running game and the update will fail.

 

Btw have you read this, if we are talking about Valheim:

 

 

For example here: Click

 

The log and the configuration looks good and indicate a successfull startup.

 

If your Router/Firewall doesn't support NAT Reflection then you can't connect from your local network with your PUBLICIP:2457, I would first try to connect to with your LOCALIP:2457

 

If you forwarded the ports correctly in your Router/Firewall 2456-2458 UDP (and only UDP) then you should be able to connect to the server from outside with PUBLICIP:2457

 

 

Was the server running before because I see you are using a old template, version of the Container, if it was running before eventually you are affected by the world destroy bug (I built in a backup function in the Container so that you can restore the world if needed - see the second recommended post in this thread on the top for more information).

 

Peeerfect! Very much appreciated! :D

Link to post
6 minutes ago, Sparkypk said:

My server at times becomes laggy and I am unsure on how to help. Server is connected via ethernet with 1 gig fiber connection so should be good on that part. I am not sure if I can tell docker it can use more resources or not. Only other docker I use is Plex and GPU is doing a lot of the transcoding and what not.

This is a known problem with Valheim if more people playing on the server, there is a workaround out there but I don't know exactly where...

 

Please leave the developers of Valheim a short message about that on their Discord/Forums/Steam Community Forums, I think they will fix this soon.

Link to post

Tried searching this thread for help but search wasn't much help.

Trying to run a second server for Valheim and am just getting this loop

Connecting anonymously to Steam Public...Logged in OK
Waiting for user info...OK
Update state (0x5) verifying install, progress: 0.20 (2102498 / 1051599543)
Update state (0x5) verifying install, progress: 18.02 (189461290 / 1051599543)
Update state (0x5) verifying install, progress: 49.91 (524853563 / 1051599543)
Update state (0x5) verifying install, progress: 82.05 (862813403 / 1051599543)
Success! App '896660' fully installed.
---Prepare Server---
---Server ready---
---Starting Backup daemon---
---Start Server---
---Checking if UID: 99 matches user---
usermod: no changes
---Checking if GID: 100 matches user---
usermod: no changes
---Setting umask to 000---
---Checking for optional scripts---
---No optional script found, continuing---
---Starting...---
---Update SteamCMD---
---Checking if UID: 99 matches user---
usermod: no changes
---Checking if GID: 100 matches user---
usermod: no changes
---Setting umask to 000---
---Checking for optional scripts---
---No optional script found, continuing---
---Starting...---
---Update SteamCMD---
Redirecting stderr to '/serverdata/serverfiles/Steam/logs/stderr.txt'
[ 0%] Checking for available updates...
[----] Verifying installation...
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK.

Connecting anonymously to Steam Public...Logged in OK
Waiting for user info...OK
---Update Server---
---Validating installation---
Redirecting stderr to '/serverdata/serverfiles/Steam/logs/stderr.txt'
[ 0%] Checking for available updates...
[----] Verifying installation...
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK.

Only settings different from default are game port range (2460-2462), game port(2460) and folder location for server files.

The installer metions no need to change/add a second steamcmd directory.

Link to post
5 minutes ago, theagain said:

Tried searching this thread for help but search wasn't much help.

Trying to run a second server for Valheim and am just getting this loop


Connecting anonymously to Steam Public...Logged in OK
Waiting for user info...OK
Update state (0x5) verifying install, progress: 0.20 (2102498 / 1051599543)
Update state (0x5) verifying install, progress: 18.02 (189461290 / 1051599543)
Update state (0x5) verifying install, progress: 49.91 (524853563 / 1051599543)
Update state (0x5) verifying install, progress: 82.05 (862813403 / 1051599543)
Success! App '896660' fully installed.
---Prepare Server---
---Server ready---
---Starting Backup daemon---
---Start Server---
---Checking if UID: 99 matches user---
usermod: no changes
---Checking if GID: 100 matches user---
usermod: no changes
---Setting umask to 000---
---Checking for optional scripts---
---No optional script found, continuing---
---Starting...---
---Update SteamCMD---
---Checking if UID: 99 matches user---
usermod: no changes
---Checking if GID: 100 matches user---
usermod: no changes
---Setting umask to 000---
---Checking for optional scripts---
---No optional script found, continuing---
---Starting...---
---Update SteamCMD---
Redirecting stderr to '/serverdata/serverfiles/Steam/logs/stderr.txt'
[ 0%] Checking for available updates...
[----] Verifying installation...
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK.

Connecting anonymously to Steam Public...Logged in OK
Waiting for user info...OK
---Update Server---
---Validating installation---
Redirecting stderr to '/serverdata/serverfiles/Steam/logs/stderr.txt'
[ 0%] Checking for available updates...
[----] Verifying installation...
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK.

Only settings different from default are game port range (2460-2462), game port(2460) and folder location for server files.

The installer metions no need to change/add a second steamcmd directory.

Can you post the config for this container?

Link to post
1 minute ago, Spectral Force said:

Can you post the config for this container?

Yeah,

Repository:	ich777/steamcmd:valheim
Network Type:	bridge
Console shell command:	shell
SteamCMD:	/mnt/user/appdata/steamcmd
ServerFiles:	/mnt/cache/appdata/val2
GAME_ID:	896660
GAME_PARAMS:	
Steam-Username:	
Validate Installation:	
Steam-Password:	
Server Name:	Chars
World Name:	Charland
Server Password:	***
Public Server:	1
Backup:	true
Backup Interval (in minutes):	62
Backups to keep:	24
ValheimPlus:	
UDP - Game Port Range::	2460-2462
GAME_PORT:	2460
UID:	99
GID:	100
Debug Log Output:	false

 

Link to post

Hey ich777,

 

Would you be able to create one for an Astroneer Server? Or point me to directions on how to modify one of your existing steamcmd docker images to download it?  Thanks! 

Link to post
5 minutes ago, ptyler said:

Hey ich777,

 

Would you be able to create one for an Astroneer Server? Or point me to directions on how to modify one of your existing steamcmd docker images to download it?  Thanks! 

Actually that's a game that I want a server for...

From what I've know the Dedicated Server for Linux hasn't released or am I wrong?

The Windows version of the Dedicated Server doesn't run stable with WINE.

If they release a Linux Dedicated Server feel free to contact me and I will create one.

 

grafik.png.1afee5e755ae9dc69be158b7513ab0eb.png

Link to post
9 minutes ago, theagain said:

Yeah,


Repository:	ich777/steamcmd:valheim
Network Type:	bridge
Console shell command:	shell
SteamCMD:	/mnt/user/appdata/steamcmd
ServerFiles:	/mnt/cache/appdata/val2
GAME_ID:	896660
GAME_PARAMS:	
Steam-Username:	
Validate Installation:	
Steam-Password:	
Server Name:	Chars
World Name:	Charland
Server Password:	***
Public Server:	1
Backup:	true
Backup Interval (in minutes):	62
Backups to keep:	24
ValheimPlus:	
UDP - Game Port Range::	2460-2462
GAME_PORT:	2460
UID:	99
GID:	100
Debug Log Output:	false

 

can you post a screen shot. theres missing info i need to see.

Link to post
10 minutes ago, ich777 said:

Actually that's a game that I want a server for...

From what I've know the Dedicated Server for Linux hasn't released or am I wrong?

The Windows version of the Dedicated Server doesn't run stable with WINE.

If they release a Linux Dedicated Server feel free to contact me and I will create one.

 

grafik.png.1afee5e755ae9dc69be158b7513ab0eb.png

Oh yeah I forgot it doesn't run on Linux yet. My mistake! I will keep an eye on it and report back if I notice the change. Thanks for the quick response

Link to post
3 minutes ago, Spectral Force said:

Everything looks good in the config as far as I can tell. Try removing true from verify.

Was  one of the first things I had tried. Still continues to loop.

Thinking it's to do with the game ports which is the only thing that's really changed.

 

Defaults are already in use though

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.