Jump to content
ich777

[Support] ich777 - Gameserver Dockers

2210 posts in this topic Last Reply

Recommended Posts

Reinstalled the docker...

It's now on the cache drive but still getting a weird warning.

Here's the log:

 

Redirecting stderr to '/serverdata/Steam/logs/stderr.txt'
[ 0%] Checking for available updates...
[----] Verifying installation...
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK.
"@sSteamCmdForcePlatformType" = "windows"
[0mLogging in user 'linotharhino' to Steam Public ...
Logged in OK
Waiting for user info...OK
Update state (0x5) validating, progress: 0.09 (5645322 / 5950216105)
Update state (0x5) validating, progress: 5.34 (317906420 / 5950216105)
Update state (0x5) validating, progress: 12.94 (769787648 / 5950216105)
Update state (0x5) validating, progress: 20.74 (1233946938 / 5950216105)
Update state (0x5) validating, progress: 28.41 (1690231138 / 5950216105)
Update state (0x5) validating, progress: 36.01 (2142845058 / 5950216105)
Update state (0x5) validating, progress: 43.55 (2591262303 / 5950216105)
Update state (0x5) validating, progress: 51.28 (3051197829 / 5950216105)
Update state (0x5) validating, progress: 59.05 (3513606429 / 5950216105)
Update state (0x5) validating, progress: 66.78 (3973293951 / 5950216105)
Update state (0x5) validating, progress: 74.42 (4428215707 / 5950216105)
Update state (0x5) validating, progress: 82.09 (4884254645 / 5950216105)
Update state (0x5) validating, progress: 89.80 (5343038213 / 5950216105)
Update state (0x5) validating, progress: 97.63 (5808912929 / 5950216105)
Success! App '242760' fully installed.
---Prepare Server---
---Checking for 'saves' directory---
---Directory 'saves' found!---
---Checking for 'config.cfg'---
---Server ready---
---Start Server---
it looks like wine32 is missing, you should install it.
multiarch needs to be enabled first. as root, please
execute "dpkg --add-architecture i386 && apt-get update &&
apt-get install wine32"
wine: cannot find '/serverdata/serverfiles/TheForestDedicatedServer.exe'
---Update SteamCMD---
---Update SteamCMD---
WARNING: setlocale('en_US.UTF-8') failed, using locale: 'C'. International characters may not work.
Redirecting stderr to '/serverdata/Steam/logs/stderr.txt'
[ 0%] Checking for available updates...
[----] Verifying installation...
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK.
Logging in user 'linotharhino' to Steam Public ...
Logged in OK
Logged in OK
Waiting for user info...OK
---Update Server---
---Validating installation---
WARNING: setlocale('en_US.UTF-8') failed, using locale: 'C'. International characters may not work.
Redirecting stderr to '/serverdata/Steam/logs/stderr.txt'
[ 0%] Checking for available updates...
[----] Verifying installation...
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK.
"@sSteamCmdForcePlatformType" = "windows"
[0mLogging in user 'linotharhino' to Steam Public ...
WARNING: setlocale('en_US.UTF-8') failed, using locale: 'C'. International characters may not work.
Redirecting stderr to '/serverdata/Steam/logs/stderr.txt'
[ 0%] Checking for available updates...
[----] Verifying installation...
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK.
"@sSteamCmdForcePlatformType" = "windows"
[0mLogging in user 'linotharhino' to Steam Public ...
Logged in OK
Waiting for user info...OK
Update state (0x5) validating, progress: 0.06 (3548170 / 5950216105)
Update state (0x5) validating, progress: 5.02 (298430508 / 5950216105)
Update state (0x5) validating, progress: 12.20 (725747456 / 5950216105)
Update state (0x5) validating, progress: 19.54 (1162643770 / 5950216105)
Update state (0x5) validating, progress: 27.06 (1610225806 / 5950216105)
Update state (0x5) validating, progress: 34.29 (2040251885 / 5950216105)
Update state (0x5) validating, progress: 41.63 (2477324714 / 5950216105)
Update state (0x5) validating, progress: 48.62 (2892705007 / 5950216105)
Update state (0x5) validating, progress: 56.05 (3334834169 / 5950216105)
Update state (0x5) validating, progress: 63.28 (3765221673 / 5950216105)
Update state (0x5) validating, progress: 70.42 (4190436107 / 5950216105)
Update state (0x5) validating, progress: 77.45 (4608154239 / 5950216105)
Update state (0x5) validating, progress: 84.86 (5049635929 / 5950216105)
Update state (0x5) validating, progress: 92.34 (5494602473 / 5950216105)
Update state (0x5) validating, progress: 99.66 (5929954785 / 5950216105)
Success! App '242760' fully installed.
---Prepare Server---
---Checking for 'saves' directory---
---Directory 'saves' found!---
---Checking for 'config.cfg'---
---Server ready---
---Start Server---
it looks like wine32 is missing, you should install it.
multiarch needs to be enabled first. as root, please
execute "dpkg --add-architecture i386 && apt-get update &&
apt-get install wine32"
wine: cannot find '/serverdata/serverfiles/TheForestDedicatedServer.exe'
it looks like wine32 is missing, you should install it.
multiarch needs to be enabled first. as root, please
execute "dpkg --add-architecture i386 && apt-get update &&
apt-get install wine32"
wine: cannot find '/serverdata/serverfiles/TheForestDedicatedServer.exe'
---Update SteamCMD---
WARNING: setlocale('en_US.UTF-8') failed, using locale: 'C'. International characters may not work.
Redirecting stderr to '/serverdata/Steam/logs/stderr.txt'
[ 0%] Checking for available updates...
[----] Verifying installation...
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK.
Logging in user 'linotharhino' to Steam Public ...
Logged in OK
WARNING: setlocale('en_US.UTF-8') failed, using locale: 'C'. International characters may not work.
Redirecting stderr to '/serverdata/Steam/logs/stderr.txt'
[ 0%] Checking for available updates...
[----] Verifying installation...
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK.
Logging in user 'linotharhino' to Steam Public ...
Logged in OK
Waiting for user info...OK
---Update Server---
---Validating installation---
WARNING: setlocale('en_US.UTF-8') failed, using locale: 'C'. International characters may not work.
Redirecting stderr to '/serverdata/Steam/logs/stderr.txt'
[ 0%] Checking for available updates...
[----] Verifying installation...
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK.
"@sSteamCmdForcePlatformType" = "windows"
[0mLogging in user 'linotharhino' to Steam Public ...
Logged in OK

Share this post


Link to post
9 minutes ago, lionel.pereira85 said:

Success! App '242760' fully installed.

You've installed the wrong app id. The Forest dedicated server has app id 556450 and not 242760 <- is The Forest.

Please delete the docker and the directory completely and reinstall it from the Community Apps.

I think you've understand the post with the steamtoken wrong.

Share this post


Link to post
1 hour ago, ich777 said:

You've installed the wrong app id. The Forest dedicated server has app id 556450 and not 242760 <- is The Forest.

Please delete the docker and the directory completely and reinstall it from the Community Apps.

I think you've understand the post with the steamtoken wrong.

Ok... I've changed the token along with the ID I'm using 556450.

 

Still not working though. Ports are forwarded.... Here's the log after reinstall.

 

Redirecting stderr to '/serverdata/Steam/logs/stderr.txt'
[ 0%] Checking for available updates...
[----] Verifying installation...
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK.
"@sSteamCmdForcePlatformType" = "windows"
[0mLogging in user 'linotharhino' to Steam Public ...
Logged in OK
Logged in OK
Waiting for user info...OK
Update state (0x5) validating, progress: 0.34 (5881102 / 1731770417)
Update state (0x5) validating, progress: 13.13 (227436343 / 1731770417)
Update state (0x5) validating, progress: 38.68 (669922415 / 1731770417)
Update state (0x5) validating, progress: 65.05 (1126567225 / 1731770417)
Update state (0x5) validating, progress: 90.92 (1574490769 / 1731770417)
Success! App '556450' fully installed.
---Prepare Server---
---Checking for 'saves' directory---
---Directory 'saves' found!---
---Checking for 'config.cfg'---
---Server ready---
---Start Server---
it looks like wine32 is missing, you should install it.
multiarch needs to be enabled first. as root, please
execute "dpkg --add-architecture i386 && apt-get update &&
apt-get install wine32"
Mono path[0] = 'Z:/serverdata/serverfiles/TheForestDedicatedServer_Data/Managed'
Mono path[1] = 'Z:/serverdata/serverfiles/TheForestDedicatedServer_Data/Mono'
Mono config path = 'Z:/serverdata/serverfiles/TheForestDedicatedServer_Data/Mono/etc'
Player data archive not found at `Z:/serverdata/serverfiles/TheForestDedicatedServer_Data/data.unity3d`, using local filesystemInitialize engine version: 5.6.5p4 (10861494ddb7)
GfxDevice: creating device client; threaded=0
0009:err:wgl:X11DRV_wglCreateContextAttribsARB Context creation failed (error 1)
0009:err:wgl:X11DRV_wglCreateContextAttribsARB Context creation failed (error 1)
0009:err:d3d:wined3d_adapter_find_polyoffset_scale PolygonOffset scale factor detection failed, using fallback value 2^23.
0009:err:wgl:X11DRV_wglCreateContextAttribsARB Context creation failed (error 1)
0009:err:wgl:X11DRV_wglCreateContextAttribsARB Context creation failed (error 1)
0009:err:d3d:wined3d_adapter_find_polyoffset_scale PolygonOffset scale factor detection failed, using fallback value 2^23.
0009:err:wgl:X11DRV_wglCreateContextAttribsARB Context creation failed (error 1)
0009:err:wgl:X11DRV_wglCreateContextAttribsARB Context creation failed (error 1)
0009:err:wgl:X11DRV_wglCreateContextAttribsARB Context creation failed (error 1)
0009:err:wgl:X11DRV_wglCreateContextAttribsARB Context creation failed (error 1)
0009:err:d3d:wined3d_adapter_find_polyoffset_scale PolygonOffset scale factor detection failed, using fallback value 2^23.
0009:err:wgl:X11DRV_wglCreateContextAttribsARB Context creation failed (error 1)
0009:err:wgl:X11DRV_wglCreateContextAttribsARB Context creation failed (error 1)
0009:err:d3d:wined3d_adapter_find_polyoffset_scale PolygonOffset scale factor detection failed, using fallback value 2^23.
Direct3D:
Version: Direct3D 11.0 [level 10.1]
Renderer: NVIDIA GeForce 8800 GTX (ID=0x191)
Vendor: NVIDIA
VRAM: 32087 MB
Driver: 1.0
D3D shader create error for vertex shader [0x80070057]
D3D shader create error for pixel shader [0x80070057]
D3D shader create error for vertex shader [0x80070057]
D3D shader create error for pixel shader [0x80070057]
D3D shader create error for vertex shader [0x80070057]
D3D shader create error for pixel shader [0x80070057]
D3D shader create error for vertex shader [0x80070057]
ShaderProgram is unsupported, but because jobified rendering is enabled the ShaderProgram can not be removed.

(Filename: Line: 450)

D3D shader create error for vertex shader [0x80070057]
ShaderProgram is unsupported, but because jobified rendering is enabled the ShaderProgram can not be removed.

(Filename: Line: 450)

D3D shader create error for vertex shader [0x80070057]
ShaderProgram is unsupported, but because jobified rendering is enabled the ShaderProgram can not be removed.

(Filename: Line: 450)

D3D shader create error for vertex shader [0x80070057]
D3D shader create error for pixel shader [0x80070057]
D3D shader create error for vertex shader [0x80070057]
D3D shader create error for pixel shader [0x80070057]
D3D shader create error for vertex shader [0x80070057]
D3D shader create error for pixel shader [0x80070057]
WARNING: Shader Unsupported: 'Hidden/Post FX/Temporal Anti-aliasing' - Pass '' has no vertex shader
D3D shader create error for vertex shader [0x80070057]
D3D shader create error for pixel shader [0x80070057]
D3D shader create error for vertex shader [0x80070057]
D3D shader create error for pixel shader [0x80070057]
D3D shader create error for vertex shader [0x80070057]
D3D shader create error for pixel shader [0x80070057]
D3D shader create error for vertex shader [0x80070057]
D3D shader create error for pixel shader [0x80070057]
D3D shader create error for vertex shader [0x80070057]
D3D shader create error for vertex shader [0x80070057]
D3D shader create error for vertex shader [0x80070057]
D3D shader create error for vertex shader [0x80070057]
D3D shader create error for vertex shader [0x80070057]
D3D shader create error for vertex shader [0x80070057]
D3D shader create error for vertex shader [0x80070057]
D3D shader create error for vertex shader [0x80070057]
D3D shader create error for vertex shader [0x80070057]
D3D shader create error for vertex shader [0x80070057]
D3D shader create error for pixel shader [0x80070057]
ShaderProgram is unsupported, but because jobified rendering is enabled the ShaderProgram can not be removed.

(Filename: Line: 450)

D3D shader create error for vertex shader [0x80070057]
D3D shader create error for vertex shader [0x80070057]
D3D shader create error for vertex shader [0x80070057]
D3D shader create error for vertex shader [0x80070057]
D3D shader create error for vertex shader [0x80070057]
D3D shader create error for vertex shader [0x80070057]
D3D shader create error for vertex shader [0x80070057]
D3D shader create error for vertex shader [0x80070057]
D3D shader create error for vertex shader [0x80070057]
D3D shader create error for vertex shader [0x80070057]
D3D shader create error for pixel shader [0x80070057]
ShaderProgram is unsupported, but because jobified rendering is enabled the ShaderProgram can not be removed.

(Filename: Line: 450)

ALSA lib confmisc.c:767:(parse_card) cannot find card '0'
ALSA lib conf.c:4528:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:4528:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib confmisc.c:1246:(snd_func_refer) error evaluating name
ALSA lib conf.c:4528:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:5007:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2495:(snd_pcm_open_noupdate) Unknown PCM default
ALSA lib confmisc.c:767:(parse_card) cannot find card '0'
ALSA lib conf.c:4528:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:4528:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib confmisc.c:1246:(snd_func_refer) error evaluating name
ALSA lib conf.c:4528:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:5007:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2495:(snd_pcm_open_noupdate) Unknown PCM default
Begin MonoManager ReloadAssembly
Platform assembly: Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\UnityEngine.dll (this message is harmless)
Loading Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\UnityEngine.dll into Unity Child Domain
Platform assembly: Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\Assembly-CSharp-firstpass.dll (this message is harmless)
Loading Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\Assembly-CSharp-firstpass.dll into Unity Child Domain
Platform assembly: Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\Assembly-CSharp.dll (this message is harmless)
Loading Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\Assembly-CSharp.dll into Unity Child Domain
Platform assembly: Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\Assembly-UnityScript-firstpass.dll (this message is harmless)
Loading Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\Assembly-UnityScript-firstpass.dll into Unity Child Domain
Platform assembly: Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\Assembly-UnityScript.dll (this message is harmless)
Loading Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\Assembly-UnityScript.dll into Unity Child Domain
Platform assembly: Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\UnityEngine.UI.dll (this message is harmless)
Loading Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\UnityEngine.UI.dll into Unity Child Domain
Platform assembly: Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\UnityEngine.Networking.dll (this message is harmless)
Loading Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\UnityEngine.Networking.dll into Unity Child Domain
Platform assembly: Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\SteamworksManaged.dll (this message is harmless)
Loading Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\SteamworksManaged.dll into Unity Child Domain
Platform assembly: Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\AmplifyOcclusion.dll (this message is harmless)
Loading Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\AmplifyOcclusion.dll into Unity Child Domain
Platform assembly: Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\Pathfinding.ClipperLib.dll (this message is harmless)
Loading Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\Pathfinding.ClipperLib.dll into Unity Child Domain
Platform assembly: Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\Pathfinding.Ionic.Zip.Reduced.dll (this message is harmless)
Loading Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\Pathfinding.Ionic.Zip.Reduced.dll into Unity Child Domain
Platform assembly: Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\Pathfinding.JsonFx.dll (this message is harmless)
Loading Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\Pathfinding.JsonFx.dll into Unity Child Domain
Platform assembly: Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\Pathfinding.Poly2Tri.dll (this message is harmless)
Loading Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\Pathfinding.Poly2Tri.dll into Unity Child Domain
Platform assembly: Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\bolt.dll (this message is harmless)
Loading Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\bolt.dll into Unity Child Domain
Platform assembly: Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\bolt.user.dll (this message is harmless)
Loading Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\bolt.user.dll into Unity Child Domain
Platform assembly: Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\udpkit.common.dll (this message is harmless)
Loading Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\udpkit.common.dll into Unity Child Domain
Platform assembly: Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\udpkit.dll (this message is harmless)
Loading Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\udpkit.dll into Unity Child Domain
Platform assembly: Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\Newtonsoft.Json.dll (this message is harmless)
Loading Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\Newtonsoft.Json.dll into Unity Child Domain
Platform assembly: Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\RestSharp.dll (this message is harmless)
Loading Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\RestSharp.dll into Unity Child Domain
Platform assembly: Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\TheForest.Commons.dll (this message is harmless)
Loading Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\TheForest.Commons.dll into Unity Child Domain
Platform assembly: Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\TheForest.Modding.dll (this message is harmless)
Loading Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\TheForest.Modding.dll into Unity Child Domain
Platform assembly: Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\PlayMaker.dll (this message is harmless)
Loading Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\PlayMaker.dll into Unity Child Domain
Platform assembly: Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\Rewired_Core.dll (this message is harmless)
Loading Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\Rewired_Core.dll into Unity Child Domain
Platform assembly: Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\Rewired_Windows_Lib.dll (this message is harmless)
Loading Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\Rewired_Windows_Lib.dll into Unity Child Domain
- Completed reload, in 0.084 seconds
Platform assembly: Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\System.Core.dll (this message is harmless)
Platform assembly: Z:\serverdata\serverfiles\TheForestDedicatedServer_Data\Managed\System.dll (this message is harmless)
OnLevelWasLoaded was found on FocusLostAudio
This message has been deprecated and will be removed in a later version of Unity.
Add a delegate to SceneManager.sceneLoaded instead to get notifications after scene loading has completed

(Filename: Line: 376)

OnLevelWasLoaded was found on RoomLoader
This message has been deprecated and will be removed in a later version of Unity.
Add a delegate to SceneManager.sceneLoaded instead to get notifications after scene loading has completed

(Filename: Line: 376)

OnLevelWasLoaded was found on PlaneCrashAudioState
This message has been deprecated and will be removed in a later version of Unity.
Add a delegate to SceneManager.sceneLoaded instead to get notifications after scene loading has completed

(Filename: Line: 376)

OnLevelWasLoaded was found on SwitchGrassSettings
This message has been deprecated and will be removed in a later version of Unity.
Add a delegate to SceneManager.sceneLoaded instead to get notifications after scene loading has completed

(Filename: Line: 376)

OnLevelWasLoaded was found on MenuMain
This message has been deprecated and will be removed in a later version of Unity.
Add a delegate to SceneManager.sceneLoaded instead to get notifications after scene loading has completed

(Filename: Line: 376)

OnLevelWasLoaded was found on PlayerInventory
This message has been deprecated and will be removed in a later version of Unity.
Add a delegate to SceneManager.sceneLoaded instead to get notifications after scene loading has completed

(Filename: Line: 376)

OnLevelWasLoaded was found on DeathMPTut
This message has been deprecated and will be removed in a later version of Unity.
Add a delegate to SceneManager.sceneLoaded instead to get notifications after scene loading has completed

(Filename: Line: 376)

OnLevelWasLoaded was found on PlayerPreferences
This message has been deprecated and will be removed in a later version of Unity.
Add a delegate to SceneManager.sceneLoaded instead to get notifications after scene loading has completed

(Filename: Line: 376)

OnLevelWasLoaded was found on DebugConsole
This message has been deprecated and will be removed in a later version of Unity.
Add a delegate to SceneManager.sceneLoaded instead to get notifications after scene loading has completed

(Filename: Line: 376)

OnLevelWasLoaded was found on JSONLevelLoader
This message has been deprecated and will be removed in a later version of Unity.
Add a delegate to SceneManager.sceneLoaded instead to get notifications after scene loading has completed

(Filename: Line: 376)

OnLevelWasLoaded was found on PauseMenuAudio
This message has been deprecated and will be removed in a later version of Unity.
Add a delegate to SceneManager.sceneLoaded instead to get notifications after scene loading has completed

(Filename: Line: 376)

OnLevelWasLoaded was found on LevelLoader
This message has been deprecated and will be removed in a later version of Unity.
Add a delegate to SceneManager.sceneLoaded instead to get notifications after scene loading has completed

(Filename: Line: 376)

OnLevelWasLoaded was found on PlayMakerFSM
This message has been deprecated and will be removed in a later version of Unity.
Add a delegate to SceneManager.sceneLoaded instead to get notifications after scene loading has completed

(Filename: Line: 376)

The referenced script on this Behaviour (Game Object 'VR System') is missing!

(Filename: Line: 1744)

UnloadTime: 2.492000 ms
EntryPointNotFoundException: AttachConsole
at (wrapper managed-to-native) Bolt.ConsoleWriter/PInvoke:AttachConsole (uint)
at Bolt.ConsoleWriter.Open () [0x00000] in <filename unknown>:0
at CoopDedicatedBootstrap.ServerRoutine (System.String[] args) [0x00000] in <filename unknown>:0
at CoopDedicatedBootstrap.Awake () [0x00000] in <filename unknown>:0

(Filename: Line: -1)
 

Share this post


Link to post
16 minutes ago, lionel.pereira85 said:

Ok... I've changed the token along with the ID I'm using 556450.

 

Still not working though. Ports are forwarded.... Here's the log after reinstall.

Have you created a server token for App ID 242760 and put in like in the discription of the docker (The App ID for the created token must be from The Forest -> 242760)?

You can also check the page: https://steamcommunity.com/dev/managegameserver and look at the 'last login' section, if the container was able to connect to steam.

16 minutes ago, lionel.pereira85 said:

(Filename: Line: -1)

Also this looks not like the end of the log (btw the best way to post logfiles here is to create a textfile and copy all text from the log into it, save it, and then insert it here into the post).

 

Have you changed any port or config? Wich network mode are you using (You can also check here on this site if the ports are really available from outside, just enter your public internet ip adress and the port)?

 

Look at this post it shows what it sould say if it can connect to steam:

 

 

 

 

Edited by ich777

Share this post


Link to post

Here's the docker config

 

This is the end of the log. Nothing happens after the (Filename: Line: -1)

 

 

forest server log.txt

forest server.png

I created the server token for 242760.

Should I have that ID in the docker setup as well?

 

Sorry.. I have no idea why I'm not getting this... 

Edited by lionel.pereira85

Share this post


Link to post
5 minutes ago, lionel.pereira85 said:

Now getting this:

Steam Manager Started.
GameServer init success. Port: 27015
Set a Logon
Failed to connect to Steam

Then your ports are not reachable from 'outside' go to: https://www.yougetsignal.com/tools/open-ports/ enter you public ip and the adresses that are forwarded if they are reachable.

 

That sounds only like a portforwarding issue.

You can send me your public ip in a PM and i will try to connect to the ports.

Edited by ich777

Share this post


Link to post
5 minutes ago, ich777 said:

Then your ports are not reachable from 'outside' go to: https://www.yougetsignal.com/tools/open-ports/ enter you public ip and the adresses that are forwarded if they are reachable.

 

That sounds only like a portforwarding issue.

You can send me your public ip in a PM and i will try to connect to the ports.

Sent you a PM

 

It's weird.... my plex is working just fine.

Share this post


Link to post

So I got the factorio docker up and running. How do I make myself the admin? I added my name in the server-settings json but can't get it to take. I restarted the server but then it wouldn't publish to factorio. HELPPPPPP please.

Share this post


Link to post
6 hours ago, jagr200 said:

So I got the factorio docker up and running. How do I make myself the admin? I added my name in the server-settings json but can't get it to take. I restarted the server but then it wouldn't publish to factorio. HELPPPPPP please.

Please look at this post:

 

Share this post


Link to post

Has anybody had any luck running multiple OpenRCT Docker instances? I can get one running with the default port settings but when I start create another instance and change the default ports, say for example in the picture below:

 

image.thumb.png.fb6004c3eaa3104c21271b9c23500698.png

 

I get the "Unable to connect to server" error when trying to connect to the game on my internal network.  FYI, I do have port forwarding set up already for all the ports I've specified for OpenRCT.

 

Are there any additional settings that I need to modify such as the config file?

 

image.png

 

FYI, here are my docker container settings:

 

image.thumb.png.31248b48d86512197d9db836651fb933.png

 

and the docker command: image.thumb.png.6662701fc155d3ad43fa130b9e0eb13d.png

Edited by TstormDoc
Added picture of docker settings

Share this post


Link to post
52 minutes ago, TstormDoc said:

Has anybody had any luck running multiple OpenRCT Docker instances? I can get one running with the default port settings but when I start create another instance and change the default ports, say for example in the picture below:

 

image.thumb.png.fb6004c3eaa3104c21271b9c23500698.png

 

I get the "Unable to connect to server" error when trying to connect to the game on my internal network.  FYI, I do have port forwarding set up already for all the ports I've specified for OpenRCT.

Under Advanced settings you have to change the GAME_PORT to 11754 and you must delete the TCP - Game Port and create a new port with the container port 11753 and unraid port 11754 (like the discription of the TCP - Game Port says than it should just work fine, also change your config file to 11754.

This doesn't work if you forward the port 11753 to 11754 through docker

 

If you put 11754 under GAME_PORT the game would start with port 11754 exposed but the docker would translate port 11753 from the docker to 11754 to unraid since the game is running on port 11753 (from your config file) it could not connect to this port inside the docker, if this makes sense to you.

Edited by ich777

Share this post


Link to post
22 minutes ago, ich777 said:

Under Advanced settings you have to change the GAME_PORT to 11754 and you must delete the TCP - Game Port and create a new port with the container port 11753 and unraid port 11754 (like the discription of the TCP - Game Port says than it should just work fine, also change your config file to 11754.

This doesn't work if you forward the port 11753 to 11754 through docker

 

If you put 11754 under GAME_PORT the game would start with port 11754 exposed but the docker would translate port 11753 from the docker to 11754 to unraid since the game is running on port 11753 (from your config file) it could not connect to this port inside the docker, if this makes sense to you.

@ich777, appreciate the speedy response!  Thanks for clarifying that I had to physically delete the port variable:

image.png.b844882e54ddef4a26f55cb4cd72f5ee.png

 

I was under the impression that all I needed to do was delete the main entry from the unraid GUI.

 

All that really needs to be done is to edit the TCP - Game Port Configuration and modify both the host and container ports so they're the same.

 

My only suggestion for this Docker container is to change the language in the description to clarify to remove the a parameter TCP - Game Port and create a new port configuration variable or even just clarify to modify the port configuration for both host and container.

 

Anyways, I just created three different instances and it's all up and running now. Thanks for your help!

Share this post


Link to post
16 hours ago, ich777 said:

Please look at this post:

 

 

I appreciate the response. I did exactly that and it still didn't work.

Share this post


Link to post
4 minutes ago, jagr200 said:

 

I appreciate the response. I did exactly that and it still didn't work.

Have you set it to online or offline mode? Also did you specify your factorio.com login details in the file if you set it to online mode?

If you set it to online mode you must provide another name like the name you're connecting with, please look at the factorio forums how that works since im not familar with that.

Share this post


Link to post
2 minutes ago, ich777 said:

Have you set it to online or offline mode? Also did you specify your factorio.com login details in the file if you set it to online mode?

If you set it to online mode you must provide another name like the name you're connecting with, please look at the factorio forums how that works since im not familar with that.

 

I have it in online mode. It connects fine. Soon as I put my name in the admin line it no longer shows up in the factorio public browser. I'm checking the factorio forums now but can't find anything.

Share this post


Link to post
1 minute ago, jagr200 said:

 

I have it in online mode. It connects fine. Soon as I put my name in the admin line it no longer shows up in the factorio public browser. I'm checking the factorio forums now but can't find anything.

What does the log say?

Share this post


Link to post
2 minutes ago, ich777 said:

What does the log say?

The only error I could find was this 0.000 Error Util.cpp:83: Unexpected character (") at /factorio/config/server-settings.json:70

Edited by jagr200

Share this post


Link to post
Just now, jagr200 said:

The only error I could find was this 0.000 Error Util.cpp:83: Unexpected character (") at /factorio/config/server-settings.json:70

Yep, that's why you couldn't see the server, the username is not entered correctly and the server is stuck (in other words it couldn't start because it's failing to read line 70 in the server-settings.json - this is the username line i think in your case)

Share this post


Link to post
1 minute ago, ich777 said:

Yep, that's why you couldn't see the server, the username is not entered correctly and the server is stuck (in other words it couldn't start because it's failing to read line 70 in the server-settings.json - this is the username line i think in your case)

 

Ya that is the username line. I literally put it in exactly like that image in the post you linked to. Just obviously put my username in place of his.

Share this post


Link to post
1 minute ago, jagr200 said:

 

Ya that is the username line. I literally put it in exactly like that image in the post you linked to. Just obviously put my username in place of his.

Can you post a screenshot?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.