Jump to content
ich777

[Support] ich777 - Gameserver Dockers

741 posts in this topic Last Reply

Recommended Posts

7 hours ago, K0RNBR3D said:

Hey there, I was wondering if you could make a docker for Miscreated when you get a chance. https://steamdb.info/app/302200/ 

 

Don't know if it's possible but i could totaly try to make a docker using WINE (if you don't know it it's a wraper for linux to make windows programs run on linux... the more or less).
But please be aware that if i try that with WINE it's much likely to have much overhead, use very much system resources (more than on a real windows machine) and could even lag really much (besides that it can crash really often).
You could post on their forums or contact the developers if there ever will be a dedicated linux server version for the game.

You can try out my 'The Forest' docker it uses a lot of memory and a lot of cpu power (it's also created with WINE).

Share this post


Link to post
20 hours ago, ich777 said:

Don't know if it's possible but i could totaly try to make a docker using WINE (if you don't know it it's a wraper for linux to make windows programs run on linux... the more or less).
But please be aware that if i try that with WINE it's much likely to have much overhead, use very much system resources (more than on a real windows machine) and could even lag really much (besides that it can crash really often).
You could post on their forums or contact the developers if there ever will be a dedicated linux server version for the game.

You can try out my 'The Forest' docker it uses a lot of memory and a lot of cpu power (it's also created with WINE).

Ahh. I guess I'll stick to running it in a VM. Thanks for checking! :)

 

Share this post


Link to post

Hey ich,

how do I give myself op on the minecraft server using your docker, is there a way to access the minecraft console?

Share this post


Link to post
1 hour ago, joonizz said:

Hey ich,

how do I give myself op on the minecraft server using your docker, is there a way to access the minecraft console?

Yes if you read the discription of the docker you know how... :D

 

Click on the docker image of minecraft, click on Console and enter: screen -xS Minecraft

Share this post


Link to post

Oh...

Read that when I first started the server but totally forgot it.

Thank you!

Share this post


Link to post

As you said the DayZ Server isn't possible that easy, I saw you made a Docker for ARMA3 Exile, is it possible to get an ARMA3 EPOCH Server Docker?

Share this post


Link to post
1 hour ago, Select25 said:

As you said the DayZ Server isn't possible that easy, I saw you made a Docker for ARMA3 Exile, is it possible to get an ARMA3 EPOCH Server Docker?

DayZ mod for Arma is based on Arma 2, but should be doable but i don't have much spare time in the summer months.
Will take a look into EPOCH.

Share this post


Link to post
On 8/3/2019 at 7:53 AM, ich777 said:

Docker is now finished, should be available in a few hours, check the Community Applications. ;)

Thank you!

Share this post


Link to post
Posted (edited)

First off...thank you for these awesome game servers.  I have my 8 and 9 year old boys playing HL2DM and TF2.  The interaction is hilarious.  :)

 

As described earlier in this post, I also added RCBOT2 to both games and have it running as expected.  The issue is that the console is now spammed with messages like these:

 

weapon_357[257]: Playing sequence 3 but there's only 2 in total?
weapon_357[257]: Playing sequence 3 but there's only 2 in total?
weapon_357[257]: Playing sequence 3 but there's only 2 in total?
weapon_357[257]: Playing sequence 3 but there's only 2 in total?
weapon_357[257]: Playing sequence 3 but there's only 2 in total?

 

More info here:  https://steamcommunity.com/sharedfiles/filedetails/?id=157466467

 

So, I added the lines below to my server.cfg file but it does not seem to have any effect.  If I type the commands in a console, they work.

 

con_filter_enable 1
con_filter_text_out "Playing sequence"

 

Any ideas?

 

TIA.

 

John

Edited by johnodon

Share this post


Link to post
20 hours ago, johnodon said:

So, I added the lines below to my server.cfg file but it does not seem to have any effect.  If I type the commands in a console, they work.

 

con_filter_enable 1
con_filter_text_out "Playing sequence"

Hi John, I think you would have to add those to each of the client PC's in a autoexec.cfg as it says in that guide.

It makes sense that it would not work from the server.cfg, its the clients console that's the problem. 

 

Verified the game files? https://support.steampowered.com/kb_article.php?ref=2037-QEUH-3335

 

By the way, doing the same with dods with my son... and his sons playing on ich777 's Dockers.

Loads of fun.

 

I have not seen the spam in the TF2 one last time I played, I'll check the boys pc's.

Share this post


Link to post
Posted (edited)
7 minutes ago, INsane said:

Hi John, I think you would have to add those to each of the client PC's in a autoexec.cfg as it says in that guide.

It makes sense that it would not work from the server.cfg, its the clients console that's the problem. 

 

Verified the game files? https://support.steampowered.com/kb_article.php?ref=2037-QEUH-3335

 

By the way, doing the same with dods with my son... and his sons playing on ich777 's Dockers.

Loads of fun.

 

I have not seen the spam in the TF2 one last time I played, I'll check the boys pc's.

Thx insane.  I'll add those to the autoexec.cfg on the boys. machines.

 

BTW, I sent you a PM (hope you don't mind...didn't want to make this thread longer than needed).  I only got rcbot2 to play nicely on tf2 just the once although the bots didn't move.  Ever since, it generates a segfault when I try to join my local server.  Disabling rcbot2 and I am able to join without issue.

 

John

Edited by johnodon

Share this post


Link to post
Posted (edited)
On 5/15/2019 at 5:36 PM, jordanmw said:

Mods-

Edit GameUserSettings.ini

Under

[ServerSettings]
ActiveMods=517605531,519998112,496026322

 

Admins-

you will need their steamid and then create a file:

\ShooterGame\Saved\AllowedCheaterSteamIDs.txt and enter the ID of each of the admins you want to have admin rights.

I have managed to edit the gameusersettings as required, but even after a restart the mods are not installed. Is there anything I have to run to allow them to download?

thanks

 

Have found this, so will give that a go. I guess you just copy over the mods to the docker as they update?

https://www.akliz.net/manage/knowledgebase/66/How-to-Install-ARK-Survival-Evolved-Mods-on-a-Server.html

Edited by Kuwabara89
found solution

Share this post


Link to post
1 hour ago, Kuwabara89 said:

I have managed to edit the gameusersettings as required, but even after a restart the mods are not installed. Is there anything I have to run to allow them to download?

thanks

 

Have found this, so will give that a go. I guess you just copy over the mods to the docker as they update?

https://www.akliz.net/manage/knowledgebase/66/How-to-Install-ARK-Survival-Evolved-Mods-on-a-Server.html

That is correct.  At this time, the built in Mod Manager for ARK doesn't work right (this is an ARK Dev issue, and the only known fix involves Symlinking folders and running the executable from a specific directory).

 

One thing to be aware of is that ARK Mods require you to start ARK once after you finish the download, to finish the extraction and installation of the Mod.  If you do not start ARK once after the Mod download, and wait for it to finish "Installing Mod(s)" (seen in the lower right corner of the menu), then the files you copy over will be incomplete.

 

Also, be aware that if you have Mods on the server and the Mod updates, the server will not be visible to any clients that have the updated Mod until you are able to update the Mod on the server.  Updating the server Mod involves the same steps as installing it (download, start ARK, wait for the install to finish, copy files)

Share this post


Link to post

I have been trying to get the Minecraft Bedrock version to work, but Minecraft on Win10 bedrock always kicks back saying it is out of date. In the docker set up I have entered 1.12 (I think thats the most recent..?) and it still is showing up as out of date. Do I need to adjust that somewhere else? 

Share this post


Link to post
Posted (edited)
On 8/25/2019 at 5:41 PM, Skoden said:

I have been trying to get the Minecraft Bedrock version to work, but Minecraft on Win10 bedrock always kicks back saying it is out of date. In the docker set up I have entered 1.12 (I think thats the most recent..?) and it still is showing up as out of date. Do I need to adjust that somewhere else? 

According to the wiki the latest server version is 1.12.0.28.

 

EDIT: Tested it and it works with version 1.12.0.28

 

Screenshot_20190825-182008_Chrome.thumb.png.455505ea7693db2b2eeb9b769707fd04.png

Edited by ich777

Share this post


Link to post

Request for Unreal Tournament 2004.  I see a few dockerized versions on docker hub and github so I imagine it is quite doable.

 

John

Share this post


Link to post

I'm having an issue when I set up multiple minecraft dockers in which only the server with the default port I'm able to connect to. I have changed the ports on both the unraid docker settings and server.properties file but I'm still only able to connect to the server on the default port.

Share this post


Link to post
7 hours ago, johnodon said:

Request for Unreal Tournament 2004.  I see a few dockerized versions on docker hub and github so I imagine it is quite doable.

 

John

Yes, this is totaly possible and i think it was already requested but since the game files (or at least the server game files) are not opensource or to download for everyone i wouldn't do such a server. My dockers are built for easy use and not having to do much (except for FiveM, recently the developers added a captcha to the download so you must put the archive in the main directory of the server).

There are a bunch of dockers out there and you easily can get them to work with unraid.

Share this post


Link to post
Posted (edited)
18 minutes ago, GeneralTed said:

I have changed the ports on both the unraid docker settings

I think there is the problem, you must delete this entry entirely and add a new port. Say for example you set the port in the server.properties to 26569 you must delete the standard port and create a new port in the docker settings page with the container port 26569 and the host port 26569.

Edited by ich777

Share this post


Link to post

I am loving your dockers for Rust, Hurtworld and 7D2D..    what are the chances of getting a "life is feudal" docker for hosting a server?

Share this post


Link to post
5 hours ago, Newtious said:

I am loving your dockers for Rust, Hurtworld and 7D2D..    what are the chances of getting a "life is feudal" docker for hosting a server?

From a quick research online this is also a windows only game like Space Engeneers.

It also involves to set up a database (that would be no problem) but i think since i must run it through WINE it's not that easy and causes a lot of overhead and slow response times but i can try to create a docker also you can try out my The Forest docker (this runs also with WINE and uses a lot of system resources because auf WINE).

Share this post


Link to post

Maybe I'm just having a dumb moment, but I can't seem to make the ARK server save any gameusersetting.ini changes.  They are over written on restart.  Am I missing something stupidly simple?

 

 

Share this post


Link to post
12 hours ago, GaziusMesa said:

Maybe I'm just having a dumb moment, but I can't seem to make the ARK server save any gameusersetting.ini changes.  They are over written on restart.  Am I missing something stupidly simple?

 

 

Maybe @bubo can help with this, is it possible that the docker overwrites the values from the start paramaters overwrite the gameusersettings.ini?

Nothing else from my perspective can overwrite the file else.

Share this post


Link to post
13 hours ago, GaziusMesa said:

Maybe I'm just having a dumb moment, but I can't seem to make the ARK server save any gameusersetting.ini changes.  They are over written on restart.  Am I missing something stupidly simple?

 

 

The Docker will overwrite certain values if they are populated in the Docker template.

 

1.  What are you using to edit gameusersetting.ini?

 

2.  Which parts of the gameusersetting.ini are being overwritten?  (If you suspect that it is the entire thing, then please add a new entry to see if it's deleting anything.)

 

3.  What are the contents of your Game Parameters and Extra Game Parameters fields?

 

4.  Just to check possibilities, what is the path to the gameusersetting.ini that you are using?

Edited by bubo

Share this post


Link to post
On 8/25/2019 at 9:22 AM, ich777 said:

According to the wiki the latest server version is 1.12.0.28.

 

EDIT: Tested it and it works with version 1.12.0.28

 

Screenshot_20190825-182008_Chrome.thumb.png.455505ea7693db2b2eeb9b769707fd04.png

So I just install the docker, with 1.12.0.28 in the docker settings and then do I need to run any other settings for it before getting it to work? I have not set up a minecraft server before, not sure if there are other settings I need to fix first. If there is a directions page or readme I am just missing, please let me know. 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.