[Support] ich777 - Gameserver Dockers


4015 posts in this topic Last Reply

Recommended Posts

7 minutes ago, thunderclap said:

Yes, I changed all the port numbers in the container as well as the server config file. As I previously mentioned, I installed the second container using the latest stable build (18.4) using your install and it worked along side the first container install. It's only after I upgraded to the latest experimental that it stops working.

Sorry but then I really can't help but maybe @WeAreTheDynamite can help since I don't own the game and simply can't troubleshoot this.

Link to post
  • Replies 4k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Summary: Support Thread for ich777 Gameserver Dockers (CounterStrike: Source & ConterStrike: GO, TeamFortress 2, ArmA III,... - complete list in the second post) Application: SteamCMD Do

Just thought I'd share my experience setting up a Valheim server with this docker app from @ich777(thank you!)   You don't need to worry about Steam authentication for Valheim, the default a

Dockers Available so far:   SteamCMD DedicatedServers: CounterStrike: Source CounterStrike: Global Offensive TeamFortress 2 ArmA3 - requested by @MrSage D

Posted Images

46 minutes ago, thunderclap said:

I realize it's hard to troubleshoot for you since you don't have the game

Hint. Find a way to get him a license for the game. If it's too expensive for you personally, reach out to other users in this thread that have expressed interest in the game and coordinate a purchase somehow.

Link to post
11 hours ago, ich777 said:

So you have created a second Container?

Have you changed the port inside the template?

If so have you deleted the port entries in the template and created new ones and also change it in your serversettings file?

 

If you only change them in the template it will not work...

So I finally got it working: the trick is to NOT change the port in the serverconfig file, but to leave it at 26900. Who would have thought? :) Once I did that the port I assigned the container to opened right up.

Link to post
4 hours ago, DirkDiggler531 said:

Hey ich777, have you looked into building a docker for a 'Hell Let Loose' game server? The game is on Steam and it is similar to Squad but set in WWII. Would be a great addition to the multitude of game server dockers you've already created, but not sure if its doable.

Read this:

https://steamcommunity.com/games/686810/announcements/detail/1608261661815739994

 

There is a plan for it but no detailed information on this yet, I already have the game in my library.

If you know more or find a newer link or newer informations I would definetly try it. ;)

Link to post
1 hour ago, lelouch420 said:

i'm confused on how to get into the console for minecraft server, also is there a way to update the game pas 1.15?

Are we talking about the java or bedrock edition?

The java edition can be updated manually by simply downloading the server jar and replacing the existing one.

The bedrock edition updates on every restart of the container automatically.

 

To get to the console open up a console window of unraid (not the container) and type in: 'docker exec -u minecraft -ti NAMEOFYOURCONTAINER screen -xS Minecraft' (replace NAMEOFYOURCONTAINRR with your containername for example: MinecraftBasicServer) and you sould be connected to the console.

Link to post
3 hours ago, lelouch420 said:

Thanks for the info. Just one question. Even though i put the 1.16.1 jar in the folder, its still running the 1.15 version of minecraft. even after restart ofc. 

You have to rename the downloaded file to the server.jar and replace it or you have to change the variable 'Serverfile name' to the downloaded .jar name without the extension (please read the description of the variables and also the container).

With this methode you are able to run forge, spigot or whatever you want.

Link to post

Hey ich777. First of all thanks for all the work you've done with these dockers. I started having an issue with Conan Exiles docker. I believe they changed something in their dedicated server app and now it's not working. I saw some people having similar issues with pc dedicated server app too.

 I'm getting 002b:fixme:wininet:InternetSetOptionW Option 77 STUB and it keeps going on like that. It used to work a month ago or so and didn't change anything on my machine. I also did a clean install but still getting the same issue. Is it possible for you to take a look at it when you have the time? Many thanks in advance!

Link to post
3 hours ago, EG-Thundy said:

Hey ich777. First of all thanks for all the work you've done with these dockers. I started having an issue with Conan Exiles docker. I believe they changed something in their dedicated server app and now it's not working. I saw some people having similar issues with pc dedicated server app too.

I will look into this.

 

3 hours ago, EG-Thundy said:

002b:fixme:wininet:InternetSetOptionW Option 77 STUB

Only for info, this is actually a WINE warning (since this container runs with WINE).

 

 

EDIT: No problem here, attached the log and also a screenshot where it shows that is up and running. Can also connect to the server without no problem. Please report back if the problem persists for you (Also get that warning from WINE but that can be ignored).

Log: Conan.log

Screenshot:

Screenshot.png.7df532ac118926387b4be90be3a3e1d9.png

Link to post

EDIT: I dug in more and apparently it's a issue on the game's end. Server does not show up on sever list in-game and it's not possible to connect using steam connect BUT if you go in-game and direct connect using the server ip, it connects.

 

Thanks for looking into it so quickly. It's still not working. I can see it on steam servers list but not in game. When I click on connect from steam, I get the error "Unable to connect to server, app id specified by server is invalid"  I checked the game_id on the docker and compared it with the steam server list. It is correct so kinda stuck again. I attached my log here too. Thanks again.log.txt

Edited by EG-Thundy
Link to post

Hi ich777,  Thank you so much for the ich777/minecraftbedrockserver! It has been awesome! 

Tonight when I restarted the docker, it says "1.16.0.2 - Prefered:, downloading v---
---Something went wrong, can't download Minecraft Bedrock Edition, putting server in sleep mode---"  

 

My game version was set to 'latest', it has been auto upgrading to the latest version without any issue.  Now I had to change it to '1.16.1.02' in order to start the server. 

 

Please have a look when you have time. 

 

Thank you!

Link to post
3 hours ago, asdfpp said:

Hi ich777,  Thank you so much for the ich777/minecraftbedrockserver! It has been awesome! 

Tonight when I restarted the docker, it says "1.16.0.2 - Prefered:, downloading v---
---Something went wrong, can't download Minecraft Bedrock Edition, putting server in sleep mode---"  

 

My game version was set to 'latest', it has been auto upgrading to the latest version without any issue.  Now I had to change it to '1.16.1.02' in order to start the server. 

 

Please have a look when you have time. 

 

Thank you!

I think there might be something wrong with the site where you download the server executable itself...

https://www.minecraft.net/en-us/download/server/bedrock

 

There are no downloads listed... That's why the container can't download the server executable.

 

I will look into this ;)

 

EDIT: I think you mean version: 1.16.1.02

 

 

EDIT2: I think they messed up something with the linux version of v1.16.10.02 look at this site:

https://minecraft.gamepedia.com/Bedrock_Edition_1.16.10

Even when I click on download linux server I can't get the file...

Here is the bug track entry:

https://bugs.mojang.com/browse/BDS-7618?jql=text ~ "1.16.10.02"

Link to post
11 hours ago, EG-Thundy said:

EDIT: I dug in more and apparently it's a issue on the game's end. Server does not show up on sever list in-game and it's not possible to connect using steam connect BUT if you go in-game and direct connect using the server ip, it connects.

Eventually they have changed some startup command or something but my game shows up in the ingame server list if I forward all the required ports.

Link to post
30 minutes ago, Zyrr3 said:

Hi, could you look in to a PvPGN and D2GS server?

 

Tried to get it to work myself but im quite clueless when it comes to this 😛

 

https://forums.pvpgn.pro/viewtopic.php?id=1875

I will look into this but this is also a application where you need to provide the game files I think or am I wrong?

I'm also not sure if this is a really good idea to make a container for this, remember this is battle.net and they are not happy when someone is emulating their services...

Link to post
5 minutes ago, ich777 said:

I will look into this but this is also a application where you need to provide the game files I think or am I wrong?

I'm also not sure if this is a really good idea to make a container for this, remember this is battle.net and they are not happy when someone is emulating their services...

Yeah you need to provide gamefiles but those are available on blizzards website, you need a valid cdkey to play tho.

Dunno if they really care that much as https://pathofdiablo.com/p/ has been up and running for a long time and have a lot of active players.

Link to post
11 minutes ago, D'n'S137 said:

What about a Farming Simulator Server? Like to see this one and should not be to complicated.

This is too complicated. Tried it with Farming Simulator 16, first of all there is no Linux server, only Windows, second you need to install the game by hand (also very complicated because if it works you need to open up a virtual webvnc viewer and enter there the key) and lastly you need an extra license for the Server itself.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.