** Hackintosh ** Tips to make a bare metal MacOS


Leoyzen

824 posts in this topic Last Reply

Recommended Posts

Can i use a copy of this now fine working OC EFI also for my Mojave VM's, so is it downwards compatibe ? Or do i need to use a specific older version or some other changes ? (assuming same vanilla OS install for simplicity sake)

Link to post
  • Replies 823
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

It is time to start a new thread and share my tips, and we can discuss here. For those who don't have much information, see  SpaceInvaderOne's **VIDEO GUIDE** How to Install MacOS Mojave or High

Good news, no more AMD reset bug with RX 6xxx XT series GPUs in macOS 11.4 beta 1 on UnRAID.

Latest release of OVMF_CODE.fd and OVMF_VARS.fd from edk2, v. 202102 published today. Compiled in kali linux with gcc, tested and working. Enjoy edk2-OVMF-202102-Stable-RELEASE-GCC5-Kali.

Posted Images

As lockdown is the best time to experiment i just went ahead (after making a few extra zfs snapshots as am not crazy) and migrated all my VM's incl productive to OpenCore.

With a minor hickup to get the Radeon passthru to work (remove your device properties entry from the plist) everyting worked straight out the box with the exact same EFI/plist. Crazy and amazing.

Love it.

Tnx again for all your work. Clover is history......

Link to post

Thanks @Leoyzen.

 

I am currently trying to passthrough my entire Intel USB controller, but macOS does not seem to recognize the devices connected to it, it shows as an USB controller but is not named correctly. I have tried with USBInjectAll.kext and XHCI-unsupported.kext without luck. Do I need to rename the device under DeviceProperties? 244192357_ScreenShot2020-03-31at1_25_01AM.thumb.png.34d2fd095403c106ed7680bedbb0b5a1.png2021241368_ScreenShot2020-03-31at1_25_11AM.thumb.png.f7cced99a67871d34d2f33da494eb865.png1530262788_ScreenShot2020-03-31at1_25_26AM.png.388b5751c79ce1f1f154caaab724fcbb.png  

Link to post

@Leoyzen I just changed the bus to 0x00 and changed the slot, I can see the controller type is now named S30. I know it must be renamed properly so it can be recognized by the USBInjectAll.kext. How can you rename the device in the config.plist?

Edited by chalboly
Link to post

@Leoyzen Unfortunately it does not seem to be supported by USBInjectAll.kext.

 

What is strange is that I can see the controller and the devices connected, this controller is internal and the only device is the Bluetooth, but this is not detected at boot but rather later when in macOS and when I open the IOregister app. Of course Bluetooth does not work because it can't be patched by BrcmPatchRAM at boot.

Link to post

@Leoyzen I decided to just pass through a different USB controller (ASM1042A) and is working fine. Bluetooth is internal USB on my motherboard so I'm just passing through the USB device, works without any patches except that I am having issues with connected devices. If I use AirPods they disconnect after a while or have audio dropouts. Apple Watch unlock works for a moment and then disconnects. Handoff is also intermittent, so something seems off.  Do you know if SSDT patching is required? Map the virtual USB ports correctly depending on the SMBios?

Edited by chalboly
Link to post

@Leoyzen Thanks, I just tested with a USB Bluetooth device, based on the same chipset BCM920702 which is supported without additional kexts, but the same issue persists. There is audio dropouts when connected to Bluetooth headphones, Continuity works sporadic and Apple Watch unlock does not stay connected to the watch. There are a lot of errors in the logs about this. My Wi-Fi is natively supported (BCM4360). I also moved the USB Bluetooth right next to my devices using an extension. The signal did not improve much (checking with Bluetooth Explorer), and had the same issues, so not sure what else to try.

 

 

Image 4-5-20 at 6.19 PM.jpg

Link to post
1 minute ago, ghost82 said:

The release version?

Yes, I replaced the boot files on the EFI partition, added OpenRuntime and removed FWRuntimeServices and updated my config.plist, used OCConfigCompare. There are several new keys I needed to add and two or three that I had to remove. Make sure to remove those old keys, otherwise it won't boot.

 

Just now, Leoyzen said:

@chalbolySo, did it work or not?

It is working for me, I still have Target set to 83 and it is booting.

Link to post

@chalbolyIt is quite strange because I may find the root cause but your is working.Maybe you did not truely update to 0.5.7 but using 0.5.6?

 

Also to all:

I recommand to switch EFI qcow2/img to usb, this make my bootcamp works(but not work for MacPro7,1, it required no external disk injected.)

    <disk type='file' device='disk'>
      <driver name='qemu' type='qcow2' cache='none'/>
      <source file='/mnt/user/domains/Catalina/opencore.beta.qcow2' index='1'/>
      <backingStore/>
      <target dev='hdc' bus='usb'/>
      <address type='usb' bus='0' port='1'/>
    </disk>

 

Link to post

I noticed, after passing through a GPU to macOS, I can no longer boot up the VM without an actual GPU attached. I created a copy of the VM, removed the GPU, and added the Spice display through virt-manager. On bootup it now hangs on "PCI configuration begin". If I add the GPU back, it boots fine then.

 

Anyone else encounter this? I would like to have a copy of my VM that I can boot quickly without passing through a GPU, just for testing purposes.

 

Using OpenCore with the config provided here https://github.com/Leoyzen/KVM-Opencore

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.