Help Take the Fight to COVID-19 with BOINC and Folding@home


333 posts in this topic Last Reply

Recommended Posts

  • Replies 332
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Use extra Unraid CPU or GPU computing power to help take the fight to COVID-19 with BOINC or Folding@Home!   https://unraid.net/blog/help-take-the-fight-to-covid-19-with-boinc-or-folding-hom

Just caught onto this today (Thx @SpaceInvaderOne !), saw we're "only" #2, which just won't do --- Just "remembered" I have a Threadripper 2950x new in box - was going to sell the old dual Xeon E5 V2s

Posted Images

Once I heard about F@H having coronavirus work units I went ahead and installed it on my work laptop (running full tilt all the time), my main windows driver, and my HTPC.

 

While it is immaterial what team you use (if you even want one), if you do choose, unRaid's F@H team number is 227802.

 

If you do happen to be one of those persons who feel that this isnt a big deal, that choice is yours, but bear in mind that donating some spare cycles costs you nothing and can only help.

Link to post

Although the forumpost for the folding@home container is leaning towards the GPU not beeing supported, i can say the container has the ability to use a GPU, by adding the same arguments as you would add to your mediaserver

Go Team Unraid!

Link to post
11 hours ago, ptr727 said:

I just installed BOINC, any instructions on how to get GPU working?

I added options similar to my Plex docker, but I see no GPU activity.

 

It looks like unfortunately, the Rosetta@home project isn't utilizing GPU's. I believe Folding@home it though. 

89436000_10163065943140253_770926902847209472_n.jpg

Link to post

I use my GPU with a Windows VM. Linux works to but is harder to configure.

Assign one core and its HT portion to the GPU folding VM and leave the rest of your unused cores to F@H/BOINC!

i have 3900x, 290, 2x5700XT. This is used for a 2Gamers1CPU build normally but now all folding!

 

Link to post
1 hour ago, SpencerJ said:

It looks like unfortunately, the Rosetta@home project isn't utilizing GPU's. I believe Folding@home it though. 

89436000_10163065943140253_770926902847209472_n.jpg

Maybe the blog post can be updated to make it easier and clearer on how to get started, e.g. what are the folding@home GPU instructions?

Link to post
3 minutes ago, ptr727 said:

what are the folding@home GPU instructions?

As I said in the second comment on this post, you should get going by defining runtime, and add the variables for capabilities and devices. as you would to your mediaserver

Link to post
5 minutes ago, Roxedus said:

As I said in the second comment on this post, you should get going by defining runtime, and add the variables for capabilities and devices. as you would to your mediaserver

I'll take a look, but for a moment imagine somebody like me read the blog post, wanting to contribute, I come to the forum, I see pages and pages of posts, with no single place pointing to instructions, after reading a couple pages, you know what they do, they leave.

Update: I added the same runtime and device parameters as for my Plex docker, no web UI, event the app says web ui is broken, folding at home forum post is 6 pages long, no single point of instructions.

Edited by ptr727
Tried it
Link to post
2 minutes ago, ptr727 said:

I'll take a look, but for a moment imagine somebody like me read the blog post, wanting to contribute, I come to the forum, I see pages and pages of posts, with no single place pointing to instructions, after reading a couple pages, you know what they do, they leave.

I just wanted to help, chill. 
I agree, @SpencerJ should clarify the setup process a bit.

Link to post
15 minutes ago, Roxedus said:

As I said in the second comment on this post, you should get going by defining runtime, and add the variables for capabilities and devices. as you would to your mediaserver

even with that, mine only uses cpu.....

 

logs show

 

15:52:30: GPUs: 0
15:52:30: CUDA: Not detected: cuInit() returned 100

 

Edited by 1812
Link to post
7 minutes ago, Roxedus said:

In the config.xml, remove 


<gpu v='false'/>

and add


  <slot id='1' type='GPU'/>

 

this helps recognize the gpu. thanks. but now I'm seeing this error:

 

16:03:24:WU01:FS01:Connecting to 65.254.110.245:8080
16:03:24:WU01:FS01:Assigned to work server 155.247.166.220
16:03:24:WU01:FS01:Requesting new work unit for slot 01: READY gpu:0:GP107 [GeForce GTX 1050 LP] 1862 from 155.247.166.220
16:03:24:WU01:FS01:Connecting to 155.247.166.220:8080
[91m16:03:24:ERROR:WU01:FS01:Exception: 10001: Server responded: HTTP_SERVICE_UNAVAILABLE[0m

16:03:24:WU01:FS01:Connecting to 65.254.110.245:8080
16:03:24:WU01:FS01:Assigned to work server 155.247.166.220
16:03:24:WU01:FS01:Requesting new work unit for slot 01: READY gpu:0:GP107 [GeForce GTX 1050 LP] 1862 from 155.247.166.220
16:03:24:WU01:FS01:Connecting to 155.247.166.220:8080
[91m16:03:24:ERROR:WU01:FS01:Exception: 10001: Server responded: HTTP_SERVICE_UNAVAILABLE[0m

problem with F@H?

Link to post
24 minutes ago, ptr727 said:

I appreciate the help, my point was that it should no be necessary if the blog post was complete and anticipated needs of new setups.

Frankly, people seem to be having a lot of issues with Folding@home with GUI and GPU setup. Seeing that I was trying to help out in an easy way for the most amount of people, I went with showing how to set up BOINC. 
 

Recent GPU/webgui support threads start around here: 

 

Link to post
56 minutes ago, Roxedus said:

I got mine working. mind raising the capabilities to `all`?

mine was set that way. I just left it alone for a bit and it eventually figured itself out. all good now!

 

1024181730_ScreenShot2020-03-14at1_02_08PM.png.984343ff7ac53a7f900fabcb1d4705fc.png

Edited by 1812
Link to post
6 minutes ago, mattekure said:

One suggestion for the Boinc Install instructions.  In order for the File->Select Computer option to show up, you have to switch to Advanced View.  Simple view does not show that option.

Strangely, it's under FIle --> Select Comp for me but have updated with CTRL+Shift+I as a hotkey to open this. TY

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.