[Plugin] DVB-Driver


ich777

Recommended Posts

1 hour ago, Furaxio said:

WinTV-HVR-5525

LibreELEC is the driver package you should use.

 

1 hour ago, Furaxio said:

So far so good, but only two tuners show up (DVB-T, DVB-C). The DVB-S / S2 is missing and when I try to set them up in Plex it only shows the T/C.

Do you only tested this with Plex?

Eventually try it with TVHeadend too for troubleshooting reasons and if TVHeadend actually sees the DVB-S part of the card (what I think it would do).

What device did you pass through to Plex in the template?

Link to comment

Thanks for the relpy, I installed TVHeadend, there it show's the DVB-S Part:

image.png.24c2b65436ddd964aee847f510a914f2.png

 

I passed /dev/dvb/ (on Plex and TVHeadend). If I only pass /dev/dvb/adapter0 it shows the card in Plex on the DVR Settings Page but the Dropdown-Menue for the Type is empty and I can't select a Type.

image.png.ff796dac7e40ad7b169bd685f336bcdb.png

 

 

Link to comment
25 minutes ago, Furaxio said:

I passed /dev/dvb/

I would recommend doing it this way.

 

26 minutes ago, Furaxio said:

Plex on the DVR Settings Page but the Dropdown-Menue for the Type is empty and I can't select a Type.

Eventually @alturismo can help here.

I think, if I remember correctly, he always recommends using a combination of TVHeadend and Plex if you are using Plex and a really good EPG in addition to that.

Link to comment
Posted (edited)
2 hours ago, Furaxio said:

so basically running the Tuners in TVHeadend and connecting Plex over Network? 

 

personal suggestion

 

setup tvheadend with your channels

get a proxy for m3u -> plex, personal recommendation xteve

depending now if you need a seperate guide, setup guide2go (xteve dockers have them included)

use the xteve tuner in plex

in case of xml guide data, use xml guide in plex, otherwise PMS guide

enjoy

Edited by alturismo
  • Thanks 1
Link to comment
Posted (edited)

FYI, my T230C2 arrived and it works perfectly without tinkering using the libreelec drivers. Let me know if you need any testing with T230A, I think I put it in a drawer until it gets reliable DVB-C support at which point I can probably sell it.

Edited by andris
  • Like 1
Link to comment
7 hours ago, andris said:

T230A

Thank you for the feedback!

The problem with this device is that you don't know what you actually get inside the device, so I don't think further testing is needed... Just sell it and eventually mention that Linux is not supported, at least on this specific device...

Link to comment

Hi @ich777,

 

thanks for that awesome work. Hope you will keep it going for the upcoming releases of unraid. Cant miss that.

I just tryed to get my Tevii S470 running with openElec drivers and it worked just plug and play with your plugin!

 

Danke, Alles Gute!

Cheers

  • Like 1
Link to comment
7 hours ago, knex666 said:

Hope you will keep it going for the upcoming releases of unraid.

For sure, at least I hope so... ;)

My dev server rebuilds all plugins automatically when it detects that a new version for Unraid is released. :)

 

Just make sure before you upgrade Unraid to come back to this thread and look at the second post if I already updated the second post, where you can actually see for what versions the plugins are available.

The automatic rebuild should take about an hour for all plugins (takes that long because I also build the Nvidia Drivers, ZFS, USBIP and much more) after the release of a new Unraid version.

 

Danke vielmals für die Rückmeldung. :)

Link to comment
  • 2 weeks later...
Posted (edited)

Hi Ich777 i was wondering if you could give me a hand. I have this tuner Xboxtuner which is https://www.linuxtv.org/wiki/index.php/Xbox_One_Digital_TV_Tuner that works in a VM passed through with the firmware in /var/firmware and plex finds the tuner and works however the dvb-drivers only show usb if i try the same with plex in a docker container.1251708137_2021-06-0711_17_1610.0.0.362d1b276e3c6.thumb.png.5229b602f20905c22821085abd041f2b.png

i have a pihole but i have pointed my unraid server to cloudflares public dns 1.1.1.1 and 1.0.0.1 and i have reinstalled multiple times with restarts in between and all of the DVB packages and i can't seem to get it to work. --runtime=nvidia --device=/dev/dvb/ is my extra parameter and the nvidia gpu works fine.  Appreciate if you can give me any advice otherwise i'm not too fussed on just running it inside a VM.

 

output.txt

 

 

usb.thumb.png.044245ecd1aa29c9b60c3f9ac1be026a.png

 

 

 

 

2021-06-07 11.44.42 10.0.0.3 9a07c0207898.png

Edited by Lucien
deleted picture
Link to comment
15 minutes ago, Lucien said:

the dvb-drivers only show usb if i try the same with plex in a docker container

This tuner should work just fine with the LibreELEC drivers.

Can you post your Diagnostics (Tool -> Diagnostics -> Download -> drop the downloaded zip file here in the text box) with the LibreELEC drivers installed please.

 

The plugin won't display any more (usb) if you got a USB device installed.

Can you please try if you get it to show up in TVheadend (I recommend the @linuxserver.io container) and if it works there?

Link to comment
Posted (edited)
37 minutes ago, ich777 said:

This tuner should work just fine with the LibreELEC drivers.

Can you post your Diagnostics (Tool -> Diagnostics -> Download -> drop the downloaded zip file here in the text box) with the LibreELEC drivers installed please.

 

The plugin won't display any more (usb) if you got a USB device installed.

Can you please try if you get it to show up in TVheadend (I recommend the @linuxserver.io container) and if it works there?

Thanks for your help, i have attached the zip diagnostics and a screenshot of tvheadend.

2021-06-07 12.09.33 10.0.0.3 cecd268d0f02.png

 

Edited by Lucien
Link to comment

Sorry i should have tried earlier but your advice to check tvheadend let me see that the device was being detected so i removed the binhex plex and installed the linuxserver container and it is now detected. Sorry for the time waste but thank you for responding so quickly.

  • Like 1
Link to comment

Running Unraid 6.9.2

 

Installed the plugin, rebooted (cold boot)

 

getting this

1145740007_Screenshot2021-06-12191512.thumb.png.f6522e4b7b0b2d3b40e47b5ffbbd423a.png

End state is I have a USB webcam im trying to pass into an Octoprint container (which shows on lsusb)

 

I Run ls /dev/dvb (directory not found) /dev/video0 doesn't exist either.

 

I feel i haven't done something. Any help would be much appreciated

Edited by GregBobery
Link to comment
26 minutes ago, GregBobery said:

Running Unraid 6.9.2

 

Installed the plugin, rebooted (cold boot)

 

getting this

End state is I have a USB webcam im trying to pass into an Octoprint container (which shows on lsusb)

 

I Run ls /dev/dvb (directory not found) /dev/video0 doesn't exist either.

 

I feel i haven't done something. Any help would be much appreciated

Please post your diagnostics, this plugin wasn't designed to support USB Cameras but it does for the most time.

 

On the DVB plugin page you can't get anything since it displays only DVB card.

Link to comment
4 minutes ago, ich777 said:

Please post your diagnostics, this plugin wasn't designed to support USB Cameras but it does for the most time.

 

On the DVB plugin page you can't get anything since it displays only DVB card.

 

Okay, Hopefully we can get it working.

 

It's showing it need video4linux which i heard the LibreELEC supports

 

 

I'd appreciate any help

 

PSB system diagnostics

unraid-diagnostics-20210612-0942.zip

 

 

Edited by GregBobery
Link to comment
Just now, GregBobery said:

Unfortunately not, ive successfully passed it into a VM if that helps?

No because that's something completely different.

I'm not very into USB cams but I will try it after the weekend if I can find my USB cam. :D

Link to comment
Just now, ich777 said:

No because that's something completely different.

I'm not very into USB cams but I will try it after the weekend if I can find my USB cam. :D

Aha that would be wonderful thank you :)

 

Can I try a the kernal helper container??

Link to comment
7 hours ago, GregBobery said:

Maybe the other driver packages??

No because the V4L module is integrated in all of them but the modules for USB cams are only in the LibreELEC package.

 

Have you got a friend with a different USB camera that you can borrow for testing?

 

If it's recognized there should be a directory /dev/videoX

 

I will see if I can find my USB camera but I really don't know what I've did with it or where I've put it...

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.