[Plugin] DVB-Driver


ich777

299 posts in this topic Last Reply

Recommended Posts

31 minutes ago, anon1105 said:

Just confused why it works with tvheadend, but not Plex; so weird.

Eventually you have to configure something else, I don't know much about Plex, I can try it after the weekend.

As I said @alturismo said it can be quite hard to get it to run directly in Plex.

Link to post
  • Replies 298
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

DVB-Driver (only Unraid 6.9.0beta35 and up) This Plugin will add DVB Drivers to Unraid. Please note that this Plugin is community driven and if a newer version of Unraid is released the driv

Keep in mind he's probably sleeping.  

it shouldnt matter, plugin runs anytime, docker runs only when docker engine is running (array is up)   descrambling is working nice on both so you rather should take a look at your setup(s)

Posted Images

when you say it worked before it should work the same way when the dependencies are the same ...

 

now 1st to clarify

 

DVB-T - u have a DVB-T Antenna plugged in ?

DVB-C - is cable, no Antenna, just a simple cable from the wall outlet usually

DVB-S - also a cable going to a dish

 

and your tuner is recognized as a LG... in tvheadend which looks weird to me but who knows ;)

 

about dependencies, you use the same plex as before (official plex, lsio plex, binhex plex, ...), u use the same driver version as before (libreelec, TBS, ...)

Link to post

Going for DVB-T; currently don't have antenna available (already moved it to the remote site.)

I thought LG made the some of the tuners for Hauppauge; always seen mine that way. 🤷‍♂️

Yeah, running binhex plex and libreelec drivers.

 

What's different now is that I don't have an antenna plugged in; I don't see why that would make a difference, just when doing plex setup, tuners should show but not have any channels. My problem is that the tuners never showed up.

 

I don't want to waste everyone's time with this, as my backup plan is to use an HD Homerun; it'll make my remote setup more complicated, but at least it'll work for the time being.

 

Is there anything else simple I could have missed?

 

Thank you for replying and troubleshooting with me.

Link to post
25 minutes ago, alturismo said:

for a hdhr you dont need any dvb plugins, so yes, its just simple as is ... nothing to watch for ;)

Thanks for helping and looking into this; I may give it a try again later after awhile; let you all know if it was a config error. 

Hopefully it will help someone else out.

Link to post
45 minutes ago, anon1105 said:

Thanks for helping and looking into this; I may give it a try again later after awhile; let you all know if it was a config error. 

Hopefully it will help someone else out.

The privileges could also be a problem when they don't show up but I have to look into this tomorrow evening.

Link to post
22 hours ago, alturismo said:

for a hdhr you dont need any dvb plugins, so yes, its just simple as is ... nothing to watch for ;)

I can see the tuner just fine in Plex itself, which container are you using, the one that is made by Plex Inc. iteself?

 

Screenshot (sorry it's in German but I think you will see that it should work - I think since this is not a supported tuner and we have a very weak DVB-T network here I will don't get any results, I use the plex/plexinc container):

grafik.thumb.png.6f2d775368557bf399706b49de2995fc.png

Link to post
18 hours ago, ich777 said:

I can see the tuner just fine in Plex itself, which container are you using, the one that is made by Plex Inc. iteself?

 

Screenshot (sorry it's in German but I think you will see that it should work - I think since this is not a supported tuner and we have a very weak DVB-T network here I will don't get any results, I use the plex/plexinc container):

grafik.thumb.png.6f2d775368557bf399706b49de2995fc.png

I was using the binhex plexpass docker.

Link to post
5 minutes ago, anon1105 said:

I was using the binhex plexpass docker.

I tried it with the plexinc/pms-docker, please try to use this container for testing purposes (I think in the case of Plex you can install multiple servers at once).

 

Link to post

What is better to use on a Pcie sat-2 tuner? Tvheadend linuxserver docker or Mettbrot's Tvheadend plugin?

With the docker container I can get first channel to descramble, but if I try to change channel doesn't work anymore. I have to restart Oscam to be able put one channel again.

With the Tvheadend plugin, I can't even descramble one first channel. And looks like it crash a lot.

Link to post

it shouldnt matter, plugin runs anytime, docker runs only when docker engine is running (array is up)

 

descrambling is working nice on both so you rather should take a look at your setup(s) and try different solutions and/or debug  and look for oscam what is happening and search in the proper places what could cause this behaviour.

 

both tested here and working but this is prolly the wrong place cause this is the unraid dvb driver subforum ;)

Link to post
16 hours ago, alturismo said:

it shouldnt matter, plugin runs anytime, docker runs only when docker engine is running (array is up)

 

descrambling is working nice on both so you rather should take a look at your setup(s) and try different solutions and/or debug  and look for oscam what is happening and search in the proper places what could cause this behaviour.

 

both tested here and working but this is prolly the wrong place cause this is the unraid dvb driver subforum ;)

You are right, but I thought maybe ask here as here should be people using both versions, docker or plugin; and what people thinks is more stable.

Anyway, if someone with the same problem read this, I fixed it changing the Tvheadend's CA mode from "Oscam net protocol" mode to "Oscam TCP" mode.

 

Plus for DVB driver reference: I'm using a DVBSky S952 Dual DVB-S/S2 PCIe (V3) with LibreELEC Driver-package. Working perfect.

One more time, thanks ich777.

Edited by guillelopez
Link to post
2 hours ago, guillelopez said:

I thought maybe ask here as here should be people using both versions, docker or plugin;

I use the Tvheadend Docker from linuxserver.

Never used or needed Oscam.

 

2 hours ago, guillelopez said:

Plus for DVB driver reference: I'm using a DVBSky S952 Dual DVB-S/S2 PCIe (V3) with LibreELEC Driver-package. Working perfect.

I'm also planing to adding support for these cards from their closed source drivers but no garantuee that this cards will arrive... :D

Link to post
4 hours ago, ich777 said:

I use the Tvheadend Docker from linuxserver.

Never used or needed Oscam.

 

I'm also planing to adding support for these cards from their closed source drivers but no garantuee that this cards will arrive... :D

Well if some day you add those drivers, I can be your guinea pig. But with LibreELEC at least my card is working great.

Link to post

Hello, I have a TBS 6205 Card and the driver isn't working. The plugin installation failes after reboot and the installed plugin disappears. I selected the TBS or Libreelec driver. Same issue. I tested unraid with a clean, fresh usb stick and trial key and it worked. Something must be wrong with my configuration....

I hope you can help my, Thanks!!!

Bildschirmfoto 2020-12-07 um 01.00.54.png

Bildschirmfoto 2020-12-07 um 01.13.49.png

Link to post
4 hours ago, Dexter84 said:

Hello, I have a TBS 6205 Card and the driver isn't working. The plugin installation failes after reboot and the installed plugin disappears. I selected the TBS or Libreelec driver. Same issue. I tested unraid with a clean, fresh usb stick and trial key and it worked. Something must be wrong with my configuration....

I hope you can help my, Thanks!!!

That's really weird if it works on a fresh installation.

 

Can you try to boot with your default usb stick and install the plugin once again (of course first remove the plugin that errors out) and reboot.

After you rebooted go to Tools -> Diagnostigs and click on the bottom on Download and upload the file here.

 

EDIT: What you also can do is after you did the steps from above is to remove the errored out plugin, then look if the folder /boot/config/dvb-driver exists on your Unraid machine.

Link to post

Good Morning,

 

thanks for your help.

 

- tower-diagnostics-20201207-0846.zip. This is a fresh usb stick with DVB Driver Plugin. /dev/dvb works and the plugin has no error.

- unraid-diagnostics-20201207-0853.zip. This is normal, productive unraid with the plugin problem.

 

The folder /boot/config/plugins/dvb-driver was still available. I deleted this folder and made a reboot and reinstall. Without success. Same issue.

tower-diagnostics-20201207-0846.zip unraid-diagnostics-20201207-0853.zip

Edited by Dexter84
Link to post
1 hour ago, Dexter84 said:

unraid-diagnostics-20201207-0853.zip. This is normal, productive unraid with the plugin problem.

I don't see that the plugin isn't even trying to install...

 

Can you please try the follwing:

  1. Delete the plugin if it's in your plugins tab
  2. Delete it from the Error Plugins
  3. Go to /boot/config/plugins and look for the file 'dvb-driver.plg' and delete it if it's there
  4. In /boot/config/plugins look for the folder 'dvb-driver' and delete it if it's there
  5. Go to /boot/config/plugins-error and delete anything that is relate to the dvb driver like in step 3. & 4.
  6. Reboot your server (this step is optional but I would recommend it)
  7. Go to the CA App and redownload it from there
  8. Reboot your server

I think there is something left in a folder that is preventing it from installing.

 

1 hour ago, Dexter84 said:

I deleted this folder and made a reboot and reinstall. Without success. Same issue.

You have to also go to the plugins page in unraid and delete it from the Plugin-Errors

Link to post

i guess i already did these steps. I did them again:

 

I deleted:

 

/boot/config/plugins/dvb-driver

/boot/config/plugins-error/dvb-driver.plg

 

Then reboot & installed the plugin.

Before reboot:

unraid-diagnostics-20201207-1321.zip

After reboot:

unraid-diagnostics-20201207-1325.zip

 

The plugin is still under install error. I guess i deleted everything. Whats preventing from installation? :(

 

 

Edit: Could it be a modules problem?

 

/lib/modules/5.8.18-Unraid

 

🤯

 

 

 

 

Bildschirmfoto 2020-12-07 um 13.17.14.png

Bildschirmfoto 2020-12-07 um 13.19.07.png

Bildschirmfoto 2020-12-07 um 13.20.48.png

unraid-diagnostics-20201207-1325.zip

unraid-diagnostics-20201207-1321.zip

Edited by Dexter84
Link to post
17 minutes ago, Dexter84 said:

I deleted:

 

/boot/config/plugins/dvb-driver

Have you also deleted also the file '/boot/config/plugins/dvb-driver.plg'?

 

18 minutes ago, Dexter84 said:

The plugin is still under install error. I guess i deleted everything. Whats preventing from installation? :(

What files are in /boot/config/plugins/dvb-driver after the installation of the plugin?

 

Have you waited until the plugin is installed successfully and the 'Done' button appeared or did you close it with the red 'x' button on the top right corner?

 

I think it doesn't or at least can't download the package that needs to be installed...

 

Have you PiHole installed in your network somewhere?

 

21 minutes ago, Dexter84 said:

Edit: Could it be a modules problem? I#m on unraid 6.9.0-beta35 but

 

/lib/modules/5.8.18-Unraid

 

🤯

What is wrong with this? beta35 is on Kernel 5.8.18.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.