[Plugin] DVB-Driver


ich777

Recommended Posts

On 3/6/2021 at 3:11 PM, ich777 said:

In Unraid go to 'Main' click on 'Flash' (blue text) then append 'cx23885.debug=8' to the green box like:

grafik.thumb.png.dcfc9e97b8f97c844e3da7741c34a799.png

press 'Apply' on the bottom and then reboot.

 

That's it. ;)

SOLVED (Sorta)!!!  My Hauppauge WinTV QuadHD PCIe is now working like normal!!  Thanks again!

 

EDIT:  Although the card now works as it should, my log memory gets filled to capacity very rapidly.  Not sure how to resolve this.  I'm playing with different debug values now.

 

EDIT#2:  So I replaced debug=8 with dma_reset_workaround=2 and this solved everything, no more log issues.  A hint to this solution was found here.

Edited by GitBoxer
Not solved due to secondary problem
  • Like 1
Link to comment

Hello,

 

First of all, thank you very much for making this plugin!

 

I use unRAID 6.9.0, Tvheadend 4.3, and TBS-6909 card.

The TVHeadend did not recognize the card until i removed equal charcter /=/ from extra parameter.

In my case the following works:

--device /dev/dvb/

 

Sorry, it I missed the information in earlier posts.

Link to comment
26 minutes ago, gogos said:

The TVHeadend did not recognize the card until i removed equal charcter /=/ from extra parameter.

Thank you for the report but in my case this works perfectly fine:

grafik.png.cfdd45d2580c56dcc1ed30792160ef5a.png

 

You can also add a device also when you click on 'Add another Path, Port, Variable, Label or Device' in the template and create it like this (but then you should not pass it through the Extra Parameters):

grafik.thumb.png.f83880aa93069d7c5b6b2b91e16028ac.png

Link to comment
On 2/15/2021 at 2:36 PM, ich777 said:

Yes but that's not my approach to DVB, since these are the DVB drivers, I will look into it as soon as possible...

Haven't got much spare time at the moment...

 

Hi @ich777,

 

Just following up to see if you've had a chance to look into FireWire support?

 

I see a new build of Unraid Kernel Helper was released, but I don't see an option to include FireWire support in the build.

 

Thanks!

Link to comment
1 minute ago, -=Striker=- said:

Just following up to see if you've had a chance to look into FireWire support?

No haven't got time yet.

 

1 minute ago, -=Striker=- said:

I see a new build of Unraid Kernel Helper was released, but I don't see an option to include FireWire support in the build.

No this was just a minor update as 6.9.0 stable was released.

 

EDIT: I will look into it ;)

  • Like 1
Link to comment
1 hour ago, s.Oliver said:

Hey 6.9.1 is out! I guess we need an adapted DVB Driver Package?

Please see the second post.

Will announce it there if I built it and well I've built it already.

  • Like 1
Link to comment
6 hours ago, ich777 said:

Please see the second post.

Will announce it there if I built it and well I've built it already.

 

thx. for the reminder. i always tend to forget, that i've to look at the beginning (even for actual news) 🙂

works perfect!

  • Like 1
Link to comment

My DVB card works fine with Libreelec, but WebCam doesn't

Also with Digital Devices WebCam works fine, but DVB not.

Is there a way to install selected drivers only?

PS: by the way, updated to 6.9.1, since kernel version is the same, everything works fine as before for my card Hauppauge WinTV-dualHD DVB (except webcam of course).

Edited by IGHOR
Link to comment
1 hour ago, IGHOR said:

My DVB card works fine with Libreelec, but WebCam doesn't

Also with Digital Devices WebCam works fine, but DVB not.

What chip is your Webcam is based on? Eventually something in the DigitalDevices supports this chip or the V4L driver supports it.

The LibreELEC drivers that I made are not strictly supporting Webcams

 

1 hour ago, IGHOR said:

Is there a way to install selected drivers only?

What do you mean with that?

 

1 hour ago, IGHOR said:

by the way, updated to 6.9.1, since kernel version is the same, everything works fine as before

From what version did you upgrade and which Kernel version is the same?

6.9.0rc2 = Kernel v5.10.1

6.9.0 = Kernel v5.10.19

6.9.1 = Kernel v5.10.21

Link to comment
1 hour ago, ich777 said:

What chip is your Webcam is based on? Eventually something in the DigitalDevices supports this chip or the V4L driver supports it.

The LibreELEC drivers that I made are not strictly supporting Webcams

 

Logitech Webcam C170

 

1 hour ago, ich777 said:

What do you mean with that?

I mean can I install single driver for my device from libreelec and another single webcam driver from DigitalDevices?

 

1 hour ago, ich777 said:

From what version did you upgrade and which Kernel version is the same?

6.9.0rc2 = Kernel v5.10.1

6.9.0 = Kernel v5.10.19

6.9.1 = Kernel v5.10.21

 

Hm, as I remember while used 6.9.0 I had kernel version 5.10.21, so with updating to 6.9.1 no kernel version changed.

Maybe I'm mistaken, but anyway 6.9.1 working fine for me with that DVB plugin (libreelec) right now.

Link to comment
10 minutes ago, IGHOR said:

I mean can I install single driver for my device from libreelec and another single webcam driver from DigitalDevices?

With my package no.

I can look into it if I can make a Plugin to support webcams regardless if the DVB Plugin is installed or not.

 

10 minutes ago, IGHOR said:

as I remember while used 6.9.0

Nope 6.9.0 is 5.10.19:

grafik.png.b6cb21fd263fd24e90a6ef556d0885c4.png

 

Trust me, I know which version had which Kernel... :D

I rebuild the Plugins for each version. ;)

 

10 minutes ago, IGHOR said:

but anyway 6.9.1 working fine for me with that DVB plugin (libreelec) right now.

Yes, because the Plugins update itself on boot and look for a newer version. ;)

 

EDIT: That's why I recommend waiting for a day after a new version of Unraid is released so that I actually can build the Plugins and they can update on boot.

You can see which versions are available in the second postof this thread.

Link to comment
1 hour ago, ich777 said:

EDIT: That's why I recommend waiting for a day after a new version of Unraid is released so that I actually can build the Plugins and they can update on boot.

You can see which versions are available in the second postof this thread.

 

Thats nice, but is there a chance you may not be able to do it some times? I mean we could get long delays in some reasons.
Can you make build fully automated once new version released without your interaction?

Link to comment
1 hour ago, IGHOR said:

Thats nice, but is there a chance you may not be able to do it some times? I mean we could get long delays in some reasons.

It is everything automated by now, if everything goes how it should it should be done in about 2 hours after the release is made.

Please read this post:

 

Link to comment
39 minutes ago, ich777 said:

It is everything automated by now, if everything goes how it should it should be done in about 2 hours after the release is made.

Please read this post:

 

Thats awesome! Thanks!

Edited by IGHOR
  • Like 1
Link to comment
4 minutes ago, IGHOR said:

Thats awesome! Thanks!

But keep in mind this is only if everything goes how it should... :D

BTW I tested it and it already built yesterday automatically the new version of ZFS, so it should at least work.

 

It is safe to upgrade when I update the second post in this thread with the Unraid version and Kernel version. :)

Link to comment

I have a issue with this plugin aftes upgrading to 6.9.1

 

I reinstalled the pluging to make it work again and it broke all the boot files of the flash. I recovered to 6.9.0 boot files again, upgraded to 6.9.1 and as I see I get a Kernel version mismatch at the installation that breaks everything.

 

Downgraded to 6.9.0 I got same error:

 

plugin: installing: https://github.com/ich777/unraid-dvb-driver/raw/master/dvb-driver.plg
plugin: downloading https://github.com/ich777/unraid-dvb-driver/raw/master/dvb-driver.plg
plugin: downloading: https://github.com/ich777/unraid-dvb-driver/raw/master/dvb-driver.plg ... done

+==============================================================================
| Installing new package /boot/config/plugins/dvb-driver/dvb-driver-2020.11.17.txz
+==============================================================================

Verifying package dvb-driver-2020.11.17.txz.
Installing package dvb-driver-2020.11.17.txz:
PACKAGE DESCRIPTION:
Package dvb-driver-2020.11.17.txz installed.

+==============================================================================
| WARNING - WARNING - WARNING - WARNING - WARNING - WARNING - WARNING - WARNING
|
| Don't close this window with the red 'X' in the top right corner until the 'DONE' button is displayed!
|
| WARNING - WARNING - WARNING - WARNING - WARNING - WARNING - WARNING - WARNING
+==============================================================================

-------------Downloading DVB-bzImage for Kernel v5.10.19---------------
--------This could take some time, please don't close this window!----------

---------------------Sucessfully downloaded DVB-bzImage---------------------

-----Kernel version missmatch patching bzImage for Kernel v5.10.19-----

-----------------Downloading -DVB-Driver-Package-------------------
---------This could take some time, please don't close this window!---------

---------------Can't download -DVB-Driver-Package-----------------
plugin: run failed: /bin/bash retval: 1

Updating Support Links



Finished Installing. If the DONE button did not appear, then you will need to click the red X in the top right corner

 

 

PD: I deleted the /boot/config/plugins/dvb-drivers folder and now I got installed...

Edited by yayitazale
Link to comment
47 minutes ago, yayitazale said:

I have a issue with this plugin aftes upgrading to 6.9.1

 

I reinstalled the pluging to make it work again and it broke all the boot files of the flash. I recovered to 6.9.0 boot files again, upgraded to 6.9.1 and as I see I get a Kernel version mismatch at the installation that breaks everything.

 

Downgraded to 6.9.0 I got same error:

What have you done exactly?

Haven't got a problem upgrading to 6.9.1.

 

Also the log that you posted above is from a 6.9.0 Plugin installation not from a 6.9.1

You can also try to uninstall the Plugin, Upgrade to 6.9.1 by going to Tools -> Upgrade OS, or put the files manually on the flash device then reboot install the Plugin and reboot again.

 

Unraid 6.9.1 is Kernel version 5.10.21 not 5.10.19

Link to comment

Hello

I'm having some issues getting a USB Terratec H7 DVB-T adapter to work.
I'm running Unraid 6.9.1
I'm using the librelec driver package.
Something is detected, but no version is listed:

dvb1.png

 

Note: I have two DVB adapters plugged in, one of them is however attached to a windows VM, only the adapter not attached to a VM is created in /dev/dvb which I figured was just fine.
If I remove it from the windows VM the device is created correctly, but it still shows no version.

I've tried to use it in both tvheadend and minisatip.
Once the container is started the log will show this:

Mar 12 16:57:57 Unraid kernel: mt2063: detected a mt2063 B3
Mar 12 16:58:03 Unraid kernel: dvb_ca_en50221: dvb_ca adapter 1: DVB CAM detected and initialised successfully

 

Which I guess means it's detected and running?

Now my problem is neither tvheadend or minisatip through dvbviewer media server seems to work, the symptoms are that it seems no signal is available.
I''m currently using a DVBsky T680C in my windows VM, and I've tried to remove this from the VM and use it through tvheadend/minisatip and the symptoms are the same, I know this adapter works when attached to the VM though.

 Now, my problem is, I'm not really sure what my next step is here?
 The adapter is seemingly detected just fine, it's just not working :S
Any tips would be appreciated

Link to comment
41 minutes ago, LeetDonkey said:

Something is detected, but no version is listed:

This is just normal for the usb tuners...

 

43 minutes ago, LeetDonkey said:

Which I guess means it's detected and running?

It should yes. USB Tuners always a little problematic...

 

Can you post a few screenshots from the tuners inside tvheadend?

Link to comment

If I remove the GPU do I just simply Disable Hardware Transcoding in Plex, remove the plugin and shut off and pull card and reboot?

 

I have a 1050TI in my unraid machine now and I might have to use it in another project. Sadly with all the Bit Coin mining its getting nearly impossible to buy GPU's anymore at a reasonable price. 

Link to comment
32 minutes ago, kizer said:

If I remove the GPU do I just simply Disable Hardware Transcoding in Plex, remove the plugin and shut off and pull card and reboot?

I think you are in the wrong thread.

 

You have to remove '--runtime=nvidia' from the Extra Parameters from Plex, disable HW transcoding in Plex, remove the plugin, reboot.

 

34 minutes ago, kizer said:

Sadly with all the Bit Coin mining its getting nearly impossible to buy GPU's anymore at a reasonable price.

Yes this is a big problem, if you got a Intel Processor with a iGPU it should be also capable of HW transcoding, 4x 4k streams should be no problem...

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.