My Servers Early Access Plugin


490 posts in this topic Last Reply

Recommended Posts

38 minutes ago, wgstarks said:

I really haven't had a chance to research this question and it may be answered in the wiki but is it only the flash that is backed up or does it also backup the other items that were covered by the CA Backup/Restore plugin? libvirt image and appdata IIRC.

 

Basically its backing up your USB stick. I see my docker xml's in it along with my Plugin's and Config files. 

I personally back up my Cache/system/appdata to another smaller SSD in its own pool. Why do I do that? I backup my appdata once a week and I Figure if there is a BIG change to my appadata I could easily restore it from a daily snap shot. 

 

I don't run VM's as of now so I couldn't tell you if any of that data would be on the Flash of course if you run User.Scripts those are on their too. 

 

Has anybody else tried using it? Backup and Restore? I'd guess this is the place to bring up suggestions and problems if there are any. ;)

 

 

Link to post
  • Replies 489
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hello Unraid Community!   Today we're excited to give you a sneak peak at something we've been working on for quite some time.  A new feature we like to call My Servers.   "My Serv

Would you mind running `unraid-api restart` in a terminal and let me know if that sorts it. I’ve added this to our bug tracker. 

Now available in CA  

Posted Images

10 minutes ago, kizer said:

I personally back up my Cache/system/appdata to another smaller SSD in its own pool.

Yeah, I have a similar backup strategy. Might still set this up as a secondary backup. No such thing as too many I guess. Thanks

Link to post
3 hours ago, wgstarks said:

Yeah, I have a similar backup strategy. Might still set this up as a secondary backup. No such thing as too many I guess. Thanks

 

Check this out.  You can register a new USB to your account if you loose your old from your backup, by clicking a button. 

 

 

Link to post
5 minutes ago, kizer said:

You can register a new USB to your account if you loose your old from your backup, by clicking a button.

Pretty sure I can do that now. Might be 2 button clicks. Been a while since I had to do it but the current automated process is very simple. Not putting down the my servers feature though. I’m guessing there’s plenty more to come.

Link to post

Having trouble  with creating the cert, I keep getting the DNS rebinding error. I've tried using different public DNS servers (Google, Coudflare) and searched high and low in my router (Netgear RAx45) settings to disable this feature...which doesn't exist. I really want to be able to remote access my server any help is much appreciated. 

Link to post

First of all thank you for this feature!

 

So I've just seen Spaceinvader's video (thanks for you content btw).

Anyone here doing the port forwarding on a PfSense router could confirm that this is right (I will change the port number though since I'm already using it for something else on the network). The rule as is works, but I'm not an expert in router science and not wanting to let all the world have fun with my data. 

 

1098800620_Capturedecran2021-04-07a16_00_11.thumb.png.5e8836d0a01e8a94ef8ad45faa15dd75.png

 

Many thanks

 

Link to post

Is there a command line or can there be to enable/disable remote connection? This is why I ask. If I can schedule remote access while at work and disable while I’m home it would be really nice. 
 

it’s a personal feeling, but I’d like to be able to schedule a turn on/off when I’m using remote access vs leaving it on all the time. I could use a cron script via User.Scripts or a built in scheduler via unraid.net Plugin. 
 

I have other ways of logging in to enable/disable if this isn’t a possibility or doesn’t make sense. Just a future feature request of sorts. ;)

Link to post

I have an Orbi (Netgear) router with 2 satellites.  In order to get the remote access to work, along with adding the port forwarding, I had to enable "Use UPnP" setting on the Management Settings page.  Is there a better way to do this, or is this in any way compromising my system's security?

Link to post
1 hour ago, dius said:

I have an Orbi (Netgear) router with 2 satellites.  In order to get the remote access to work, along with adding the port forwarding, I had to enable "Use UPnP" setting on the Management Settings page.  Is there a better way to do this, or is this in any way compromising my system's security?

 

The WireGuard plugin will take advantage of UPnP if it is enabled, but the Remote Access feature of the My Servers Unraid.net plugin currently does not. So today, that setting will have no effect on whether Remote Access works.

 

Note that if you are concerned about UPnP security, the main place you need to disable it is in your router. 

Link to post
12 minutes ago, ljm42 said:

 

The WireGuard plugin will take advantage of UPnP if it is enabled, but the Remote Access feature of the My Servers Unraid.net plugin currently does not. So today, that setting will have no effect on whether Remote Access works.

 

Note that if you are concerned about UPnP security, the main place you need to disable it is in your router. 

Thanks for this info.  As I was setting it up, I couldn't get the remote access to work without it.  I'm sure I just didn't have the port forwarding setup quite right.  I turned off the UPnP in unRaid and tested the remote access and it seems to be working still, so something I had done earlier fixed the remote access issue but it wasn't the UPnP setting.  Thanks for your help.

Link to post
4 hours ago, glennv said:

Just installed plugin just for the cloud usb flash backup, but after login on and then clicking activate i immediately get this error:

image.thumb.png.7e67e60c893009c7eb0784bf3d32c016.png

 

Do you remember the process you used to upgrade to 6.9.1? Some of the expected files are missing from the flash drive.

 

No matter, we can regenerate them. Please open a web terminal window and copy/paste the following:

cd /boot
sha256sum bzfirmware | cut -d ' ' -f -1 > bzfirmware.sha256
sha256sum bzimage | cut -d ' ' -f -1 > bzimage.sha256
sha256sum bzmodules | cut -d ' ' -f -1 > bzmodules.sha256
sha256sum bzroot | cut -d ' ' -f -1 > bzroot.sha256
sha256sum bzroot-gui | cut -d ' ' -f -1 > bzroot-gui.sha256

 

Thanks for reporting this. A future version of the plugin will automatically generate any of these files that are missing.

 

Link to post

With regards to port forwarding, am I able to enter the actual subnets that require forwarding, rather than anyone on the internet ?

I currently only allow cloudflare IP's to access my home nginx server and re-direct that way.

I have in the past used tailscale for access to unraid, and various other servers securely with zero config.

Link to post

@ljm42 I checked and these files already exist.

I upgraded using the kernel builder docker from ich777 (as i need to build with the AMD GPU reset bug patch) and then placed the resulting files in /boot.  Do i need to recreate these ?

 

image.png.8322b4e7c39a55c88cc8e68b9c382149.png

 

Same issue on my backup unraid server (upgraded with same method)

Edited by glennv
Link to post

I just found the issue. The .sha256 files on my system contained 2 values and if i use your command only 1, which makes more sense. So i replaced them and now it works. Thanks.

 

image.png.677b50a11cf9f360f3b445423b749609.png

Link to post

Is it possible that the plugin can cause crash with "tired" usb flash drive, caused by the add of git. I've deleted the plugin because I've lost my array (not the data) multiple times since I've installed the plugin. No problem without the plugin.

Link to post
8 hours ago, glennv said:

I just found the issue. The .sha256 files on my system contained 2 values and if i use your command only 1, which makes more sense. So i replaced them and now it works. Thanks.

 

image.png.677b50a11cf9f360f3b445423b749609.png

 

aha! thanks for checking that.

 

FYI the Unraid.net Flash Backup will not restore custom bz* files, if you do a restore it will give you the latest stable bz* files.

 

@ich777 can you please change the format of the bz*.sha256 files created by the kernel builder docker so that they just contain the hash and not hash+filename? This will match the format of the files distributed with the OS.

Link to post
13 minutes ago, ljm42 said:

@ich777 can you please change the format of the bz*.sha256 files created by the kernel builder docker so that they just contain the hash and not hash+filename? This will match the format of the files distributed with the OS.

Done, container is already rebuilt and uploaded to Docker Hub. :)

  • Like 1
  • Thanks 1
Link to post

I've added three servers into the My Servers dashboard and all are showing offline. I added one just this afternoon. Was showing online... and then just as suddenly, now showing offline along with the two that have been there for about a week. I ran the unraid-api restart command on one, seemed to go through ok, but no change, all servers offline.

 

And as I glanced back at the My Servers tab, the one I added today is now showing online, again.  

 

Edit - updated plugin on two of them, now showing online, one still offline for some reason.

Edited by Whaler_99
Link to post
33 minutes ago, MyKroFt said:

how do I correct this to fix what i cant read

Quote from the wiki-

Quote

Note: If the text in this area is hard to read, go to Settings -> Display Settings and remove any "Header custom text color" and "Header custom background color" values you had previously set. This will get you back to the standard colors for your chosen theme, and you can customize from there.

 

Link to post
3 hours ago, Whaler_99 said:

I've added three servers into the My Servers dashboard and all are showing offline. I added one just this afternoon. Was showing online... and then just as suddenly, now showing offline along with the two that have been there for about a week. I ran the unraid-api restart command on one, seemed to go through ok, but no change, all servers offline.

 

And as I glanced back at the My Servers tab, the one I added today is now showing online, again.  

 

Edit - updated plugin on two of them, now showing online, one still offline for some reason.

 

Sorry, we are still working through some issues with this beta. Until we get it resolved you may notice the servers go offline / come online on their own. Once it is stable they will stay online.

Link to post
5 hours ago, dada051 said:

Is it possible that the plugin can cause crash with "tired" usb flash drive, caused by the add of git. I've deleted the plugin because I've lost my array (not the data) multiple times since I've installed the plugin. No problem without the plugin.

 

If the flash is that flaky it is likely going to fail fully in the near future. I would replace it ASAP.

 

Note that flash backup (and remote access) are optional features that can be enabled/disabled on the settings page. You don't need to remove the entire plugin to disable them.

 

Link to post
On 4/7/2021 at 7:03 AM, yaneck said:

First of all thank you for this feature!

 

So I've just seen Spaceinvader's video (thanks for you content btw).

Anyone here doing the port forwarding on a PfSense router could confirm that this is right (I will change the port number though since I'm already using it for something else on the network). The rule as is works, but I'm not an expert in router science and not wanting to let all the world have fun with my data. 

 

1098800620_Capturedecran2021-04-07a16_00_11.thumb.png.5e8836d0a01e8a94ef8ad45faa15dd75.png

 

Many thanks

 

 

I don't have pfSense but that looks correct to me

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.