Folder Permissioning issues on Unraid

Go to solution Solved by Squid,

Recommended Posts

I am running unraid version 6.11.1. On top I have a docker for EmbyServer, which provides a gateway for all my backed up movies on the unraid server.

A while ago I upgraded both the docker and the unraid OS. I am not sure what broke where, but since October my emby server has not complete a scan of the library, therefore any movies I added to the library are not being added. 

Hello, I have a question about an emby problem, which I reported here

Judging by the embyserver log file seems like something has gone wrong with the folder permissions

"System.UnauthorizedAccessException: System.UnauthorizedAccessException: Access to the path '/mnt/user/unraid/bluray/The.Hateful.Eight (2015)' is denied. ---> System.IO.IOException: Permission denied"

I have tried moving the movie folder out of the overall bluray folder, but it finds another, and then another and then another folder that it cannot access, and this stops the scan.

I was advised to fix the permissioning, but I have no idea how to do that.

Shall I go to Tools / New Permissions and just click on the Start button? Would that fix my issues?

Link to comment

Where do I find the path mappings? I also don't seem to have an option to install an updated version, and I can't force an install it seems. I don't want to uninstall it. 
I have installed the docker, then via its interface chose which folders on the servers to scan. The TV folder works fine and the Movies folder has also worked find for a very long time. It finds the movies in the folder, it just reports it cannot access the folders. When I move a movie out of the folder, it is scanning the right uberfolder and it finds another movie which is correct, but cannot access.

Link to comment
  • Solution

No fundamental reason why it wouldn't work off of that docker run command issued.  Run the New Permissions from Tools against the share and see if anything changes


If it doesn't then instead of mapping /mnt to /mnt change it to map instead /movies to /mnt/user/unraid/bluray/ and rebuild the library looking for files in /movies


Mapping /mnt to /mnt has never been particularly recommended (although its a convenient shortcut) as it is a security risk as now emby has complete read/write access to not only your media, but also any banking info on your server, the "special" pictures you keep etc etc

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.