VirtualBox Plugin for unRAID v5 and v6


Recommended Posts

Please mummy, help me...


This is clearly way above my pay grade, but in a vein attempt to try this, inevitably I need some help...


Running unraid 5final, I have installed this plugin...

I've read this entire thread, and to go along side this plugin I need some sort of front end, ie phpvirtualbox.

I also need a web server to run said phpvirtualbox and there in lies the rub. As I don't use simplefeatures (and the fact it's not compatible with 5final) I have no way of going any further.


What are other people doing? Are there any simple steps for simpletons?



Link to comment

Ockingshay, a search of this forum shows Re: "SimpleFeatures" - WebServer Plugin [sUPPORT] where others are using the latest Simple Features web server with the latest 5.0 of unRAID. This link shows a change you will need to make to get the plugin to work.


As a side note, you do not "need" a web server to use VirtualBox, it just makes it much easier to use (graphical interface versus command line). Everything in VirtualBox can be done via the command line. shows a list of some of the commands you can use without a web server.

Link to comment

ok thanks, that's good to know...


I don;t think it is even starting correctly.


I have both log and and symbolic link set to /mnt/cache/apps/virtualbox. I can see it installs, and the log is created. The permissions are automatically set to -rw-------, is that normal? Clicking on the "start vboxwebsrv" button never actually completes, it simply shows /etc/rc.d/rc.virtualbox start_vboxwebsrv at the bottom of the webpage.


i've chmod the log so i can read it:




VirtualBox XPCOM Server 4.2.16 r86992 linux.x86 (Jul  4 2013 15:50:55) release log

00:00:00.000452 main    Log opened 2013-09-08T16:07:16.200781000Z

00:00:00.000455 main    OS Product: Linux

00:00:00.000456 main    OS Release: 3.9.6p-unRAID

00:00:00.000457 main    OS Version: #23 SMP Wed Jun 26 19:25:49 PDT 2013

00:00:00.000516 main    Host RAM: 8087MB total, 7359MB available

00:00:00.000519 main    Executable: /opt/VirtualBox/VBoxSVC

00:00:00.000520 main    Process ID: 2395

00:00:00.000520 main    Package type: LINUX_32BITS_GENERIC

00:00:00.107356 nspr-2  Loading settings file "/root/.VirtualBox/VirtualBox.xml" with version "1.12-linux"

00:00:00.112591 nspr-2  Successfully initialised host USB using sysfs

00:00:00.115525 nspr-2  VDInit finished




VirtualBox web service 4.2.16 r86992 linux.x86 (Jul  4 2013 15:50:55) release log

00:00:00.000496 main    Log opened 2013-09-08T16:07:23.316769000Z

00:00:00.000498 main    OS Product: Linux

00:00:00.000499 main    OS Release: 3.9.6p-unRAID

00:00:00.000500 main    OS Version: #23 SMP Wed Jun 26 19:25:49 PDT 2013

00:00:00.000553 main    Host RAM: 8087MB total, 7362MB available

00:00:00.000555 main    Executable: /opt/VirtualBox/vboxwebsrv

00:00:00.000555 main    Process ID: 2559

00:00:00.000556 main    Package type: LINUX_32BITS_GENERIC

00:00:00.012115 main    Pumping COM event queue

00:00:00.012136 main    Pumping COM event queue

00:00:00.012399 SQPmp    Socket connection successful: host =, port = 8009, master socket = 12

00:00:00.016510 Watchdog Watchdog thread started

00:00:00.016520 Watchdog Watchdog: sleeping 5 seconds

00:00:05.016597 Watchdog Watchdog: checking 0 sessions

00:00:05.016619 Watchdog Watchdog: sleeping 5 seconds

00:00:10.016698 Watchdog Watchdog: checking 0 sessions

00:00:10.016725 Watchdog Watchdog: sleeping 5 seconds

00:00:15.013153 main    Pumping COM event queue


Anything i am missing?


EDIT** If i refresh the page "control actions" gives me the options to restart and stop, which would suggest it is running.


EDIT** I just noticed the link in your sig and there is some guidance on there....i'll give that a whirl and see how far i get.


Link to comment

If i stop it the log says:


VirtualBox XPCOM Server 4.2.16 r86992 linux.x86 (Jul  4 2013 15:50:55) release log

00:00:00.000837 main    Log opened 2013-09-09T13:25:17.168042000Z

00:00:00.000842 main    OS Product: Linux

00:00:00.000844 main    OS Release: 3.9.6p-unRAID

00:00:00.000846 main    OS Version: #23 SMP Wed Jun 26 19:25:49 PDT 2013

00:00:00.000936 main    Host RAM: 8087MB total, 7588MB available

00:00:00.000941 main    Executable: /opt/VirtualBox/VBoxSVC

00:00:00.000942 main    Process ID: 30040

00:00:00.000944 main    Package type: LINUX_32BITS_GENERIC

00:00:00.113139 nspr-2  Loading settings file "/root/.VirtualBox/VirtualBox.xml" with version "1.12-linux"

00:00:00.123058 nspr-2  Successfully initialised host USB using sysfs

00:00:00.128615 nspr-2  VDInit finished

00:00:07.948110 Watcher  ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={3b2f08eb-b810-4715-bee0-bb06b9880ad2} aComponent={VirtualBox} aText={The object is not ready}, preserve=false


I again had to change the it normal to be -rw------- 1 root  root    954 2013-09-09 14:25 VBoxSVC.log ?


Link to comment
  • 2 weeks later...

First of all Thanks Theone for the plugin and Laine and others for making this all work.


I've been using this plugin / VB for a few weeks and its seems to work well. My goal was to move all my plugins from unRaid into a Windows VM. I have 2 problems that I can't seem to solve.


1. CPU utilization in the Windows VM seems excessively high. Adding more CPU cores doesn't seem to help. CPU in the Windows VM jumps to 100% and stays there for seconds just opening IE while the unRAID CPU is near idle. I'm pretty sure this is a VB/unRAid thing and not related to the plugin.

2. Accessing unRaid's cache/data drive is simply too slow from the Windows VM. Again not sure why this is because the unRAID and the Windows VM are actually on the same machine, so there's no network traffic.


I'm using an Intel Ivy Bridge Quad cpu and have guest additions installed in the Windows VM. Only the 1 Windows VM exists.


Due to these limitations, I've had to leave SabNZBd, Sickbeard and PLEX Media server as plugins in unRaid. I've moved everything else that is not CPU or disk intensive into the Windows VM.


Thanks for any help

Link to comment
  • 2 weeks later...

What port do I access this on? It doesn't provide a link that I can see from the plugin setting page.


Should this be running at host to provide access to the network? or like SABNZBD?


I think i have this set up and running but I can't access it...  If it is this setting: vboxwebsrv Port: then I have tried that and i get this:

This XML file does not appear to have any style information associated with it. The document tree is shown below.
      <SOAP-ENV:Envelope><SOAP-ENV:Body><SOAP-ENV:Fault SOAP-ENV:encodingStyle=""><faultcode>SOAP-ENV:Client</faultcode><faultstring>HTTP GET method not implemented</faultstring></SOAP-ENV:Fault></SOAP-ENV:Body></SOAP-ENV:Envelope>

Link to comment

Hey guys,


the plugin seems to work fine.. everything gets installed.. but when i try to access the virtualbox web server i get the following code displayed in the browser window.


This XML file does not appear to have any style information associated with it. The document tree is shown below.

<SOAP-ENV:Envelope xmlns:SOAP-ENV="" xmlns:SOAP-ENC="" xmlns:xsi="" xmlns:xsd="" xmlns:vbox="">


<SOAP-ENV:Fault SOAP-ENV:encodingStyle="">


<faultstring>HTTP GET method not implemented</faultstring>






Does anybody know why?



cheers Jaddel

Link to comment

Thanks for the plug-in, I have a small question.


I initially setup/add my VM's using Simplefeature with the SF Webserver and PHPvirtualbox.


My VM's then show up on the webgui so I'm able to happily start them from there and don't need SF+Webserver and PHPvirtualbox anymore.


However after I removed  SF+Webserver plugin and PHPvirtualbox I get an error when I click "Start VM" button using the plug-in GUI. When I use command line to manually start the VM using: VBoxManage startvm "vmname" in telnet I also get the error.  However..when I start with: VBoxManage startvm "vmname" --type headless All is well.


My question is: How can I edit the "Start VM" button behavior so it uses the --type headless option.

SF doesn't run good on v5 final and I simply don't prefer to use SF just to use VB. I'm not sure but I think --type headless option can always be used in any case running VB on unraid. so maybe it can be standard implemented.


And maybe a button can be added: (Start VM ignore State)

VBoxManage discardstate "vmname" + VBoxManage startvm "vmname" --type headless


Thanks  ;)







Link to comment

I'm having issues getting this installed:



Clicking the 'Update' and 'Install' buttons don't seem to accomplish anything.  Any ideas?


you need to delete the boot/config/plugins/virtualbox folder and redownload from the plugin, may require a restart inbetween. It seems the packages downloaded would have not been completed correctly.

Link to comment

Exception Object


    [message:protected] => Could not connect to host (

    [string:Exception:private] =>

    [code:protected] => 64

    [file:protected] => /mnt/cache/Apps/www/lib/ajax.php

    [line:protected] => 128

    [trace:Exception:private] => Array




    [previous:Exception:private] =>



Has anyone found a solution to the above? Have seen it posted a few times, but no-one seems to know what they did to correct it.


EDIT: in case anyone has the same, run vboxwebsrv >nul & from the command line, ive added this to my go file to see if that works as well

Link to comment

so I was having issues and before posting decided to do as much noobdiligence as I could to get this working and finally did, so I thought i'd post about it.


Here's my setup:

unRAID Server Plus version 5

simpleFeatures (most installed, including web server)

unMenu, Plex

Unplugged - Sabnzbd, Couch Potato, Sickbeard, Transmission

MB: Gigabyte Technology Co., Ltd. - EP45-UD3P (disabled bios backup via bios menu)

CPU: Intel® Core2 Quad CPU - 2.666 GHz

Cache: 64 kB, 3072 kB

Memory: 8192 MB (max. 32 GB)


So I copied the plugin to /boot/config/plugins and ran:

installplg /boot/config/plugins/virtualbox.plg


Plugin installed without any errors.


When I logged into the unraid main and navigated to the settings -> virtualbox page it showed config settings, etc.


I updated the config and saved, but was unable to get anything else going as it didn't show any "online / local / installed" versions for VirtualBox, VirtualBox Extensions, VirtualBox Guest Additions.  The only local version was VirtualBox Plugin.


I then manually downloaded VirtualBox (plus extensions and guest additions) version 4.2.18 and saved them to:




returning to the virtualbox settings now listed 4.2.18 in the "Local Version" column.


I manually installed the virtualbox package:

installpkg /boot/config/plugins/virtualbox/vbox-4.2.18-unRAID-3.9.6p.tgz


then ran rc script:

/etc/rc.d/rc.virtualbox boot


Its now working, also running phpvirtualbox via lighttpd from the simpleFeatures web server plugin.


had to tweak config.php


/* Username / Password for system user that runs VirtualBox */

var $username = 'vbox';

var $password = 'xxxx';


/* SOAP URL of vboxwebsrv (not phpVirtualBox's URL) */

var $location = '';


// Disable authentication

var $noAuth = true;


// Host / ip to use for console connections

var $consoleHost = 'tegunux';


In the end I beleive the big issue was connection problems with the hosted versions of the virtualbox builds on the site... could just be temporary, but the plugin / settings menu couldn't grab the right files so the install wouldn't complete.  This would be a manual install if you can get the packages downloaded to the plugin folder


Link to comment
  • 2 weeks later...

Its now working, also running phpvirtualbox via lighttpd from the simpleFeatures web server plugin.


I need help with this, not an expert in linux, i have V5.0 stable, I tried to use SF but they do not work correctly. I downloaded lighttp from UnMenu.. Now what? I've read the example from "theone" website but it made no sense to me on how to configre lighttp.  How to do you install the phpvirtualbox once lighttp is installed and configured.

Thanks for helping  noob


My end goal is to up a windows 7 64bit to run some vpn functions and other things

Link to comment

I use webserver for SF, then download php and point webserver to the php


I have V5.0 stable i can install SF but when I add the web server it just craps out, i get no home page. I remove all instances of SF homepage works. that is why i had to use UnMenu's install


You will need to update the webserver plugin as its not maintained at the moment


Most likely it is conflicting with another plugin at the moment


Link to comment

Need some help, i forgo the SF install, i dont like to reboot the server alot. I need help with minor tweaks to get phpvirtual to work i feel im really close.


Pictures are attached for reference.


Background info

DL the plg from here install virtual box and downloaded all the updates (running on V5 stable)

I DL lighttpd from unmenu installed it and configure it to port 7000, works fine see picture.


DL phpvirtualbox from git hub choose the versin 4.3 (which is what i have) extracted it to a folder on my cache drive named (www same folder that lighttpd is configure to use as the web server). renamed config.php and edited a few lines. see picture


On vbox i used the ip of the tower and port 7001, which is also in the config.php. See picture


When i call the webpage for phpvirtualbox i get prompted for a user name and password. If you notice that on my config.php i un-commented the not auth variable. (side note i do have a password to get to the main unraid webpage, in other words 'root" has a password)


So i have tried the username and password in the PHP file no luck, it keep prompting for user/pass. I read the instructions for phpvirtualbox and used "admin' and password "admin" this yielded a blank webpage.


Using unraid 'root' login also yielded the same outcome of a blank webpage.


So i know i must be close, i just know that i missed a step.




Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.