VirtualBox Plugin for unRAID v5 and v6


Recommended Posts

  • 4 weeks later...

Running Xbuntu 14.04 i386 in Virtualbox for a Subsonic premium install.  I have the subsonic service running as non-root user and I have installed guest additions.  I can see the files/folder in the shared folders which is linked to the music folder on my array, but am unable to access the music for playback.  How can I add permissions to Xubuntu without running as root and get access to array files via shared folder?  I have created user subsonic for the non-root user in Xubuntu.  Do I need to match the nobody user on unraid in Xubuntu? Thanks.

Link to comment

Have you tried the "share folders" option in virtualbox (from phpvirtualbox UI)?


It grants direct access to unRAID folders not through your LAN network shares - you will get a "VBOXSRV" pseudo network device that is actually the host unRAID.


Yeah, that is how I was going about accessing my music library on the array from the VM.  I solved the problem by adding the non-root user to the vboxsf group then loging out/in and it works now.  When using shared fodlers the 'sf_{share}' under /media is in the vboxsf group.

Link to comment

I have compiled Virtualbox 5.0.8 for unRAID 6.1.3.

Waiting for it to be uploaded to lainie's site.


if you upgrade don't forget to to upgrade to the latest phpvirtualbox 5.x otherwise you won't be able to access the Virtualbox WEBUI.

Also clear your browser's cache - I had to.


Link to comment

I seem to be missing something.  I installed the plugin, had it download the dependencies, etc.  But I can't access the webserver to start configuring VMs.  Is there a step by step guide?  I think I'm missing a PHP plugin, but I don't know which one or where it goes. 


Sorry if I'm obtuse, I feel like I should have this cracked but I can't seem to make sense of what the dependencies are.



Link to comment
  • 2 weeks later...
  • 1 month later...

In the "Mount and Startup" options, what is the field labeled "VirtualBox symbolic link (part of install package) - Change from default /boot/custom/vbox:" supposed to point to?


I have my virtualbox vms at /mnt/cache/appdata/virtualbox.  Is this where I should be pointing the Virtualbox symbolic link?


It is where some of the log files are kept. You can leave it where it is originally (flash drive) but that means there will be multiple writes to the flash drive and thus a chance of reducing its lifetime.


Link to comment

Hey all.


I have installed virtualbox plugin. Everything is peachy. Kinda. I have one annoyance that I can't get past.


When I create a Linux virtual box (have not tried windows), I set the network adapter to be bridge (eth0). During the install of linux, it's downloading happily and things seem great. But the minute the install is done and I boot into my new OS, I get that dreaded "for Wait For" during bootup which means it isn't getting an IP.


NAT is ok and I get 10.x.x.x ip. (or whatever it is) and it can surf, but I want to create hosts that reside on my 192.168.0.x using bridge mode, it fails.


For the life of me, I can't get it working. Any ideas? Thanks in advance.


I should note that in UnRaid: My eth0 adapter shows no IP. Ifconfig shows xenbr0 as having the 192.168.0.x number that is used on my network.



Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.