Jump to content
jonp

unRAID 6 NerdPack - CLI tools (iftop, iotop, screen, kbd, etc.)

1094 posts in this topic Last Reply

Recommended Posts

I can't seem to update PERL. It indicates an update is ready but nothing happens. Am I supposed to do anything at this point?

 

Also, can MC (master commander) be added? I can't remember if I installed that manually or it is already part of unraid.

Thanks for the NP.

The package manager isn't very smart. The old under installed just means Perl is already installed but not by NerdPack. What version unRAID are you on? Older versions had Perl. It might also be left over from another plugin if you uninstalled it. You could deselect it. Apply. Reselect. Apply.

 

As long as is selected it will be installed on server start up.

 

I did install Perl manually before NerdPack. I turned OFF then applied, then turned it back ON and applied as you suggested and now it says up-to-date. Thanks.

 

Share this post


Link to post

During reboot to apply 6.1.8 update, I have an error on console from Nerdpack:

 

chmod: cannot access '/usr/local/emhttp/plugins/NerdPack/events/*' : No such file or directory

 

Nerd Tools v.2016.02.08

Share this post


Link to post

 

 

During reboot to apply 6.1.8 update, I have an error on console from Nerdpack:

 

chmod: cannot access '/usr/local/emhttp/plugins/NerdPack/events/*' : No such file or directory

 

Nerd Tools v.2016.02.08

 

Thanks. It should be event. I updated the plg file. Everything installed on boot though?

Share this post


Link to post

I rebooted earlier today and noticed that nothing from Nerd Pack installed.  I just updated to today's version of the plugin and rebooted, everything installed as expected.  Thanks!

Share this post


Link to post

 

 

During reboot to apply 6.1.8 update, I have an error on console from Nerdpack:

 

chmod: cannot access '/usr/local/emhttp/plugins/NerdPack/events/*' : No such file or directory

 

Nerd Tools v.2016.02.08

 

Thanks. It should be event. I updated the plg file. Everything installed on boot though?

 

oddly enough I am not sure. I *think* I had everything installed before since that was default behavior before the new ala carte system was introduced. Now it shows Python only is installed.

 

I just checked for update and no new found (still at 2016.02.08)

Share this post


Link to post

I didn't push a whole new version for a letter. :) Just pushed a plg file with event instead of events. The event script is executable anyway unlike the previous version. I just added  the chmod just in case. Which I messed up too. You could edit your /boot/config/Nerdpack.plg file or uninstall and reinstall.

 

Share this post


Link to post

Thanks for a great plugin.

 

But since my last update I can't run unrar or git commands. It just says:

-bash: unrar: command not found

-bash: git: command not found

 

I'm on version 2016.02.08 and has rebooted after install during a pending unRaid version update.

 

Any clues?

 

Kind regards,

Olle

Share this post


Link to post

Thanks for a great plugin.

 

But since my last update I can't run unrar or git commands. It just says:

-bash: unrar: command not found

-bash: git: command not found

 

I'm on version 2016.02.08 and has rebooted after install during a pending unRaid version update.

 

Any clues?

Have you gone to Settings->Nerd Pack to check that you have those set to install?    Maybe this is the first time you have rebooted since Nerd pack was updated to provide individual control over which packages are installed?

Share this post


Link to post

Have you gone to Settings->Nerd Pack to check that you have those set to install?    Maybe this is the first time you have rebooted since Nerd pack was updated to provide individual control over which packages are installed?

 

And there it was. I guess I missed the memo :)

Thanks!

Share this post


Link to post

Thanks for a great plugin.

 

But since my last update I can't run unrar or git commands. It just says:

-bash: unrar: command not found

-bash: git: command not found

 

I'm on version 2016.02.08 and has rebooted after install during a pending unRaid version update.

 

Any clues?

Have you gone to Settings->Nerd Pack to check that you have those set to install?    Maybe this is the first time you have rebooted since Nerd pack was updated to provide individual control over which packages are installed?

 

Nice! Thank you! My server crashed for some reason (still haven't had time to look into why). Thought the plugins not working was caused by it. Even restored to one of my backup configs.

Share this post


Link to post

Trying to install python.  I get:

 

Processing Packages...

 

apr-1.5.0 package up to date

 

...

 

Downloading python-2.7.9-x86_64-1.txz package...

[||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||

 

The |||| go out approximately 700 million miles to the right.  The Chrome processing trying to chunk it is flipping out between 100MB and 300MB of memory and a full CPU utilization. 

 

I tried to copy and paste the error into notepad, and that was about 10 minutes ago.  Notepad, I assume, has barfed.

 

EDIT: I take that back, it just finished pasting into Notepad.  I am now the proud papa of a 4.31MB text file filled with almost entirely |||||||

Share this post


Link to post
EDIT: I take that back, it just finished pasting into Notepad.  I am now the proud papa of a 4.31MB text file filled with almost entirely |||||||

Which will probably zip down to less than 5KB.  :D

Share this post


Link to post

I'll check it out. I noticed some weird behavior with chrome on my phone too. I'll just remove the download animation. It's not necessary and only works on the first package anyway.

Share this post


Link to post

thank you for the inclusion of 7zip..

 

may i please ask [i know this has been discussed] ::) for the inclusion of midnight commander, I do realize that it is already part of UNraid OS but the versioning goes out if the the OS does not update when the new release comes out.

 

Can the nerdpack carry midnight commander please that can overwrite the version in the OS if the user chooses?

 

Thank you

Share this post


Link to post

may i please ask [i know this has been discussed] ::) for the inclusion of midnight commander, I do realize that it is already part of UNraid OS but the versioning goes out if the the OS does not update when the new release comes out.

 

Can the nerdpack carry midnight commander please that can overwrite the version in the OS if the user chooses?

 

The NerdPack has been a supplementary collection of modules that not every one needs.  It helps to keep the installed core leaner.  Your request is a different usage, a way to provide newer versions of the installed modules, whenever users feel LimeTech is not moving quickly enough.  That's possibly valid, but I think I would prefer a separate collection.  With each unRAID release, you'll have to decide what to change with it, what's no longer necessary to install because it's now included in the core.  That makes this new collection quite volatile, much more than the NerdPack has been.

 

There's good value in the NerdPack, in keeping our core systems leaner.  I can see in the future Tom and Eric getting together and moving more modules from the installed unRAID core into NerdPack (or its built-in successor).  It would be especially attractive to those users who only wanted a 'lean and mean' NAS.  They would uncheck all VM support and uncheck all Docker support, and any other feature support they don't plan to use.  Some things can't be separated, have to be compiled into the kernel core, but others should be (libvirt?).

Share this post


Link to post

may i please ask [i know this has been discussed] ::) for the inclusion of midnight commander, I do realize that it is already part of UNraid OS but the versioning goes out if the the OS does not update when the new release comes out.

 

Can the nerdpack carry midnight commander please that can overwrite the version in the OS if the user chooses?

 

The NerdPack has been a supplementary collection of modules that not every one needs.  It helps to keep the installed core leaner.  Your request is a different usage, a way to provide newer versions of the installed modules, whenever users feel LimeTech is not moving quickly enough.  That's possibly valid, but I think I would prefer a separate collection.  With each unRAID release, you'll have to decide what to change with it, what's no longer necessary to install because it's now included in the core.  That makes this new collection quite volatile, much more than the NerdPack has been.

 

There's good value in the NerdPack, in keeping our core systems leaner.  I can see in the future Tom and Eric getting together and moving more modules from the installed unRAID core into NerdPack (or its built-in successor).  It would be especially attractive to those users who only wanted a 'lean and mean' NAS.  They would uncheck all VM support and uncheck all Docker support, and any other feature support they don't plan to use.  Some things can't be separated, have to be compiled into the kernel core, but others should be (libvirt?).

 

soo does that mean no?

Share this post


Link to post

Screen stopped working for me w/ latest update. Am I missing something? I am having some issue w/ my unRAID in terms of failed drives and such.

 

Thanks.

 

H.

Share this post


Link to post

Screen stopped working for me w/ latest update. Am I missing something? I am having some issue w/ my unRAID in terms of failed drives and such.

 

Thanks.

 

H.

Still working for me. Screen requires utempter. Is it installing? Normally the plugin will turn on the dependency for you but I haven't tested this lately.

Share this post


Link to post

Screen stopped working for me w/ latest update. Am I missing something? I am having some issue w/ my unRAID in terms of failed drives and such.

Works fine for me - how is it failing?

 

Do not forget that if you select screen from the Settings->Nerd Pack that you must also make sure utempter is selected as screen needs it.

Share this post


Link to post

Screen stopped working for me w/ latest update. Am I missing something? I am having some issue w/ my unRAID in terms of failed drives and such.

 

Thanks.

 

H.

I changed the install point in the latest versions from array dependent to plugin install. So all packages selected should be installed when the plugin is installed at boot time instead of when the array is started. I have rebooted a couple times and everything is installed and screen works for me.

 

If you're running in maintenance mode with no plugins installed then screen wouldn't be installed.

 

Also when screen is selected, utempter will be selected also. Same for iotop, python will be selected.

Share this post


Link to post

At the command line, I type "screen" and I get a command not found message.

 

I have an unresponsive web gui at the moment. I am copying stuff from a failing or corrupted drive. Once that is done, I will reboot, check the utempter, and try again.

 

Thank you guys.

Share this post


Link to post

At the command line, I type "screen" and I get a command not found message.

Have you actually gone to Settings->Nerd Pack and checked that screen has been selected for install? Earlier versions of the plugin installed all the options, but a while ago it was upgraded to only install the selected options.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.