Jump to content
Capt.Insano

Release: Folding@Home Docker

113 posts in this topic Last Reply

Recommended Posts

Posted (edited)

I can't seem to get the gpu detected when passing it to the container, anyone have any ideas? I tried installing the nvidia driver 410 on the image, but all that did was increase the build time for the image and cause folding at home to not detect cuda, which is did beforehand at version 6.1

 

09:58:37:************************* Folding@home Client *************************
09:58:37: Website: http://folding.stanford.edu/
09:58:37: Copyright: (c) 2009-2014 Stanford University
09:58:37: Author: Joseph Coffland <joseph@cauldrondevelopment.com>
09:58:37: Args: --config /config/config.xml
09:58:37: Config: /config/config.xml
09:58:37:******************************** Build ********************************
09:58:37: Version: 7.4.4
09:58:37: Date: Mar 4 2014
09:58:37: Time: 12:02:38
09:58:37: SVN Rev: 4130
09:58:37: Branch: fah/trunk/client
09:58:37: Compiler: GNU 4.4.7
09:58:37: Options: -std=gnu++98 -O3 -funroll-loops -mfpmath=sse -ffast-math
09:58:37: -fno-unsafe-math-optimizations -msse2
09:58:37: Platform: linux2 3.2.0-1-amd64
09:58:37: Bits: 64
09:58:37: Mode: Release
09:58:37:******************************* System ********************************
09:58:37: CPU: Intel(R) Xeon(R) CPU E5-2667 v2 @ 3.30GHz
09:58:37: CPU ID: GenuineIntel Family 6 Model 62 Stepping 4
09:58:37: CPUs: 32
09:58:37: Memory: 62.94GiB
09:58:37:Free Memory: 1.49GiB
09:58:37: Threads: POSIX_THREADS
09:58:37: OS Version: 4.19
09:58:37:Has Battery: false
09:58:37: On Battery: false
09:58:37: UTC Offset: 0
09:58:37: PID: 28
09:58:37: CWD: /config
09:58:37: OS: Linux 4.19.23-Unraid x86_64
09:58:37: OS Arch: AMD64
09:58:37: GPUs: 0
09:58:37: CUDA: 6.1
09:58:37:CUDA Driver: 10000
09:58:37:***********************************************************************

Edited by MobiusNine
more detail

Share this post


Link to post

In your config file make sure GPU=True

 

 

<!-- Folding Slot Configuration -->
  <gpu v='false'/>  <!-- If true, attempt to autoconfigure GPUs -->

Share this post


Link to post

Once that is done you should see it in the logs and then be able to remotely configure it to add the GPU slot. However I could not get mine to actually fold. I have posted on the linuxserver.io but they don’t seem interested in helping. That whole support chain seems dedicated to Plex. 

Share this post


Link to post
6 hours ago, MobiusNine said:

Here's my repository. the updated FoldingAtHome is the only template in it. https://github.com/MobiusNine/docker-templates

 

Added in, and deprecated CaptInsano's version.  TY

Share this post


Link to post
1 hour ago, Squid said:

Added in, and deprecated CaptInsano's version.  TY

Thanks!  I removed the old version and added MobiusNine's version.   After passing the capabilities (all) and the GUID of the GPU, ensuring the config XML is correct.  As stated above, it looks like CUDA is not detected in this method as it was before (although it's worth noting that while it was detected in the CaptInsano version, it still didn't work either).

 

Edited this below to show the info in question, cleaned it up as there's a lot of stuff that doesn't apply.

5:14:41:******************************* System ********************************
15:14:41:        CPU: Intel(R) Xeon(R) CPU E5-2448L v2 @ 1.80GHz
15:14:41:     CPU ID: GenuineIntel Family 6 Model 62 Stepping 4
15:14:41:       CPUs: 20
15:14:41:     Memory: 31.43GiB
15:14:41:Free Memory: 317.09MiB
15:14:41:    Threads: POSIX_THREADS
15:14:41: OS Version: 4.18
15:14:41:Has Battery: false
15:14:41: On Battery: false
15:14:41: UTC Offset: 0
15:14:41:        PID: 33
15:14:41:        CWD: /config
15:14:41:         OS: Linux 4.18.20-unRAID x86_64
15:14:41:    OS Arch: AMD64






15:14:41:       GPUs: 1
15:14:41:      GPU 0: NVIDIA:4 GM107 [Quadro K2200]
15:14:41:       CUDA: Not detected




15:14:41:***********************************************************************
15:14:41:<config>

15:16:24:  <slot id='0' type='CPU'>
15:16:24:    <paused v='true'/>
15:16:24:  </slot>
15:16:24:  <slot id='1' type='GPU'/>
15:16:24:</config>

 

Share this post


Link to post

I was able to get gpu folding working. The image needed to have opencl installed, which has been taken care of. Here are some logs showing it working.

 

21:26:25:******************************* System ********************************
21:26:25: CPU: Intel(R) Xeon(R) CPU E5-2667 v2 @ 3.30GHz
21:26:25: CPU ID: GenuineIntel Family 6 Model 62 Stepping 4
21:26:25: CPUs: 32
21:26:25: Memory: 62.94GiB
21:26:25:Free Memory: 2.23GiB
21:26:25: Threads: POSIX_THREADS
21:26:25: OS Version: 4.19
21:26:25:Has Battery: false
21:26:25: On Battery: false
21:26:25: UTC Offset: 0
21:26:25: PID: 31
21:26:25: CWD: /config
21:26:25: OS: Linux 4.19.23-Unraid x86_64
21:26:25: OS Arch: AMD64
21:26:25: GPUs: 1
21:26:25: GPU 0: NVIDIA:7 GP106 [GeForce GTX 1060 6GB] 4372
21:26:25: CUDA: 6.1
21:26:25:CUDA Driver: 10000

21:26:25: <!-- Folding Slots -->
21:26:25: <slot id='0' type='GPU'/>
21:26:25:</config>
21:26:25:Trying to access database...
21:26:25:Successfully acquired database lock
21:26:25:Enabled folding slot 00: READY gpu:0:GP106 [GeForce GTX 1060 6GB] 4372
21:26:25:WU00:FS00:Starting
21:26:25:WU00:FS00:Running FahCore: /opt/fah/usr/bin/FAHCoreWrapper /config/cores/cores.foldingathome.org/Linux/AMD64/NVIDIA/Fermi/Core_21.fah/FahCore_21 -dir 00 -suffix 01 -version 704 -lifeline 31 -checkpoint 15 -gpu 0 -gpu-vendor nvidia
21:26:25:WU00:FS00:Started FahCore on PID 41
21:26:25:WU00:FS00:Core PID:45
21:26:25:WU00:FS00:FahCore 0x21 started
21:26:26:WU00:FS00:0x21:*********************** Log Started 2019-03-15T21:26:25Z ***********************
21:26:26:WU00:FS00:0x21:Project: 14163 (Run 43, Clone 1, Gen 85)
21:26:26:WU00:FS00:0x21:Unit: 0x000000730002894c5c38bfb015a28477
21:26:26:WU00:FS00:0x21:CPU: 0x00000000000000000000000000000000
21:26:26:WU00:FS00:0x21:Machine: 0
21:26:26:WU00:FS00:0x21:Reading tar file core.xml
21:26:26:WU00:FS00:0x21:Reading tar file integrator.xml
21:26:26:WU00:FS00:0x21:Reading tar file state.xml
21:26:26:WU00:FS00:0x21:Reading tar file system.xml
21:26:26:WU00:FS00:0x21:Digital signatures verified
21:26:26:WU00:FS00:0x21:Folding@home GPU Core21 Folding@home Core
21:26:26:WU00:FS00:0x21:Version 0.0.18
21:26:29:WU00:FS00:0x21:Completed 0 out of 12500000 steps (0%)
21:26:29:WU00:FS00:0x21:Temperature control disabled. Requirements: single Nvidia GPU, tmax must be < 110 and twait >= 900
21:27:41:WU00:FS00:0x21:Completed 125000 out of 12500000 steps (1%)
21:27:41:WU00:FS00:0x21:Completed 125000 out of 12500000 steps (1%)
21:28:53:WU00:FS00:0x21:Completed 250000 out of 12500000 steps (2%)

  • Like 1

Share this post


Link to post

If there's interest I could look into integrating some sort of fan control script since there's no real way to control temps/fan speed atm.

  • Like 1

Share this post


Link to post

That is fantastic!  I assume the published image in the APPS will now pull the latest version?  I will test it now!

Share this post


Link to post

Hmmm... still no luck here.  Are you passing ALL as the variable for the Driver Capabilities variable, or are you using Compute?

 

 

Still Shows Cuda Not Detected.

*********************** Log Started 2019-03-15T22:28:31Z ***********************
22:28:31:************************* Folding@home Client *************************
22:28:31:    Website: http://folding.stanford.edu/
22:28:31:  Copyright: (c) 2009-2014 Stanford University
22:28:31:     Author: Joseph Coffland <joseph@cauldrondevelopment.com>
22:28:31:       Args: --config /config/config.xml
22:28:31:     Config: /config/config.xml
22:28:31:******************************** Build ********************************
22:28:31:    Version: 7.4.4
22:28:31:       Date: Mar 4 2014
22:28:31:       Time: 12:02:38
22:28:31:    SVN Rev: 4130
22:28:31:     Branch: fah/trunk/client
22:28:31:   Compiler: GNU 4.4.7
22:28:31:    Options: -std=gnu++98 -O3 -funroll-loops -mfpmath=sse -ffast-math
22:28:31:             -fno-unsafe-math-optimizations -msse2
22:28:31:   Platform: linux2 3.2.0-1-amd64
22:28:31:       Bits: 64
22:28:31:       Mode: Release
22:28:31:******************************* System ********************************
22:28:31:        CPU: Intel(R) Xeon(R) CPU E5-2448L v2 @ 1.80GHz
22:28:31:     CPU ID: GenuineIntel Family 6 Model 62 Stepping 4
22:28:31:       CPUs: 20
22:28:31:     Memory: 31.43GiB
22:28:31:Free Memory: 297.75MiB
22:28:31:    Threads: POSIX_THREADS
22:28:31: OS Version: 4.18
22:28:31:Has Battery: false
22:28:31: On Battery: false
22:28:31: UTC Offset: 0
22:28:31:        PID: 33
22:28:31:        CWD: /config
22:28:31:         OS: Linux 4.18.20-unRAID x86_64
22:28:31:    OS Arch: AMD64
22:28:31:       GPUs: 1
22:28:31:      GPU 0: NVIDIA:4 GM107 [Quadro K2200]
22:28:31:       CUDA: Not detected
22:28:31:***********************************************************************
22:28:31:<config>
22:28:31:  <!-- Client Control -->
22:28:31:  <fold-anon v='true'/>
22:28:31:
22:28:31:  <!-- HTTP Server -->
22:28:31:  <allow v='192.168.1.1/24'/>
22:28:31:
22:28:31:  <!-- Network -->
22:28:31:  <proxy v=':8080'/>
22:28:31:
22:28:31:  <!-- Remote Command Server -->
22:28:31:  <password v='********'/>
22:28:31:
22:28:31:  <!-- Slot Control -->
22:28:31:  <power v='FULL'/>
22:28:31:
22:28:31:  <!-- User Information -->
22:28:31:  <passkey v='********************************'/>
22:28:31:  <team v='111065'/>
22:28:31:  <user v='Tiger770'/>
22:28:31:
22:28:31:  <!-- Web Server -->
22:28:31:  <web-allow v='192.168.1.1/24'/>
22:28:31:
22:28:31:  <!-- Folding Slots -->
22:28:31:  <slot id='0' type='CPU'/>
22:28:31:  <slot id='1' type='GPU'/>
22:28:31:</config

 

Share this post


Link to post
15 minutes ago, Tiger770 said:

Hmmm... still no luck here.  Are you passing ALL as the variable for the Driver Capabilities variable, or are you using Compute?

 

 

Still Shows Cuda Not Detected.


*********************** Log Started 2019-03-15T22:28:31Z ***********************
22:28:31:************************* Folding@home Client *************************
22:28:31:    Website: http://folding.stanford.edu/
22:28:31:  Copyright: (c) 2009-2014 Stanford University
22:28:31:     Author: Joseph Coffland <joseph@cauldrondevelopment.com>
22:28:31:       Args: --config /config/config.xml
22:28:31:     Config: /config/config.xml
22:28:31:******************************** Build ********************************
22:28:31:    Version: 7.4.4
22:28:31:       Date: Mar 4 2014
22:28:31:       Time: 12:02:38
22:28:31:    SVN Rev: 4130
22:28:31:     Branch: fah/trunk/client
22:28:31:   Compiler: GNU 4.4.7
22:28:31:    Options: -std=gnu++98 -O3 -funroll-loops -mfpmath=sse -ffast-math
22:28:31:             -fno-unsafe-math-optimizations -msse2
22:28:31:   Platform: linux2 3.2.0-1-amd64
22:28:31:       Bits: 64
22:28:31:       Mode: Release
22:28:31:******************************* System ********************************
22:28:31:        CPU: Intel(R) Xeon(R) CPU E5-2448L v2 @ 1.80GHz
22:28:31:     CPU ID: GenuineIntel Family 6 Model 62 Stepping 4
22:28:31:       CPUs: 20
22:28:31:     Memory: 31.43GiB
22:28:31:Free Memory: 297.75MiB
22:28:31:    Threads: POSIX_THREADS
22:28:31: OS Version: 4.18
22:28:31:Has Battery: false
22:28:31: On Battery: false
22:28:31: UTC Offset: 0
22:28:31:        PID: 33
22:28:31:        CWD: /config
22:28:31:         OS: Linux 4.18.20-unRAID x86_64
22:28:31:    OS Arch: AMD64
22:28:31:       GPUs: 1
22:28:31:      GPU 0: NVIDIA:4 GM107 [Quadro K2200]
22:28:31:       CUDA: Not detected
22:28:31:***********************************************************************
22:28:31:<config>
22:28:31:  <!-- Client Control -->
22:28:31:  <fold-anon v='true'/>
22:28:31:
22:28:31:  <!-- HTTP Server -->
22:28:31:  <allow v='192.168.1.1/24'/>
22:28:31:
22:28:31:  <!-- Network -->
22:28:31:  <proxy v=':8080'/>
22:28:31:
22:28:31:  <!-- Remote Command Server -->
22:28:31:  <password v='********'/>
22:28:31:
22:28:31:  <!-- Slot Control -->
22:28:31:  <power v='FULL'/>
22:28:31:
22:28:31:  <!-- User Information -->
22:28:31:  <passkey v='********************************'/>
22:28:31:  <team v='111065'/>
22:28:31:  <user v='Tiger770'/>
22:28:31:
22:28:31:  <!-- Web Server -->
22:28:31:  <web-allow v='192.168.1.1/24'/>
22:28:31:
22:28:31:  <!-- Folding Slots -->
22:28:31:  <slot id='0' type='CPU'/>
22:28:31:  <slot id='1' type='GPU'/>
22:28:31:</config

 

I am passing all as shown in the attached picture, and yes, the latest image is accessible through Community Apps. I wonder if using a quadro is causing some other sort of issue.

FaHdocker.jpg

Share this post


Link to post

the odd thing is that FaH reports Cuda 6.1 for me, but when I run nvidia-smi in the console for the docker it reports 410.78 for the driver and 10.0 for Cuda.

Share this post


Link to post
Posted (edited)

Yeah.  I'm daft.  I got it to work.  If you look at my screen grab, it shows you the problem.  When I tried to recreate from template it stuck in some junk in front of the description "CONTAINER VARIABLE:"

 

I deleted the whole thing.  Added it new (no custom configs) and when it started, stopped the container.  Edited it to add all the stuff back in for passthrough, clicked apply, and it fired right up.  Here's what mine now reports (and is folding without issue).

 

01:52:37:       GPUs: 1
01:52:37:      GPU 0: NVIDIA:4 GM107 [Quadro K2200]
01:52:37:       CUDA: 5.0
01:52:37:CUDA Driver: 10010

This is also on the 418.43 driver.

 

 

Edit:  It could have just been dumping it all and starting from scratch with a proper config POST download was what fixed it.  At least it's working now, and for that you get major props from me.  No more having to run a windows VM to GPU fold!  

Edited by Tiger770

Share this post


Link to post
18 hours ago, Tiger770 said:

Yeah.  I'm daft.  I got it to work.  If you look at my screen grab, it shows you the problem.  When I tried to recreate from template it stuck in some junk in front of the description "CONTAINER VARIABLE:"

 

I deleted the whole thing.  Added it new (no custom configs) and when it started, stopped the container.  Edited it to add all the stuff back in for passthrough, clicked apply, and it fired right up.  Here's what mine now reports (and is folding without issue).

 


01:52:37:       GPUs: 1
01:52:37:      GPU 0: NVIDIA:4 GM107 [Quadro K2200]
01:52:37:       CUDA: 5.0
01:52:37:CUDA Driver: 10010

This is also on the 418.43 driver.

 

 

Edit:  It could have just been dumping it all and starting from scratch with a proper config POST download was what fixed it.  At least it's working now, and for that you get major props from me.  No more having to run a windows VM to GPU fold!  

I'm glad to hear it! Also, after looking into it I don't think the version of Cuda that Folding at Home reports matters as the version of Cuda installed with the drivers in unraid seems to be the latest and the work is passed through to it. I could be wrong, but it works and I can't find anything to the contrary.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now