Jump to content
binhex

[Support] binhex - Couchpotato

137 posts in this topic Last Reply

Recommended Posts

Gday All, Thankyou kindly to Binhex - Im just getting started with unRaid , Sickrage and DelugeVPN all working soo far (Thankyou BINHEX again).

 

Ive decided to configure couchpotato next.  Just before i totally configure it.... Im just trying to get it to TEST connect to Deluge.  using my unraid ip 192.168.0.1:8112  or  58846

 

CP keeps coming back with "Connection Failed: Check log files"    But there is no mention of deluge in either Couchpotato log or Docker Log.

 

Note: Deluge is setup as defualt configuration - No username and password of "deluge"

 

Cheers,

Mark

Edited by markh

Share this post


Link to post
2 hours ago, markh said:

Gday All, Thankyou kindly to Binhex - Im just getting started with unRaid , Sickrage and DelugeVPN all working soo far (Thankyou BINHEX again).

 

Ive decided to configure couchpotato next.  Just before i totally configure it.... Im just trying to get it to TEST connect to Deluge.  using my unraid ip 192.168.0.1:8112  or  58846

 

CP keeps coming back with "Connection Failed: Check log files"    But there is no mention of deluge in either Couchpotato log or Docker Log.

 

Note: Deluge is setup as defualt configuration - No username and password of "deluge"

 

Cheers,

Mark

 

before you spend too much more time on this, you might first consider instead of CP you use Radarr, this is the new kid on the block and apparently (i dont use either) it works pretty well, so you might want to go for that instread of CP. If however you are more comfy with CP then let me know and i will send you some links on how to get it running, link to Radarr below:-

 

https://forums.lime-technology.com/topic/53807-support-binhex-radarr/

 

 

Share this post


Link to post

Yeah ok , ive been using couchpotato on a WHS2011 server for a few years.

So yeah - id love to get it working again.

 

Share this post


Link to post

I have an issue where three movies are stuck under "Snatched & Available" on the start page and I can't get rid of them. The movies are added to Plex and are listed on the library in CouchPotatoe. 

Any ideas on how to get rid of them? 

Share this post


Link to post
13 hours ago, azzilla said:

I have an issue where three movies are stuck under "Snatched & Available" on the start page and I can't get rid of them. The movies are added to Plex and are listed on the library in CouchPotatoe. 

Any ideas on how to get rid of them? 

cursor over the top and then "Mark as done" ?

Share this post


Link to post
3 hours ago, tjb_altf4 said:

cursor over the top and then "Mark as done" ?

 

Thanks but that is the problem. It doesn’t matter if I clck “mark as done”, these three particular movies just come back after I refresh couch potato

Share this post


Link to post
On 19/09/2017 at 6:47 PM, binhex said:

 

before you spend too much more time on this, you might first consider instead of CP you use Radarr, this is the new kid on the block and apparently (i dont use either) it works pretty well, so you might want to go for that instread of CP. If however you are more comfy with CP then let me know and i will send you some links on how to get it running, link to Radarr below:-

 

https://forums.lime-technology.com/topic/53807-support-binhex-radarr/

 

Gday Binhex,

 

I have tried Radarr - but it has no renaming feature.

That would be great if you could send me through some details.

 

Share this post


Link to post

Hello,

 

Fist off thanks Binhex for providing this docker, i have been able to setup most things without issue but i do have a problem with setting the sabnzbd ip address in the downloaders section.

 

Every time i change it from local host to the ip address i hit test it comes back successful i exit go back in and it is back to local host this is stopping me being able to setup a connection to sabnzbd.

 

Anyone any ideas?

 

I have gone and directly change the settings file to the ip address but its not picked up in the web interface, if i restart the docker the settings file is changed back to local host.

 

This happens on Bin Hex docker and linuxserver docker, so seems i may be doing something wrong? I don't think its permissions as all other settings remain persistent.

 

Thanks

 

Marc

sabnzbd setting.JPG

Share this post


Link to post

Maybe check the config file in appdata/ directory.  Check where you have it setup to save the config file and then you could try to edit.

Share this post


Link to post

My couchpotato docker appears to have lost the ability to access imdb.  All the Box Office and Top 250 Movies displays ar grey and say "Unknown movie    n/a".  "Search & add new media" never finds anything.  The pop up window opened by the CouchPotato bookmark never displays a movie in the drop down menu box.

 

I've tried restarting the container several times, to no avail.

 

What could be causing this?

Share this post


Link to post
11 hours ago, PeterB said:

My couchpotato docker appears to have lost the ability to access imdb.  All the Box Office and Top 250 Movies displays ar grey and say "Unknown movie    n/a".  "Search & add new media" never finds anything.  The pop up window opened by the CouchPotato bookmark never displays a movie in the drop down menu box.

 

I've tried restarting the container several times, to no avail.

 

What could be causing this?

Same here....started doing this after the most recent update.

Share this post


Link to post

Hmmm .... just looked at the Docker page - it says that binhex-couchpotato image was created one year ago!  I know that it was working properly just days ago.

Share this post


Link to post

Are you guys using privoxy?
I removed my proxy from my CP config and once I cleared some of the crap everything went back to normal.

Share this post


Link to post

I think I may have spoken to soon :/

Looks like its an issue around the omdbapi... maybe time to give up on the good ship CP

Share this post


Link to post

Hello,

the container works fine, but it is possible to upgrade to the latest Git version.

My current version is 4a0999d9 (6.9.2016)

Share this post


Link to post
4 hours ago, king79 said:

Hello,

the container works fine, but it is possible to upgrade to the latest Git version.

My current version is 4a0999d9 (6.9.2016)

 

i can update to the latest master commit sure, but i wouldn't guarantee this will fix the omdbapi issue, as CP is not really being developed any more, and the issue (i would guess) is a change of api at the omdb end, and until that change is fixed in CP it will remain broken, i would encourage you all to migrate to  Radarr:- 

 

p.s this docker image has been marked as deprecated for a while and should be shown as such in CA.

Share this post


Link to post
2 hours ago, binhex said:

p.s this docker image has been marked as deprecated for a while and should be shown as such in CA.

No its not.  You deprecated SickBeard.  CP is still available

Share this post


Link to post
2 hours ago, Squid said:

No its not.  You deprecated SickBeard.  CP is still available

lol thanks @squid what would i do without you eh, i blame old age, my memory isn't what it was, ok well i think unless there is some development on CP soon then i will be marking this as deprecated too.

Edited by binhex

Share this post


Link to post

Apparently one of the CP devs has said a fix is coming, but I suspect its already too late for many... 

 

I got up and running fairly quickly with Radarr thanks to @gridrunner's helpful vid, just importing my sizable library is taking a while :/

Lots of improvements over CP, yet to see any drawbacks, but not had any post-processing jobs yet (which CP did well).

Edited by tjb_altf4

Share this post


Link to post

fyi guys i have marked arch-couchpotato (not arch-couchpotato-git) as deprecated, last github "release" was 2015, highly unlikely CP will ever see a new release.

Edited by binhex

Share this post


Link to post

Maybe I'm being a bit slow - wouldn't be the first time...

 

I found "binhex couchpotato git" in CA:

image.thumb.png.d5296f2e2d44f881d5da443c399baa3a.png

But when I click the "Support Thread" link, it brings me here.

 

I've been running the "regular" "binhex couchpotato" for quite a while:

image.png.e41d847a92f0acaa5aabff67739d521e.png

for the most part it seems to be working reasonably well, but there have been a few minor glitches.

 

A) is this the proper support thread for the "git" version?

B) if I install the "git" version, do I have to manually reconfigure everything or can I copy my current appdata\couchpotato directory contents to the new appdata\couchpotato-git (or whatever it will be called) directory to maintain my existing configuration?

C) Should I really just move on to Radarr and figure out how to get that working instead?

 

It does appear that the most recent pull on CP's GitHub repository was about 6 months ago, so development isn't super active, but it's not totally dead ("I'm not dead yet!", "Shut up! He will be soon.").

 

Either way, thanks @binhex for all your work over the years!

Share this post


Link to post
On 09/12/2017 at 9:29 PM, FreeMan said:

Maybe I'm being a bit slow - wouldn't be the first time...

 

I found "binhex couchpotato git" in CA:

image.thumb.png.d5296f2e2d44f881d5da443c399baa3a.png

But when I click the "Support Thread" link, it brings me here.

 

I've been running the "regular" "binhex couchpotato" for quite a while:

image.png.e41d847a92f0acaa5aabff67739d521e.png

for the most part it seems to be working reasonably well, but there have been a few minor glitches.

 

A) is this the proper support thread for the "git" version?

B) if I install the "git" version, do I have to manually reconfigure everything or can I copy my current appdata\couchpotato directory contents to the new appdata\couchpotato-git (or whatever it will be called) directory to maintain my existing configuration?

C) Should I really just move on to Radarr and figure out how to get that working instead?

 

It does appear that the most recent pull on CP's GitHub repository was about 6 months ago, so development isn't super active, but it's not totally dead ("I'm not dead yet!", "Shut up! He will be soon.").

 

Either way, thanks @binhex for all your work over the years!

 

Quote

But when I click the "Support Thread" link, it brings me here.

yep i got lazy :-), couchpotato and couchpotato-git are both supported in this thread, and as i have just deprecated couchpotato i dont think i will bother seperating it.

 

Quote

for the most part it seems to be working reasonably well, but there have been a few minor glitches.

impressive for software that was last released in 2015! (talking about github "release" here) :-)

 

A) yes

B) you SHOULD be able to just copy your config across and it SHOULD pick it up - not tested, so be cautious when doing this.

C) if i were you, yes.

 

ha nice ref to monty python, "i feel better, you're not fooling anyone!)

 

 

Share this post


Link to post
14 hours ago, binhex said:

C) if i were you, yes.

 

ha nice ref to monty python, "i feel better, you're not fooling anyone!)

 

It didn't take long to get Radarr setup & working, but it doesn't seem to have the management of existing movies down as well as CP. I guess I really don't need that, but I do like to pull up CP in NZB Unity while I'm out and about to see if this movie that's on sale is one I've already got or not. I've already deleted it, but maybe I'll reinstall it (it was just that easy) and let it do its thing again.

 

And... I'm glad someone got the reference. :)

Share this post


Link to post

Hi, i think i have a brainfart here.. cant seem to understand how to setup couchpotato within docker. 

Se attached pictures for docker setup and settings in couch. But i cant seem to get the files downloaded to right directory, and the renamer to get into action.

 

Anyone can give me a step by step here? thx.

 

Capture3.PNG

Capture2.PNG

Capture1.PNG

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.