Jump to content
binhex

[Support] binhex - Plex Pass

355 posts in this topic Last Reply

Recommended Posts

10 hours ago, Shomil Saini said:

Hi @binhex Thanks for the plexpass unraid docker container. Really appreciate your work on all the other repos as well.

However, I was going to customize my plex - chromecast.xml for obvious reasons of audio and video passthrough and such and couldn't find that anyhow.

 

Could you please let us know the path to that folder.

Typically it is /usr/lib/plexmediaserver/Resources/Profiles/Chromecast.xml in standard ubuntu linux installs or at

/mnt/HD/HD_a2/Nas_Prog/plexmediaserver/binaries/Resources/Profiles/Chromecast.xml on WD NAS PR4100 or such devices.

 

Your help would be highly appreciated as always.

 

Cheers!

@binhex - Ok, so I was able to find the path in running processes directory (I believe) from Krusader Search :

//proc/5063/task/5069/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/usr/share/licenses/plex-media-server-plexpass
file:///ROOT/proc/5063/task/5069/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/proc/132/task/153/root/usr/lib/plexmediaserver/Resources/Profiles/Chromecast.xml

However If I go manually inside the folders one by one in Krusader, I can reach via this path :

/ROOT/proc/5063/task/5069/root/lib/plexmediaserver/Resources/Profiles/Chromecast.xml

So, I believe it is getting that data at run-time from somewhere... Not sure where only thing I can think of is Docker.img. I am not sure how to get to that file to edit the source of that.

 

Please Help!!! @binhex

 

Cheers!!

Share this post


Link to post
10 hours ago, Shomil Saini said:

/usr/lib/plexmediaserver/Resources/Profiles/Chromecast.xml

looking at your output from krusader, i would say this is the path to the file you want to change, looks like this is located inside the container, so you would need to do the following:-

 

docker exec -it <name of container> bash
nano /usr/lib/plexmediaserver/Resources/Profiles/Chromecast.xml

once you have edited the above file then ctrl +x , press y to confirm change, then return to overwrite file, type 'exit' then restart container.

 

note the above is a TEMPORARY fix, if you pull down a new image then your container will be deleted, but lets see first if it fixes the problem you are trying to overcome.

Share this post


Link to post
8 hours ago, binhex said:

looking at your output from krusader, i would say this is the path to the file you want to change, looks like this is located inside the container, so you would need to do the following:-

 


docker exec -it <name of container> bash
nano /usr/lib/plexmediaserver/Resources/Profiles/Chromecast.xml

once you have edited the above file then ctrl +x , press y to confirm change, then return to overwrite file, type 'exit' then restart container.

 

note the above is a TEMPORARY fix, if you pull down a new image then your container will be deleted, but lets see first if it fixes the problem you are trying to overcome.

As always, You're awesome @binhex !!

 

That seems to work. Although I understand this is a temporary solution, is there a way we can make it permanent.

As I have seen people being able to move Profiles and libraries on a big Media Library migration as well as modifying DLNA and Chromecast profiles is quite common.

 

I can live with this for now though.

 

Many thanks @binhex :)

 

Have a good weekend.

Share this post


Link to post

I used to have binhex plex but now I have binhex plexpass I cannot get Plex to talk to the outside of my network. Using the standard port 32400 worked flawlessly before. When check the settings it's not getting a port allocated how to I get that port allocated.

 

Capture.PNG.adf95aa577c8ded9e21effd6228ddca7.PNG

Capture1.PNG

 

Edit: I have complete removed all Plex files from the appdata folder. I've tried putting binhex plex back on still the same.

Edited by shadowless82

Share this post


Link to post
On 1/19/2019 at 4:20 AM, shadowless82 said:

I used to have binhex plex but now I have binhex plexpass I cannot get Plex to talk to the outside of my network. Using the standard port 32400 worked flawlessly before. When check the settings it's not getting a port allocated how to I get that port allocated.

 

Capture.PNG.adf95aa577c8ded9e21effd6228ddca7.PNG

Capture1.PNG

 

Edit: I have complete removed all Plex files from the appdata folder. I've tried putting binhex plex back on still the same.

I am having the same issue. Fresh install and port is forwarded on my router.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now