[SUPPORT] pihole for unRaid - Spants repo


904 posts in this topic Last Reply

Recommended Posts

  • Replies 903
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

See Spaceinvader One's setup video here:        I wrote the template that pulls in the Official Docker Container from PiHole. I swapped over from my unofficial one a long

Hi, I wanted to use this pihole docker as my second dns server, i already have a hardware raspberry pi as my main pihole dns, but having a backup is always good. I was wondering how i could

I just wanted to share a trick I used to have hostnames show up in the Pihole Dashboard for my local devices instead of IP addresses. Like this:     First make a copy of the /etc/

Posted Images

 

 

On 13/11/2017 at 12:25 AM, H2O_King89 said:

any info about the cornjob for the logs?

 

Sorry - I cant find any log details on the diginc docker website. I guess that the userscript will work but havent tried it.

 

edit: Looks like I will have to look into it as my logfile refuses to load (probably too big)

 

Edited by spants
Link to post
  • 3 weeks later...

I am trying to get pihole working in unraid but I keep getting this error when I try to start it gives an error. listen tcp 0.0.0.0:80: bind: address already in use. I have changed the Unraid port to 81 and it still doesn't work. I was told I can assign IP addresses to separate dockers in 6.4 so I upgraded but I still have no idea what to do. This is the only real hurdle I have run into since installing unraid. 

 

Never mind! I got it working I had two conflicting IP addresses.

Edited by ucliker
Link to post
  • 2 weeks later...
On 14/12/2017 at 12:33 PM, PiZZaMaN2K said:

Is there any ETA on ipv6 support? it seems that over 50% of my DNS requests are ipv6 on my network. 

 

It seems that 6.4 unraid supports ipv6, pihole supports ipv6 but even when you choose (in the template) ipv6 = True, the options are greyed out....not sure...

You could try changing the repository to point to one of the other builds https://hub.docker.com/r/diginc/pi-hole/tags/ - but I couldnt get the latest debian_dev to work.

 

The template uses "alpine" although alpine_dev also works

 

 

 

 

Edited by spants
Link to post

I am having an issue related to a problem that was reported using a previous version of the Docker template, to which no clear resolution seems to have been outlined in this thread.  I was wondering if perhaps this had been solved, or perhaps would help solve this once and for all.

 

I can install Pi-Hole without issues on my unRAID system.  I'm running 6.4rc15, and have assigned a dedicated IP to the docker.  I can pink the IP, and I can access the WebUI (although it is not very responsive).  DNS queries of any computers or devices pointed to the Pi-Hole are not getting through.  They are not logged on the Pi-Hole, and the DNS query never gets resolved on the device, obviously.

 

What seems out of place to me however is that the load stats reported in the Pi-Hole WebUI is typically around 12.xx, 12.xx, 12.xx .  I'm running on a Ryzen 1700x 8-core 16-thread CPU, so those numbers would not be out of place under heavy server load, but there is nothing of consequence happening on the server at this point (except a file transfer), and the unRAID UI should server load at about 5% max. Other Dockers include Sonarr, sabNZBD and Plex, and all are running fine.

 

Is there an issue between PiHole and unRAID on Ryzen?  I was hoping to get this to work since it would make sense to run this on the unRAID server, but I'm a bit at a loss at this point.  I may have to go back to running I on the Pi if this isn't solvable.

 

Thanks,

 

Link to post

I can't get this thing to work.

 

Updated to 6.4rc18f to use the custom IP so.I don't have to change the WebGui port, disabled the VM Manager in the Settings but I still get the following error:

 

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name="pihole" --net="bridge" -e TZ="Europe/Berlin" -e HOST_OS="unRAID" -e "ServerIP"="192.168.1.169" -e "DNS1"="8.8.8.8" -e "DNS2"="8.8.4.4" -e "IPv6"="False" -e "TZ"="Europe/London" -e "WEBPASSWORD"="admin" -e "INTERFACE"="br0" -e "DNSMASQ_LISTENING"="all" -p 53:53/tcp -p 53:53/udp -p 80:80/tcp -v "/mnt/user/appdata/pihole/pihole/":"/etc/pihole/":rw -v "/mnt/user/appdata/pihole/dnsmasq.d/":"/etc/dnsmasq.d/":rw --cap-add=NET_ADMIN diginc/pi-hole:alpine

ef6fe6f9920330e35c5f4fa95cdbd1c6dcffcc9b40035b3b853c7d2a8f92ea66
/usr/bin/docker: Error response from daemon: driver failed programming external connectivity on endpoint pihole (925bd810733853ba4e7ce50fefa1130e787865a32609efa12665970d857e8278): Error starting userland proxy: listen tcp 0.0.0.0:80: bind: address already in use.

The command failed.

Link to post
13 hours ago, Natrium said:

I can't get this thing to work.

 

Updated to 6.4rc18f to use the custom IP so.I don't have to change the WebGui port, disabled the VM Manager in the Settings but I still get the following error:

 

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name="pihole" --net="bridge" -e TZ="Europe/Berlin" -e HOST_OS="unRAID" -e "ServerIP"="192.168.1.169" -e "DNS1"="8.8.8.8" -e "DNS2"="8.8.4.4" -e "IPv6"="False" -e "TZ"="Europe/London" -e "WEBPASSWORD"="admin" -e "INTERFACE"="br0" -e "DNSMASQ_LISTENING"="all" -p 53:53/tcp -p 53:53/udp -p 80:80/tcp -v "/mnt/user/appdata/pihole/pihole/":"/etc/pihole/":rw -v "/mnt/user/appdata/pihole/dnsmasq.d/":"/etc/dnsmasq.d/":rw --cap-add=NET_ADMIN diginc/pi-hole:alpine

ef6fe6f9920330e35c5f4fa95cdbd1c6dcffcc9b40035b3b853c7d2a8f92ea66
/usr/bin/docker: Error response from daemon: driver failed programming external connectivity on endpoint pihole (925bd810733853ba4e7ce50fefa1130e787865a32609efa12665970d857e8278): Error starting userland proxy: listen tcp 0.0.0.0:80: bind: address already in use.

The command failed.

Are you starting this from docker manager tab

is ServerIP = the ip of the new ip for the docker that you have given it?

 

Link to post
5 hours ago, bmdegraaf said:

I am getting the following error message:
[✗] DNS resolution is currently unavailable

As a result, the block lists will not update... Can someone point me in the right direction?

I just installed for the first time and can confirm the same.

Link to post
On 07/01/2018 at 10:07 AM, bmdegraaf said:

I am getting the following error message:
[✗] DNS resolution is currently unavailable

As a result, the block lists will not update... Can someone point me in the right direction?

 

Add the following to Extra Parameters in the docker template to get it working:
 

--dns 127.0.0.1 --dns 8.8.8.8

 

Edited by Weavus
Link to post
On 9/25/2017 at 12:45 PM, MowMdown said:

 

Stop the KVM Hyper-Visor (Virtual Machine Manager) in unraids settings, install pi-hole, then restart the KVM. Should work.

 

If you then get an issue with port 80 you need to edit the ~/boot/config/go file from 80 to 81 (look this up because I forget the proper syntax)

 

Is this issue something that will eventually get fixed? I've had to restart a few times and everytime I have to stop/start to VM manager to get the docker working again.

Link to post
On 09/01/2018 at 12:07 AM, bluesky509 said:

 

Is this issue something that will eventually get fixed? I've had to restart a few times and everytime I have to stop/start to VM manager to get the docker working again.

 

There is nothing I can do to "fix" this as the template is working as designed, I am not sure that Limetech will change the operation of unRaid.

The solution is to use v6.4 and giving the pihole docker its own IP address. 

Link to post
On 12/22/2017 at 9:01 PM, Gary489 said:

I was successful in running PiHole at port 81 so no need to change unraid's port. But unraid pihole docker is out of date so i chose not to run it on unraid and keep it on a raspberry pi.

 6.4 is out now - but to combat this kind of stuff I had just setup PiHole on a very slim (~3GB) Debian 9 VM and setup a crontab to run pihole -up at 5AM nightly. 

 

I'd like to use the container but how often is it updated or if development on the container ceases how can we get this updated? I want to be sure I'm not throwing away all my config on Debian and getting things *just* right haha.

Link to post
4 hours ago, bobokun said:

After updating the docker to the new template and updating to unRaid to v6.4 I can't seem to update my lists. It keeps coming back with 

 

[✗] DNS resolution is currently unavailable

Waiting up to 91 seconds before continuing...

 

Did you give the Docker container a static IP address (since this is now part of 6.4)? If so that may be messing with something that was previously set? I currently am not using this container right now but that may be a good place to start troubleshooting. 

 

For some insight when I setup a Debian VM and installed pihole last night, it lost my static IP after a reboot of the VM, I had to go into /etc/network/interfaces and make my changes there.

Link to post
15 hours ago, bobokun said:

After updating the docker to the new template and updating to unRaid to v6.4 I can't seem to update my lists. It keeps coming back with 

 

[✗] DNS resolution is currently unavailable

Waiting up to 91 seconds before continuing...

 

did you see a couple of posts up... 

 

 

There is a slight issue on the dockers that the author is addressing. The "extra parameters" tip solves it...

 

Link to post

Excellent job on the template/build etc.  I run Pi-Hole on a separate raspberry pi, been thinking of re-purposing that Pi and do this container.  I got it installed and running with no issues.  Pointed a couple devices at it and all is well, I can see it doing its thing.  

 

Question...  I see things have changed based on the layout of the first post, do we still need to do those CRON jobs or was that modified too?  If not, is there not a way to map the logs outside of the container and to the appdata folder?  

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.