**VIDEO GUIDE How to Setup Collabora with Nextcloud for our own online document suite **


21 posts in this topic Last Reply

Recommended Posts

Hey guys here is a tutorial on how to install and setup a Collabora Document Server and configure it to work with Nextcloud as a Docker container on Unraid. It shows how to set it up running through a reverse nginx proxy. Collabora is a LibreOffice Online document suite. this gives you control over your own documents and integrates with nextcloud. So no longer any need for google drive and google docs!

 

This video guide makes use of   @chvb  great container.

 

 

Link to post

Thanks for this, but I couldn't get this to work by just changing the two lines you suggested.  Shouldn't the other lines referencing 'Collabora' also be changed?


This is what I currently have:

 


resolver 127.0.0.11 valid=30s;
upstream collabora {
    server 192.168.50.74:9980;
}

server {
    listen       443 ssl;
    server_name office.*;
    include /config/nginx/ssl.conf;
	
   # static files
    location ^~ /loleaflet {
        proxy_pass https://192.168.50.74:9980;
        proxy_set_header Host $host;
    }

    # WOPI discovery URL
    location ^~ /hosting/discovery {
        proxy_pass https://192.168.50.74:9980;
        proxy_set_header Host $host;
    }
	
    # Capabilities
    location ^~ /hosting/capabilities {
        proxy_pass https://192.168.50.74:9980;
        proxy_set_header Host $http_host;
    }

	# main websocket
	    location ~ ^/lool/(.*)/ws$ {
	        proxy_pass https://192.168.50.74:9980;
	        proxy_set_header Upgrade $http_upgrade;
	        proxy_set_header Connection "Upgrade";
	        proxy_set_header Host $http_host;
	        proxy_read_timeout 36000s;
	    }
		
    # Admin Console websocket
    location ^~ /lool/adminws {
	proxy_buffering off;
        proxy_pass https://192.168.50.74:9980;
        proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection "Upgrade";
        proxy_set_header Host $host;
        proxy_read_timeout 36000s;
    }

    # download, presentation and image upload
       location ~ ^/lool {
           proxy_pass https://192.168.50.74:9980;
           proxy_set_header Host $http_host;
       }
}

 

Link to post

It should work just changing the container name to the server ip


resolver 127.0.0.11 valid=30s;
upstream collabora {
    server 10.10.20.199:9980;
}

This part above sets the name collabora to 10.10.20.199:9980  so then nothing else needs changing after its defined.

Then later when collabora  is in the config as below,  it relates to what was defined above.


   # static files
    location ^~ /loleaflet {
        proxy_pass https://collabora;
        proxy_set_header Host $host;
    }

  

 

So then the https://collabora is the same as https://10.10.20.199:9980;

But how your file is will work too specifying the IP and port each time instead.

Link to post
  • 2 weeks later...
  • 1 month later...

Hi,

 

I have followed the wonderful SpaceInvaderOne video on setting up Collabora, but when I click on a document, I get a blank screen with nextcloud headers, and then the message 'Failed to load Collabora Online - please try later'. 

 

When I check the nextcloud error.log i can see the following errors:

 

[error] 312#312: *15849 upstream sent invalid status "0" while reading response header from upstream

 

and 

 

[error] 312#312: *245 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Cannot declare class GuzzleHttp\Handler\CurlFactory, because the name is already in use

 

I have googled for these error messages but cannot find anything that works.

 

If I go to the https://office.mydomain.com/hosting/discovery I and shown an xml page and can also log into the Collabora admin console using the url 

https://office.mydomain.com/loleaflet/dist/admin/admin.html.

 

Any help much appreciated.

 

Thanks

Link to post
  • 4 weeks later...

I'm also running into this issue, has anyone seen a workaround?  The comments under the YouTube site for this video indicates there's an issue with an update to the collabora app in nextcloud.  Can a previous version of the app be enabled?

Link to post
  • 5 weeks later...
On 4/13/2019 at 4:59 PM, Idolwolf said:

I'm also running into this issue, has anyone seen a workaround?  The comments under the YouTube site for this video indicates there's an issue with an update to the collabora app in nextcloud.  Can a previous version of the app be enabled?

I too am running into the same issue. with Failed to load. Any help would be greatly appreciated!!

 

EDIT: not sure how i fixed it. but got it all up and running.

Edited by Drazzilb
Link to post
  • 2 months later...

Hello,

I have difficulty setting up the Collabora docker because it doesn't seem to get an IP?

Container setup:

2019-07-19_18-37-00.png.3b1a520fcb5fd69a527e3afe516092c9.png

 

 

Docker screen:

2019-07-19_18-38-20.png.d54e35cafd654bd54eff12ab5eea6ab4.png

 

 

So Collabora will not start. I see it gets a 0.0.0.0 IP. I tried putting "172.18.0.30" in the custom IP for the docker settings, but that resulted in a failed container install.

 

What would be the correct settings here for the docker container?

Thanks,

Ari

Link to post
  • 1 month later...

Hi. Followed your instructions to a T. It still says failed to load Collabora Online.

I am using proxynet as well.
I changed the server name to somethingoffice.duckdns.org.

Restarted letsencrypt, collabora and nextcloud. Can't open Doc files within Nextcloud.

I am using Sophos Firewall. Is it still necessary to do some port forwarding?

 

***Update***

 

Reading above comments about PFSense NAT reflection, and doing some research, I changed my Sophos XG Firewall rule on the DNAT:

 

Ticked- Rewrite source address (masquerading)

Use outbout address MASQ

 

Got everything working!

 

Edited by jang430
Link to post
  • 2 months later...
  • 1 month later...
  • 5 weeks later...
  • 4 weeks later...
  • 4 months later...

after i add the collabora conf file i get this message in letsencrypt i get

error nginx: [emerg] "resolver" directive is duplicate in /config/nginx/proxy-confs/collabora.subdomain.conf:6

 

and network is custom

 

 

a fix that is working for me is to remove the line 6 (resolver 127.0.0.11 valid=30s;) in my case that was on line 6

Edited by Danuel
Link to post

Hi everyone,

 

I have installed collabora based off this video and whenever i try to launch collabora, the docker stops automatically and the log error says:

 

Signature ok
subject=C = DE, ST = BW, L = Stuttgart, O = Dummy Authority, CN = localhost
Getting CA Private Key
/etc/loolwsd/proof_key exists already.
Setting up watches.
Watches established.
SAXParseException: Tag mismatch in '/etc/loolwsd/loolwsd.xml', line 171 column 6

 

It seems i need to find this loolwsd.xml but i can't find the loolwsd folder in my /etc folder.

 

Thanks for your help

Link to post
  • 4 weeks later...
  • 2 months later...
  • 3 months later...

I recently followed this video and ran into some issues myself, so I'm going to add what got things working for me. 

 

I was getting the following error when trying to open a document: "Unauthorized WOPI host. Please try again later and report to your administrator if the issue persists."

 

If found this fix on a reddit thread. Navigate to the Docker tab in Unraid > Collarbora (open the configuration for the container) > Domain: 

 

change the domain from "yoursubdomain\\.example\\.com" to "yoursubdomain.example.com"

 

After I changed this I was able to open documents.

 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.