[Support] diamkil - Overseerr


diamkil

Recommended Posts

On 3/18/2021 at 8:32 PM, crazygambit said:

Is anyone having trouble with setting up email notifications? For some reason the same settings that work perfectly in Ombi don't work here at all. I never get the test email.

 

Yes - I am having the same issue but trying to get reverse proxy (using Ngninx Reverse Proxy) to work before I tackle the email issue.

Anyone have this working with Ngninx Reverse Proxy on CloudFlare? Any tricks? Thanks!

Link to comment
8 hours ago, TexasDave said:

 

Yes - I am having the same issue but trying to get reverse proxy (using Ngninx Reverse Proxy) to work before I tackle the email issue.

Anyone have this working with Ngninx Reverse Proxy on CloudFlare? Any tricks? Thanks!

I got reverse proxy working using Letsencrypt (now called Swag) using nginx just by modifying the provided sample for subdomain. The install instructions mention that subfolder doesn't work so I made a new subdomain using duckdns.org. I've never used Cloudflare, so no clue there.

  • Like 1
Link to comment

@crazygambit - Thanks! I moved away from SWAG and have been using the Nginx Proxy Manager docker. Just a personal preference. All on hold right now but will circle back to see if I can get Overseer to work as it looks to be more intuitive versus Ombi. But Ombi is up and working....

 

EDIT: I fixed it. Typo in Nginx Proxy Manager Setup. Extra  "one" in my IP. I knew it was something stoopid. Will post if and when I sort out the email bits....Thanks!

Edited by TexasDave
Link to comment

Having issues getting reverse proxy working on my end. I followed spaceinvader's video, but no dice. The Overseerr webUI works fine and I can port forward to access from outside the network with `PUBLICIP:5055`, but that defeats the purpose of reverse proxy.

 

Here's what I've done:

  • I have my own domain name through namecheap
  • I'm using Cloudflare's nameservers
  • I've created `customsubdomain.duckdns.org`
  • In Cloudflare, I've created a subdomain by adding CNAME - `requests` and pointed it to `custumsubdomain.duckdns.org`
  • I've created a custom docker proxynet and pointed both the SWAG docker and the Overseerr docker to that
  • I've edited the nginx proxy config for Overseer to `server_name requests.*;
  • In SWAG docker config I've set Host Port: 180 for Container Port: 80 and Host Port 1443 for Container Port: 443
  • In Overseerr, I've added Application URL `https://requests.customdomain.com` and ticked the box for Enable Proxy Support

I'm not sure where to go from here. Any help is greatly appreciated

 

EDIT: Fixed it. This was an issue on Cloudflare. I needed to change the Proxy Status from Proxied to DNS only

Edited by ramair02
Link to comment
  • 2 weeks later...

Sorry if this is a bit off topic.  I'm trying to customize by app a bit.  I was able to map my public folder to a place in appdata so I could change the logo.  After replacing the png file and restarting the container, everything looks good.

 

I also wanted to remove some text from the login page.  I tried mapping the src folder which holds this info (/app/src/components/Login/index.tsx) just as I did with the public folder, and while the folder seems to have mapped correctly, changes aren't showing up after I save and restart the container.  Does anyone know how I can get these changes to take effect?

Link to comment
  • 3 weeks later...
  • 5 months later...

I love Overseerr.

It worked perfectly until yesterday.

Now I can't open the GUI although Docker says it is running.

 

Here is the log. The bold line is the red error.

Any clues to fix it? Thanks in advance.

 

_____________

 

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] 00-env-file-init: executing...
[cont-init.d] 00-env-file-init: exited 0.
[cont-init.d] 00-start-container: executing...

----------------------------------------------------------------------
ENVIRONMENT
----------------------------------------------------------------------
PUID=99
PGID=100

2
TZ=Europe/Berlin
----------------------------------------------------------------------

Executing usermod...
Applying permissions to /config
[cont-init.d] 00-start-container: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
yarn run v1.22.10
$ NODE_ENV=production node dist/index.js
warning Cannot find a suitable global folder. Tried these: "/usr/local, /app/.yarn"
2021-10-20T06:10:36.279Z [[32minfo[39m]: Commit Tag: 1.27.0
2021-10-20T06:10:36.321Z [[32minfo[39m]: Starting Overseerr version 1.27.0
2021-10-20T06:12:46.725Z [[31merror[39m]: Error: connect ETIMEDOUT 172.18.0.1:32400
at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1148:16)
error Command failed with exit code 1.
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
[cont-finish.d] executing container finish scripts...
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.
[s6-finish] sending all processes the KILL signal and exiting.
[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] 00-env-file-init: executing...
[cont-init.d] 00-env-file-init: exited 0.
[cont-init.d] 00-start-container: executing...
 

Edited by Profezor
Spelling
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.