ProFTPD Plugin for unRAID v6.8.x


SlrG

747 posts in this topic Last Reply

Recommended Posts

  • Replies 746
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

ProFTPd Support the plugin?   This is the support thread for my ProFTPD Plugin for unRAID v6.8.x   To install it: If you have installed the Community Applications

@188pilas For 6.7.0-rc you need to install the beta version plugin from here: http://sdevel.de/ProFTPd.plg Once 6.7.0 is released, I'll work on a new version of the plugin which should be availab

@cjm187 I'm personally not using sftp and I don't have the time at the moment to try the whole process again. I remember ssh-keygen was broken on some unRAID version, which number, I don't rememb

Posted Images

Spent an hour on it and couldn't figure out how to get the SSH cert to.work properly.

So sorry, between my screening kid right now, SFTP being slower and I have OpenVPN already, not sure if I'll look at this in a timely manner

 

perfectly understandable – thx. alot for trying!

well, i would also use VPN, but this backup-software doesn't support FTP – just SFTP.

 

may i ask, what errors you were seeing? and is there's anything special related to unRAID v6.2 (is it compatible)?

 

thx. again,

oliver

 

Link to post

Here is an example of how I like to setup the FTP.

Thanks for this - similar to mine, but the tmp directory technique is a good trick.

 

Do you know how to setup permissions for different users?  Say for myself I wanted write access to certain directories, but for other users I want it all locked down?

Link to post

Thanks for this - similar to mine, but the tmp directory technique is a good trick.

Do you know how to setup permissions for different users?  Say for myself I wanted write access to certain directories, but for other users I want it all locked down?

 

What I do is make FTP groups via file structure.

So my file structure isn't exactly how my guide has it.

 

and example would be

 

mkdir /tmp/FTP/
mkdir /tmp/FTP/Cessquill

mount --bind /mnt/user/Media/Videos /tmp/FTP/Cessquill/Media/
mount --bind /mnt/user/Uploads /tmp/FTP/Cessquill/Uploads

mkdir /tmp/FTP/JaY_III
mount --bind /mnt/user/

 

#File Permissions
<Directory /tmp/FTP/Cessquill/Media>
<Limit WRITE>
DenyAll
</Limit>
</Directory>

 

Then i would jail you too

ftpuser /tmp/FTP/Cessquill

 

And jail myself to

ftpuser /tmp/FTP/JaY_III

 

I have full access to /mnt/user aka then entire array pretty much

and you have read only to the media and upload permissions.

 

Is this the best way to do it, probably not, but it works

Link to post

Hi,

 

First great plugin!

 

I have a question how i can chroot a user? because now a user can browse over the whole file-structure when it press the arrow key to go out his starting folder.

 

Thanks.

 

if a user account has access to "/" restart  the service.

If restarting the service doesnt work, restarting the array will.

 

I had the problem when i made an account for my sister, unRAID reboot was required.

Link to post

Hi,

 

First great plugin!

 

I have a question how i can chroot a user? because now a user can browse over the whole file-structure when it press the arrow key to go out his starting folder.

 

Thanks.

 

if a user account has access to "/" restart  the service.

If restarting the service doesnt work, restarting the array will.

 

I had the problem when i made an account for my sister, unRAID reboot was required.

 

Thanks for your reply that working for me to ;)

 

Link to post

Spent an hour on it and couldn't figure out how to get the SSH cert to.work properly.

So sorry, between my screening kid right now, SFTP being slower and I have OpenVPN already, not sure if I'll look at this in a timely manner

 

perfectly understandable – thx. alot for trying!

well, i would also use VPN, but this backup-software doesn't support FTP – just SFTP.

 

may i ask, what errors you were seeing? and is there's anything special related to unRAID v6.2 (is it compatible)?

 

thx. again,

oliver

 

 

I may be off on SFTP but isn't that simply enabling SSL? If so I placed a guide towards the start of this thread. See below:

 

EDIT: Nvm, shouldve googled first. Seems like the SFTP requires a lot more work including a recompile.....meh

 

Setting up SSL (YMMV, these are the settings I set for myself that I was able to get to work. Any change suggestions welcome)

 

1) Stop Proftpd (just in case)

 

2) Login through telnet and paste the following two lines in order. Please note I had to specify the config file (for some reason the default is .cnf but the one I had in my ssl folder is .cfg)

mkdir /boot/config/plugins/proftpd/ssl/
openssl req -new -x509 -config /etc/ssl/openssl.cfg -days 3650 -nodes -out /boot/config/plugins/proftpd/ssl/ftp.cert.pem -keyout /boot/config/plugins/proftpd/ssl/ftp.key.pem

 

3) Add following to the end of your proftpd.conf

<IfModule mod_tls.c>
TLSEngine on

TLSLog /var/log/proftpd.tls.log

TLSProtocol SSLv23 TLSv1

TLSOptions NoCertRequest NoSessionReuseRequired 

TLSRSACertificateFile /boot/config/plugins/proftpd/ssl/ftp.cert.pem

TLSRSACertificateKeyFile /boot/config/plugins/proftpd/ssl/ftp.key.pem

TLSVerifyClient off

TLSRequired on

</IfModule>

 

4) Start Proftpd again and log in. Remember to enable TLS/SSL authentication for your client.

Link to post

Doing a quick search I have not found anything about this issue. I have tried this on a server without ProFTPD, but logging in as root and it works. Maybe on my home server I am not doing things correctly. I have sshfs setup on a VM for my brother to use and I am trying to mount his FTP share within the VM. We do this for CrashPlan on my work server and it works fine when logging in as root. Here is the command I'm using for my brother's VM.

 

sshfs brother@server.ip: /home/brother/FTP

 

All I am getting is "remote host has disconnected".

Link to post
  • 2 weeks later...
  • 5 weeks later...

I tried to install the plugin on unRAID 6.2.1 but when I try to start it, I get a "Cannot start ProFTPd -- /etc/proftpd.conf missing" error.

 

Is that normal? I expect the plugin to come with a barebone config file.

I have the same problem. I have just installed the plugin, added the ftpuser tag to a user's description. Now if I enable proftpd it doesn't start. The only thing I see in my syslog is :

Nov 19 20:35:00 Tower emhttp: cmd: /usr/local/emhttp/plugins/ProFTPd/scripts/rc.ProFTPd buttonstart

 

but the server is not running.

 

If I try to start it manually using shell:

root@Tower:/etc# /usr/local/emhttp/plugins/ProFTPd/scripts/rc.ProFTPd start

Cannot start ProFTPd -- /etc/proftpd.conf missing

 

Link to post
  • 1 month later...

Hello all- Been using ProFTPD and was working fine.  I think my roommate installed a flavor of vsftpd and now that appears to be taking over ftp requests (and I have no users configured so it does not work).  Does anyone know how to completely remove vsftpd so ProFTPD can continue to work correctly?

 

Sorry if someone else has already answered this question.  I could not find any info on this.

 

EDIT  And I have removed the vsftpd docker he installed but it still seems to be trying to answer ftp requests.

EDIT To the EDIT- Running unraid 6.1.4

Final EDIT- Fixed.  Re-added and removed the docker one more time and it seems like that took care of it.  Thanks for reading

Link to post
  • 2 weeks later...

Hi There,

 

Can anyone shed some light on this issue i'm having.

 

When I try to install proFTPd i get the following error even though I have a working internet connection:

 

plugin: installing: https://raw.githubusercontent.com/SlrG/unRAID/master/Plugins/ProFTPd.plg

plugin: downloading https://raw.githubusercontent.com/SlrG/unRAID/master/Plugins/ProFTPd.plg

plugin: downloading: https://raw.githubusercontent.com/SlrG/unRAID/master/Plugins/ProFTPd.plg ... done

Cleaning up previous install files...

Executing selfremoval commands if present...

...Cleanup complete!

Downloading any missing plugin files...

Latest plugin control files downloading

...Unable to download missing plugin control files. Aborting install

plugin: run failed: /bin/bash retval: 1

 

Thank you in advance

Link to post
  • 3 weeks later...

I just installed this plugin into v6.2.4.

 

I've noticed when I select Settings->ProFTPd the Lime Tech logo in the upper left of the screen in the banner has a solid white background. Compared to all other pages in unRAID which have the logo with a transparent background.

 

Not sure if this is a problem in unRAID or just the ProFTPd plugin. It seems like just the plugin since it only happens on that page.

Link to post
  • 2 weeks later...

@jeffreywhunter

The path to the webserver needs to be a full path. I have /mnt/cache/Web. The plugin will copy the files of the config editor to a ProFTPd directory there. You need a webserver running on your unraid which serves files from that directory, or it won't work. You should be able to connect to the config editor by typing http://x.x.x.x:8088/ProFTPd/ConfEdit.php into your browsers url field. x.x.x.x should be the ip of your unraid server. Also the port 8088 needs to be the port the webserver is listening on.

@StevenHB

Please contact me again via PM. The forum upgrade seems to have killed you message in my inbox? I don't think the error messages you listed are related to this plugin. Please enable the TransferLog and check the output you get in this when trying to connect.

Link to post
41 minutes ago, SlrG said:

@jeffreywhunter

The path to the webserver needs to be a full path. I have /mnt/cache/Web. The plugin will copy the files of the config editor to a ProFTPd directory there. You need a webserver running on your unraid which serves files from that directory, or it won't work. You should be able to connect to the config editor by typing http://x.x.x.x:8088/ProFTPd/ConfEdit.php into your browsers url field. x.x.x.x should be the ip of your unraid server. Also the port 8088 needs to be the port the webserver is listening on.

@StevenHB

Please contact me again via PM. The forum upgrade seems to have killed you message in my inbox? I don't think the error messages you listed are related to this plugin. Please enable the TransferLog and check the output you get in this when trying to connect.

Which web server should I install to support ProFTPd?  Will it work with the internal unRaid web server?

As to the error messages, I was able to get ProFTPd working with only this remaining problem.

Edited by jeffreywhunter
Link to post
59 minutes ago, SlrG said:

@jeffreywhunter

The path to the webserver needs to be a full path. I have /mnt/cache/Web. The plugin will copy the files of the config editor to a ProFTPd directory there. You need a webserver running on your unraid which serves files from that directory, or it won't work. You should be able to connect to the config editor by typing http://x.x.x.x:8088/ProFTPd/ConfEdit.php into your browsers url field. x.x.x.x should be the ip of your unraid server. Also the port 8088 needs to be the port the webserver is listening on.

When I try to access the config editor, I get 

Not Found

The requested URL /ProFTPd/ConfEdit.php was not found on this server.

BOTH from a web browser or from within ProFTPd.

Link to post

@jeffreywhunter

No it won't work with unRAIDs  internal webserver. As webserver I recommend the Apache Web Server Plugin as I am using this myself. I tried the available dockers first, but somehow I was not able to get it to work there. I see you posted in the plugins thread already. I recommend running as user nobody and setting the permissions and group of the web folder accordingly. Most of the files on your unRAID will have this user and group. You can use the newperms script to achieve proper settings:

newperms /mnt/cache/web

And a side note: You don't need the config editor to change your proftpd.conf.  You can always use nano or something and edit it in an unRAID console. :)

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.