VirtualBox Plugin for unRAID v5 and v6


theone

778 posts in this topic Last Reply

Recommended Posts

Clear your cache also post a screenshot of you box config

 

Cleared my cache virtualbox config as below:

 

# VirtualBox plugin configuration

INSTALL_ON_BOOT="true"

UPGRADE_ON_BOOT="false"

UPGRADE_PLG_ON_BOOT="false"

START_ON_ARRAY_MOUNT="true"

START_VMS_ON_START="false"

VBOX_SYMLINK_LOCATION="mnt/cache/appdata/virtualbox/vbox"

VBOXWEBSRV_HOST_IP="127.0.0.1"

VBOXWEBSRV_HOST_PORT="18083"

VBOXWEBSRV_LOGFILE="mnt/cache/appdata/virtualbox/vboxwebsrv.log"

VBOXWEBSRV_VERBOSE="true"

VBOXWEBSRV_LOGROTATE="0"

VBOXWEBSRV_LOGSIZE="50000"

VBOXWEBSRV_LOGINTERVAL="604800"

 

Is that what you are looking for? In the mnt/cache/appdata/virtualbox/vbox there is no files at all, is that normal?

Link to post
  • Replies 777
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hello,   I am proud to present: VirtualBox plugin for unRAID v5 and v6   The plugin installs both VirtualBox package and the VirtualBox Extension package (it does not ins

Looks like issue with 5.1.20 extension pack.  I see a brief question something like do I agree to these terms or whatever with a y/n? along the bottom of the GUI before a message saying install failed

Posted Images

You need to change your vboxwebsrb location back to default not on your

Cache. That was my biggest problem it would. Not work until I put it back to default. I'm using my mobile so I can't take a screenshot but I bet you can find a screenshot if you do a search.

 

 

Sent from my iPhone using Tapatalk

Link to post

Ok, so now I have moved the vboxwebsrv log file to mnt/config/plugins/virtualbox

 

and also moved the symbolic link to /mnt/cache/vbox and that folder now has files in it which it didnt before on my cache drive

 

But I still have the screen I attached a few posts ago.

 

Going to try a restart

Link to post

Great thanks I will do

 

Got one other question for you, I have downloaded guest additions through the plugin but I seem to having issues with the resolution on the Lubuntu VM I have. I am wondering if I need to install guest additions for this specific VM, are you able to tell me how to do this?

 

Thanks

 

Lee

Link to post

Great thanks I will do

 

Got one other question for you, I have downloaded guest additions through the plugin but I seem to having issues with the resolution on the Lubuntu VM I have. I am wondering if I need to install guest additions for this specific VM, are you able to tell me how to do this?

 

Thanks

 

Lee

 

I don't have linux running on my vm, win7, but i did the same thing downloaded it and  (my self) have a software share and place it there. The i mounted the iso and install the addtions. My guess is you have to the same.

Link to post
  • 3 weeks later...

New plugin version posted 0.5.4:

 

- Changed unRAID compiled VirtualBox version availability and presentation in WEBUI (compatible and latest)

- Changed timeout to 10 seconds (instead of 60)

- Added plugin forum link to WEBUI

- Automatic support for 32/64bit packages depending on OS

 

Updated OP and screenshot

 

Link to post

New plugin versions posted 0.5.5 and 0.5.6:

 

0.5.6    - Added MD5 checksum verification for all downloaded packages immediately after download - delete download if MD5 cannot be verified or fails verification

0.5.5    - Fixed kernel version number extraction from online package

Link to post

I have been trying to figure this out for 4 or 5 hours now. Im a slight noob with linux. I have had my unraid server running for about a year to run my plex media center.

 

Now Im wanting it to run a VM as well. I have the latest virtualbox plugin installed and the Dynamix webserver installed... but I cant figure out how to launch the virtualbox web. I see people mention the config.php file but have no idea where it is. Im running unraid 5.0.4.

 

Any help would be great. Im not one to normally ask because I like to figure things out for myself and I've Googled the hell out of this... but I'm stuck.

Untitled.jpg.cd9ee1f31efae2b406932cba894bd246.jpg

Link to post

I have been trying to figure this out for 4 or 5 hours now. Im a slight noob with linux. I have had my unraid server running for about a year to run my plex media center.

 

Now Im wanting it to run a VM as well. I have the latest virtualbox plugin installed and the Dynamix webserver installed... but I cant figure out how to launch the virtualbox web. I see people mention the config.php file but have no idea where it is. Im running unraid 5.0.4.

 

Any help would be great. Im not one to normally ask because I like to figure things out for myself and I've Googled the hell out of this... but I'm stuck.

Where exactly are you stuck? Have you downloaded phpvirtualbox and put it in the Dynamix webserver?

 

Link to post

I have been trying to figure this out for 4 or 5 hours now. Im a slight noob with linux. I have had my unraid server running for about a year to run my plex media center.

 

Now Im wanting it to run a VM as well. I have the latest virtualbox plugin installed and the Dynamix webserver installed... but I cant figure out how to launch the virtualbox web. I see people mention the config.php file but have no idea where it is. Im running unraid 5.0.4.

 

Any help would be great. Im not one to normally ask because I like to figure things out for myself and I've Googled the hell out of this... but I'm stuck.

Where exactly are you stuck? Have you downloaded phpvirtualbox and put it in the Dynamix webserver?

 

Is phpvirtualbox still not part of the virtualbox package? I thought it was. I thought that was one of the items that it installed from the virtualbox gui. I see it mentioned a lot but dont see how to get it or install it.

 

EDIT: okay I got phpvirtualbox from sourceforge, and have it extracted. what do I need from here? do I dump all of it into a location, or just a select few items?

Link to post

I have been trying to figure this out for 4 or 5 hours now. Im a slight noob with linux. I have had my unraid server running for about a year to run my plex media center.

 

Now Im wanting it to run a VM as well. I have the latest virtualbox plugin installed and the Dynamix webserver installed... but I cant figure out how to launch the virtualbox web. I see people mention the config.php file but have no idea where it is. Im running unraid 5.0.4.

 

Any help would be great. Im not one to normally ask because I like to figure things out for myself and I've Googled the hell out of this... but I'm stuck.

Where exactly are you stuck? Have you downloaded phpvirtualbox and put it in the Dynamix webserver?

 

Is phpvirtualbox still not part of the virtualbox package? I thought it was. I thought that was one of the items that it installed from the virtualbox gui. I see it mentioned a lot but dont see how to get it or install it.

 

EDIT: okay I got phpvirtualbox from sourceforge, and have it extracted. what do I need from here? do I dump all of it into a location, or just a select few items?

vboxwebsrv is installed, but you need something to talk to it. Download phpvirtualbox and put it in the web root you set up in Dynamix webserver.
Link to post

Now thats done and I'm getting a credentials error using default vbox and pass

Username: admin Password: admin

 

AWESOME! Thank you! up and running. Time to play around and see if I cant get this server imported.

And now that you have it running you don't need this info but I just setup my VMs using VBoxManage and the command line.  So didn't need a web server or phpvirtualbox.  I do use this plugin to start and stop the VMs.
Link to post

Now thats done and I'm getting a credentials error using default vbox and pass

Username: admin Password: admin

 

AWESOME! Thank you! up and running. Time to play around and see if I cant get this server imported.

And now that you have it running you don't need this info but I just setup my VMs using VBoxManage and the command line.  So didn't need a web server or phpvirtualbox.  I do use this plugin to start and stop the VMs.

 

if I only had the patience for command line, i like a gui, im not sure how this will work for me once i get xen. It should be interesting.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.