Jump to content
jonp

unRAID 6 NerdPack - CLI tools (iftop, iotop, screen, kbd, etc.)

1369 posts in this topic Last Reply

Recommended Posts

Hi, I tried to uninstall everything but nerdpack without luck.
 
Digging in this thread i saw a year-old message from you about recompiling ipmitool from github for the 6.7, do you think it could be related?
 
Btw this is the ldd:
root@Tower:~# ldd /usr/bin/ipmitool       linux-vdso.so.1 (0x00007ffece0e4000)       libm.so.6 => /lib64/libm.so.6 (0x0000153a34160000)       libncurses.so.5 => /lib64/libncurses.so.5 (0x0000153a33f09000)       libcrypto.so.1 => not found       libc.so.6 => /lib64/libc.so.6 (0x0000153a33d24000)       /lib64/ld-linux-x86-64.so.2 (0x0000153a342bc000)       libdl.so.2 => /lib64/libdl.so.2 (0x0000153a33d1f000)

Thanks again and sorry to bother you whit that (if I will not find a solution for the fan noise, I'll be in deep trouble with the wife )

root@Server:~# ldd /usr/bin/ipmitool       linux-vdso.so.1 (0x00007ffe876a7000)       libm.so.6 => /lib64/libm.so.6 (0x000014cb76a42000)       libreadline.so.7 => /usr/lib64/libreadline.so.7 (0x000014cb767f4000)       libncurses.so.6 => /lib64/libncurses.so.6 (0x000014cb767c8000)       libtinfo.so.6 => /lib64/libtinfo.so.6 (0x000014cb76799000)       libcrypto.so.1.1 => /lib64/libcrypto.so.1.1 (0x000014cb764bf000)       libc.so.6 => /lib64/libc.so.6 (0x000014cb762da000)       /lib64/ld-linux-x86-64.so.2 (0x000014cb76b9f000)       libdl.so.2 => /lib64/libdl.so.2 (0x000014cb762d3000)       libz.so.1 => /lib64/libz.so.1 (0x000014cb760bc000)       libpthread.so.0 => /lib64/libpthread.so.0 (0x000014cb7609a000)root@Server:~# ipmitool -Vipmitool version 1.8.18root@Server:~#



I never checked if the 6.7 version worked on 6.8. I just recompiled ipmitool for 6.8. I did just now change the package version in the package name to 1.8.18 (I had 1.8.19 since that is was the source I used said) but that should make no difference. I think you have a different version installed somehow

Share this post


Link to post

Does anyone know how to request an update to Nerd Pack?

 

I noticed that Borg Backup was moved to 1.1.11 due to an error in the 1.1.10 that is current in Nerd Pack. 

 

I am sure it will get updated eventually but thought I could draw someones attention to it. 

If you're affected you can follow directions here to fix it, after the update in Nerd Pack, of course. 

Share this post


Link to post
21 minutes ago, wesman said:

Does anyone know how to request an update to Nerd Pack?

Message @dmacias directly or tag him in this thread with your specific request.

Share this post


Link to post

@Hoopster thanks!

 

@dmacias Thanks for the awesome plug in!, is it possible to request an update for BorgBackup?

 

Thank YOU for your awesome work!

Share this post


Link to post



@Hoopster thanks!
 
@dmacias Thanks for the awesome plug in!, is it possible to request an update for BorgBackup?
 
Thank YOU for your awesome work!


Updated.

Share this post


Link to post
56 minutes ago, dmacias said:

Updated.

 

Thanks, you're the best

Share this post


Link to post

Hi dmacias,

 

Thanks for your plug-in, love it! Could the docker compose  be updated please? 

 

Share this post


Link to post
Hi dmacias,
 
Thanks for your plug-in, love it! Could the docker compose  be updated please? 
 
Updated

Share this post


Link to post

Most appreciated ! Big thanks for responding so faaaaaaaaaaaaast !!  🙂

Share this post


Link to post
On 3/21/2020 at 9:08 AM, dmacias said:

Updated.

 

Hi @dmacias my target unraid server, is still at 6.7.2, and it still shows borg 1.1.10 as the latest? are there two different updates for this? could you update that as well?

Share this post


Link to post

You prob need to update to 6.8.x to get latest versions from nerdpack.

Share this post


Link to post
14 minutes ago, BRiT said:

You prob need to update to 6.8.x to get latest versions from nerdpack.

I hope this isn't the case, on my old server 6.8 doesn't want to be stable, i've tried several times but I am keeping this one at 6.7.2 until I can get that fixed

Share this post


Link to post
Hi @dmacias my target unraid server, is still at 6.7.2, and it still shows borg 1.1.10 as the latest? are there two different updates for this? could you update that as well?
Sorry. I only update the current stable for the most part. I just don't have the time to keep up with betas and past version compatibility.

Share this post


Link to post
5 minutes ago, dmacias said:
1 hour ago, wesman said:
Hi @dmacias my target unraid server, is still at 6.7.2, and it still shows borg 1.1.10 as the latest? are there two different updates for this? could you update that as well?

Sorry. I only update the current stable for the most part. I just don't have the time to keep up with betas and past version compatibility.

I understand, since its an install, will the basic "sudo apt-get install package" get what I need on unraid?

Share this post


Link to post
9 hours ago, wesman said:

will the basic "sudo apt-get install package" get what I need on unraid?

No. You would need to find the appropriate slackware package.

Share this post


Link to post
2 hours ago, jonathanm said:

No. You would need to find the appropriate slackware package.

Thanks, I've been trying to research this, but there does not appear to be much information on this out there. is this the correct procedure?

1.) Install Slackware on a temp box somewhere. (lastest version I assume)

2.) Install Borg and all its dependancies. 

3.) move the freshly compiled slackware '/usr/bin/borg' to my unraid '/usr/bin/borg'
4.) reboot unraid? 
 

Am I close?

Share this post


Link to post
13 hours ago, wesman said:

I hope this isn't the case, on my old server 6.8 doesn't want to be stable, i've tried several times but I am keeping this one at 6.7.2 until I can get that fixed

What are you doing to "get that fixed"?

Share this post


Link to post

@trurl That's a great question, with no answer.  :(
 

As you might remember (or might not, I am sure you see 1000's of these all day), from this post. 

 

 

6.8.3, continually crashed and ran Parity Checks every 3 days or so. I ran down every possible error log, scrubbed through, 100's of log files, posted several times :) - No fix. No Fixes. 

I was really tearing my hear out, especially considering my old server is at 6.8.3 and running like a champ. new server, not so much. tried everything, including completely reinstalling, twice. 

and the only difference between the two are these

intel i7-7700    ---->  intel i9-9900

ASUS Z170-A Mobo.   ---->    Asrock z390 Taichi Ultimate

Virtually everything else is the same. SOOOOOO Now I am thinking:

The only other difference is that the old server started on 6.7.2 then went to 6.8.3

the new server started at 6.8.3

I reinstalled (fresh) the new server at 6.7.2 and its been running like a champ since 14 March 2020. 

I am completely installing all my programs, then I am going to upgrade it to 6.8.3

Is there anything pulled up from 6.7.2 to 6.8.x that would not be the same if it was just a 6.8.3 fresh install? maybe the docker image?

 

if it goes back to being on stable at 6.8.X i'll just go back to 6.7.2.
just need to figure out how to get my borg updated

Share this post


Link to post
3 minutes ago, wesman said:


Is there anything pulled up from 6.7.2 to 6.8.x that would not be the same if it was just a 6.8.3 fresh install? maybe the docker image?

 

@trurl I ask these, because in 6.8.x it appears to have issues revolving around dockers hanging and freezing etc. not no real logs errors in syslog

Share this post


Link to post
2 minutes ago, wesman said:

@trurl I ask these, because in 6.8.x it appears to have issues revolving around dockers hanging and freezing etc. not no real logs errors in syslog

Do you have another thread about this? If not, start one in General Support and post your diagnostics.

Share this post


Link to post
Just now, trurl said:

Do you have another thread about this? If not, start one in General Support and post your diagnostics.

yes, I liked it two posts up. and it has several diagnostics and sys logs posted in it. 
 

and the only difference between the two servers are these

intel i7-7700    ---->  intel i9-9900

ASUS Z170-A Mobo.   ---->    Asrock z390 Taichi Ultimate

Virtually everything else is the same. SOOOOOO Now I am thinking:

The only other difference is that the old server started on 6.7.2 then went to 6.8.3

the new server started at 6.8.3

is anything pulled forward in the upgrade path, that is different in fresh install path that might cause this?

Share this post


Link to post

@dmacias given that /usr/bin/borg and /usr/bin/borgfs on both 6.7.2 and 6.8.3 have the same dependancies, which are at the same level, can I just move copy them into the 6.7.2 folder and would it work?

Share this post


Link to post
@dmacias given that /usr/bin/borg and /usr/bin/borgfs on both 6.7.2 and 6.8.3 have the same dependancies, which are at the same level, can I just move copy them into the 6.7.2 folder and would it work?
You can try and installpkg the 6.8 version on 6.7 but it will probably complain of missing versions of dependencies.

Share this post


Link to post
+1
 
There's no slackware packages or slackbuild for this. And I imagine they probably require many more dependencies also

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.