Jump to content
linuxserver.io

[Support] Linuxserver.io - NZBGet

450 posts in this topic Last Reply

Recommended Posts

Regarding NZBget and SABNZB what are the Pros and Cons between the two.

 

 

How does portmapping work and how should it be setup?

 

If you don't map a port you can't access anything on it.  Never change the port on the container side, only the host side.  If you find that two applications both want to use the same port just change it on the host side.  Easy.

 

I now use PHAZEs plugin of SABNZB and have several Categories setup.

 

Can I use something similar in NZBget?

Yes NZBGet has categories

 

My guess is that NZBGet also has a watched folder, download folder etc. How do I setup folder mappings to these.

Or can I point it to /mnt?

 

You can point it to /mnt but that means that container then has full access to mount with all the risks that entails.  One advantage of containers vs plugins is that you restrict their access to just the bits they need access to.

 

Otherwise see my answer to the same question in the SABnzbd thread.

Share this post


Link to post

Hello

 

Just getting started with usenet and have installed NZBGet

 

I am not able to open web GUI though

 

http://192.168.1.28:6789

 

This site can’t be reached

 

192.168.1.28 refused to connect.

Try:

Reloading the page

Checking the connection

Checking the proxy and the firewall

ERR_CONNECTION_REFUSED

 

Do not have problems accessing Transmission or Sickrage

 

Doing this from a remote windows 10 computer within local network

Share this post


Link to post

Hello

 

Just getting started with usenet and have installed NZBGet

 

I am not able to open web GUI though

 

http://192.168.1.28:6789

 

This site can’t be reached

 

192.168.1.28 refused to connect.

Try:

Reloading the page

Checking the connection

Checking the proxy and the firewall

ERR_CONNECTION_REFUSED

 

Do not have problems accessing Transmission or Sickrage

 

Doing this from a remote windows 10 computer within local network

 

Post a screenshot of how you got the container set up.  And the log.

Share this post


Link to post

Howdy

 

okay not sure what the deal was but I removed restarted installed could not open GUI

 

Openned log file and waited and then was able to access GUI

 

For now moving on I guess.

 

Share this post


Link to post

Howdy

 

okay not sure what the deal was but I removed restarted installed could not open GUI

 

Openned log file and waited and then was able to access GUI

 

For now moving on I guess.

It was probably updating the application

Share this post


Link to post

I can't get nzbget to go to the gui.  It seems to be stuck in a loop:

 

-------------------------------------

_ _ _

| |___| (_) ___

| / __| | |/ _ \

| \__ \ | | (_) |

|_|___/ |_|\___/

|_|

 

Brought to you by linuxserver.io

We do accept donations at:

https://www.linuxserver.io/donations

-------------------------------------

GID/UID

-------------------------------------

User uid: 99

User gid: 100

-------------------------------------

 

finding fastest mirror

 

-------------------------------------

_ _ _

| |___| (_) ___

| / __| | |/ _ \

| \__ \ | | (_) |

|_|___/ |_|\___/

|_|

 

Brought to you by linuxserver.io

We do accept donations at:

https://www.linuxserver.io/donations

-------------------------------------

GID/UID

-------------------------------------

User uid: 99

User gid: 100

-------------------------------------

 

finding fastest mirror

1. mirrors.tripadvisor.com

Latency: 12.65 ms

Org: TripAdvisor

Status: Up to date

Speed: 1 Gbps

2. ubuntu.mirror.constant.com

Latency: 17.47 ms

Org: Constant.com

Status: Up to date

Speed: 2 Gbps

3. us.archive.ubuntu.com

Latency: 19.02 ms

Org: None

Status: Up to date

Speed: 100 Mbps

New config file saved to /defaults/sources.list

We are now refreshing packages from apt repositories, this *may* take a while

Ign http://mirrors.tripadvisor.com trusty InRelease

Get:1 http://mirrors.tripadvisor.com trusty-updates InRelease [65.9 kB]

Get:2 http://mirrors.tripadvisor.com trusty-security InRelease [65.9 kB]

Get:3 http://mirrors.tripadvisor.com trusty Release.gpg [933 B]

Get:4 http://mirrors.tripadvisor.com trusty-updates/main Sources [352 kB]

Get:5 http://mirrors.tripadvisor.com trusty-updates/restricted Sources [5,217 B]

Get:6 http://mirrors.tripadvisor.com trusty-updates/universe Sources [199 kB]

Get:7 http://mirrors.tripadvisor.com trusty-updates/multiverse Sources [5,946 B]

Get:8 http://mirrors.tripadvisor.com trusty-updates/main amd64 Packages [1,003 kB]

Get:9 http://mirrors.tripadvisor.com trusty-updates/restricted amd64 Packages [23.5 kB]

Get:10 http://mirrors.tripadvisor.com trusty-updates/universe amd64 Packages [470 kB]

Get:11 http://mirrors.tripadvisor.com trusty-updates/multiverse amd64 Packages [14.3 kB]

Get:12 http://mirrors.tripadvisor.com trusty Release [58.5 kB]

Get:13 http://mirrors.tripadvisor.com trusty-security/main Sources [150 kB]

Get:14 http://mirrors.tripadvisor.com trusty-security/restricted Sources [3,920 B]

Get:15 http://mirrors.tripadvisor.com trusty-security/universe Sources [44.1 kB]

Get:16 http://mirrors.tripadvisor.com trusty-security/multiverse Sources [2,550 B]

Get:17 http://mirrors.tripadvisor.com trusty-security/main amd64 Packages [638 kB]

Get:18 http://mirrors.tripadvisor.com trusty-security/restricted amd64 Packages [20.2 kB]

Get:19 http://mirrors.tripadvisor.com trusty-security/universe amd64 Packages [170 kB]

Get:20 http://mirrors.tripadvisor.com trusty-security/multiverse amd64 Packages [4,850 B]

Get:21 http://mirrors.tripadvisor.com trusty/main Sources [1,335 kB]

Get:22 http://mirrors.tripadvisor.com trusty/restricted Sources [5,335 B]

Get:23 http://mirrors.tripadvisor.com trusty/universe Sources [7,926 kB]

Get:24 http://mirrors.tripadvisor.com trusty/multiverse Sources [211 kB]

Get:25 http://mirrors.tripadvisor.com trusty/main amd64 Packages [1,743 kB]

Get:26 http://mirrors.tripadvisor.com trusty/restricted amd64 Packages [16.0 kB]

Get:27 http://mirrors.tripadvisor.com trusty/universe amd64 Packages [7,589 kB]

Get:28 http://mirrors.tripadvisor.com trusty/multiverse amd64 Packages [169 kB]

Fetched 22.3 MB in 7s (3,087 kB/s)

Reading package lists...

Useing STABLE Branch:

Checking som config options

Jul 28 18:28:53 df39d76c7d8e syslog-ng[144]: syslog-ng starting up; version='3.5.3'

nzbget.conf(888): Option "DeleteCleanupDisk" is obsolete, ignored

nzbget.conf(1237): Option "ParCleanupQueue" is obsolete, ignored

[WARNING] nzbget.conf(888): Option "DeleteCleanupDisk" is obsolete, ignored

[WARNING] nzbget.conf(1237): Option "ParCleanupQueue" is obsolete, ignored

 

Share this post


Link to post

I can't get nzbget to go to the gui.  It seems to be stuck in a loop:

 

Jul 28 18:28:53 df39d76c7d8e syslog-ng[144]: syslog-ng starting up; version='3.5.3'

This line above shows the app is starting.

 

nzbget.conf(888): Option "DeleteCleanupDisk" is obsolete, ignored
nzbget.conf(1237): Option "ParCleanupQueue" is obsolete, ignored
[WARNING] nzbget.conf(888): Option "DeleteCleanupDisk" is obsolete, ignored
[WARNING] nzbget.conf(1237): Option "ParCleanupQueue" is obsolete, ignored

These lines indicate that your user configured file is a bit screwy, whether that is causing the app to not load or not I couldn't say.

 

Have you successfully run this container before or is this a new install?  Can you post your setup?  Ports and folder mappings etc.

Share this post


Link to post

I had it running for over a year.  Not sure what happened.  I deleted the folder and did a clean install and it works now.

Share this post


Link to post

I had it running for over a year.  Not sure what happened.  I deleted the folder and did a clean install and it works now.

 

That was a bit more drastic than what I had it mind, but if it works for you....  :o

Share this post


Link to post

I didn't have anything in the queue and I  have default settings so I figured that was the easiest way to do it.

Share this post


Link to post

I didn't have anything in the queue and I  have default settings so I figured that was the easiest way to do it.

 

Still got to add your servers and stuff and setup categories?

 

The other option would have been to retrieve a copy of nzbget.conf from a backup if you've activated that feature in Community Applications, or to edit the file manually and try and fix the offending bits.

Share this post


Link to post

Does anyone know where I can get a generic script and or help compiling one so I can get email notifications when a download is completed or failed?

 

Thanks

 

Ash

Share this post


Link to post

https://github.com/nzbget/nzbget/wiki/Catalog-of-post-processing-scripts

 

I warn you though.  Getting email to work in Alpine containers isn't necessarily straightforward.  I don't anticipate us adding any extra dependencies either unless needed by the core nzbget system.  Both myself, sparklyballs and kodestar spent a good few hours getting email notifications working for the cops container.  Never again.....  ::)

Share this post


Link to post

I found this:

 

EMail - send E-Mail notification

 

Sends E-Mail notification when the job is done. The message includes:

 

job-status (success, failure);

the list of resulted files (optionally);

content of _brokenlog.txt (if exists - for failed jobs);

full post-processing log of the job (optionally: always, never, on-failure).

The script is included with NZBGet.

 

 

Says its included with Nzbget ?  ??? ??? What do I have to do to implement it?

 

Share this post


Link to post

I found this:

 

EMail - send E-Mail notification

 

Sends E-Mail notification when the job is done. The message includes:

 

job-status (success, failure);

the list of resulted files (optionally);

content of _brokenlog.txt (if exists - for failed jobs);

full post-processing log of the job (optionally: always, never, on-failure).

The script is included with NZBGet.

 

 

Says its included with Nzbget ?  ??? ??? What do I have to do to implement it?

 

I don't know Ash as I've never done so, strictly speaking we support getting the container up and running, we don't as a rule support setting up the app and configuring it.  I admit I'll sometimes go the extra mile if it's something I'm curious about or already know and is straightforward, but this one isn't piquing my interest purely based on my previous experience with getting email in an Alpine container working, albeit that time was with php. 

 

Also we're planning to rebase this shortly to Alpine, so the list of dependencies included may well change, (I thought we already had, but it's just a test version that we've been running in house) so you may be best to hold off trying anything until after then, and like I've said, it's not always simple.  Basic scripts may well work though.

Share this post


Link to post

Updated to the latest, getting a continual error that loops on forever, might have been my error somehow but any thoughts?

 

_ _ _
| |___| (_) ___
| / __| | |/ _ \ 
| \__ \ | | (_) |
|_|___/ |_|\___/
|_|

Brought to you by linuxserver.io
We do accept donations at:
https://www.linuxserver.io/donations
-------------------------------------
GID/UID
-------------------------------------
User uid: 99
User gid: 100
-------------------------------------

[cont-init.d] 10-adduser: exited 0.
[cont-init.d] 30-config: executing... 
[cont-init.d] 30-config: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
nzbget.conf(888): Option "DeleteCleanupDisk" is obsolete, ignored
nzbget.conf(1237): Option "ParCleanupQueue" is obsolete, ignored
[WARNING] nzbget.conf(888): Option "DeleteCleanupDisk" is obsolete, ignored
[WARNING] nzbget.conf(1237): Option "ParCleanupQueue" is obsolete, ignored
[iNFO] nzbget 17.0 server-mode
nzbget.conf(888): Option "DeleteCleanupDisk" is obsolete, ignored
nzbget.conf(1237): Option "ParCleanupQueue" is obsolete, ignored
[WARNING] nzbget.conf(888): Option "DeleteCleanupDisk" is obsolete, ignored
[WARNING] nzbget.conf(1237): Option "ParCleanupQueue" is obsolete, ignored
[iNFO] nzbget 17.0 server-mode
nzbget.conf(888): Option "DeleteCleanupDisk" is obsolete, ignored
nzbget.conf(1237): Option "ParCleanupQueue" is obsolete, ignored
[WARNING] nzbget.conf(888): Option "DeleteCleanupDisk" is obsolete, ignored
[WARNING] nzbget.conf(1237): Option "ParCleanupQueue" is obsolete, ignored
[iNFO] nzbget 17.0 server-mode
nzbget.conf(888): Option "DeleteCleanupDisk" is obsolete, ignored
nzbget.conf(1237): Option "ParCleanupQueue" is obsolete, ignored
[WARNING] nzbget.conf(888): Option "DeleteCleanupDisk" is obsolete, ignored

Share this post


Link to post

Updated to the latest, getting a continual error that loops on forever, might have been my error somehow but any thoughts?

 

_ _ _
| |___| (_) ___
| / __| | |/ _ \ 
| \__ \ | | (_) |
|_|___/ |_|\___/
|_|

Brought to you by linuxserver.io
We do accept donations at:
https://www.linuxserver.io/donations
-------------------------------------
GID/UID
-------------------------------------
User uid: 99
User gid: 100
-------------------------------------

[cont-init.d] 10-adduser: exited 0.
[cont-init.d] 30-config: executing... 
[cont-init.d] 30-config: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
nzbget.conf(888): Option "DeleteCleanupDisk" is obsolete, ignored
nzbget.conf(1237): Option "ParCleanupQueue" is obsolete, ignored
[WARNING] nzbget.conf(888): Option "DeleteCleanupDisk" is obsolete, ignored
[WARNING] nzbget.conf(1237): Option "ParCleanupQueue" is obsolete, ignored
[iNFO] nzbget 17.0 server-mode
nzbget.conf(888): Option "DeleteCleanupDisk" is obsolete, ignored
nzbget.conf(1237): Option "ParCleanupQueue" is obsolete, ignored
[WARNING] nzbget.conf(888): Option "DeleteCleanupDisk" is obsolete, ignored
[WARNING] nzbget.conf(1237): Option "ParCleanupQueue" is obsolete, ignored
[iNFO] nzbget 17.0 server-mode
nzbget.conf(888): Option "DeleteCleanupDisk" is obsolete, ignored
nzbget.conf(1237): Option "ParCleanupQueue" is obsolete, ignored
[WARNING] nzbget.conf(888): Option "DeleteCleanupDisk" is obsolete, ignored
[WARNING] nzbget.conf(1237): Option "ParCleanupQueue" is obsolete, ignored
[iNFO] nzbget 17.0 server-mode
nzbget.conf(888): Option "DeleteCleanupDisk" is obsolete, ignored
nzbget.conf(1237): Option "ParCleanupQueue" is obsolete, ignored
[WARNING] nzbget.conf(888): Option "DeleteCleanupDisk" is obsolete, ignored

 

I've seen this error before.  Basically they DeleteCleanupDisk & ParCleanupQueue are defunct options.  It was a problem with a version change of NZBget iirc.  If you edit the nzbget.conf file in /config with a suitable texteditor (Notepad++ on Windows I'd recommend) then search for those terms and delete both corresponding lines I think that fixes it.  Make a backup first though.

Share this post


Link to post

Updated to the latest, getting a continual error that loops on forever, might have been my error somehow but any thoughts?

 

I've seen this error before.  Basically they DeleteCleanupDisk & ParCleanupQueue are defunct options.  It was a problem with a version change of NZBget iirc.  If you edit the nzbget.conf file in /config with a suitable texteditor (Notepad++ on Windows I'd recommend) then search for those terms and delete both corresponding lines I think that fixes it.  Make a backup first though.

 

Appreciate the tip! Just wanted to follow up in case anyone else ran across the same issue.  I did go in and delete those two lines however was still running into issues so I just re-installed the docker completely, seems to be running smoother now than ever.

Share this post


Link to post

Is there a way to have this download through a different nic. specifically a usb wifi adapter. rather than the main nic uraid is using?

 

Share this post


Link to post

No, not as far as I know.

 

Sent from my LG-H815 using Tapatalk

 

 

Share this post


Link to post

Wow. Wow

 

I used Nzbget from around 2008-2013  But this was before I used unraid.  It worked just fine.  When I moved onto unraid I pretty much automatically started using SABNZBD. It was much glossier.  It worked well and no complaints.

 

Now I have a huge library and sabnzbd is not so great. Lots of repair fails and repairs are slow as molasses.

 

Enter CHBMBs suggestion to try NZBGET.  Not as glossy as SABNZBD.  But wow!  It's fast!  It repairs!  It repairs fast!!  I recognizes duplicates!  This is exactly what I needed. 

 

Thanks guys.  Donation on the way.

 

 

Sent from my SM-N920V using Tapatalk

 

 

Share this post


Link to post

Wow. Wow

 

I used Nzbget from around 2008-2013  But this was before I used unraid.  It worked just fine.  When I moved onto unraid I pretty much automatically started using SABNZBD. It was much glossier.  It worked well and no complaints.

 

Now I have a huge library and sabnzbd is not so great. Lots of repair fails and repairs are slow as molasses.

 

Enter CHBMBs suggestion to try NZBGET.  Not as glossy as SABNZBD.  But wow!  It's fast!  It repairs!  It repairs fast!!  I recognizes duplicates!  This is exactly what I needed. 

 

Thanks guys.  Donation on the way.

 

 

Sent from my SM-N920V using Tapatalk

 

Glad you're pleased and thanks for the donation, much appreciated.  ;)

Share this post


Link to post

Hey i am new in nzbget, i have used sabnzbd all the time.

 

But i am now trying to move to nzbget that i have problems with sabnzbd.

 

I have it all up and running, but i keep getting an error when i paste in the rss feed from my index site.

 

i get this error: Error parsing rss feed: Unsupported encoding windows-1251

 

anyone knows what wrong? and maybe know how i can fix it?

 

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.