[Support] Linuxserver.io - Nextcloud


5007 posts in this topic Last Reply

Recommended Posts

nextcloud\nginx\site-confs\default ? Add the codes from this video? This is all spanish to me. I'm a hardcore noob.  
 
Yes that looks like the right directory path. My default file had the header but it was comment out "#" I removed the comment.

If your file doesn't have the header you can add it there.

You can also do it like this video also.

There is more then one way to skin a cat

Sent from my Pixel 4 XL using Tapatalk

Link to post
  • Replies 5k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Application Name: Nextcloud Application Site: https://nextcloud.com/ Docker Hub: https://hub.docker.com/r/linuxserver/nextcloud/ Github: https://github.com/linuxserver/docker-nextcl

Here's my list of instructions....    Use them at your own risk.....   If upgrading to v12 please see here:   ##Turn on maintenance mode docker exec -it nextcloud occ m

I replaced these lines in the '/mnt/cache/appdata/nextcloud/nginx/site-confs/default' file. (Adjust path to your appdata path, if it's different)   location = /.well-known/carddav { return

Posted Images

14 minutes ago, H2O_King89 said:

Yes that looks like the right directory path. My default file had the header but it was comment out "#" I removed the comment.

If your file doesn't have the header you can add it there.

You can also do it like this video also.

There is more then one way to skin a cat emoji74.png

Sent from my Pixel 4 XL using Tapatalk
 

"add_header Strict-Transport-Security "max-age=15768000; includeSubDomains; preload;" always;" This is the one right? It's saying waring to only add the preload option once you read about the consequences.  I add the header with the other header blocks or does it matter? 

Link to post
"add_header Strict-Transport-Security "max-age=15768000; includeSubDomains; preload;" always;" This is the one right? It's saying waring to only add the preload option once you read about the consequences.  I add the header with the other header blocks or does it matter? 
If I'm reading this correctly you're asking if you should have it in both places? You only need it in one place That's why I uncommented and restarted next cloud and it worked fine.

Sent from my Pixel 4 XL using Tapatalk

Link to post
2 minutes ago, H2O_King89 said:

If I'm reading this correctly you're asking if you should have it in both places? You only need it in one place That's why I uncommented and restarted next cloud and it worked fine.

Sent from my Pixel 4 XL using Tapatalk
 

Ayye it worked. How about the other two issues? 

Your web server is not properly set up to resolve "/.well-known/caldav". Further information can be found in the documentation.

Your web server is not properly set up to resolve "/.well-known/carddav". Further information can be found in the documentation.

Link to post
Ayye it worked. How about the other two issues? 

Your web server is not properly set up to resolve "/.well-known/caldav". Further information can be found in the documentation.

Your web server is not properly set up to resolve "/.well-known/carddav". Further information can be found in the documentation.

I would guess that's an issue how you have your reverse proxy setup. Are you using swag?

 

What it's saying is when it appends that directory to the end of your domain it's not resolving. For example

 

https://nextcloud.domain.com/.well-known/carddav

 

Sent from my Pixel 4 XL using Tapatalk

 

 

 

Link to post
Just now, H2O_King89 said:

Post your nextcloud.subdoamin.conf

Sent from my Pixel 4 XL using Tapatalk
 

 make sure that your dns has a cname set for nextcloud
# assuming this container is called "swag", edit your nextcloud container's config
# located at /config/www/nextcloud/config/config.php and add the following lines before the ");":
#  'trusted_proxies' => ['swag'],
#  'overwrite.cli.url' => 'https://nextcloud.your-domain.com/',
#  'overwritehost' => 'nextcloud.your-domain.com',
#  'overwriteprotocol' => 'https',
#
# Also don't forget to add your domain name to the trusted domains array. It should look somewhat like this:
#  array (
#    0 => 'xxx.xxx.0.1:444', # This line may look different on your setup, don't modify it.
#    1 => 'nextcloud.your-domain.com',
#  ),

server {
    listen 443 ssl;
    listen [::]:443 ssl;

    server_name nextcloud.*;
	include /config/nginx/ssl.conf;
	add_header Strict-Transport-Security "max-age=15768000; includeSubDomains; preload;";
    client_max_body_size 0;

    location / {
        include /config/nginx/proxy.conf;
        resolver 127.0.0.11 valid=30s;
        set $upstream_app nextcloud;
        set $upstream_port 443;
        set $upstream_proto https;
        proxy_pass $upstream_proto://$upstream_app:$upstream_port;

        proxy_max_temp_file_size 2048m;
    }
}

 

Link to post
 make sure that your dns has a cname set for nextcloud# assuming this container is called "swag", edit your nextcloud container's config# located at /config/www/nextcloud/config/config.php and add the following lines before the ");":#  'trusted_proxies' => ['swag'],#  'overwrite.cli.url' => 'https://nextcloud.your-domain.com/',#  'overwritehost' => 'nextcloud.your-domain.com',#  'overwriteprotocol' => 'https',## Also don't forget to add your domain name to the trusted domains array. It should look somewhat like this:#  array (#    0 => 'xxx.xxx.0.1:444', # This line may look different on your setup, don't modify it.#    1 => 'nextcloud.your-domain.com',#  ),server {   listen 443 ssl;   listen [::]:443 ssl;   server_name nextcloud.*;include /config/nginx/ssl.conf;add_header Strict-Transport-Security "max-age=15768000; includeSubDomains; preload;";   client_max_body_size 0;   location / {       include /config/nginx/proxy.conf;       resolver 127.0.0.11 valid=30s;       set $upstream_app nextcloud;       set $upstream_port 443;       set $upstream_proto https;       proxy_pass $upstream_proto://$upstream_app:$upstream_port;       proxy_max_temp_file_size 2048m;   }}

 

https://forums.unraid.net/topic/48383-support-linuxserverio-nextcloud/?do=findComment&comment=773685

Sent from my Pixel 4 XL using Tapatalk

Link to post

Hi,

I am having a problem with setting the X-Frame-Options, I tried changing in the appdata\swag\nginx\ssl.conf that didn't work. So then I followed Spaceinvader One advice in his video and placed it in the nextcloud.subdomain.conf and that still did not work. So my question is there anything that I'm missing?

Link to post

I had to change my networks routers IP from 192.168.178.0 to 192.168.xxx.0 so I'm able to use my VPN, when I'm at work, where the routers IP is 192.168.178.0. Unfortunately this obviously also changed all the docker IPs, which seems to be why I can not access the nextcloud webui anymore. I guess the problem is that the IP of the "mariadb" docker has changed and now nextcloud can't find the database anymore. In case that this is the issue, how can I update the nextcloud settings so that it has the new mariadb IP?

 

Do you have any other ideas what the issue could be?

 

I really need to get the nextcloud going again ASAP. Thank you so much for your help!

 

SOLUTION: I found the config.php and updated the respective IPs. 

Edited by 1q8448q1
Link to post

Good day to everyone, i'm trying to install face recognition app and it needs pdlib installed. I checked the documentation for installing pdlib. But the easy way wont work on docker and the docker way is a bit complicated for my level. I checked lsio, that they provide some kind of easy docker-mod implementation.
But again my level isn't that good.. So i'm here to ask if anyone have successfully installed pdlib in this docker! 


Thanks!!

Link to post
On 10/6/2020 at 6:31 AM, CorneliousJD said:

Well, I spun up PostgreSQL 13 and created a databse and executed the following command inside the Nextcloud container. 


occ db:convert-type --port 5432  --all-apps --clear-schema pgsql nextcloud 10.0.0.10 nextcloud

It took about 2 hours to convert my MariaDB to PostgreSQL and when it finally finished, Nextcloud seems slightly faster, by a small margin, but not by a ton like I had hoped. 

Is there anything else that can be done to speed up this container? I'm accessing it via SWAG with pretty basic/default settings, and haven't installed too many third party apps so far, only really using it for file shares for myself and 2 smaller users.

 

Thanks in advance again.

Which docker did you used? Did you instal from cli? On Community apps i can see up to v11. Also which redis docker.
Thanks! 

 

EDIT* Nevermind about version, didn't think to check for tags! 

EDIT2* If you could share how you created the database in postgres it would be very helpful. Thanks!

Edited by skois
Link to post
Which docker did you used? Did you instal from cli? On Community apps i can see up to v11. Also which redis docker.
Thanks! 
I was wondering the same thing. So I went with 11 and changed Repository to postgres:13 as a guess and work.

Sent from my Pixel 4 XL using Tapatalk

Link to post

Hey there just a quick question on my end. All is working great except of one thing.
 

For example, I am copying a file FROM THE SERVER to a users folder ON THE SERVER, which is connected to a desktop app. After that, the file is not showing up on the desktop device, so I guess I will have to initialize a sync or check, for new files first.

I looked around and found this line here, which doesnt do the trick on my end:
sudo -u root php /mnt/user/nextcloud/aj/files files:scan --all ncp

Any ideas what is starting the sync correctly?

Edited by acidburn666
Link to post
10 hours ago, skois said:

Which docker did you used? Did you instal from cli? On Community apps i can see up to v11. Also which redis docker.
Thanks! 

 

EDIT* Nevermind about version, didn't think to check for tags! 

EDIT2* If you could share how you created the database in postgres it would be very helpful. Thanks!

For anyone having the same questions.
I used the postgres11 from app store, changed tag to 13
I used official redis docker
Added the redis config posted from @CorneliousJD and changed to my server ip
Restarted Nextcloud, bashed into it and run the db convert replacing it with my ip, user and db names.
It asked for my postgres db password.
I got a warning that some DBs wont convert, this is a normal warning that is documented. This DBs is old dbs from apps that are not used anymore or apps you have removed completely.
After that i just waited to finish the conversion. It took like 10minutes. I have a small instance.
(I did not had to create any db in postgres, just filled the template with username and db name and a password)

Link to post

Hey,

I tried to update nextcloud via the WebUI. Somehow, I now only get to the setup page where I can create an admin account. None of my clients can connect to my cloud anymore. I already tried to delete my plugins and did a reinstall of the docker container. Neither of that worked out. Does anyone have an idea how to fix that?

Link to post

Hey Guys,

I installed nextcloud following the instructions of spaceinvader one with MariaDB and SWAG (using a duckdns IP).

 

My problem is that when using the duckdns IP, my connection speed to my nextcloud is averaging at about 100 Kbyte/s. When connecting locally, my connection speed is higher and what I would I expect from a gigabit ethernet cable.
My ISP up/down speed is 200/20 Mbit/s (which do reach the server), so from my understanding I would expect a connection speed of around 2.5 Mbyte/s (minus some tolerance).

 

Do you guys have any ideas on how I can improve my connection speed?
I guess that it is related to SWAG?

Link to post
1 hour ago, Simom said:

Hey Guys,

I installed nextcloud following the instructions of spaceinvader one with MariaDB and SWAG (using a duckdns IP).

 

My problem is that when using the duckdns IP, my connection speed to my nextcloud is averaging at about 100 Kbyte/s. When connecting locally, my connection speed is higher and what I would I expect from a gigabit ethernet cable.
My ISP up/down speed is 200/20 Mbit/s (which do reach the server), so from my understanding I would expect a connection speed of around 2.5 Mbyte/s (minus some tolerance).

 

Do you guys have any ideas on how I can improve my connection speed?
I guess that it is related to SWAG?

There is no speed limitations in swag, so that is not the issue. I don't have any good suggestions about what it can be.

Link to post
52 minutes ago, saarg said:

There is no speed limitations in swag, so that is not the issue. I don't have any good suggestions about what it can be.

Okay, thanks for the info. In this case, I am just going to try a fresh install of the dockers and see if that changes anything.

Link to post

I reinstalled the mariadb, swag and nextcloud dockers and nothing changed. I don't really know what to try now. I will keep you posted if I can up the speed somehow.

 

EDIT:

I tested around somemore and found out that I get the expected connection speed from outside my local network (e.g. connecting to a VPN and then to my nextcloud over its duckdns IP)

Edited by Simom
Link to post

After looking for almost a month how to install Face Recognition App on Nextcloud. I had found the install instructions but never was able to complete them. Because apt install wasn't working. But i was too stupid and today realised it was alpine underneath. So.. googled what package manager alpine uses and managed to get Face Rec working (ill have some results in some hours!). 

For anyone wanna install pdlib and try the Face Rec app, here is what i did to install it.

First, DO IT ON TESTING DOCKER NOT ON THE PRODUCTION DOCKER! 

Have some photos on your nextcloud (not on external storages, it won't work, been there)

Now the installation.
1 - Go to Dockers, Open console on your test nextcloud docker

Insert the following commands one line at a time.

Hopefully you won't have any errors.

apk add make cmake gcc g++ php7-dev libx11-dev openblas-dev

**RESTART DOCKER AFTER THE PREVIOUS LINE, open console on docker again and continue**

git clone https://github.com/davisking/dlib.git
cd dlib/dlib
mkdir build
cd build
cmake -DBUILD_SHARED_LIBS=ON ..
make
sudo make install

cd / 

git clone https://github.com/goodspb/pdlib.git
cd pdlib
phpize
PKG_CONFIG_PATH=/usr/local/lib64/pkgconfig ./configure
make
sudo make install

* Now to go appdata folder /php/phplocal.ini and add on the end

 

[pdlib]
extension="pdlib.so"
 


2 - Restart NC Docker once again.

3 - Go to Apps and install/enable Face Recognition App
4 - Go to NC Docker console again and do "occ face:setup -m 1"

5 - Go to Settings > Face Recognition (on the lower menu)

6 - I don't know if its supposed to start automatically, mine was saying Analysis started but didn't seem to process any photo until i open the docker console again and do "occ face:background_job" EDIT* This command justs forces to start, if you want you can let it start automaticly via cron job
7 - Wait for results ( i'm also waiting. so i can't really tell you how it works yet)

*For more info for fine tuning check here https://github.com/matiasdelellis/facerecognition/wiki/Usage

*This is all info gathered around, so I can't be sure that i haven't messed any other module of NC while installing those packages. 
DO IT AT YOUR OWN RISK!

PS. As you can see i'm just good at googling! Not an expert. Hehe
 

Edited by skois
Link to post

Hi there,

 

I've read the thread and can see a number of individuals are experiencing the same issue as me:

 

From with Nexcloud I receiving a warning about: The "X-Frame-Options" HTTP header is not set to "SAMEORIGIN". This is a potential security or privacy risk, as it is recommended to adjust this setting accordingly.

 

I'm using swag and have updated the following locations /config/www/nextcloud/config/config.php
'trusted_proxies' => ['swag'],
'overwrite.cli.url' => 'https://nextcloud.your-domain.com/',
'overwritehost' => 'nextcloud.your-domain.com',
'overwriteprotocol' => 'https',

array (
0 => '192.168.0.1:444',
1 => 'nextcloud.your-domain.com',

 

and included

 

add_header X-Frame-Options "SAMEORIGIN" always;

 

in my nextcloud.subdomain.conf file

 

Any ideas why I'm still seeing the warning?

 

Any assistance would be appreciated.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.