Jump to content
linuxserver.io

[Support] Linuxserver.io - Nextcloud

4072 posts in this topic Last Reply

Recommended Posts

well here is what i looded. you tell me i liked it was "official docker hub image"
 
"Nextcloud based on the official docker hub image. Nextcloud 20.X with full ONLYOFFICE integration. Based on Apache."
Please post a screenshot of your docker template

Sent from my Mi 10 Pro using Tapatalk

Share this post


Link to post
3 hours ago, John Graham said:

well here is what i looded. you tell me i liked it was "official docker hub image"

 

"Nextcloud based on the official docker hub image. Nextcloud 20.X with full ONLYOFFICE integration. Based on Apache."

That is not ours. Please use the support thread for that container and not here.

Share this post


Link to post
1 hour ago, skois said:

Please post a screenshot of your docker template

Sent from my Mi 10 Pro using Tapatalk
 

It's not ours, as we don't use Apache. And also the user is wrong.

Share this post


Link to post

Is there a way to force update to the latest stable version? If I'm not mistaken latest stable is 20.0.1. I have a test docker and a "production" docker.
The test docker was just a copy of the "production" that i made couple days ago. Update the test to beta 20.0.0 and i got offered the 20.0.1 stable today.

But on my prod docker i have 19.0.4 and it says i'm up to date. 
I'd like to update to 20.0.1!

Share this post


Link to post
1 hour ago, skois said:

Is there a way to force update to the latest stable version? If I'm not mistaken latest stable is 20.0.1. I have a test docker and a "production" docker.
The test docker was just a copy of the "production" that i made couple days ago. Update the test to beta 20.0.0 and i got offered the 20.0.1 stable today.

But on my prod docker i have 19.0.4 and it says i'm up to date. 
I'd like to update to 20.0.1!

Do the manual update using the command line. Be sure to update to the latest version of 19 before going to 20.

Share this post


Link to post
2 minutes ago, saarg said:

Do the manual update using the command line. Be sure to update to the latest version of 19 before going to 20.

Will be the updated offered later? I' dont feel much confident doing the update manually. Not yet atleast! 

Is the updates roll out gradually? Do you know how they select to which the update rolls?

Thanks!

Share this post


Link to post
Do the manual update using the command line. Be sure to update to the latest version of 19 before going to 20.
When I did my updates it forced me to go through all of them before I hit 20. Also ran into an issue where I was updating to the new update. During the manual update my unraid did auto update on Dockers. I was on part 6. When the docker came back up it would not get off of 6 and finish.

After hours of troubleshooting even nuking NC and the DB and using appdata back up it was still stuck in the update.

Then I finally found the update folder. It wasn't located in the appdata it was in the Nextcloud share. After deleting the folder I was able to restart the update process with success.

Sent from my Pixel 4 XL using Tapatalk

Share this post


Link to post
Will be the updated offered later? I' dont feel much confident doing the update manually. Not yet atleast! 

Is the updates roll out gradually? Do you know how they select to which the update rolls?

Thanks!
What you do is change the channel to beta inside of next cloud and then run the manual update through the docker console. It's super easy and I trust it more than the gui update

Sent from my Pixel 4 XL using Tapatalk

Share this post


Link to post
Just now, H2O_King89 said:

What you do is change the channel to beta inside of next cloud and then run the manual update through the docker console. It's super easy and I trust it more than the gui update

Sent from my Pixel 4 XL using Tapatalk
 

Isn't the 20.0.1 supposed to be stable? Why should i go to beta first? Just curius!

Share this post


Link to post
Isn't the 20.0.1 supposed to be stable? Why should i go to beta first? Just curius!
When I checked for updates when I was on version 18 it did not show version 20 for some reason but if I switch the beta it did show 20 once I got up to 20 on updates I switched back to stable

Sent from my Pixel 4 XL using Tapatalk

Share this post


Link to post
1 hour ago, H2O_King89 said:

What you do is change the channel to beta inside of next cloud and then run the manual update through the docker console. It's super easy and I trust it more than the gui update

Sent from my Pixel 4 XL using Tapatalk
 

BTW manually your mean running the updater.phar or following these instructions? 
https://docs.nextcloud.com/server/latest/admin_manual/maintenance/manual_upgrade.html

Updater.phar gives me this

root@62a067466074:/config/www/nextcloud/updater# updater.phar 
Nextcloud Updater - version: v19.0.3-8-gbfdc40b

Current version is 19.0.4.

No update available.

Nothing to do.

 

Share this post


Link to post
7 minutes ago, skois said:

BTW manually your mean running the updater.phar or following these instructions? 
https://docs.nextcloud.com/server/latest/admin_manual/maintenance/manual_upgrade.html

Updater.phar gives me this


root@62a067466074:/config/www/nextcloud/updater# updater.phar 
Nextcloud Updater - version: v19.0.3-8-gbfdc40b

Current version is 19.0.4.

No update available.

Nothing to do.

 

Read the first post for how to upgrade. You can't use updater.phar or the webgui for the update until nextcloud decides you are worthy the upgrade. Or you can change to beta channel to get it now.

Share this post


Link to post
Just now, saarg said:

Read the first post for how to upgrade. You can't use updater.phar or the webgui for the update until nextcloud decides you are worthy the upgrade. Or you can change to beta channel to get it now.

Thanks just wanted to clarify! 

Share this post


Link to post

I successfully upgraded to 20.0.1. But everything was working fine. But later Mail app had an update to 1.5.1 after than mail is not working.
Deleted the mail account, run "occ mail:clean-up", disabled and removed app, reinstalled, added the account again, but i still get "Loading messages".

Opened the database with pgAdmin, the account is added, but no new messages appear on the db. 
Tried running "occ mail:account:sync 10 -f" (my current account id) and got:

 

[debug] account is up to date, skipping mailbox sync

In MailboxLockedException.php line 33:
                               
  331 is already being synced  
                               

 

After 3 hours i still get "331 is alerady being synced" so it doesn't do anything...

Does your mail app works? Or is just me?

PS. i have an @outlook.com account!

 

Edited by skois

Share this post


Link to post
On 10/26/2020 at 8:21 PM, skois said:

With which app you trying to map? Android or iOS?

i am actually trying to add them in windows under explorer. i think i will try to setup Nextcloud and swag from the scratch. but i need to know what to do to be able to also delete the files if i connect the drive where nextcloud data is stored in windows.

Share this post


Link to post
31 minutes ago, un4given said:

i am actually trying to add them in windows under explorer. i think i will try to setup Nextcloud and swag from the scratch. but i need to know what to do to be able to also delete the files if i connect the drive where nextcloud data is stored in windows.

Don't start messing around with trying to use the nextcloud data folder in both nextcloud and through unraid. The point of nextcloud is to go through its UI, be it WebDAV or webui.

If you have to share anything from an unraid share, do it using external sources (forgot the correct name right now, but someone probably remembers).

 

Share this post


Link to post
36 minutes ago, un4given said:

i am actually trying to add them in windows under explorer. i think i will try to setup Nextcloud and swag from the scratch. but i need to know what to do to be able to also delete the files if i connect the drive where nextcloud data is stored in windows.

https://help.dreamhost.com/hc/en-us/articles/216473357-Accessing-WebDAV-with-Windows
From the Win 10. Ignore step 4
I Mapped as webDav. Any change on mapped folder takes effect immidiately on NC web also

Share this post


Link to post

My install of nextcloud is now completely borked. I really, really, REALLY hate updating this thing. This is what's happening after occ upgrade. Followed the steps in the first post, but upgrading to 18.0.8 (currently on 18.0.7).

 

An unhandled exception has been thrown:

Error: Class 'Doctrine\DBAL\Types\Types' not found in /config/www/nextcloud/apps/user_status/lib/Migration/Version0001Date20200602134824.php:52

 

Would appreciate tips in getting past this. I'm so close to just giving up on nextcloud altogether.

Share this post


Link to post

Does anyone have an issue with public access / downloads not showing up in the activity tab?

 

I have a public password protected photo share set up using reverse proxy with swag and nothing shows up under activity (or under individual file activity). I can however look at swag's nginx logs, though it's difficult to find out what url represents what file.

 

Using the latest linuxserver/nextcloud docker

nexcloud 19.0.4

activity 2.12.1

unraid 6.8.3

 

Edited by robobub

Share this post


Link to post

Of course now that I'm trying to work out of an older backup and try to do an update, nextcloud's damn SSL certificate expired... I've just about had it with all the random issues you can run into when trying to update this thing. Will try again tomorrow I guess.

Share this post


Link to post

So the last days after upgrading to 20.0.1 and mail to 1.5.1, i'm dealing with the problem i mentioned here. (https://github.com/nextcloud/mail/issues/3908#issuecomment-721111498). I dont know if it caused from the docker update, nextcloud update or mail app update. But the conclusion of the issue on github was that the problem is the iconv package installed on the alpine image.

If anyone from LSIO can give me an insight on how to fix this or even better do an update on the docker that would be awesome! 
I just started reading dockers, so i dont have much knowledge, but happy to try things and give feedback.

Share this post


Link to post
20 hours ago, constellation said:

My install of nextcloud is now completely borked. I really, really, REALLY hate updating this thing. This is what's happening after occ upgrade. Followed the steps in the first post, but upgrading to 18.0.8 (currently on 18.0.7).

 

An unhandled exception has been thrown:

Error: Class 'Doctrine\DBAL\Types\Types' not found in /config/www/nextcloud/apps/user_status/lib/Migration/Version0001Date20200602134824.php:52

 

Would appreciate tips in getting past this. I'm so close to just giving up on nextcloud altogether.

Update, fixed this by reverting to an old appdata backup for nextcloud. Removed the install .step file so it's not stuck at Step 4. Then used "docker exec -it nextcloud updater.phar". I think I'll use that to update from now on and completely avoid using the UI, since the UI always gives me random issues.

Share this post


Link to post
On 3/20/2020 at 6:16 PM, siamsquare said:

Foound the cause but does anyone have a solution?

https://support.microsoft.com/en-us/kb/2386902

Is there already an solution to this problem where available space is equal to available space on client? Would like to use Nextcloud for photo and video backup off family phones.

Thanks!

Edited by siamsquare

Share this post


Link to post
7 hours ago, EdgarWallace said:

I was trying to get Collabora running as seperate Docker: I installed the container with default name (collabora), renamed the sample proxy conf, added the subdomain in SWAG and as CNAME at my DNS provider. SWAG log is showing:


[cont-init.d] done.
[services.d] starting services
nginx: [emerg] "server" directive is not allowed here in /config/nginx/proxy-confs/collabora.subdomain.conf:3
Server ready
nginx: [emerg] "server" directive is not allowed here in /config/nginx/proxy-confs/collabora.subdomain.conf:3
nginx: [emerg] "server" directive is not allowed here in /config/nginx/proxy-confs/collabora.subdomain.conf:3
nginx: [emerg] "server" directive is not allowed here in /config/nginx/proxy-confs/collabora.subdomain.conf:3
nginx: [emerg] "server" directive is not allowed here in /config/nginx/proxy-confs/collabora.subdomain.conf:3
......

I thought that I followed @SpaceInvaderOne guide quite well but obviously I made a mistake.....

 

Swag issues should be posted in the swag support thread.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.