Jump to content
segator

DSM UI On docker + unraid

48 posts in this topic Last Reply

Recommended Posts

Can't get it work, nothing happens when i start it. Some logs where everything seems normal.

Share this post


Link to post

I'm on 6.3.5, and I'm getting this error when I try and start the container:

 

INFO: KVM acceleration enabled
ERROR: AUTO_ATTACH incorrect or undefined. It must be one of [Yy1Nn0]

 

Share this post


Link to post

Also getting the following error: 

INFO: KVM acceleration enabled
ERROR: AUTO_ATTACH incorrect or undefined. It must be one of [Yy1Nn0]

Is there a step by step tutorial?

 

1.thumb.png.8658820aa91002cbcfb00d75fc447392.png

2.png

Share this post


Link to post
On 11/1/2017 at 1:57 PM, Squid said:

I'm surprised that a search for segator through CA didn't pull up the results included xpenology

Anyone make any progress on this?

I'm getting nowhere.

Share this post


Link to post
On 12/4/2017 at 10:20 AM, revilo951 said:

I'm on 6.3.5, and I'm getting this error when I try and start the container:

 


INFO: KVM acceleration enabled
ERROR: AUTO_ATTACH incorrect or undefined. It must be one of [Yy1Nn0]

 

@kabloomy posted this, and it seems to work for me

Quote

Add an AUTO_ATTACH variable and set it to Y.

auto_attach.PNG.4c40bafc3d1ff6d2d6822bf38ffe23fe.PNG

Share this post


Link to post

The attached config worked for me. Notice the repository is not as per docker hub, it's:

segator/xpenology:6.1.3-15152

Docker offers an upgraded container that doesn't appear to do anything (?) but attempting to upgrade did reset some settings within the xpenology instance. Does this imply that not all config is stored in the single volume (image)? That might need fixing.

I added a raid group and then a volume (basic, btrfs) from within storage manager.

 

I don't fully understand this (from the segator/xpenology-docker github read.me)

Quote

Mount Docker Host Volumes to Xpenology

To mount Host Path/Docker Volumes to your Xpenology Image you need to load 9p drivers in your xpenology image, follow this tutorial to compile drivers for your specific xpenology version. After have your image with 9p drivers loaded you need to create and script that will executed on every boot in your xpenology, this script will load the drivers and mount your 9p mountpoint, by default this docker image map the path /data to the 9p "hostdata" Example


insmod /volume1/homes/admin/9pnet.ko
insmod /volume1/homes/admin/9pnet_virtio.ko
insmod /volume1/homes/admin/9p.ko
mkdir /volume1/\@unraid
mount -t 9p -o trans=virtio,version=9p2000.L,msize=262144  hostdata /my/host/data

Are the 9P drivers already integrated?

I need an idiot's guide!

xpenology-docker.PNG

Share this post


Link to post

if you have shell access run this command.

''docker run --privileged -v /mnt/user/appdata/Xpenology/instance:/image -p 5000:5000 -p 22:5022 segator/xpenology:6.1.3-15152''

Note, you must make the folders match mine. 

Within Xpenology, unzip the files from segators repo, 

image.png.d205cc6e9abc87722a0aa3c08d47796a.png

And put the synoboot.img in the Xpenology folder also.

image.png.61b006d115d341649cf7ff5d1920904d.png

This will get you up and running but you cannot edit the docker and make mods, i'm working my way back to try get this running by setting up manually. 

Hopefully now you can work out how to set up manually and show me now :)

Thanks,




 

 

Edited by foster182

Share this post


Link to post

also interested if this is still being updated. Just downloaded it and will have a play later. would be amazing if this is still going

 

Share this post


Link to post

Hi to everyone, sorry to take this topic abandoned, I decided 1 year ago to don't use anymore unraid(No snapshot support, Switched to glusterFS) and I Forgot to answer replies.

Well I see pretty interest in this docker, I don't know the situation of Xpenology right now, it does support latest Synology versions?

Now i'm going 2 weeks to japan, when I return I will try to take time to update and simplify the docker image.

 

 

Share this post


Link to post
6 hours ago, segator said:

Hi to everyone, sorry to take this topic abandoned, I decided 1 year ago to don't use anymore unraid(No snapshot support, Switched to glusterFS) and I Forgot to answer replies.

Well I see pretty interest in this docker, I don't know the situation of Xpenology right now, it does support latest Synology versions?

Now i'm going 2 weeks to japan, when I return I will try to take time to update and simplify the docker image.

 

 

Brilliant, thank you segator!

Share this post


Link to post
On 9/10/2018 at 10:01 AM, segator said:

Hi to everyone, sorry to take this topic abandoned, I decided 1 year ago to don't use anymore unraid(No snapshot support, Switched to glusterFS) and I Forgot to answer replies.

Well I see pretty interest in this docker, I don't know the situation of Xpenology right now, it does support latest Synology versions?

Now i'm going 2 weeks to japan, when I return I will try to take time to update and simplify the docker image.

 

 

Yes please! 😀

Share this post


Link to post
On 9/10/2018 at 10:01 AM, segator said:

Hi to everyone, sorry to take this topic abandoned, I decided 1 year ago to don't use anymore unraid(No snapshot support, Switched to glusterFS) and I Forgot to answer replies.

Well I see pretty interest in this docker, I don't know the situation of Xpenology right now, it does support latest Synology versions?

Now i'm going 2 weeks to japan, when I return I will try to take time to update and simplify the docker image.

 

 

Hey. Have you made any progress with this?

Sorry to nag but I'm really keen to use it!

Share this post


Link to post

I was pretty excited to give this a try depending how the thread was going. Owning a Synology the file manager and app UI is a first-class experience. Good news is this project is on github, and anyone can fork that and make modifications to improve upon it. I see one user has out of the few forks there.

Share this post


Link to post

Hi, i just found this and I'm trying to get this run (IntelNuc + LinuxServer + Docker).

My problem is that i get an error while it tries to boot xpenology

 


[    0.024331] general protection fault: 0000 [#1] SMP
[    0.025000] Modules linked in:
[    0.025000] CPU: 0 PID: 1 Comm: swapper/0 Not tainted 3.10.102 #15152
[    0.025000] Hardware name: QEMU Standard PC (i440FX + PIIX, 1996), BIOS Ubuntu-1.8.2-1ubuntu1 04/01/2014
[    0.025000] task: ffff88007c487800 ti: ffff88007c4a4000 task.ti: ffff88007c4a4000
[    0.025000] RIP: 0010:[<ffffffff81881d06>]  [<ffffffff81881d06>] intel_pmu_init+0x2cf/0x7b7
[    0.025000] RSP: 0000:ffff88007c4a7eb0  EFLAGS: 00010202
[    0.025000] RAX: 0000000000000003 RBX: 0000000000000000 RCX: 0000000000000345
[    0.025000] RDX: 0000000000000003 RSI: 0000ffffffffffff RDI: ffffffff81862290
[    0.025000] RBP: 0000000000000001 R08: 0000000000000001 R09: 0000000000000007
[    0.025000] R10: 0000000000000000 R11: ffffffff81862100 R12: 0000000000000000
[    0.025000] R13: 0000000000000000 R14: 0000000000000000 R15: 0000000000000000
[    0.025000] FS:  0000000000000000(0000) GS:ffff88007fc00000(0000) knlGS:0000000000000000
[    0.025000] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[    0.025000] CR2: ffff880001ab7000 CR3: 000000000180d000 CR4: 00000000003406f0
[    0.025000] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
[    0.025000] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
[    0.025000] Stack:
[    0.025000]  ffffffff818810cb ffffffff818810ff ffffffff8102c304 0000000000000000
[    0.025000]  ffffffff818810cb 0000000000000001 0000000000000000 0000000000000000
[    0.025000]  0000000000000000 0000000000000000 ffffffff810003aa ffffffff8191d7f0
[    0.025000] Call Trace:
[    0.025000]  [<ffffffff818810cb>] ? check_bugs+0x28/0x28
[    0.025000]  [<ffffffff818810ff>] ? init_hw_perf_events+0x34/0x506
[    0.025000]  [<ffffffff8102c304>] ? set_memory_x+0x44/0x50
[    0.025000]  [<ffffffff818810cb>] ? check_bugs+0x28/0x28
[    0.025000]  [<ffffffff810003aa>] ? do_one_initcall+0xea/0x140
[    0.025000]  [<ffffffff8187ad21>] ? kernel_init_freeable+0x95/0x1bb
[    0.025000]  [<ffffffff8149cb60>] ? rest_init+0x70/0x70
[    0.025000]  [<ffffffff8149cb65>] ? kernel_init+0x5/0x180
[    0.025000]  [<ffffffff814aea88>] ? ret_from_fork+0x58/0x90
[    0.025000]  [<ffffffff8149cb60>] ? rest_init+0x70/0x70
[    0.025000] Code: a1 04 fe ff 44 89 0d a2 04 fe ff 89 05 54 05 fe ff 7e 2d 83 e2 1f b8 03 00 00 00 66 b9 45 03 83 fa 02 0f 4e d0 89 15 6a 04 fe ff <0f> 32 48 89 d1 89 c0 48 c1 e1 20 48 09 c1 48 89 0d fd 04 fe ff
[    0.025000] RIP  [<ffffffff81881d06>] intel_pmu_init+0x2cf/0x7b7
[    0.025000]  RSP <ffff88007c4a7eb0>
[    0.025013] ---[ end trace 4b5bc8a6fd37ccbb ]---
[    0.026039] Kernel panic - not syncing: Attempted to kill init! exitcode=0x0000000b
[    0.026039]

I'm pretty much a Linux Noob so i would be happy if you post potential fixes detailed.

Share this post


Link to post
34 minutes ago, Kilian said:

My problem is that i get an error while it tries to boot xpenology

It seems like you aren't talking about Unraid. Does your post have anything to do with our forum? 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.