[Support] ich777 - Gameserver Dockers


4015 posts in this topic Last Reply

Recommended Posts

  • Replies 4k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Summary: Support Thread for ich777 Gameserver Dockers (CounterStrike: Source & ConterStrike: GO, TeamFortress 2, ArmA III,... - complete list in the second post) Application: SteamCMD Do

Just thought I'd share my experience setting up a Valheim server with this docker app from @ich777(thank you!)   You don't need to worry about Steam authentication for Valheim, the default a

Dockers Available so far:   SteamCMD DedicatedServers: CounterStrike: Source CounterStrike: Global Offensive TeamFortress 2 ArmA3 - requested by @MrSage D

Posted Images

Started my first game server with Unraid and it was easy! thanks to ich777 

If anyone out there having problems connecting to a Valheim dedicated server I suggest to close GameFirst software by Asus, when I tried to join a server the server crashed. Figure it out after 5 hours

Time for some Valheim+, thanks again for the great job

Edited by Tesano
Link to post

Hi all

i setup a ARK Server and everything works fine. But i can´t get the mods to work. I download the mods via my Steam Workshop - Run Ark to let them install. Then copy the mod folders and the mod files to "unraid Server\appdata\ark-se\ShooterGame\Content\Mods" - After this i add "?ActiveMods=731604991" at the Game Parameter field in the Container config. 

But no mods are still there after a server restart. 

Have i forget somethng?

Link to post
1 minute ago, MX-Hero said:

Hi all

i setup a ARK Server and everything works fine. But i can´t get the mods to work. I download the mods via my Steam Workshop - Run Ark to let them install. Then copy the mod folders and the mod files to "unraid Server\appdata\ark-se\ShooterGame\Content\Mods" - After this i add "?ActiveMods=731604991" at the Game Parameter field in the Container config. 

But no mods are still there after a server restart. 

Have i forget somethng?

Please read the first recommended post at the top, eventually @Cyd can help.

Link to post
8 hours ago, ich777 said:

@PeacefulDiscord & @Duglz:

 

I have now integrated ValheimPlus into the container.

In order to activate it and enable it you first have to force an update of the container itself with grafik.png.8aaa63440195186f1a257009262a6529.png and then create a variable with:

grafik.thumb.png.10036d7d91c5152af86827bdfc360323.png

and start the container.

 

Or you can also wait until the template in the CA App has been updated (takes usualy 1 to 2 hours) and redownload a fresh copy of the template from there.

 

The container will then check on every start/restart if there is a newer version available and install it if there is a newer one available or install it if it isn't installed.

 

Hope that helps :)

@PeacefulDiscord  & @ich777

 

Awesome! thanks for this! Started using your docker as a Valheim server about 4 days back. Playing with 2 friends. Good fun, thanks for the effort!

 

Now we ran in to the issue that we can see each others map (fog of war is personal). This is an option to share in Valheim+ so started looking in to this. Found the update in docker and now we can enable it in our game. cool!

 

What we did:

Install the new docker and install the client window side files (from nexusmods).

Changed the config file (valheim_plus.cfg i think its called) to enable the map visibility share and also disabled the teleport limit (with copper and tin).

Put the config file in the server folde.

Started server and logged in. Result = incompatible version... hmm ok.

Copied the config file to all our client folders and tada! we can log in again!

 

The mod seems to work as we have the black crow on our smelter saying hi, welcome to valheim plus bla bla donate here.

However, the changes we made to the config don't have any affect. Still cant use portal with copper and cant see friends map.

 

Looking at Nexusmods website and the description, the unix version of valheim plus states:

Make sure to execute 'chmod u+x run_bepinex.sh'
Make sure to run the run_bepinex.sh

Is this something we still need to do? or do you run this in the docker start command?

When I try to do this I get an error.

Possibly I need to stop the server first? but how? I usually stop the docker container but then I close the docker, not just stop the server....

 

Any idea what we are doing wrong? How do we load the Valheim+ config file?

Again, thanks for the help, cool docker to have and easy to setup and use!

 

Edited by Wabs
Link to post

OK, maybe I'm stupid, but I cannot for the life of me get 2 of these Valheim dockers to run simultaneously. They spin up just fine but only one is actually accessible. I have forwarded a separate port range and put the correct ports in the container. When I use Steam Server List, the server shows up at the correct port with the correct game name but when trying to join I get this:
image.png.4d221b598cc63a1edef1a296d8d268d4.png

 

Please help

Link to post
1 hour ago, Wabs said:

Make sure to execute 'chmod u+x run_bepinex.sh'
Make sure to run the run_bepinex.sh

Is this something we still need to do? or do you run this in the docker start command?

You have to do none of that because the container does all for you...

 

1 hour ago, Wabs said:

Possibly I need to stop the server first? but how?

Why would you do that? It says that you should run the server vith run_bepinex.sh and that is what the container does.

 

1 hour ago, Wabs said:

How do we load the Valheim+ config file?

The file loads autmatically, you don't have to do anything about it, just be sure to Enable the option in the template but I think you have done this because of:

1 hour ago, Wabs said:

The mod seems to work as we have the black crow on our smelter saying hi, welcome to valheim plus bla bla donate here.

 

If you got any problem you should post an issue (search first if anyone else is experinecing this) on the Github for ValheimPlus but keep in mind as said many times in this thread for Valheim that it is in really early alpha state and I think also ValheimPlus isn't mature enough that a update of the game itself can break the whole server (the Github also sais that).

 

1 hour ago, rcm024 said:

OK, maybe I'm stupid, but I cannot for the life of me get 2 of these Valheim dockers to run simultaneously.

What isn't working and what have you done/changed exactly (screenshots of both templates would be also helpful)? Have you read the description of the variables?

I can run multiple servers with different port ranges just fine...

 

Please look here also got a report where it doesn't run but I think it's working now because the user hasn't responded again (you have to look also a few posts below where I posted also a screenshot where I can connect to the server):

 

Link to post
36 minutes ago, ich777 said:

Please look here

This did help thanks. I didn't realize the GAME_PORT under the extra settings needed to be changed. Working now. Thanks @ich777 you rock. Keep up the great work and know the community appreciates you and your hard work!

Link to post
1 hour ago, ich777 said:

You have to do none of that because the container does all for you...

 

Why would you do that? It says that you should run the server vith run_bepinex.sh and that is what the container does.

 

The file loads autmatically, you don't have to do anything about it, just be sure to Enable the option in the template but I think you have done this...

 

 

Thanks for the reply. Found the issue!

The config file is seperated in to sections. Such as Items, player etc.

I had changed the sub entries such as "teleportprevention = true" but I had missed the switch for the complete section "items".

So after changing that line in the config to true and restarting the server it works.

 

Again, thanks for your work, much appreciated!

Link to post

My friends and I are absolutely loving the Valheim server docker. Just quick question, where is the start_headless_server.bat’-file (Linux: ‘start_server.sh’) equivalent so that I can manually change server name, instance name and password etc besides going through the UNRAID docker GUI. 

 

Thanks for a fantastic piece of software

 

James

Link to post

Hi @ich777, thanks for the great work on this!

 

It appears my buddies and I are running into the net code issue described here --> https://indiefaq.com/guides/valheim-fix-for-multiplayer-lag.html

 

Is there a means of addressing this issue in the container?

Link to post
1 hour ago, davlucmac said:

It appears my buddies and I are running into the net code issue described here

Please read this post:

 

 

3 hours ago, Roma4593 said:

equivalent so that I can manually change server name, instance name and password etc besides going through the UNRAID docker GUI. 

Are you running Valheim on Unraid?

To change the server name please look in the template you can change the name and the password in there (click on the icon on the Docker page and then Edit).

Link to post

I got it confirmed on the Valheim Discord channel that the property "public" is not in use (servers are always public). And the property "password" is required and must be 5 characters or more. Could you update the description of the fields in the Unraid docker container for Valheim?

Link to post

Newb preface: this is my first game server docker of any form and my docker knowledge is limited to running a jellyfin / radarr / sonarr / etc server for a few months. 

Issue: 7dtd server is taking a VERY long time to do map generation (hours). 

 

Reading up it seems the map generator utilizes GPUs these days. My server does have a 1060 6gb for transcoding but I'm assuming the Steam docker doesn't have GPU access set up. 

 

My CPU on my Unraid box is a bit underwhelming (3770K). 

 

What I'm wondering:

 

  1. can I create the map on my gaming PC (3800x/3070) and the move it to the container afterwards? 
  2. where is the map generated (as in path)? I'm guessing it's all in memory right now as I can't find any significantly large files in the container's appdata. 
  3. is it viable to map the container's save game folder outside of the docker so that I can wipe the docker as needed without losing save games (might already be done, just don't have a way to check yet since it's still running setup)
  4. I'm not even sure the docker is working yet :) Is there a setup guide that goes into the steam docker basics step-by-step? I'm piecing things together from this thread as best I can.

 

Links/guides appreciated. If none just ELI50 please (explain it like I'm 50 ... since ... I'm 50). 


Thanks!

Edited by Jahf
Link to post
6 hours ago, ich777 said:

Please read this post:

 

 

Are you running Valheim on Unraid?

To change the server name please look in the template you can change the name and the password in there (click on the icon on the Docker page and then Edit).

I am running it in unraid. I was just wondering where the file was that the template modifies that includes the server name, password, ports, etc. 

 

Thanks

Link to post
2 hours ago, Durin said:

I got it confirmed on the Valheim Discord channel that the property "public" is not in use (servers are always public).

Nice, then please tell them to remove this from their installation instructions that ship with the dedicated servers... :D

But one thing that I've discovered is that when public is set to '1' and no password is entered the server won't start but if you set public to '0' you can actually leave the password empty and connect to it.

I will leave it in because it hurts no one by now... :D

 

2 hours ago, Durin said:

Could you update the description of the fields in the Unraid docker container for Valheim?

This is already in there, eventually you got an old template:

grafik.thumb.png.71e35f5b284762f601e02bfc62f8bdc8.png

 

1 hour ago, Jahf said:

Reading up it seems the map generator utilizes GPUs these days. My server does have a 1060 6gb for transcoding but I'm assuming the Steam docker doesn't have GPU access set up. 

I don't think this should be necessary because I tried today to create a server and everything works flawlessly, do you mean eventually the first startup that could take long since the container has to download the entire gamefiles and dedicated server files?

 

1 hour ago, Jahf said:

where is the map generated (as in path)? I'm guessing it's all in memory right now as I can't find any significantly large files in the container's appdata. 

In your appdata folder you should find a folder that is named '7dtd' and in there is a folder named 'Saves' and there you should find everything. Have you changed anything in the template? Also have you installed a Cache drive in your server?

 

1 hour ago, Jahf said:

I'm not even sure the docker is working yet :) Is there a setup guide that goes into the steam docker basics step-by-step? I'm piecing things together from this thread as best I can.

Have you got a log output from the container?

 

1 hour ago, Jahf said:

can I create the map on my gaming PC (3800x/3070) and the move it to the container afterwards? 

This is something that eventually @Spectral Force can help.

 

 

9 minutes ago, Roma4593 said:

I was just wondering where the file was that the template modifies that includes the server name, password, ports, etc. 

This is all included in the container because I start the server not with the default scripts but the startup is similar to the default startup, please don't change anything in the Container because I won't give support for that and also the changes are not persistent.

 

With the variable GAME_PARAMS you can basically append everything you want to the startup command but keep in mind that you have to fill in the server name and password at the other variables since they are fixed values and have to be filled in otherwise the server wouldn't start.

 

You can always look into my Github if you want the source code.

Link to post
7 minutes ago, ich777 said:

Nice, then please tell them to remove this from their installation instructions that ship with the dedicated servers... :D

But one thing that I've discovered is that when public is set to '1' and no password is entered the server won't start but if you set public to '0' you can actually leave the password empty and connect to it.

I will leave it in because it hurts no one by now... :D

Are you sure about this? I have tried that several times because I do not want to have a password on the server, but the server does not start when I do that! All sources I have found says that password is required...

Edited by Durin
Link to post
4 minutes ago, Durin said:

Are you sure about this? I have tried that several times because I do not want to have a password on the server

When I created the container for this I stumbled across this, eventually something has changed lately with a update...

 

But I've connected with public set to '0' and no password set and it worked.

Link to post
45 minutes ago, ich777 said:

When I created the container for this I stumbled across this, eventually something has changed lately with a update...

 

But I've connected with public set to '0' and no password set and it worked.

I really wanted to find out how to start the server without password so... I checked the source code, and I can confirm that as the code is now, there is now way to start the server without a valid password, and "public" is hardcoded to "true". :)

Link to post

@ich777 just wanted to say thank you for these awesome dockers and continued support!

 

Had to dig in the docker app page to find a donate option, but just sent you some vodka money. You should put the link on the original post and/or in your forum profile so others can easily express some thanks.

 

Thanks again!

Link to post
9 hours ago, ich777 said:

 

In your appdata folder you should find a folder that is named '7dtd' and in there is a folder named 'Saves' and there you should find everything. Have you changed anything in the template? Also have you installed a Cache drive in your server?

 

Have you got a log output from the container?

 

This is something that eventually @Spectral Force can help.

 

Thanks for the reply (and docker).

No, it's not necessary to run the map generator to play, but it is necessary if you want to play a fully random map. That was my goal ... large random map that my friends could explore with a server that keeps running even between logins. 

 

It's 7 hours later and it's still running so I'm going to reinstall, get it working default, then generate the map on my gaming PC, and see if I can find a way to move it to the Docker. 

 

Link to post

Literally about 100 hours since Feb 9 trying to get Factorio to load the mods. It simply will not load mods onto the server. It worked before. It no longer does. Anyone have success with it? Or is this docker officially no longer supported?

Link to post
6 hours ago, jagr200 said:

Literally about 100 hours since Feb 9 trying to get Factorio to load the mods.

You've already posted on the Github of the creator of this Container or am I wrong?

Have you also made a post in the Factorium Forums?

 

6 hours ago, jagr200 said:

Or is this docker officially no longer supported?

This is a question for the creators Github and the main problem is that everything is working in the case you just want to run a simple Factorio server without mods or am I wrong?

 

8 hours ago, Jahf said:

No, it's not necessary to run the map generator to play, but it is necessary if you want to play a fully random map. That was my goal

But even if you create a bigger world it should not take that long I think...

 

8 hours ago, Jahf said:

generate the map on my gaming PC

Yes, that should be possible. to import the map, the main folders are the Saves folder and the User folder that is located in your 'appdata/7dtd' directory, just be sure to stop the Container before importing the map.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.