Jump to content
ich777

[Support] ich777 - Gameserver Dockers

438 posts in this topic Last Reply

Recommended Posts

29 minutes ago, milfer322 said:

Anyone can test the server for DST? 

As i said, you must put the line in your server.ini at Master:

 

[ACCOUNT]
lan_only_server = true

 

otherwise the server will not show up evin if you only want to play on LAN (this line is a requirement for LAN play).

Share this post


Link to post
Posted (edited)
58 minutes ago, Spectral Force said:

Also I've been reading through some of the posts and most server files are free and do not require to purchase the game, even for linux.  Not sure if you were aware of that.  Also for 7DTD Alloc has linux script that will download and install steamcmd and the server files.  I can provide a link if interested. 

The 7DTD is already in the list and runns fine, the problem is that i can't test the dockers and profe if they work. And testing with people who owns the game is difficult because i am located in europe. (Like you said the most apps doesn't need a game purchase but a few needs a token or a valid steam account - these details are all in the discription of my dockers).

 

The next problem is that i must read every server tutorial how to build the dedicated server and this take a lot of time and i even don't know what 'aloc' is... Because i simply don't own the game and never set up a server for that (I promise, for every game that i've own at some time i have set up a dedicated server ;) )

 

In my dockers you can use only one steamcmd dir in the appdata directory and run many many server so that you don't wast space on your disk. The dockers are designed to be easily set up, for highly customisation and to save disk space.

Edited by ich777

Share this post


Link to post
Posted (edited)
5 minutes ago, ich777 said:

The 7DTD is already in the list and runns fine, the problem is that i can't test the dockers and profe if they work. And testing with people who owns the game is difficult because i am located in europe. (Like you said the most apps doesn't need a game purchase but a few needs a token or a valid steam account - these details are all in the discription of my dockers).

 

In my dockers you can use only one steamcmd dir in the appdata directory and run many many server so that you don't wast space on your disk. The dockers are designed to be easily set up, for highly customisation and to save disk space.

 

Ok good to know.  I will volunteer to be a test dummy for any game that I own and can help with and I only will request servers for what I do own.

 

Re: Alloc's server script  https://7dtd.illy.bz/wiki/Installation  I have used this on my linux vm from A15 to A16.4, but had an issue and lost my vm so now I"m just running them on windows save for your docker.  I'm rooted in the 7d community and if you need any questions answered I can help.

Edited by Spectral Force

Share this post


Link to post
5 hours ago, ich777 said:

if you write direct to a disk the parity won't work!

Where did you get this idea? It's wrong.

Share this post


Link to post
Posted (edited)
8 hours ago, trurl said:

Where did you get this idea? It's wrong.

A while ago i've read a thread where it was discussed i think, since then when i do something in the terminal i work only in the /mnt/user directory.

If i'm wrong i'm sorry... 

Edited by ich777

Share this post


Link to post
5 hours ago, ich777 said:

A while ago i've read a thread where it was discussed i think, since then when i do something in the terminal i work only in the /mnt/user directory...

When i'm wrong i'm sorry... 🤔

You likely confused a few facts and came up with 1+1=3.

1. Mixing /mnt/diskX or /mnt/cache with /mnt/user paths can cause issues if you aren't careful, search "unraid user share copy bug" for a detailed explanation.

2. Writing directly to a hardware disk array member at /dev/sdX1 will invalidate parity. This would typically only happen if you followed some random internet directions for working with linux disks at the partition level.

 

It is perfectly ok to access the mount points /mnt/diskX as long as you understand how /mnt/user paths interact with them. Just don't do it without a thorough grasp on how /mnt/user actually works.

Share this post


Link to post
7 minutes ago, jonathanm said:

It is perfectly ok to access the mount points /mnt/diskX as long as you understand how /mnt/user paths interact with them. Just don't do it without a thorough grasp on how /mnt/user actually works.

Thank you for the clarification, i think i've read the 1st thread that you described above. :)

Share this post


Link to post
13 hours ago, milfer322 said:

Anyone can test the server for DST? 

DST works with caves now, at least for me.

 

Remember - DST Server port is - 10889 and NOT 10999 (Wrong configuring?)

Need to update that in the container or forward container port 10889 to 10999 (UDP)

 

Use console to connect;

c_connect("IP")

If you are using custom port;

c_connect("IP",PORT)
c_connect("IP",PORT,"Password")

 

Share this post


Link to post

Ok Ich, I'm needing a little help with the 7D docker.  Not sure what I'm doing wrong.  Ports are forwarded correctly in my firewall.  The docker downloads the server files fine, I setup my game, restart the docker so the server starts and generates the world, server appears to be running, but I can't connect via telnet nor does it show up in the game browser.  I can provide the log from unraid if necessary.  Just not sure why I can't find it when it seems to be running.  

 

Anyone else with the 7D docker is more than welcome to chime in.  This is my first foray into running any kind of game server via a docker.  I've been running 7DTD servers since 2016 so its not a new thing to me.

Share this post


Link to post
Posted (edited)
27 minutes ago, Spectral Force said:

Ok Ich, I'm needing a little help with the 7D docker.  Not sure what I'm doing wrong.  Ports are forwarded correctly in my firewall.  The docker downloads the server files fine, I setup my game, restart the docker so the server starts and generates the world, server appears to be running, but I can't connect via telnet nor does it show up in the game browser.  I can provide the log from unraid if necessary.  Just not sure why I can't find it when it seems to be running.  

 

Anyone else with the 7D docker is more than welcome to chime in.  This is my first foray into running any kind of game server via a docker.  I've been running 7DTD servers since 2016 so its not a new thing to me.

If you want to telnet into the docker you must add the port for telnet, i think i've don't enabled it by default... But i may be wrog (i'm at work and can't tell for sure)

 

Have you changed any port numbers in the docker or in you configuration files?

 

You can also try to install the vanilla docker and look if it shows up in the server browser.

Since i don't own the game it's a little difficult for me to test this. But my sister and 3 others tested this docker on my server and it was working and showing up in the server browser (if you want to test it i can set it up again on my server and you can try to connect)...

Edited by ich777

Share this post


Link to post
32 minutes ago, ich777 said:

If you want to telnet into the docker you must add the port for telnet, i think i've don't enabled it by default... But i may be wrog (i'm at work and can't tell for sure)

 

Have you changed any port numbers in the docker or in you configuration files?

 

You can also try to install the vanilla docker and look if it shows up in the server browser.

Since i don't own the game it's a little difficult for me to test this. But my sister and 3 others tested this docker on my server and it was working and showing up in the server browser (if you want to test it i can set it up again on my server and you can try to connect)...

I have changed the ports in the docker to match my serverconfig.xml.  All ports are forwarded in the router.  Telnet is turned on in the serverconfig with the matching port set in the docker.  You do have the port in the docker for telnet but you have it called something else, also at work so can't remember off the top of my head. By default that port is 8080.  I can post screenshots later if that would help.

Share this post


Link to post
Posted (edited)
7 minutes ago, Spectral Force said:

I have changed the ports in the docker to match my serverconfig.xml.  All ports are forwarded in the router.  Telnet is turned on in the serverconfig with the matching port set in the docker.  You do have the port in the docker for telnet but you have it called something else, also at work so can't remember off the top of my head. By default that port is 8080.  I can post screenshots later if that would help.

You have to delete the whole port in the docker configuration and make a new one with the right port from you serverconfig.xml as the container port and the host port also the same (and don't forget to set te right protocoll type).

 

This is something i can't change since steam handles ports a little bit different from my experience.

 

If you post a screenshot please also share the serverconfig.xml (without password).

Edited by ich777

Share this post


Link to post
3 minutes ago, ich777 said:

You have to delete the whole port in the docker configuration and make a new one with the right port from you serverconfig.xml as the container port and the host port also the same (and don't forget to set te right protocoll type).

 

This is something i can't change since steam handles ports a little bit different from my experience.

 

If you post a screenshot please also share the serverconfig.xml (without password).

So I just can't replace the base port with the one I want to use?

 

When I get home from work I will post a screenshot of the ports and attach my server config sans passwords.  Thanks.

Share this post


Link to post
7 minutes ago, Spectral Force said:

So I just can't replace the base port with the one I want to use?

Sadly not, but you can delete all the ports in the docker config page of 7DTD and set up new ports that match your ports (You must set the container and host ports as the same, otherwise NAT will not work).

 

You know what i mean?

Share this post


Link to post

Ok so what I did was replace the default ports you had like the game port is tcp 26900 with 25050.  Do I have to delete your entry with 26900 and then create my own with 25050?

Share this post


Link to post
4 minutes ago, Spectral Force said:

Ok so what I did was replace the default ports you had like the game port is tcp 26900 with 25050.  Do I have to delete your entry with 26900 and then create my own with 25050?

Exactly, with the container and host port to match yours from the serverconfig.xml

Share this post


Link to post
Posted (edited)
15 minutes ago, Spectral Force said:

So why is it have to delete them and not just change values?  Just curious.

Because you changed the value in the file so you changed the port in the docker and my port was for example 27015 and you set it to 27016 it can't work because the docker container port for the container is set to 27015 but you've changed it to 27016 and you only changed the host port to 27016 not the container port.

Edited by ich777

Share this post


Link to post

Just setup the 7dtd container- working perfectly, thanks again ich777!

Share this post


Link to post
Posted (edited)

Update:  I changed the ports like you said, I can connect to telnet so far, just waiting for everything to finish starting up but its looking good.

 

OK, so still wont' show up in the server list.  

http://prntscr.com/npm5o3  Docker Ports 

 

http://prntscr.com/npm77c  From the docker Edit area

 

http://prntscr.com/npm7gt  Forwarded Ports

 

Attached: Server config sans passwords.

 

Not sure wtf is going on and why it's not showing.

serverconfig.xml

Edited by Spectral Force

Share this post


Link to post
7 hours ago, Spectral Force said:

OK, so still wont' show up in the server list.

I will test that today evening.

 

If you are able, can you test the docker with the standard config and with nothing changed?

Only for testing?

Share this post


Link to post
5 hours ago, ich777 said:

I will test that today evening.

 

If you are able, can you test the docker with the standard config and with nothing changed?

Only for testing?

Possibly, but I have an active server with those ports already running on another active 7d server on my network.  I'd have to take that offline to do it.

Share this post


Link to post
13 hours ago, Spectral Force said:

Update:  I changed the ports like you said, I can connect to telnet so far, just waiting for everything to finish starting up but its looking good.

 

OK, so still wont' show up in the server list.  

http://prntscr.com/npm5o3  Docker Ports 

 

http://prntscr.com/npm77c  From the docker Edit area

 

http://prntscr.com/npm7gt  Forwarded Ports

 

Attached: Server config sans passwords.

 

Not sure wtf is going on and why it's not showing.

serverconfig.xml 11.98 kB · 2 downloads

Take a quick look at the ports, something is wrong look at this: https://7dtd.illy.bz/wiki/Ports

I think you must open the 25020 also UDP + 1 + 2

 

And why did you open so much steam ports? One is enough in the range of 27015-27030

Share this post


Link to post
Posted (edited)
5 minutes ago, ich777 said:

Take a quick look at the ports, something is wrong look at this: https://7dtd.illy.bz/wiki/Ports

I think you must open the 25020 also UDP + 1 + 2

 

And why did you open so much steam ports? One is enough in the range of 27015-27030

Based on my experience, 7D servers don't always show if you do the 3 ports especially since A16.  I found opening a 5 port block will always list the server both in the steam list and in the 7D server browser. 

 

27010-27020 is already assigned to my other server.

Edited by Spectral Force

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.