Jump to content
ich777

[Support] ich777 - Gameserver Dockers

503 posts in this topic Last Reply

Recommended Posts

On 5/1/2019 at 2:52 PM, yellowcooln said:

Unrelated to the topic,

 

@Corodeanu N How did you get your dashboard to look like this? sQ63pPN.png

go to settings , display settings , dynamix color theme change to black

Share this post


Link to post
Posted (edited)
On 5/4/2019 at 11:44 AM, killasniff said:

Can you add rust too?

Added to the todo list ;)

Edited by ich777

Share this post


Link to post

Hi!  Thanks for all these game containers.  I'm trying to run an Ark server, installed your Docker, disabled steamguard and entered my username/password.  Everything seemed to install fine, but the log shows:

 

Update state (0x5) validating, progress: 99.13 (8450729018 / 8525214156)
Success! App '376030' fully installed.
---Prepare Server---
---Server ready---
---Start Server---
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.

 

And the server doesn't show up on my network.  Please let me know what other info you might need.

 

Thanks!

 

-P

Share this post


Link to post
5 hours ago, pengrus said:

I'm trying to run an Ark server, installed your Docker, disabled steamguard and entered my username/password.  Everything seemed to install fine, but the log shows:

 

I don't recommend it doing it this way (your entire library can be stolen!!!). Just make a dedicated account for your gameservers and disable steamguard for that account than you should be fine (you don't have to own ark for the installation of the dedicated server).

 

5 hours ago, pengrus said:

[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.

That's totally fine since Steam isn't running when the dedicated server launches, that`s just a warning.

 

 

Are your ports forwarded properly? In wich list did you search for the server on the ark server browser? Wich ports and what protocol did you forward?

Share this post


Link to post
Posted (edited)

on the edit and install area of the CS-GO docker under USERID   ( the help area tell you to put the account password here )  might what to change this?

csgo.png

Edited by Kodx

Share this post


Link to post
Posted (edited)
On 5/4/2019 at 11:44 AM, killasniff said:

Can you add rust too?

@killasniff The Developer EAC drops support on linux, RUST server is not going to happen... Link

 

Edit: @killasniff After further investigation the RUST Docker is now available. ;)

Edited by ich777

Share this post


Link to post
1 hour ago, Kodx said:

on the edit and install area of the CS-GO docker under USERID   ( the help area tell you to put the account password here )  might what to change this?

Thank you, was wrong in all of my SteamCMD Docker tamplates changed it and should be updated shortly.

Share this post


Link to post
22 hours ago, ich777 said:

I don't recommend it doing it this way (your entire library can be stolen!!!). Just make a dedicated account for your gameservers and disable steamguard for that account than you should be fine (you don't have to own ark for the installation of the dedicated server).

 

That's totally fine since Steam isn't running when the dedicated server launches, that`s just a warning.

 

 

Are your ports forwarded properly? In wich list did you search for the server on the ark server browser? Wich ports and what protocol did you forward?

Ok, wasn't sure I could do this without providing Steam a u/p, I'll reconfigure when I get everything up and running.

 

I'm not forwarding anything, just trying to run everything on the LAN.  I searched in LAN, and added by IP address in favorites.

 

Thanks!

Share this post


Link to post
Posted (edited)
4 hours ago, pengrus said:

I'm not forwarding anything, just trying to run everything on the LAN.  I searched in LAN, and added by IP address in favorites.

If you do that you find the server?

You musz provide a udp and tcp port im the docker to work properly.

For ark standard 7777 and +1 (7778) and the steamport 27015 like im the docker template.

Edited by ich777

Share this post


Link to post
Posted (edited)
3 hours ago, bblair321 said:

Maybe a Day of Infamy Docker would be cool

You, got a PM

 

3 hours ago, Select25 said:

Is it possible to get a Docker for Project Cars2? 

Should be possible, can you test the server if i set one up?

Edit: Since i don't have the game i can set up no docker (need a valid steam purchase).

Edited by ich777

Share this post


Link to post

Seems that the Factorio beta is behind a few version and restarting the docker does not update it to the latest... 

Share this post


Link to post
38 minutes ago, Repooc said:

Seems that the Factorio beta is behind a few version and restarting the docker does not update it to the latest... 

Updated the template yesterday. They switched the repository, please check if you have te right template.

Repository should be factoriotools/factorio.

Share this post


Link to post
3 minutes ago, ich777 said:

Updated the template yesterday. They switched the repository, please check if you have te right template.

Repository should be factoriotools/factorio.

Thanks, didn't realize the repo changed :P

Share this post


Link to post

Hi,

 

Would love a docker for Dominions 5 if possible.

If you are interested and want help let me know.

 

Thanks

Share this post


Link to post
Posted (edited)

Hello,

Thanks ich777 for all the dockers you're creating.

One dude, can login with anonymous in steamcmd in your dockers? 

 

Thanks!

Edited by milfer322

Share this post


Link to post
1 hour ago, Rothan said:

Hi,

 

Would love a docker for Dominions 5 if possible.

If you are interested and want help let me know.

 

Thanks

Should be totaly possible, next week i will look into it. ;)

 

33 minutes ago, milfer322 said:

Hello,

Thanks ich777 for all the dockers you're creating.

One dude, can login with anonymous in steamcmd in your dockers? 

 

Thanks!

Leave the username and the password blank and the docker will automaticaly log you in with the anonymous account.

Btw a few games need that you provide a username and password, in these dockers the username and password must be filled in with an account with steamguard completely disabled, steam and i recommend to creat a dedicated account for this.

 

Can i ask what you want to change? All dockers should do all automatically and you have only to change the ports to what you want.

Share this post


Link to post
On 5/7/2019 at 12:48 AM, ich777 said:

If you do that you find the server?

You musz provide a udp and tcp port im the docker to work properly.

For ark standard 7777 and +1 (7778) and the steamport 27015 like im the docker template.

Mostly no.  I can specify the server IP in steam's server dialog and it appears.  When I try to play, it says it's "unable to query the server for invite".  I cannot find the server through Steam's browser or the browser within Ark.  I'm using your template basically unchanged, 7777 and 7778, as well as 27015 are specified.  Any other things I should check?

Share this post


Link to post
Posted (edited)

Thanks ich777,

One dude again xD

In the docker for dontstarve 

I trying desactivate the disease delay and i cant find the file for it.


In other servers what i mount manually have files for it but in this docker cant find it.

 

Info for other people add adminlist.txt in directory /token/Cluster_1/

Thanks!!

 

Edited by milfer322

Share this post


Link to post
Posted (edited)
55 minutes ago, pengrus said:

Mostly no.  I can specify the server IP in steam's server dialog and it appears.  When I try to play, it says it's "unable to query the server for invite".  I cannot find the server through Steam's browser or the browser within Ark.  I'm using your template basically unchanged, 7777 and 7778, as well as 27015 are specified.  Any other things I should check?

Are you sure you set the right list and so on (Unofficial Servers, Show servers with Password,...)

Wich ports did you open? TCP or UDP? Sounds like a Port forwarding issue.

 

I can start mine to test if you find it (i start it only when i play with friends uses too much power for my homeserver) but note that you must select the unofficial list in the ingame server browser.

 

Do you got a static or a dynamic ip? Wich internet provider do you use? Is there maybe any restriction from your provider? Can you find the server in 'lan-mode'?

 

42 minutes ago, milfer322 said:

Thanks ich777,

One dude again xD

In the docker for dontstarve 

I trying desactivate the disease delay and i cant find the file for it.


In other servers what i mount manually have files for it but in this docker cant find it.

 

Info for other people add adminlist.txt in directory /token/Cluster_1/

Thanks!!

 

I've create the dockers as vanilla as possible and with only the bare minimum files but i can edit it if this a critical file and add.

I've read that there are much more files to create if you want to customize it really really hard but in mind that this is a vanilla server as possible i've only created 2 files.

If this is a critical file please post a link to an example or post your example in a PM and tell me where to put it exactly.

Edited by ich777

Share this post


Link to post
Posted (edited)
15 minutes ago, ich777 said:

I've create the dockers as vanilla as possible and with only the bare minimum files but i can edit it if this a critical file and add.

I've read that there are much more files to create if you want to customize it really really hard but in mind that this is a vanilla server as possible i've only created 2 files.

Thanks for reply. If it isn't bothering much and if it's possible to be added, I'd like to modify the forest and the caves settings. The world can't be modified right now, and I'd like to modify a couple of options.

 

Vanilla is fine by default but is it possible to change a couple of things? Disease is annoying af for example. Thank you

unknown.png?width=609&height=341

Edited by milfer322

Share this post


Link to post
8 minutes ago, ich777 said:

Are you sure you set the right list and so on (Unofficial Servers, Show servers with Password,...)

Wich ports did you open? TCP or UDP? Sounds like a Port forwarding issue.

 

I can start mine to test if you find it (i start it only when i play with friends uses too much power for my homeserver) but note that you must select the unofficial list in the ingame server browser.

Well, I'm trying to play on my LAN.  Internal to my network.  The Ark server sits on my unRAID, and I have a Windows and a Linux client to play on that instance.  So I'm not sure unofficial servers is right for me, I'm just trying to play internal to my 192.168.1.x.  I keep looking for it in the "LAN" section of the Ark browser and it can't find it.  When I set the IP address as a favorite, it gives me the unable to query server for invite thing.

 

Again, I didn't open any ports because I am not trying to play from the WAN, just internal to my house.  Will this function in a LAN scenario or do I need to make it public-facing?

Share this post


Link to post
Posted (edited)
11 hours ago, pengrus said:

Well, I'm trying to play on my LAN.  Internal to my network.  The Ark server sits on my unRAID, and I have a Windows and a Linux client to play on that instance.  So I'm not sure unofficial servers is right for me, I'm just trying to play internal to my 192.168.1.x.  I keep looking for it in the "LAN" section of the Ark browser and it can't find it.  When I set the IP address as a favorite, it gives me the unable to query server for invite thing.

 

Again, I didn't open any ports because I am not trying to play from the WAN, just internal to my house.  Will this function in a LAN scenario or do I need to make it public-facing?

Please read this post Link

He describes that the server must conmect to the internet and show properly up in the list to show on the lan list.

Edit: But i think if the server need's to register at the Steam master server just forward the port 27015 UDP in your router to your Unraid server IP.

 

11 hours ago, milfer322 said:

Thanks for reply. If it isn't bothering much and if it's possible to be added, I'd like to modify the forest and the caves settings. The world can't be modified right now, and I'd like to modify a couple of options.

 

Vanilla is fine by default but is it possible to change a couple of things? Disease is annoying af for example. Thank you

I will take a look into that.

Edited by ich777

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.