Jump to content
ich777

[Support] ich777 - Gameserver Dockers

600 posts in this topic Last Reply

Recommended Posts

This is most likely a complete noob question but how to you access the console for the running TF2 server? if i wanted to do a command to change map and the like?

Share this post


Link to post
11 hours ago, toonamo said:

This is most likely a complete noob question but how to you access the console for the running TF2 server? if i wanted to do a command to change map and the like?

I would make this by installing metamod and sourcemod to the server.

If you do this you can make it directly from the game with a specific butten mapped to 'sm_admin'.

A onscreen menu will pop up and you can choose between multiple options including change map.

 

Second way is ingame with the console and the rcon commands.

 

3rd way is not possible because i don't install screen to my dockers if not necessary to keep the dockers small.

 

But i think the admin menu would be the best way to change maps (i do it also this way on my server with Counter Strike Source and Global Offensive)

Share this post


Link to post

Firstly, thanks for these dockers. Ive tried the one for 7 Days To Die and it works a charm with easy setup.

Has anyone been able to get their server up on the public list? I must have a port blocked or something because mine does not show up, but i am able to connect to it both locally and remotely. I have it set up on port 25550 since that is where i had it running while under windows (dedicated). I had to open up ports range 25550-25552 on TCP and UDP prior, and everything worked.

 

Right now the only thing missing is me getting the service on the public list so it is easy to find. I tried opening up 26903 (since changed to 25553, also open) and 27015 as well without making a difference.

 

Here are my port mappings if this helps. Appreciate any feedback.

image.png.884e79c64bdb0e2db6b30e8c6d7ce3df.png

Share this post


Link to post
7 hours ago, JDK said:

Firstly, thanks for these dockers. Ive tried the one for 7 Days To Die and it works a charm with easy setup.

Has anyone been able to get their server up on the public list? I must have a port blocked or something because mine does not show up, but i am able to connect to it both locally and remotely. I have it set up on port 25550 since that is where i had it running while under windows (dedicated). I had to open up ports range 25550-25552 on TCP and UDP prior, and everything worked.

Since i don't own the game testing is a little bit difficult but it should work, had a few testers and it worked.

 

Look one page back (page 6 i think) there was a simillar post to yours and it was solved.

 

Are you shure youve opened the base port TCP and UDP and then the following 3 UDP ports and also a port in the range from 27015 to 27030.

 

Can you post a picture from the firewall or router with the port mapping?

 

Have you also set another port in the config? If yes please try to delete all the port mappings from the docker and enter it manually with the same ports for Container and Host.

 

Share this post


Link to post
20 hours ago, ich777 said:

Since i don't own the game testing is a little bit difficult but it should work, had a few testers and it worked.

 

Look one page back (page 6 i think) there was a simillar post to yours and it was solved.

 

Are you shure youve opened the base port TCP and UDP and then the following 3 UDP ports and also a port in the range from 27015 to 27030.

 

Can you post a picture from the firewall or router with the port mapping?

 

Have you also set another port in the config? If yes please try to delete all the port mappings from the docker and enter it manually with the same ports for Container and Host.

 

 

Man i feel a bit silly. It was all right there on P6 as you said - thank you. I thought the ports are visible only to the container and the host, and that a mapping is done as part of that interface.

I made the changes to have the ports the same between Host and Container, as well as in the serverconfiog.xml and it came right up. thanks again!

 

I know someone offered earlier in this thread, but if you need the game i'm happy to gift it to you. PM me steam details or at least some way to buy you a beer and say thanks for this work!

Share this post


Link to post
10 hours ago, JDK said:

Man i feel a bit silly. It was all right there on P6 as you said - thank you. I thought the ports are visible only to the container and the host, and that a mapping is done as part of that interface.

I made the changes to have the ports the same between Host and Container, as well as in the serverconfiog.xml and it came right up. thanks again!

No problem, sadly there is no other way because you are changing the port in the container if you change it in the config file and then you must delete all port entries in the Docker configuration and create new with your ports specified.

10 hours ago, JDK said:

I know someone offered earlier in this thread, but if you need the game i'm happy to gift it to you. PM me steam details or at least some way to buy you a beer and say thanks for this work!

There is a 'Donate' butten in every Docker file from me, if you like my work please consider Donating since i've made for almost of all my game library games dedicated server Docker's and all Donations are used for the next requested game servers.

Donate.jpg.ad30f42b764de037f0b46409fce2fda5.jpg

Share this post


Link to post

I wish this was more accessible. Didn't even think to go back to the apps section...

Couple beers on the way!

Share this post


Link to post
17 minutes ago, JDK said:

I wish this was more accessible. Didn't even think to go back to the apps section...

Couple beers on the way!

Good idea, edited the first post and inserted the Donation link. ;)

Thank you very much, appreciate it! 🍻

Share this post


Link to post
Posted (edited)

@ich777 Thank you very much for making the Minecraft server docker for us, I'll be sure to make a donation when I can spare some money myself.

 

I got it working fine with Forge and ~40 mods. Is there a way to show the server console through either the docker console or log view via unRAID? Other than looking at the logs\latest.txt and keep refreshing it of course.

 

I'd like to be able to keep an eye on info/warn/error entries, such as people joining/leaving and the "server is overloaded" etc

Edited by Goldfire

Share this post


Link to post
4 hours ago, Goldfire said:

@ich777 Thank you very much for making the Minecraft server docker for us, I'll be sure to make a donation when I can spare some money myself.

Appreciate it! ;)

 

4 hours ago, Goldfire said:

I got it working fine with Forge and ~40 mods. Is there a way to show the server console through either the docker console or log view via unRAID? Other than looking at the logs\latest.txt and keep refreshing it of course.

 

I'd like to be able to keep an eye on info/warn/error entries, such as people joining/leaving and the "server is overloaded" etc

Update the Container (should be a little update  ~4KB :D ) now you will see the logs. Didn't realize that the logs where written to another place...

Log should be now fully working ;)

(Server will wait 30 seconds bevore showing the logs, only for security reasons, since my old Spigot build puts out a error that it's outdated and it starts after 20 seconds)

Share this post


Link to post
2 hours ago, ich777 said:

Appreciate it! ;)

 

Update the Container (should be a little update  ~4KB :D ) now you will see the logs. Didn't realize that the logs where written to another place...

Log should be now fully working ;)

(Server will wait 30 seconds bevore showing the logs, only for security reasons, since my old Spigot build puts out a error that it's outdated and it starts after 20 seconds)

Cool thanks, I'll let that update via the CA Auto Update tomorrow morning.

 

Appreciate it.

Share this post


Link to post

Having issues with assigning a static address to minecraft container.  Bridge mode works fine but static seams to have issues with the ports.  Not seeing errors in the logs either.  image.png.95d45f47af154be7cd0dacfbf4746795.png

Share this post


Link to post
Posted (edited)
13 hours ago, awalkawalk said:

Having issues with assigning a static address to minecraft container.  Bridge mode works fine but static seams to have issues with the ports.  Not seeing errors in the logs either.  image.png.95d45f47af154be7cd0dacfbf4746795.png

Can you post a picture from the Docker configuration site itself?

Also, if you assign a static IP (Custom mode) adress in the docker it should work fine if you configured the ports in the 'server.properties' file and forwarded the ports correctly in you firewall to reach it from the outside.

Why did you use the Custom mode?

 

Edit: Are you sure that you've edited the port in the server.properties also? If you put the docker in Custom mode it's like you open all ports to the Docker also it should not matter if you specify a port on the docker configuration page in Unraid since i don't expose ports.

screenshot.jpg

Edited by ich777

Share this post


Link to post

Updated the 7Days2Die server today and now when it boots up I get a error and it looks like the saved game we had was deleted as the server settings are reverted and the saved game folder is empty.

 

 NullReferenceException: Object reference not set to an instance of an object
at GUIWindowManager.Update () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

Share this post


Link to post
8 minutes ago, AKGeek said:

Updated the 7Days2Die server today and now when it boots up I get a error and it looks like the saved game we had was deleted as the server settings are reverted and the saved game folder is empty.

 

 NullReferenceException: Object reference not set to an instance of an object
at GUIWindowManager.Update () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

First of all sorry that your savegame is gone.

Can you please give me a little bit more information? When did you first download the docker and when did you update it.

I think on page 4 of this thread is this allready discussed, there was a bug in the container (since i don't have the game i don't know where the savegames were and this was fixed later on with the help of a few people).

 

You can try to completely delete the container (also delete the complete serverfolder) and download it again from the Community Applications (there should be also a few new options in the template).

 

Sorry for the bad news and inconvenience, this should not happen anymore with the new container.

Share this post


Link to post
14 minutes ago, AKGeek said:

Updated the 7Days2Die server today and now when it boots up I get a error and it looks like the saved game we had was deleted as the server settings are reverted and the saved game folder is empty.

 

 NullReferenceException: Object reference not set to an instance of an object
at GUIWindowManager.Update () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

I recommend a backup of your 7 days saves before you do the update- unless you like starting over.  ich777 is pretty awesome- but backup before update will always be on you- he does this for fun and a few beers- can't really blame him for early docker issues.  I do believe he resolved this since my update didn't wipe them.

Share this post


Link to post
2 minutes ago, ich777 said:

First of all sorry that your savegame is gone.

Can you please give me a little bit more information? When did you first download the docker and when did you update it.

I think on page 4 of this thread is this allready discussed, there was a bug in the container (since i don't have the game i don't know where the savegames were and this was fixed later on with the help of a few people).

 

You can try to completely delete the container (also delete the complete serverfolder) and download it again from the Community Applications (there should be also a few new options in the template).

 

Sorry for the bad news and inconvenience, this should not happen anymore with the new container.

No biggie on the save game, it happens and gives a chance to make things better. I will do a better job of backing up.

 

I installed the docker earlier this month and the new update for the game came out yesterday it seems.

 

I created a new container based off the template and changed the install path so it would re-download the game and it still had the same issue.

 

I will go look for the page 4 thread.

Share this post


Link to post
1 minute ago, jordanmw said:

I recommend a backup of your 7 days saves before you do the update- unless you like starting over.  ich777 is pretty awesome- but backup before update will always be on you- he does this for fun and a few beers- can't really blame him for early docker issues.  I do believe he resolved this since my update didn't wipe them.

Yeah, the deleted saved game is on me I should know better but you know. Do as I say not as I do.

Share this post


Link to post

@AKGeek Then i think you've got the very first version of the docker where the problem exists... Can you try if the save is everytime deleted if you update or change the docker, the problem should be resolved, i think. If it erases the save everytime further investigation is needed.

Share this post


Link to post
34 minutes ago, ich777 said:

@AKGeek Then i think you've got the very first version of the docker where the problem exists... Can you try if the save is everytime deleted if you update or change the docker, the problem should be resolved, i think. If it erases the save everytime further investigation is needed.

I think I understood what you were saying. I deleted the container and went back to the apps page and was able to re-download the docker image and it seems to have worked where I can play the game again though save game is still gone (no biggie).

 

How do the updates work for the template so I know I have the latest version?

 

Also I think you are doing good work on this project.

Share this post


Link to post
7 hours ago, AKGeek said:

I think I understood what you were saying. I deleted the container and went back to the apps page and was able to re-download the docker image and it seems to have worked where I can play the game again though save game is still gone (no biggie).

Yes exactly, but you won't get back the old savegame, try to make a new map and the savegame should be inside of your server folder (that was not the case bevore the update, my fault...).

 

7 hours ago, AKGeek said:

How do the updates work for the template so I know I have the latest version? 

If you delete the docker and pull the new image you will have the latest version, since there is only one version.

 

7 hours ago, AKGeek said:

Also I think you are doing good work on this project.

Thank you and sorry for the inconvenience.

Share this post


Link to post
4 hours ago, dave234ee said:

be good if we could get a Mordhau :)

I don't own the game but i've made a docker, please test it, i can't get it to show up in the steam servers list, please check if you can connect (I think there is a port configuration error but i've can't find any usefull informoation wich ports to use TCP or UDP i think the are all UDP 7777, 27015, 15000).

 

Name: MordhauDocker

Password: Docker

 

Can you see if you can find it in the server list? Since i don't own the game it's a little bit tricky to test...

Share this post


Link to post
25 minutes ago, dave234ee said:

cant seem to see it on the list your ports are correct hmmm

I think i must look into this, it has something to do with the port forwarding but i don't know wich ports are the right ones. :D

i will report back when the docker is working.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.