Ultimate UNRAID Dashboard (UUD)


Recommended Posts

On 1/7/2022 at 4:05 AM, falconexe said:


Welcome! I answered this in the release notes. Try right clicking any broken picture and open that link in a new tab. UNRAID should then prompt you to log in. Once you are logged into this secondary tab, go back to the UUD and refresh the dashboard “F5” or use the browser controls. Then simply close that other tab you used to authenticate (you don’t need to keep it open). As long as you don’t clear your browser cookies, you should be good to go. Glad you are making progress and enjoying the UUD.

 

 

Happy New Year everyone!!!

Hello, Thank you for your reply. And happy new year of course :D

 

I tried this:

  

On 3/20/2021 at 10:25 PM, falconexe said:

Docker/VM Images and the Grafana Dynamic Image Panel Plugin Issues:

 

 

There are a couple of things I noticed during development that are some quirks regarding the third party dependencies and plugins that we have to use to show all of this pretty data.

 

One of the biggest issues I immediately found had to do with browser certificate security and the Image Panel Plugin. Many of you may have run into an issue by now where the Docker/VM images do not show up and only the item words do. It will look something like this:

 

 

932477395_UnraidAPIImagesBroken.thumb.png.838972e1cd566cbff72e844d506c532e.png

 

 

This is due to the plugin not recognizing the authentication to the UNRAID web front end where these images live. We need to help it out the first time around. This fix will last until the browser cookies get wiped or you delete your web history. 

 

In order to fix this (this example is Chrome, but this workflow will also work on FireFox and other browsers), you need to right click any one of the items, and open the image/link in a new window.

 

Chrome Example:

518433523_UnraidAPIImagesFix01.thumb.png.d320205dd4e0a8f541dcc04b31bd0c1d.png

 

Firefox Example:

image.thumb.png.4568cb136b7f69296d1e5722f94f5ed9.png

 

 

Next, you will be presented with the UNRAID login page. Enter your credentials and you will land on your UNRAID web GUI homepage.

 

 

791359097_UnraidAPIImagesFix02.png.3e0ea8045f93a535962574e8996299fe.png

 

Now go back to the Grafana UUD 1.6 dashboard tab and refresh it. The Docker/VM images should magically appear. You can now close that second UNRAID tab you opened.

 

 

2091185834_UnraidAPIImagesFix03.thumb.png.44becf06485435d4515bf1b266c8222c.png

 

 

From what I can tell, this has something to do with the SSL certificate and the dynamic autogenerated URL that the UNRAID web GUI uses (if you chose to secure it). The image plugin just can't handle it natively. If anyone has a better fix for this, please let me know and I will incorporate it into the UUD.

 

 

Regarding how these image panels actually work, YOU WILL NEED TO ENTER YOUR SERVER IP into each of the image panels. You can do this by editing the panel and going to the right side settings area. Finally, modify the URL > Base URL IP address. If you are using SSL with your UNRAID Web GUI, stick with "https://", if you are not, then use "http://".

 

 

image.png.56bf6f3d8904f569fd32cf43b1772b75.png

 

 

But it did not show any Images. i Tried the https://xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx.unraid.net

 

and https://xxx.xxx.xxx.xxx

 

Tried https and http

 

Non of these worked i tried different browser.

 

BTW what do you mean with.

 

You need to adjust the IP address in the query (server).

 

Edited by [RIVINS]
Link to comment

Is this completely incompatible with InfluxDB v2.0?

 

I have Unraid sending data to InfluxDB as I can see it using the influx explorer, but the dashboards are empty. 

 

Before I spend more time troubleshooting I just want to know if Influx v1.x is absolutely necessary or not.

 

Thanks!

Link to comment

I think that the dashboard is designed for 1.x, but I haven't tested 2.0 at all.  If I recall, when the Influx upgrade got pushed out, a bunch of people had issues and rolled back to a 1.x version to keep things working.  Unless you really want to use Flux for your queries, Influx 1.x is probably more compatible with a lot of Grafana community dashboards, and better documented. I've stayed on 1.8 and have yet to see a compelling reason to upgrade as the older versions still get security updates.

 

To get the specific Docker version in UNRAID, edit the docker options and put influxdb: 1.8 (or 1.10, whatever you want) in the Repository field.

Edited by Ludditus
add docker explanation
Link to comment
  • 3 weeks later...

So on my dashboard at the top. Unraid API data source is empty what settings and where do I need to fix to get that working.

Just installed everything and running version 1.6 now. Not everything is showing data but a lot of it is. If you need screen shots or any more information let me know.

 

Found the instruction in here for this but unable to get unraid api to work.

 

Edited by Jurak
Link to comment

this looks awesome. I am trying to get this setup on a server I already have grafana/telegraf/influx/etc on. 

 

I'm still real new to grafana/ etc...   But wondering how can I point this to an external server with telegraf/influx 1.8 and grafana on it? 

 

I'll probably have more questions, but hopefully not. 🙂

Link to comment
On 1/27/2022 at 7:19 PM, Jurak said:

Ok I have gotten the unraid api to work but in the dashboard for the list of dockers. Its not showing the icons.

image.png.6507d8191b93b169740bad5bcf5ef462.png

What do i need to change to get those to show up correctly?

I had to Edit the Dockers (Running) and Dockers (Stopped) changed base url to http://10.10.10.10 (My server ip adress)

Sample.jpg

Link to comment
On 1/27/2022 at 11:19 AM, Jurak said:

 

Ok I have gotten the unraid api to work but in the dashboard for the list of dockers. Its not showing the icons.

image.png.6507d8191b93b169740bad5bcf5ef462.png

 

What do i need to change to get those to show up correctly?


Both ppl....

Read post 

 

Edited by TRusselo
  • Thanks 1
Link to comment

PROBLEM 1 -

 

So im using GUS - manually updating to UUD 1.6

On 9/14/2020 at 2:32 AM, falconexe said:
  • Telegraf Plugin - [[inputs.smart]]
    • Enable in telegraf.config
      • Also Enable "attributes = true"
    •  
    • Bash Into Telegraf Docker and Run "apk add smartmontools"
  • Telegraf Plugin - [[inputs.ipmi_sensor]]
    • Enable in telegraf.config
    • Bash Into Telegraf Docker and Run  "apk add ipmitool"

 

instructions say to APK add smartmontools and impitool

 

so I open Terminal on GUS....

and type command....
 

Bash APK not found

image.png.01b236dbe03f0182aa7a28ad32e81960.png

 

What am I doing wrong?

 

PROBLEM 2 FIXED IN NEXT POST

cant get SSD data to work.

edited values as instructed

image.thumb.png.4199a5a301348409db66ea5897cf583b.png

 

 

PROBLEM 3:  - FIXED!!! see next post.

cant get cache to show data.

image.thumb.png.31dcec1a8716dd3535f7f2a33f59ee5d.png

 

 

PROBLEM 4 :

unraid API docker is being a PITA.

had it working last year....  wont wrok this weekend.
error 503 in unraid API logs...
awaiting help in its thread.

image.png.1725389a694d247d30d1e5588c827022.png

Edited by TRusselo
Link to comment

OK fixed PROLEM 3 above !!!

it worked fine in UUD 1.3  so i compaired the queries....

 

in UUD 1.6  I had to change CACHE USED query path 

from 

SELECT last("used") FROM "disk" WHERE ("path" = '/mnt/cache') AND $timeFilter GROUP BY time($__interval)

to

SELECT last("used") FROM "disk" WHERE ("path" = '/rootfs/mnt/cache') AND $timeFilter GROUP BY time($__interval)

 

 

 

Had to edit SSD LIFETIME WRITES

to 

SELECT "raw_value" *512/1000000000000 FROM "smart_attribute" WHERE ("name" = 'Total_LBAs_Written' AND "serial_no" = 'S3Z8NB0M513251W') AND $timeFilter

 

 

edit SSD LIFE USED

to

SELECT "raw_value" *512/10000000000/600 FROM "smart_attribute" WHERE ("name" = 'Total_LBAs_Written' AND "serial_no" = 'S3Z8NB0M513251W') AND $timeFilter

 

edit SSD TEMP to

SELECT "raw_value" FROM "smart_attribute" WHERE ("name" = 'Airflow_Temperature_Cel' AND "serial_no" = 'S3Z8NB0M513251W') AND $timeFilter

 

 

SSD READS....
MY ssd does not report DATA READ or LBAs READ

sad panda

image.png

Edited by TRusselo
Link to comment

Had to edit ARRAY STORAGE

 

from 

SELECT last("used")  / 1000000000000 AS "Used", last("free")  / 1000000000000 AS "Free", last("total")  / 1000000000000 AS "Total", last("used_percent") AS "Used %" FROM "disk" WHERE ("path" =~ /.*mnt|\/var\/lib\/docker/ AND "path" !~ /\/var\/lib\/docker\/btrfs.*/ AND "path" <> '/rootfs/var/lib/docker' AND "path" !~ /rootfs*/ AND "path" <> '/var/lib/docker' AND "fstype" <> 'rootfs' AND "path" <> '/mnt/user' AND "path" <> '/mnt/user0' AND "path" <> '/mnt/cache' AND "path" !~ /^$Path_Unassigned$/ AND "host" =~ /^$Host$/) AND $timeFilter GROUP BY "path", "device", "fstype"

to

SELECT last("used")  / 1000000000000 AS "Used", last("free")  / 1000000000000 AS "Free", last("total")  / 1000000000000 AS "Total", last("used_percent") AS "Used %" FROM "disk" WHERE ("path" =~ /.*mnt|\/var\/lib\/docker/ AND "path" !~ /\/var\/lib\/docker\/btrfs.*/ AND "path" <> '/rootfs/var/lib/docker' AND "path" !~ /disabled*/ AND "path" <> '/var/lib/docker' AND "fstype" <> 'rootfs' AND "path" <> '/rootfs/mnt/user' AND "path" <> '/rootfs/mnt/user0' AND "path" <> '/rootfs/mnt/cache') AND $timeFilter GROUP BY "path", "device", "fstype"

 

 

more /rootfs/  adding

and had to DISABLE   /rootfs*/
and had to DELETE  the - AND "path" !~ /^$Path_Unassigned$/ AND "host" =~ /^$Host$/

 

image.thumb.png.cddb58a1643c49832a6c3bd351b2ecb6.png

Link to comment

PROBLEM 4 -   

 

SOLVED:
my unassigned drive is mounted to a VM and is NTFS.  so its a NO-GO.  it wont show up in UUD.

 

Unassigned Drives

 

cant figure out what to fix

I feel like its the Unassigned drives path.... and I did try adding /rootfs/ like it fixed my cache storage panels.

no fix this time.

 

image.thumb.png.617cab0352ed5bd8c080cfdc63ea539a.png

 

 

I had to remove references to UNASSIGNED drive path for any ARRAY panels to work

image.thumb.png.ec4cb41372975528495411f712c8b428.png

 

 

SOLVED:
my unassigned drive is mounted to a VM and is NTFS.  so its a NO-GO.  it wont show up in UUD.

Edited by TRusselo
Link to comment

DEVELOPER UPDATE:

 

@SpencerJ

 

Hey everyone. It's been a while since I actually messed with the UUD. I got remarried, and she's down with the UUD, so... we'll see if I get back into this. Today I am messing around with some new SSD Cache panels within a new style of header up top being more WIDE and CACHE focused. I just installed a new 2TB cache NVMe drive, so now was a great time to dive back in.

 

image.thumb.png.d4ab83aea3f254ea5307a48f939f75ea.png

 

I'm aware of Influx DB 2.0 and a number of changes that have occurred since UUD 1.6 was released. Perhaps when I get some time, I will see if upgrading the UUD to support Influx DB 2.0 is even possible. I also still had a few more ideas up my sleeves for UUD 1.7, IF I decide to proceed with it.

 

 

UUD 1.7 Ideas:

 

  • Nvidia GPU Panels
  • Realtime Log Panels Using an UNRAID Log Server
  • Actual Working Buttons to Control UNRAID via the UUD

 

 

Let me know your thoughts. In the meantime, I'll be getting back to dabbling in this stuff. Cheers!

Edited by falconexe
  • Like 2
  • Thanks 1
Link to comment

I added Read values to the Daily SSD Writes (Last 24 Hours). This is what it looks like when the MOVER offloads 2TB from Cache to the array. My new 2TB Samsung 970 Evo Plus is solid. Pretty Sweet graph.

 

 

image.thumb.png.d80e89da3a9da639bc9040d261153570.png

 

 

Edited by falconexe
  • Like 1
Link to comment

What the heck. I am kind of a Cache nerd, so I added a CURENT I/O graph to round it as well. I also added Write/Read stat panels to each of the 3 durations (Current, Day, & Year). Finally, I moved the Cache storage metrics to the Cache area, and then put a Lifetime Power On Time stat panel to round it out. I like it, and it suites my needs and focus on Cache health.

 

image.thumb.png.f39e907fbc13416efd9005b7bb7402da.png

 

 

@SpencerJ

 

 

Edited by falconexe
  • Like 2
Link to comment

So I looked into InfluxDB 2.0 and it uses a new query language called "Flux". So far, I have not seen any advantages over the InfluxDB 1.X "InfluxQL", with regards to the UUD. If fact, it poses some limitations as seen below:

 

image.png.d6eb4e27f5eb6c33b26998854f834708.png

 

For a while, InfluxDB 2.0 did not even support InfluxQL, which the UUD is written in. Now it does, but only supports read only queries.

 

 

Sources:

 

 

  • So, does any one know WHY I would re-develop UUD 1.7 into "Flux" for InfluxDB 2.0?

 

  • What would be the benefit?

 

  • What are the opportunities with InfluxDB 2.0 and the "Flux" query language (QL)?

 

  • I have not deep dived into it yet, but for the needs and requirements of the UUD, I don't see this as a must have, YET. Unless of course "InfluxQL" becomes unsupported. In that case, I will have no choice.


Let me know your thoughts.

 

 

Edited by falconexe
  • Like 1
Link to comment

Dude, I'm really freaking pumped!!! I FINALLY figured this thing out that has been bugging me for over a year. Remember how I added a Plex Log with real time statistics of streams? Well I suppressed the % Viewed because I could never get it to work right.

 

The issue was that over the 10 minute timeframe (each single data point = 10 minutes), there would be multiple values for % Viewed. For instance, if 1% equals 1 minute, you would have 10 different percent viewed data points (rows in the table) for that single time data point like 12:10 (X10 Percent Viewed rows between 12:00 - 12:10). Needles to say, this was freaking ugly because it would 10X the data for each data point. So instead of 6 rows for an hour, I would end up with 60 (per user)!

 

Tonight, I bring you the FINISHED PLEX Log with TRUE gradient gauge coloring based on ACTUAL % Viewed, and only 1 Data Point for Each 10 Minute timeframe per user. Viola!

 

image.thumb.png.3e52e766127a593a9f600f6dcb9ce7b1.png

 

image.thumb.png.c743f63b568db01b3046a7c5bc99ed95.png

 

 

Here is what you need to do in order for this to work correctly.

 

To Get the Progress % to Show Up Only Once For Each 10 Minute Period:

 

  • Add the "tag_progress_percent" Field to the Table:image.thumb.png.ef1663a3fca63920c43b8d5c6b49a7eb.png

 

  • Add a Table Transformation of OUTER JOIN By "Time" Which Reduces Multiple Data Points That Equal the Same Time in a Series, and Instead Shows Only the Last Value at that Time.image.thumb.png.94c315c386999c75ca992833c812858c.png

 

 

To Get the Sweet Dynamic Color Gauges Based on Actual Percent Viewed:

 

  • Add a Field Override to the Field "Progress %" with the Following Settings:image.thumb.png.c92673ed523e9877778b563e3c8eb838.png

 

 

 

@SpencerJ

 

 

Edited by falconexe
  • Like 1
Link to comment

Alright, after reviewing historical data, I have determined that 92% completed is considered "watched" and is about where people decide to bail on the credits. This seems to hold true for all types of media. So, in order to get this granularity, I did go back to 1 minute intervals and adjusted the thresholds accordingly. You end up with all of the colors on a clean stream which looks like this. Now that I have this dialed in, I am moving on to something else.

 

 

image.png.91f4914556cbf1c760924993f887a9b3.png

 

image.thumb.png.883a16289de083a7ac55b8543349f2ef.png

 

image.thumb.png.9ab0f88ea414c1f6360c0d048e5d097d.png

 

 

Link to comment

This is the new header of UUD 1.7. It is sleeker with more info laid out in a balanced design with everything pertinent to UNRAID server health at a glance. If something bad is going down, you will see it here first. 😁

 

 

image.thumb.png.512307081d29bc156c7173ed8106c874.png

 

 

Edited by falconexe
  • Like 2
Link to comment

Hello everyone,

 

I hope I will make myself understood correctly I use a translator

 

First of all, a big thank you to falconexe for the work done to create the various visualization tables

 

I am stalling on the establishment of information concerning the temperature, the voltage and the speed of the fan

 

Not having the IPMI function I followed the instructions to use the sensors

 

Is it necessary to modify a parameter or only indicated sensor in the following line on Grafana?

 

SELECT last("value") FROM "ipmi_sensor" WHERE ("unit" = 'degrees_c' AND "host" =~ /^$Host$/) AND $timeFilter GROUP BY time($__interval), "name"

 

Thank you in advance for your help

 

Sans titre12.jpg

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.