[support] Spants - NodeRed, MQTT, Dashing, couchDB


433 posts in this topic Last Reply

Recommended Posts

  • Replies 432
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Ya....just go into the Node-Red Docker template and change the repository as I said above and hit apply.......That's all I had to do. Love it

This is where I will be hosting some dockers that I find useful, built on a Phusion or Linuxserver base. Add to your templates if you wish.   https://github.com/spants/unraidtemplates/

Does anyone here know how to update node.js version in the Node-Red Docker Container?   docker exec -it NodeRed-OfficialDocker /bin/bash node -V The command above shows I'm on v

Posted Images

On 1/3/2021 at 11:20 PM, spants said:

You may have to keep changing it as the template is not refreshed on the update. Check your /boot/config directory structure for the cached templates and also edit it there


Sent from my SM-N976B using Tapatalk
 

The latest update (v1.2.7) went fine and I didn't have to do anything by hand. Cheers!

Link to post
  • 2 weeks later...

 

@Lebowski

sorry for the delay in the reply.  please try this fix:

Change the permissions of the appdata directory for your MQTT data:

 

for example: 

chown -R nobody:users /mnt/user/appdata/MQTT

 

and you should be ok.

 

Edited by spants
Link to post

@spants

 

Sure, here is the config: If I need to change it to false that's fine. I wasn't even sure if its an issue as everything is functioning just fine.

 

 

# Place your local configuration in /config/conf.d/

retry_interval 20
sys_interval 10
store_clean_interval 10
max_inflight_messages 40
max_queued_messages 200
queue_qos0_messages false
message_size_limit 0
allow_zero_length_clientid true
persistent_client_expiration 3m
allow_duplicate_messages false
autosave_interval 60
autosave_on_changes false
allow_anonymous false

persistence true
persistence_file mosquitto.db
persistence_location /config/data/

user mosquitto

# Port to use for the default listener.
listener 1883

listener 9001
protocol websockets

log_dest stderr
log_type all
connection_messages true
log_timestamp true

include_dir /config/conf.d

# If the password.mqtt file is empty, this has no effect.
allow_anonymous true

# DO NOT CHANGE THIS LINE BELOW!!!
password_file /config/passwords.mqtt

 

Edited by Lebowski
Link to post

about two weeks ago i setup this docker for my smarthome stuff.
since then it was ideling cause i haven't setup my devices yet.

Today i checked unraid and saw the docker stopped.
i wanted to set my devices up this weekend but i cant get the docker up again.
every time i start the docker i get this:
 

Warning: store_clean_interval is no longer needed.

1611308988: Error: No error information.

1611308988: Error: Couldn't open database.

Warning: store_clean_interval is no longer needed.

1611308997: Error: No error information.

1611308997: Error: Couldn't open database.


After this error the docker stops itself again.

i havent changed anything. no update, no config changes.

i tryed to remove the docker completly and set it up from scratch but still the same error.
any idea?

Link to post
7 hours ago, Tsumitsuki said:

about two weeks ago i setup this docker for my smarthome stuff.
since then it was ideling cause i haven't setup my devices yet.

Today i checked unraid and saw the docker stopped.
i wanted to set my devices up this weekend but i cant get the docker up again.
every time i start the docker i get this:
 


Warning: store_clean_interval is no longer needed.

1611308988: Error: No error information.

1611308988: Error: Couldn't open database.

Warning: store_clean_interval is no longer needed.

1611308997: Error: No error information.

1611308997: Error: Couldn't open database.


After this error the docker stops itself again.

i havent changed anything. no update, no config changes.

i tryed to remove the docker completly and set it up from scratch but still the same error.
any idea?

 

Does your MQTT directory look like this?:

image.png.fa371c3abcb4c9cab7b11bde96892c3b.png

 

You can also try setting open permissions on that directory:

 

cd /mnt/user/appdata

chmod -R 777 MQTT

 

 

 

Link to post
8 minutes ago, spants said:

Does your MQTT directory look like this?

Yes it dose look like this.

 

 

9 minutes ago, spants said:

You can also try setting open permissions on that directory:

 

cd /mnt/user/appdata

chmod -R 777 MQTT

Still the same error.

Link to post
1 minute ago, Tsumitsuki said:

Yes it dose look like this.

 

 

Still the same error.

 

if you dont need persistance, please edit the mosquitto.conf:

 

persistence false
persistence_file mosquitto.db
persistence_location /config/data/

 

and restart MQTT...

Link to post
7 minutes ago, spants said:

 

if you dont need persistance, please edit the mosquitto.conf:

 

persistence false
persistence_file mosquitto.db
persistence_location /config/data/

 

and restart MQTT...

Do i need it? I don't know.
For what would i need it as persistend?

Sorry for the dumb question, but first time using something like mqtt for me.

And yes, without the db it starts just fine.

Link to post

If you use RETAINED topics, it can write them to a temporary db in case of restarting. Most people dont need this.

There seems to be a permissions issue with some dockers, I should take a look at this as I made it some time ago (it just works for me!).
I saw on another thread that someone had similar issues on another docker and was advised to run a script (attached). It will reset the directory permissions on the appdata directory. Run it at your own risk (I just tried it)

 

fixAppdataPerms.sh

Link to post
  • 3 weeks later...

Hello

 

I would like to use Watch Node / File In Node in Node Red to read files, but I am not sure how I can access my Unraid shared folders? I tried "\\192.168.1.10\ShareName" but Node Red doesn't see it / can't access. Do I need to somehow map those share folders in the Node Red docker configuration?

 

Thanks!

Link to post
On 2/7/2021 at 10:28 PM, gulo said:

Hello

 

I would like to use Watch Node / File In Node in Node Red to read files, but I am not sure how I can access my Unraid shared folders? I tried "\\192.168.1.10\ShareName" but Node Red doesn't see it / can't access. Do I need to somehow map those share folders in the Node Red docker configuration?

 

Thanks!

You might try `smb://192.168.1.10/ShareName` or like you mentioned try to add the necessary share in your Node-RED template.

Link to post
On 2/7/2021 at 12:28 PM, gulo said:

Hello

 

I would like to use Watch Node / File In Node in Node Red to read files, but I am not sure how I can access my Unraid shared folders? I tried "\\192.168.1.10\ShareName" but Node Red doesn't see it / can't access. Do I need to somehow map those share folders in the Node Red docker configuration?

 

Thanks!

When you create or edit docker containers you can mount folders and files on the host to locations inside the container.

 

Example: I mount my /mnt/user/share/media directory to /media_share in the container for storing timelapse photos.

Link to post
On 2/9/2021 at 6:32 PM, Skylord123 said:

When you create or edit docker containers you can mount folders and files on the host to locations inside the container.

 

Example: I mount my /mnt/user/share/media directory to /media_share in the container for storing timelapse photos.

 

Oh, this was easier than I thought

 

Thank you Skylord123 and UNOPARATOR!

Link to post
  • 1 month later...

I have recently run into a snag that i believe has been determined to be related to the version of Node.JS used by Node red in the docker. Is there any way to upgrade that to a newer version?

Link to post
On 3/30/2021 at 1:29 PM, mavrrick said:

I have recently run into a snag that i believe has been determined to be related to the version of Node.JS used by Node red in the docker. Is there any way to upgrade that to a newer version?

 

Which version of NodeJS do you need? You can change the version by using the appropriate tag in the Repository field:

https://hub.docker.com/r/nodered/node-red/tags?page=1&ordering=last_updated

 

Link to post
  • 1 month later...
On 3/31/2021 at 12:52 PM, spants said:

 

Which version of NodeJS do you need? You can change the version by using the appropriate tag in the Repository field:

https://hub.docker.com/r/nodered/node-red/tags?page=1&ordering=last_updated

 

 

I ended up just setting up a VM and installing everything manually. It was easy enough. I needed atleast Node.js 12 i think, and maybe Node.JS 14. Thanks for advice. 

Link to post
28 minutes ago, mavrrick said:

 

I ended up just setting up a VM and installing everything manually. It was easy enough. I needed atleast Node.js 12 i think, and maybe Node.JS 14. Thanks for advice. 

No problem. If you needed Node.js 12 - just use

 

nodered/node-red:latest-12

 

in the repository field of the template

Link to post
  • 2 weeks later...
On 5/12/2021 at 9:51 AM, TheBurgundyBear said:

For the life of me, I can't figure out how to get the timezone to be correct in Node-RED! Server time is correct. Has anyone run into this issue and resolved it? 

Looks like it was as easy as opening a console in the container and typing "TZ=America/Chicago"

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.