Jump to content
binhex

[Support] binhex - rTorrentVPN

2501 posts in this topic Last Reply

Recommended Posts

Regarding the endpoints, is it possible that this is similar to a hostname issue that happened with nyc one a few weeks back?

 

The image was stable until it was restarted, so I'm almost positive it's a DNS issue. If it's a DNS issue, if we knew the european locations IP addresses?, could we modify the config file to use that instead of the hostname? That being said; spain.privateinternetaccess.com for example does resolve to a ping, so maybe it's not that. For now I guess everyone is on Canada.

Share this post


Link to post

I saw someone else post this same error a few days ago, but not additional messages were related to it.

 

I've been running rTorrentvpn under a docker container for months now with zero problems. I updated earlier this morning to the latest image and restarted and now my ruTorrent web won't open up correctly. I know my rtorrent client is running, I've got 1000+ torrents seeding and I can see them validated on the trackers without problems.

[07.08.2020 13:53:11] WebUI started.

[07.08.2020 13:53:25] JS error: [http://rutorrent:XXXXX@x.x.x.x:9080/ : 5145] Uncaught TypeError: Cannot read property 'flabel_cont' of undefined

 

Log attached.

supervisord rs5050.log

Share this post


Link to post

Is FLOOD WEbUI still available in this docker?  seems I can't have it running.  Seems to be removed?

Share this post


Link to post
Is FLOOD WEbUI still available in this docker?  seems I can't have it running.  Seems to be removed?
Flood was removed about a year ago and unfortunately will not be re added, this is due to constant breakage on install which became a real pita.

Sent from my CLT-L09 using Tapatalk

Share this post


Link to post
Just now, Rinzler said:

Realize this isn't PIA thread or subreddit, but the options seem to be dropping like flies. Just lost netherlands earlier too. Time for a new VPN? what's going on there?

they switched it to switzerland basically it seems

Share this post


Link to post
Posted (edited)

Cant get air vpn to work with Unraid. I think is the port forwarding and how I put it in editing.

 

Edited by stormense

Share this post


Link to post
Posted (edited)

Hey guys, i've been searching this post for pages and pages but i just can't seem to figure out how to set the port range for Rtorrent.


I know that changing the port on the webui won't permanently change the port since it only changes the port for that instance. Everytime i change the port in the webui and restart rutorrent the port reverts back.

 

So i went into the rtorrent.rc file and tried setting the port as follows:

 

#network.port_range.set = 49152-65535
#port_range = 49152-65535
 

i also tried with a space:

 

# network.port_range.set = 49152-65535
# port_range = 49152-65535

 

However this didn't work neither...

So i tried setting port in the docker settings itself with the same variables:

 

NETWORK.PORT_RANGE.SET = 49152-65535

PORT_RANGE = 49152-65535

 

still no success.

What am i doing wrong guys? can anyone help?

I have DHT disabled since my private trackers require me to do so.
I'm also using OPENVPN, not Airvpn.

 

Thanks in advance ❤️

rtorrent port img.jpg

Edited by wookieleader

Share this post


Link to post
36 minutes ago, wookieleader said:

Hey guys, i've been searching this post for pages and pages but i just can't seem to figure out how to set the port range for Rtorrent.


I know that changing the port on the webui won't permanently change the port since it only changes the port for that instance. Everytime i change the port in the webui and restart rutorrent the port reverts back.

 

So i went into the rtorrent.rc file and tried setting the port as follows:

 

#network.port_range.set = 49152-65535
#port_range = 49152-65535
 

i also tried with a space:

 

# network.port_range.set = 49152-65535
# port_range = 49152-65535

 

However this didn't work neither...

So i tried setting port in the docker settings itself with the same variables:

 

NETWORK.PORT_RANGE.SET = 49152-65535

PORT_RANGE = 49152-65535

 

still no success.

What am i doing wrong guys? can anyone help?

I have DHT disabled since my private trackers require me to do so.
I'm also using OPENVPN, not Airvpn.

 

Thanks in advance ❤️

rtorrent port img.jpg

one thing is that # comments out the line, so if you know that is the right range then remove the #

Share this post


Link to post
1 hour ago, Cull2ArcaHeresy said:

one thing is that # comments out the line, so if you know that is the right range then remove the #

So stupid of me..

 

Thanks for responding!

 

It worked, the port is now changed on rutorrent but it still shows port closed.

I think this has to do because rtorrent is running behind a VPN?

 

is there a fix for this or is it too complicated?

 

Regards,

Share this post


Link to post
29 minutes ago, wookieleader said:

So stupid of me..

 

Thanks for responding!

 

It worked, the port is now changed on rutorrent but it still shows port closed.

I think this has to do because rtorrent is running behind a VPN?

 

is there a fix for this or is it too complicated?

 

Regards,

does your vpn have port forwarding? i use pia and sometimes pia and rtorrent will pick the same port and it will show open, but most the time it shows closed. If i found the list of pia port ranges again (but was old list so prob bad) i would set my range to match, but be it pia or something else, port open or closed i get the same connection where it will be full speed for a while now and then but most the time it is <1m up/down. i did not buy pia for this, already had it.

Share this post


Link to post
Posted (edited)
On 8/12/2020 at 9:10 AM, stormense said:

Cant get air vpn to work with Unraid. I think is the port forwarding and how I put it in editing.

 

Answer my self : On Air VPN website go to The Client Arena and generate ovpn-file, in my case AirVPN_Sweden_UDP-443.ovpn, and put it here:

/mnt/user/appdata/binhex-rtorrentvpn/openvpn

 

The client start but not the WebUI: ERR_CONNECTION_REFUSED

 

Edited by stormense

Share this post


Link to post
Posted (edited)
22 hours ago, stormense said:

Answer my self : On Air VPN website go to The Client Arena and generate ovpn-file, in my case AirVPN_Sweden_UDP-443.ovpn, and put it here:

/mnt/user/appdata/binhex-rtorrentvpn/openvpn

 

The client start but not the WebUI: ERR_CONNECTION_REFUSED

End of log: /usr/local/bin/init.sh: line 346: /config/nginx/security/rpc2_pass: No such file or directory

Can only get the .ovpn file from the generator.

--------- EDIT--------

Never mind, I get it to work with Binhex Deluge with same settings, but I like Rutorrent way better.

 

Quote

 

 

Edited by stormense

Share this post


Link to post
On 8/7/2020 at 7:11 PM, rs5050 said:

I saw someone else post this same error a few days ago, but not additional messages were related to it.

 

I've been running rTorrentvpn under a docker container for months now with zero problems. I updated earlier this morning to the latest image and restarted and now my ruTorrent web won't open up correctly. I know my rtorrent client is running, I've got 1000+ torrents seeding and I can see them validated on the trackers without problems.


[07.08.2020 13:53:11] WebUI started.

[07.08.2020 13:53:25] JS error: [http://rutorrent:XXXXX@x.x.x.x:9080/ : 5145] Uncaught TypeError: Cannot read property 'flabel_cont' of undefined

 

Log attached.

supervisord rs5050.log 20.5 kB · 0 downloads

I had the same issue after update.  Browser (Vivaldi) would not load the client and had this JS error.  It worked fine in Chromium, and was fine after I unpinned the tab in Vivaldi and reloaded the page, ensuring adblock+tracker protection was off.

Share this post


Link to post
On 8/13/2020 at 6:46 PM, Cull2ArcaHeresy said:

does your vpn have port forwarding? i use pia and sometimes pia and rtorrent will pick the same port and it will show open, but most the time it shows closed. If i found the list of pia port ranges again (but was old list so prob bad) i would set my range to match, but be it pia or something else, port open or closed i get the same connection where it will be full speed for a while now and then but most the time it is <1m up/down. i did not buy pia for this, already had it.

I also get a very good download speed with the port closed, but i am wondering if the upload speed could be better for seeding if the port is open.
 

I use NordVPN but i just googled it, they do not currently offer port forwarding, so i guess it's not possible.

 

Thanks for thinking with me on this, and your help!

 

Regards,


Newbyleader

Share this post


Link to post

Hello there,

 

First thanks to binhex for his work. I've found this image the easiest way to setup secured rtorrent container in a blink.
Everything is well explained but I'm stuck at the reverse proxy stage. I have an almost working setup, able to connect to local_ip:port from a local computer, i'm facing a 404 when using domain.tld/rutorrent and hitting my nginx reverse proxy.

I've found the tip about php file (nginx into the container and nginx as reverse proxy). 

I've just remarked one thing that could explain I've misconfigured something (unfortunately I don't have logs on this computer ; but I could provide them later), it tries to hit path_to_rutorrent/rutorrent/rutorrent/. 

Will be glad to read something I've missed into documentation that could help to solve this issue. Note that i have linuxserver/letencrypt + organizr-v2 + tautulli + ombi working well with sso enabled so I consider my nginx configuration maybe not so bad. 

Thank you for any ideas, 

Share this post


Link to post

Hi!

 

Recently (started maybe a few weeks ago, but can't remember updating the docker) my setup stopped tracking Finished status of torrents. Finished column (from plugin seedingtime) is empty for new torrents, history tab does not track finished status and therefore Pushbullet events for finished does not work. 

 

Anyone noticed the same or know of a fix? 

 

I tried to update to latest docker revision today (ruTorrent 3.10) but the issue persists.

Share this post


Link to post
22 hours ago, erqzor said:

Hello there,

 

First thanks to binhex for his work. I've found this image the easiest way to setup secured rtorrent container in a blink.
Everything is well explained but I'm stuck at the reverse proxy stage. I have an almost working setup, able to connect to local_ip:port from a local computer, i'm facing a 404 when using domain.tld/rutorrent and hitting my nginx reverse proxy.

I've found the tip about php file (nginx into the container and nginx as reverse proxy). 

I've just remarked one thing that could explain I've misconfigured something (unfortunately I don't have logs on this computer ; but I could provide them later), it tries to hit path_to_rutorrent/rutorrent/rutorrent/. 

Will be glad to read something I've missed into documentation that could help to solve this issue. Note that i have linuxserver/letencrypt + organizr-v2 + tautulli + ombi working well with sso enabled so I consider my nginx configuration maybe not so bad. 

Thank you for any ideas, 

Hello, 

I've found my issue, so I'm sharing the issue resolution and some tips for beyond.

 

1- You must follow the installation guide (strictly, yes!, seriously, strict).
2- You must ensure the vpn settings are correct on server side (I've waste a lot of time, when the solution was into the .ovpn file)
3- You have to dig supervisor.log to find issue.

4- I didn't figure out how to make sso working between rtorrent/rutorrent - organizr (dunno if in fact its possible)
5- Bonus : if you are facing torrent client issue to connect to private tracker, double check your vpn settings, the issue is there (certainly ssl connection breaks; check vpn provider docs; adjust mtu)

 

Thank you binhex for the amazing work. 

Share this post


Link to post
On 8/13/2020 at 6:46 PM, Cull2ArcaHeresy said:

does your vpn have port forwarding? i use pia and sometimes pia and rtorrent will pick the same port and it will show open, but most the time it shows closed. If i found the list of pia port ranges again (but was old list so prob bad) i would set my range to match, but be it pia or something else, port open or closed i get the same connection where it will be full speed for a while now and then but most the time it is <1m up/down. i did not buy pia for this, already had it.


Honestly i've the same case here, image is running fine, port is forwarded (confirmed by port check from vpn provider with curl). Still red and closed. But it's working fine on download (dunno for up btw). I just don't know if it matters to have the green mark in rutorrent gui that tells you the port is open. I really don't know how it works inside the container. Honestly i've seen this green while I have my config broken (couldn't ssl private tracker by example) so afaik it doesn't tell you rtorrent is working it just tells you a port is open or not to listen connection but it's within the container... so... what does it test because it can't really test vpn port isn't it ? 

Share this post


Link to post
12 hours ago, erqzor said:

I just don't know if it matters to have the green mark in rutorrent gui that tells you the port is open

it doesn't matter whatsoever, if you have confirmed the port is open using an external website then thats all the confirmation you should need.

 

having said that i have no issues at all with the built in indicator in rutorrent and it is always green, unless PIA has a wobble, in which case it may go red temporarily before my script kicks it and corrects the issue (restarts openvpn).

12 hours ago, erqzor said:

so afaik it doesn't tell you rtorrent is working it just tells you a port is open or not to listen connection but it's within the container... so... what does it test because it can't really test vpn port isn't it ? 

it tests the incoming port as defined in rutorrent, it uses an external website (https://portchecker.co) to do the check (web scrape) and if the port is open then it is green, if not then its red, and if it cannot contact the website then it is orange, i use the same website to do my own internal check, and it always reports the correct status to me.

 

 

Share this post


Link to post
1 hour ago, binhex said:

it doesn't matter whatsoever, if you have confirmed the port is open using an external website then thats all the confirmation you should need.

 

having said that i have no issues at all with the built in indicator in rutorrent and it is always green, unless PIA has a wobble, in which case it may go red temporarily before my script kicks it and corrects the issue (restarts openvpn).

it tests the incoming port as defined in rutorrent, it uses an external website (https://portchecker.co) to do the check (web scrape) and if the port is open then it is green, if not then its red, and if it cannot contact the website then it is orange, i use the same website to do my own internal check, and it always reports the correct status to me.

 

Thank you for the explanation. As explained I don't use PIA but another VPN provider so i'm using custom preset. The ovpn file work like a charm, eveyrthing seems ok. Still have the red mark at the bottom, like you told I have confirmation from curl within the docker container the port is open. I have test the op against your website using VPN shared ip i'm assigned to and the port is Open. 

Rtorrent is still red. But I shouldn't care, it's just mental. 
Thank you again for your image, best. 

Share this post


Link to post

Hi there.


Sorry if I have missed something really obvious, but I'm trying to use Pyrocore to manage rtorrent so that it only downloads 1 torrent at a time. I followed the config guide to change the torque.ini file, but it isn't having any impact on rtorrent. Is there anything that I need to change in rtorrent.rc or anywhere else so that it is active?

 

Thanks

Share this post


Link to post
Posted (edited)

Is there any recent change regarding auto opening ports with PIA VPN? 

Since I started using PIA the incoming port used on rTorrent was automatically changed after a while on rTorrent to match the port forwarded provided by PIA api.

Since a few days ago I've seen that the red mark is present on all torrent clients and I don't seem to get lots of connections, so it seems that the ports are not being set indeed.

 

Just to clarify: The port used in ruTorrent does not seem to be updated with the forwarded port reported by the rtorrent log when retrieving it from PIA API.

Log trailing with:

 

Quote

2020-08-24 21:50:08,194 DEBG 'watchdog-script' stdout output:
[info] rtorrent incoming port closed, marking for reconfigure
2020-08-24 22:20:21,572 DEBG 'watchdog-script' stdout output:
0
2020-08-24 22:20:25,412 DEBG 'watchdog-script' stdout output:
[info] rtorrent incoming port closed, marking for reconfigure
2020-08-24 22:50:33,843 DEBG 'watchdog-script' stdout output:
0
2020-08-24 22:50:36,721 DEBG 'watchdog-script' stdout output:
[info] rtorrent incoming port closed, marking for reconfigure

 

Edited by Jeffarese

Share this post


Link to post
On 8/2/2020 at 10:56 AM, binhex said:

Change endpoint then, PIA is currently going through a transition to their next-generation network, outages are being experienced.

Sent from my CLT-L09 using Tapatalk
 

Is there any way to get the nextgen port working like with this? https://github.com/thrnz/docker-wireguard-pia/blob/master/extra/pf.sh or just sit tight until we get someting official from PIA.

Share this post


Link to post

I can no longer get this docker to run. Getting the following error

 

Wed Aug 26 21:36:02 2020 ERROR: Cannot ioctl TUNSETIFF tun: Operation not permitted (errno=1)

Wed Aug 26 21:36:02 2020 Exiting due to fatal error

 

Share this post


Link to post
3 hours ago, jrdnlc said:

I can no longer get this docker to run. Getting the following error

 


Wed Aug 26 21:36:02 2020 ERROR: Cannot ioctl TUNSETIFF tun: Operation not permitted (errno=1)

Wed Aug 26 21:36:02 2020 Exiting due to fatal error

 

tun operation not permitted is normally due to not including the following in 'extra paramers' in the edit screen for the docker container:-

--cap-add=NET_ADMIN

or you do not have 'privileged' set to on.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.