Jump to content
Waseh

[Plugin] rclone

433 posts in this topic Last Reply

Recommended Posts

16 minutes ago, Waseh said:

If the curl command doesnt solve it then the fix probably won't work either though since that's the fix im doing 😅
I just updated the plugin with a longer timeout.

Thanks for the quick reply. Strange thing is that it returns that --connect-timeout is an unknown command. Even though the info says it's a valid one. Do you get the same result?

 

EDIT: make a totally fresh install, deleted plugin and all folders. Then installed the beta and got the following result:

Verifying package rclone-2018.08.25-bundle.txz.
Installing package rclone-2018.08.25-bundle.txz:
PACKAGE DESCRIPTION:
Package rclone-2018.08.25-bundle.txz installed.
Downloading rclone
Downloading certs
Download failed - No existing archive found - Try again later
plugin: run failed: /bin/bash retval: 1

EDIT: found the issue, same as before. Can't ping 1.1.1.1 somehow. Really annoying. Will look into my router settings again. Sorry

Edited by Kaizac

Share this post


Link to post

That doesn't really make sense though since that should result in the "No internet - Skipping download and using existing archives" error.
Are you sure you can reach the rclone webpage?

Share this post


Link to post
3 minutes ago, Waseh said:

That doesn't really make sense though since that should result in the "No internet - Skipping download and using existing archives" error.
Are you sure you can reach the rclone webpage?

Yeah no problem reaching. I can ping 8.8.8.8 and 1.0.0.1 fine but not 8.4.4.8 and 1.1.1.1. Very strange, currently looking into it but seems very weird.

Share this post


Link to post

Yea but reaching 8.8.8.8 is fine. The plugin checks 8.8.8.8 first and only tries 1.1.1.1 if 8.8.8.8 fails.

Share this post


Link to post
1 minute ago, Waseh said:

Yea but reaching 8.8.8.8 is fine. The plugin checks 8.8.8.8 first and only tries 1.1.1.1 if 8.8.8.8 fails.

Disabled my pi-hole and used unbound on Pfsense box. Still can't ping 8.4.4.8 but now I got this and it just flew through the install.

 


 

Verifying package rclone-2018.08.25-bundle.txz.
Installing package rclone-2018.08.25-bundle.txz:
PACKAGE DESCRIPTION:
Package rclone-2018.08.25-bundle.txz installed.
Downloading rclone
Downloading certs
Archive: /boot/config/plugins/rclone-beta/install/rclone-beta-latest.zip
creating: /boot/config/plugins/rclone-beta/install/rclone-v1.45-185-gf3874707-beta-linux-amd64/
inflating: /boot/config/plugins/rclone-beta/install/rclone-v1.45-185-gf3874707-beta-linux-amd64/rclone.1
inflating: /boot/config/plugins/rclone-beta/install/rclone-v1.45-185-gf3874707-beta-linux-amd64/rclone
inflating: /boot/config/plugins/rclone-beta/install/rclone-v1.45-185-gf3874707-beta-linux-amd64/README.txt
inflating: /boot/config/plugins/rclone-beta/install/rclone-v1.45-185-gf3874707-beta-linux-amd64/README.html
inflating: /boot/config/plugins/rclone-beta/install/rclone-v1.45-185-gf3874707-beta-linux-amd64/git-log.txt

-----------------------------------------------------------
rclone-beta has been installed.
-----------------------------------------------------------

plugin: installed

Updating Support Links

rclone-beta --> http://lime-technology.com/forum/index.php?topic=53365.0

Still no idea why Im having this problem but at least I got it installed!

Share this post


Link to post

Yea i'm still going with your pihole blocking the rclone download. For the record i also use a pihole instance as my local dns resolver which works without any problems.
Reviewing the code that's pretty much the only way to get that exact error without any other errors.

Edited by Waseh

Share this post


Link to post
plugin: updating: rclone.plg

+==============================================================================
| Skipping package rclone-2018.08.25-bundle (already installed)
+==============================================================================

Downloading rclone
Downloading certs
Archive: /boot/config/plugins/rclone-beta/install/rclone-beta-latest.zip
creating: /boot/config/plugins/rclone-beta/install/rclone-v1.46.0-006-gef5e1909-beta-linux-amd64/
inflating: /boot/config/plugins/rclone-beta/install/rclone-v1.46.0-006-gef5e1909-beta-linux-amd64/rclone.1
inflating: /boot/config/plugins/rclone-beta/install/rclone-v1.46.0-006-gef5e1909-beta-linux-amd64/rclone
inflating: /boot/config/plugins/rclone-beta/install/rclone-v1.46.0-006-gef5e1909-beta-linux-amd64/README.txt
inflating: /boot/config/plugins/rclone-beta/install/rclone-v1.46.0-006-gef5e1909-beta-linux-amd64/README.html
inflating: /boot/config/plugins/rclone-beta/install/rclone-v1.46.0-006-gef5e1909-beta-linux-amd64/git-log.txt
Copy failed - is rclone running?
plugin: run failed: /bin/bash retval: 1

Just got the same error...

Share this post


Link to post

So was rclone running? I mean the error is pretty self explanatory. 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now