Jump to content
Waseh

[Plugin] rclone

515 posts in this topic Last Reply

Recommended Posts

I only asked you to do the ping because your post originally contained the no internet error that you removed in your edit 😛

 

Google how to kill a proces in Linux - look for rcloneorig when you call ps -A to find the pid

 

Be aware that if you kill the proces you might screw something up if say you have a rclone remote mounted and don't close it gracefully 

Edited by Waseh

Share this post


Link to post
19 minutes ago, Waseh said:

I only asked you to do the ping because your post originally contained the no internet error that you removed in your edit 😛

 

Google how to kill a proces in Linux - look for rcloneorig when you call ps -A to find the pid

 

Be aware that if you kill the proces you might screw something up if say you have a rclone remote mounted and don't close it gracefully 

Thanks!

Share this post


Link to post

I saw there was an update today - went to the plugins page, clicked update and got this below.  Is there a special instruction to stop rclone before the update or something ?  and if so, how ?  Thanks:

 

plugin: updating: rclone.plg

+==============================================================================
| Skipping package rclone-2018.08.25-bundle (already installed)
+==============================================================================


Downloading rclone
Downloading certs
Archive: /boot/config/plugins/rclone/install/rclone-current.zip
creating: /boot/config/plugins/rclone/install/rclone-v1.43.1-linux-amd64/
inflating: /boot/config/plugins/rclone/install/rclone-v1.43.1-linux-amd64/rclone.1 
inflating: /boot/config/plugins/rclone/install/rclone-v1.43.1-linux-amd64/rclone 
inflating: /boot/config/plugins/rclone/install/rclone-v1.43.1-linux-amd64/README.txt 
inflating: /boot/config/plugins/rclone/install/rclone-v1.43.1-linux-amd64/README.html 
extracting: /boot/config/plugins/rclone/install/rclone-v1.43.1-linux-amd64/git-log.txt 
Copy failed - is rclone running?
plugin: run failed: /bin/bash retval: 1

Share this post


Link to post

hhhmmmm - ok - second time, I got the same :

 

plugin: updating: rclone.plg

+==============================================================================
| Skipping package rclone-2018.08.25-bundle (already installed)
+==============================================================================


Downloading rclone
Downloading certs
Archive: /boot/config/plugins/rclone/install/rclone-current.zip
creating: /boot/config/plugins/rclone/install/rclone-v1.43.1-linux-amd64/
inflating: /boot/config/plugins/rclone/install/rclone-v1.43.1-linux-amd64/rclone.1 
inflating: /boot/config/plugins/rclone/install/rclone-v1.43.1-linux-amd64/rclone 
inflating: /boot/config/plugins/rclone/install/rclone-v1.43.1-linux-amd64/README.txt 
inflating: /boot/config/plugins/rclone/install/rclone-v1.43.1-linux-amd64/README.html 
extracting: /boot/config/plugins/rclone/install/rclone-v1.43.1-linux-amd64/git-log.txt 
Copy failed - is rclone running?
plugin: run failed: /bin/bash retval: 1

Share this post


Link to post

rclone could be doing any number of things so shutting it down gracefully really depends on what you've got going on.
As mentioned earlier on this very page you can kill the proces if you want to to force the update - However standard warnings with killing processes apply.

Share this post


Link to post
On 9/24/2018 at 3:10 AM, Dimtar said:

This appears to be broken on unRaid 6.6, is that the case for anyone else?

FWIW, I had to uninstall/re-install the rclone-beta plugin in order for it to work again........

Share this post


Link to post

This seems to be the case for atleast some of you guys. Do you get any errors during the update?

Share this post


Link to post

I had the same issue, removing and reinstalling fixed the issue, works fine. Haven't rebooted to see if it happened again.

Share this post


Link to post

no problems for me, but maybe because I've done a few reboots over the last couple of weeks

Edited by DZMM

Share this post


Link to post

I too had issues with rclone on the newly updated 6.6. I started a transfer to my google drive and then the 6 cores I have used for unraid itself pinged to max CPU usage and the whole of unraid became unresponsive and was effectively locked. No web GUI, nothing. I ended up having to physically login on the server and restart from the CLI. When I came back and checked plugins page there was a third tab at the top listing plugin errors with rclone. I then uninstalled it entirely, rebooted the server, installed rclone, rebooted one last time and the errors were all gone. I didn't have the mind to take snapshots of it or anything at the time and when the server was locked, I didn't have access to any of the drives or anything. So for the moment, it seems a simple uninstall and reinstall is what it takes to fix rclone on a unRAID6.6 upgrade. though, I haven't started using it yet since then so I will add to this when that happens.

Share this post


Link to post

I need some help, please.

 

I have rclone working with an encryted folder in krusader but when i mount the folder in windows i get this error

 

WriteFileHandle.Write: can't seek in file without --vfs-cache-mode >= writes

 

Share this post


Link to post
49 minutes ago, Greygoose said:

I need some help, please.

 

I have rclone working with an encryted folder in krusader but when i mount the folder in windows i get this error

 

WriteFileHandle.Write: can't seek in file without --vfs-cache-mode >= writes

 

So mount it with writes enabled then?

 

Edited by Dimtar

Share this post


Link to post
3 hours ago, Dimtar said:

 

So mount it with writes enabled then?

 

Thanks for the reply.

 

I have this mounted with write enabled, as in the picture.  Id be gratful for some help with this.

rclone.png

Share this post


Link to post
5 hours ago, Greygoose said:

I need some help, please.

 

I have rclone working with an encryted folder in krusader but when i mount the folder in windows i get this error

 

WriteFileHandle.Write: can't seek in file without --vfs-cache-mode >= writes

 

Check here..... Research vfs. I bet your rclone mount command needs to look something like these. Read a bit of the thread there and go to the GitHub in the first post there. Research it.

 

https://forum.rclone.org/t/my-vfs-sweetspot-updated-30-aug-2018/6132

Share this post


Link to post

@Waseh

 

Wondering ... is there any way of getting around the need to store access key IDs & secrets in plain text?

 

I realise you need shell access to get to the plugin config file, but ...

Share this post


Link to post

You could use the build in way to encrypt the config file but that just means that you have to either enter the password every time you run a command or include the password in the command kinda defeating the purpose.
If you want to do it just run rclone config and follow the instructions for password protecting the config.

Share this post


Link to post
4 hours ago, digitalformula said:

@Waseh

 

Wondering ... is there any way of getting around the need to store access key IDs & secrets in plain text?

 

I realise you need shell access to get to the plugin config file, but ...

You know the Client ID and Secret are not necessary, right? You can leave those black during setup. Only thing necessary is the AutoConfig link authorization token.

Share this post


Link to post
Just now, Stupifier said:

You know the Client ID and Secret are not necessary, right? You can leave those black during setup. Only thing necessary is the AutoConfig link authorization token.

Nope, didn't know that.  But then, I've used the plugin for about an hour.

 

Thanks for the pointer, though - I'll look up that method right now.  :)

Share this post


Link to post
5 hours ago, digitalformula said:

Nope, didn't know that.  But then, I've used the plugin for about an hour.

 

Thanks for the pointer, though - I'll look up that method right now.  :)

just open up the command line, type "rclone config".....setup a new remote and follow the on screen instructions. When it says something like "if you don't know, leave blank....." or "default: blank"......just LEAVE IT BLANK. Then near the end of the setup it will ask if you want to do Auto Config Y/N.....Say No, and Open the link on a computer to get the token.

Share this post


Link to post

plugin dissapears on reboot.

Also if i reinstall it, i goto terminal and type rclone config and command is not found :/

 

plugin was working before not sure whats happened?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.