Jump to content
Djoss

[Support] Djoss - MakeMKV

559 posts in this topic Last Reply

Recommended Posts

On 8/11/2020 at 3:53 AM, ElectricBadger said:

It works inside a private window, and if I use Vivaldi rather than Firefox Developer Edition (but that's a pain as I have to copy/paste the link rather than just clicking, obviously). All adblockers are disabled for the unRAID server's address in Firefox, but not in Vivaldi — but they all report nothing is blocked, anyway.

 

I've tried disabling each extension individually, with no effect. Most of them were active in Vivaldi anyway.

 

The connection doesn't get established when I use TigerVNC.

 

console.log.txt 22.28 kB · 1 download

 

It's very mysterious… ¿ⓧ_ⓧﮌ

If it's working inside a private window, it usually means that there is a cache issue with the browser.  Did you try with Chrome ?

 

When using a VNC client, make sure you connect to the VNC port (7906).

Share this post


Link to post
23 minutes ago, Djoss said:

If it's working inside a private window, it usually means that there is a cache issue with the browser.  Did you try with Chrome ?

 

When using a VNC client, make sure you connect to the VNC port (7906).

Ah — I was connecting to port 7806 with the VNC client. That explains a lot.

 

I don't have Chrome installed, but Vivaldi is based on Chromium (it loses a bunch of Google-specific stuff I don't want, and adds several very useful configuration options). As I said, it worked fine there, too.

 

I cleared the Firefox cache and it still didn't work without using private mode — but clearing all cookies and localStorage set by the unRAID machine did. Not sure what had got stored that was causing the confusion, but it's all resolved now. Thanks for your help!

Share this post


Link to post
On 8/5/2020 at 3:47 PM, Djoss said:

Can you try to enable privileged mode just to see if this help?

Thanks for responding.  I just now saw your reply.  I tried it with privileged mode both on and off, but still the same thing.  It was working fine when I first installed it.

Share this post


Link to post

Been using this docker for the past couple weeks, working great. One thing I haven't figured out yet is the output directory settings. Is there a way to turn off the movie folder generator on it? I thought it might have been the "/config/data" path in settings, but restarting after removing the data part didn't update.

Share this post


Link to post
On 2/16/2020 at 2:55 PM, wesman said:

That's what it suppose to do, but it hangs the entire system,  requiring a Power Button force power down to get anywhere. 

 

 

Does anyone have any additional input on this issue?

 

I have used the docker to rip about a dozen Blu Rays over several weeks, but over the last 3 weeks or so every rip requires an unclean (hold power button) shutdown before I can rip a second.  The docker hangs and will not stop or restart when using the Unraid GUI.

 

I can't make the docker stop or restart itself.

Share this post


Link to post

Hi Djoss,

 

Thank you for your great container. I've been using it quite a lot.

Recently something went wrong and de container disappeared. Now I'm trying to reinstall the container with my internal optical drive but I keep getting errors. When I add the path for my optical drive I get this Error message.

 

Quote

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name='MakeMKV' --net='bridge' -e TZ="Europe/Berlin" -e HOST_OS="Unraid" -e 'MAKEMKV_KEY'='BETA' -e 'AUTO_DISC_RIPPER'='0' -e 'AUTO_DISC_RIPPER_EJECT'='0' -e 'AUTO_DISC_RIPPER_PARALLEL_RIP'='0' -e 'AUTO_DISC_RIPPER_BD_MODE'='mkv' -e 'AUTO_DISC_RIPPER_FORCE_UNIQUE_OUTPUT_DIR'='0' -e 'USER_ID'='99' -e 'GROUP_ID'='100' -e 'UMASK'='000' -e 'APP_NICENESS'='' -e 'DISPLAY_WIDTH'='1280' -e 'DISPLAY_HEIGHT'='768' -e 'SECURE_CONNECTION'='0' -e 'X11VNC_EXTRA_OPTS'='' -e 'AUTO_DISC_RIPPER_INTERVAL'='5' -e 'AUTO_DISC_RIPPER_MIN_TITLE_LENGTH'='' -p '7806:5800/tcp' -p '7906:5900/tcp' -v '/mnt/user':'/storage':'ro' -v '/mnt/user/MakeMKV/':'/output':'rw' -v '/mnt/user/appdata/MakeMKV':'/config':'rw' --device='--device /dev/sr0 --device /dev/sg9' 'jlesage/makemkv' 

/usr/bin/docker: --device /dev/sr0 --device /dev/sg9 is not an absolute path.
See '/usr/bin/docker run --help'.

 

I don't know what I'm doing wrong. Those are exactly the devices I see in the log file.

 

Can you please help me?

Share this post


Link to post
On 8/24/2020 at 9:56 PM, patm95 said:

Thanks for responding.  I just now saw your reply.  I tried it with privileged mode both on and off, but still the same thing.  It was working fine when I first installed it.

What is the output of the following command:

docker exec MakeMKV lsscsi -g -k

 

Share this post


Link to post
On 8/27/2020 at 3:04 PM, yanksno1 said:

Been using this docker for the past couple weeks, working great. One thing I haven't figured out yet is the output directory settings. Is there a way to turn off the movie folder generator on it? I thought it might have been the "/config/data" path in settings, but restarting after removing the data part didn't update.

 Just before starting ripping the disc, do you have the ability to change the output directory?

Share this post


Link to post
On 8/29/2020 at 1:35 PM, victor93 said:

Hi Djoss,

 

Thank you for your great container. I've been using it quite a lot.

Recently something went wrong and de container disappeared. Now I'm trying to reinstall the container with my internal optical drive but I keep getting errors. When I add the path for my optical drive I get this Error message.

 

 

I don't know what I'm doing wrong. Those are exactly the devices I see in the log file.

 

Can you please help me?

It seems to have missing quotes.  Should be:

--device='--device /dev/sr0' --device '/dev/sg9'

instead of:

--device='--device /dev/sr0 --device /dev/sg9'

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.