[Support] binhex - qBittorrentVPN


binhex

1327 posts in this topic Last Reply

Recommended Posts

  • Replies 1.3k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

@binhex Does the container only use a single .ovpn file from the appdata directory for configuration? Can I put all of the PIA port-forwarding capable server .ovpn files in there so that it can try th

Support for multi remote endpoints and PIA 'Next-Gen' networks now complete, see Q19 and Q20 for details:- https://github.com/binhex/documentation/blob/master/docker/faq/vpn.md

Create a necessary folder in   \\yourservername\appdata\binhex-qbittorrentvpn\qBittorrent    Create a folder called ssl     Open up terminal and type,  

Posted Images

Excellent... it is all up and running now... thank you for your quick response, even though the info was already there 

 

: (

 

.... anyway. as usual your work is appreciated and exceptional.

Edited by questionbot
Link to post

I'm trying to route my (binhex) Jacket, Sonarr, Radarr containers through the binhex-qbitorrentvpn docker after encountering problems connecting Sonarr and Radarr to Jacket after the latest update.

I'm still having problems connecting to the webUIs. They just don't load. Followed the FAQ. 25 and 26, although I'm still having questions about that. Watched Spaceinvader One's video guide, although that one doesn't seem complete atm.

I included screenshots of my settings from the Jackett and qBittorrent dockers.

 

Jackett:

jackett.png.933ac521d7f6d5c52ce9d4178030c491.png

 

qBittorrent:

qbittorrent.thumb.png.0197a13508b1eaa0a1fc936c5c232445.png

 

It all seems to run fine?

jackettdocker.png.b2bd907562bd9cceb81ce53d9606ec31.png

 

To get back to the FAQ, Under A25 step 4 it says: "Remove any 'Host Ports' defined." But that does not seem right?
I had to create the ADDITIONAL_PORTS variable in the binhex-qBittorrentvpn docker also. As you can see above I think I got that right.

Not sure what I'm doing wrong here. Must be a silly thing I hope.

Link to post
I'm trying to route my (binhex) Jacket, Sonarr, Radarr containers through the binhex-qbitorrentvpn docker after encountering problems connecting Sonarr and Radarr to Jacket after the latest update.

I'm still having problems connecting to the webUIs. They just don't load. Followed the FAQ. 25 and 26, although I'm still having questions about that. Watched Spaceinvader One's video guide, although that one doesn't seem complete atm.

I included screenshots of my settings from the Jackett and qBittorrent dockers.
 
Jackett:
jackett.png.933ac521d7f6d5c52ce9d4178030c491.png
 
qBittorrent:
qbittorrent.thumb.png.0197a13508b1eaa0a1fc936c5c232445.png
 
It all seems to run fine?

jackettdocker.png.b2bd907562bd9cceb81ce53d9606ec31.png
 
To get back to the FAQ, Under A25 step 4 it says: "Remove any 'Host Ports' defined." But that does not seem right?
I had to create the ADDITIONAL_PORTS variable in the binhex-qBittorrentvpn docker also. As you can see above I think I got that right.

Not sure what I'm doing wrong here. Must be a silly thing I hope.
In your jackett screenshot there is a port for 9117, delete it, then try accessing the web UI again, using ≤host IP≥:9117

Sent from my iPlay_40 using Tapatalk

Link to post
14 minutes ago, binhex said:

In your jackett screenshot there is a port for 9117, delete it, then try accessing the web UI again, using ≤host IP≥:9117

Thanks for the fast response! Okay, removed the port in the Jacket settings and I'm trying to connect to http://192.168.0.202:9117/, but it still doesn't load. :( "This site can’t be reached"

Link to post
35 minutes ago, SysRq said:

Thanks for the fast response! Okay, removed the port in the Jacket settings and I'm trying to connect to http://192.168.0.202:9117/, but it still doesn't load. :( "This site can’t be reached"

what is the value for env var LAN_NETWORK for qbittorrentvpn?

Link to post
4 minutes ago, binhex said:

what is the value for env var LAN_NETWORK for qbittorrentvpn?

The value is currently set at: 192.168.0.0/24. This used to be fine. I tried to change it to: 192.168.0.202/24, but this didn't work either.

Link to post
1 minute ago, SysRq said:

The value is currently set at: 192.168.0.0/24. This used to be fine. I tried to change it to: 192.168.0.202/24, but this didn't work either.

that looks fine, what about the browser, have you by accident set it to use a proxy?

Link to post

 

1 minute ago, binhex said:

that looks fine, what about the browser, have you by accident set it to use a proxy?

 

No, I don't use a proxy with Chrome. Tried Brave, Edge. All do not connect.

Link to post
2 minutes ago, SysRq said:

 

 

No, I don't use a proxy with Chrome. Tried Brave, Edge. All do not connect.

ok can you attach your jackett config file, its located at /config/Jackett/ServerConfig.json

Link to post
6 minutes ago, SysRq said:

I removed the values in ProxyUsername and ProxyPassword, but the rest of the file I left alone.

ServerConfig.json 613 B · 0 downloads

ok you shouldn't be using a socks/http proxy as it can cause issues when using a vpn tunnel, set the option in the file as follows:-

 

  "ProxyType": -1,

save the change and restart jackett container.

 

another question too, do you have vlan's in place?, also check firewall for lan blocking.

Link to post
16 minutes ago, binhex said:

ok you shouldn't be using a socks/http proxy as it can cause issues when using a vpn tunnel, set the option in the file as follows:-

 


  "ProxyType": -1,

save the change and restart jackett container.

 

another question too, do you have vlan's in place?, also check firewall for lan blocking.

Made the change in the .json. Still not able to connect.

I don't use a vlan and checked both the firewall in windows and the router, both look fine. 

Link to post
5 minutes ago, SysRq said:

Made the change in the .json. Still not able to connect.

I don't use a vlan and checked both the firewall in windows and the router, both look fine. 

sorry then im currently out of suggestions, all i can say is this does work, i currently have jackett routed through privoxyvpn and i can access the web ui of jackett and sonarr can communicate with jackett, there must be something else blocking, but i dont know what.

 

edit - one last stab in the dark, go to the 'console' of qbittorrentvpn and issue the command 'ip route' and paste it here.

Link to post
5 hours ago, binhex said:

edit - one last stab in the dark, go to the 'console' of qbittorrentvpn and issue the command 'ip route' and paste it here.

 

0.0.0.0/1 via 10.8.3.1 dev tun0 
default via 172.17.0.1 dev eth0 
10.8.3.0/24 dev tun0 proto kernel scope link src 10.8.3.16 
128.0.0.0/1 via 10.8.3.1 dev tun0 
172.17.0.0/16 dev eth0 proto kernel scope link src 172.17.0.2 
192.168.1.0/24 via 172.17.0.1 dev eth0 
213.232.87.81 via 172.17.0.1 dev eth0

 

Hopefully this will help.

In the mean time I tried with binhex-PrivoxyVPN and trying to route it through there. Same result as with binhex-qBittorrentVPN

Link to post
22 hours ago, SysRq said:

Hopefully this will help.

sadly it doesnt, that all looks correct so the issue is not routing, im out of ideas for now.

Link to post
3 hours ago, binhex said:

sadly it doesnt, that all looks correct so the issue is not routing, im out of ideas for now.

 

Got the WebUI loading working. Supposedly I needed to:

  • add the extra parameter "--net=container:binhex-qbittorrentvpn" (did that)
  • delete my ports on the routed containers (I did, on your suggestion)
  • add them to the qbittorrent container "additional ports" line (I created that and so I did)
  • AND re-create the port in the qbittorent container (and here I failed, idiot like I am)

Seems I looked over that part. I swear I did create them, but I must have deleted those ports at one point after I didn't get it to work at first.

 

I now have the issue of not being able to connect to my indexers from Jackett and connecting to qBittorrent in Radarr and Sonarr, but at least I'm one step closer of solving the problems.


Many thanks for your support and sorry for wasting your precious time. 

 

 

Link to post

Hello again..

I have a mikrotik router..  and the standard ip range is something like 192.168.88.---- .. So think my port trouble has something to do with the internal network??

im using a regular windows pc. and when typing in ipconfig my default gateway is 192.168.88.1..  The thing is that when i go to my Dhcp server, my settings is 192.168.88.0/24.. I do not know if this helps???

 

regards

Link to post
On 2/26/2021 at 12:12 AM, binhex said:

Q25. I have recently updated my Docker image for DelugeVPN/PrivoxyVPN/SABnzbdVPN/qBittorrentVPN and can no view the Web UI for the application i am routing through the VPN container, why is this and how can i fix it?.

A25. Due to iptables tightening it is now a requirement that you add the Web UI/API ports for the application you want to route through the VPN to the 'ADDITIONAL_PORTS' env var value for the VPN container, if you have multiple ports then please separate the values with a comma, e.g. 'ADDITIONAL_PORTS' = 1234,5678

 

The other change you will need to do is when defining connections from an application to another application in the same container network (as is the case in this scenario) then you will need to set the host to 'localhost' and NOT the LAN IP address, this is because the applications are now bound to the same network and thus should communicate over 'localhost'.

 


 

If your a noob like me after following @SpaceInvaderOne video titled ‘How to use Privoxy with VPN for Ultimate Privacy when using Media Collection Apps’ here’s a step by step guide with screenshots. I’m sure SpaceInvaderone will provide guidance at some point. But it isn’t always convenient to do so if their life is busy.


Here is a noob version with screen shots for Unraid on what to do to access the web UI’s behind the VPN/Prixoxy after they stopped working in the latest security update from @binhex.
As ADDITIONAL_PORTS' env var value for the VPN container took me 15 minutes to work out 😅


Steps

1. Edit Docker configuration file for client DelugeVPN/PrivoxyVPN/SABnzbdVPN/qBittorrentVPN

2. Find Container Variable with Additional ports, Key 12 for me. 

3. Insert port number(s) for containers you have routing through VPN/Prixoxy.

In my case Radarr 7878, Sonarr 8989, Jackett 9117 and NZBGet 6789 with a comma between each port

5E35DCB1-3C39-4305-AE90-89718B3210A9.thumb.jpeg.1bcabe2a42f7bae260661bfc3dd5a95e.jpeg
 

4. Click apply to Docker Configuration 


I was then able to access my web UI’s for all the container routed through binhex-qbittorentVPN.

 

There’s also a Q26 for issues accessing the webUI of the the 'Download Client' (e.g. Deluge, rTorrent, qBittorrent, SABnzbd)

https://github.com/binhex/documentation/blob/master/docker/faq/vpn.md

 

 

Edited by CafeNevosa
Correction on network type
Link to post
5 hours ago, CafeNevosa said:

5. Next open and each container that you have routed through the VPN/Prixoxy Conatiner.

In my case that’s Radarr, Sonarr, Jackett and NZBGet.

Edit each container configuration and change the network type from none to Host.

dont do this, the network for containers you want to route through the vpn network should have a network type of 'none' see Q24. for how to route containers through:- https://github.com/binhex/documentation/blob/master/docker/faq/vpn.md

Link to post

Hi @binhex I have managed to get all my containers talking to each other in your container now (Q26) and can now access all my containers WebUI's and they are all talking to each other.

 

Just wanted to say a MASSIVE thank you for your work, time and patience, it is HUGELY appreciated!

 

 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.